none
Vista compatibility with Toshiba laptops

    General discussion

  • I installed Vista PreRC (build 5536) on a toshiba satellite A105-S4211 and found out that many of the toshiba utilities and programs are not compatible with this release of Vista. One progam in particualr, toshiba common modules(Vista called it Toshiba Mobile PC Driver), is critical for toshiba laptop operation. All other utilities depends on these common modules. Other incompatible programs include hotkey utilites, power saver, and others. This is perhaps the cause of many problems such as: Brightness of the screen cannot be adjusted, and external display cannot be enabled. 

     

     

    Thursday, August 31, 2006 3:53 AM

All replies

  • did you get the SD slot working?
    Wednesday, September 06, 2006 1:05 AM
  • Hey I have the same toshiba model and I cant get the public release of rc1 to install at all goes through whole installation screen reboot and screen the goes black and it just sits there. dash are you expierencing the same thing? Got any intel on when Toshiba might release some update to actually make the notebook compatible (BIOS/Drivers) ? I think its sad that this notebook clearly as a Vista compatible logo right on the front of it and you cant even install RC1
    Friday, September 08, 2006 12:17 AM
  • Willf,

    I have as much info as you have regarding toshiba releasing an update. As I detailed in another thread, the problem is most likely the GMA 950 display adapter. Nothing worked after installation of 945GM Express Chipset Controller 1. I also noticed that in the preRC1 (5536), the express chipset controller 0 was successfully installed after online upgrading but the controller 1 was not installed for some reason. Hopefully, MSFT or Intel will looking into this to see this is specifc to Toshiba laptop or is widely spread in all GMA 950 adapters.

     

    Friday, September 08, 2006 3:47 AM
  • I got a new 100gb HD for my Satallite A75-S2922(bought back in Feb 05). I decided what the hey, I installed Vista RC1 this last weekend and to my surprise it works; well. My machine runs cooler and quieter now. The only noticable drawback is the video display only has two settings. 800x600 and 1024x768. It is okay but my screen is a wide format so everything is streatched. I don't suppose that Toshiba will release any updates. I downloaded an ATI beta driver update but didn't seem to help.

    Overall I am really happy with Vista. I don't plan on trying to install any of the Toshiba utilities. Oh the screen dims and lightens with Fn-F6 like before just not cool icon indicator. Oh well.

    Tuesday, September 12, 2006 2:10 AM
  • I'm having the same problem right now with a Toshiba Satellite A105-S4064 laptop using the GMA950 graphics. Has ANYONE figured out how to do this yet?
    Saturday, September 16, 2006 5:18 PM
  • I have a toshiba notbook, A75 something. After a flawless Vista installation, I can't seem to get my external monitor working. If I start the computer with the external monitor connected, it will boot to that monitor (wont work at 1280x1024). If not connected, it goes to the notebook screen. I've downloaded and installed ATI's Vista Casalyst thingo and nothing. When playing the inluded games with vista, I get a message that my video card is not recognized and acceleration is not supported. What have I done?!?!? Toshiba has nothing. Thanks......
    Sunday, September 17, 2006 5:08 PM
  •  

    Toshiba M40 - similar (older) model but with ATI X300 graphics.

    This may be totally unconnected, but...

    Beta 2 installed but failed on reboot during "Completing Installation", and I could only access "Last Known Good configuration". Build 5536 wouldn't boot at all.

    I finally got RC1 working by following advice in another forum http://www.pro-networks.org/forum/about78185-10.html to use the Repair option/ CLI to rename or delete "PCMCIA.sys" from

    Windows\system32\drivers     and

    windows\system32\driverstore\filerepository\pcmcia.inf_539d559e.

    I haven't tried updating those drivers or using any of the Toshiba utilities

     I hope this is corrected by the time it hits the high street...

     

    Monday, September 18, 2006 12:58 AM
  • well, I'm sure Toshiba will tell you 'Vista-compatible' means the retail version, not a beta test.  There are still fundamental problems with lots of hardware on many different systems.

    And if you've ever owned a laptop before, you'd know that manufacturers, Toshiba especially never update drivers for a model after it's off store shelves.  So you better hope it's still in the stores by the time Vista goes RTM.
    Monday, September 18, 2006 1:05 AM
  • So far it looks like they don't support the mobility 9100 series yet.... I have the same problem. If you go into the catalyst install, and hit custom, it even says no hardware supported found.
    Tuesday, September 19, 2006 9:47 PM
  • Use the built in 9100 driver from the original install (I'm using it on my a70; it works normally but doesn't support Aero)

     

    Saturday, October 07, 2006 2:57 PM
  • I have a Toshiba Satellite A105-S2051 and the HD audio driver/services crash every program that makes a noise (pretty much everything by default) I disabled audio services and driver in order to make Vista functional. Yes, HD audio warning was said on install. Yes, there is a sticker on my laptop staring me in the face that reads "Windows Vista Capable"... not very. Any word on Toshiba support, let me know asap!

    This is on the final release of Vista (I have MSDN)

     

    -Rob

    Monday, November 20, 2006 10:54 PM
  • My Toshiba A70 is incompatible too.

    First I was required to : Uninstall - 1 DVD Form Application, 2 McAfee Internet Security Suite, and 3 Toshiba Config Free

    Second I was required to : Update drivers - Dell AI0 Printer A960

    Third I was required to : Update Programs - 1 ACU, 2 Sonic MyDVD Plus, 3 Toshiba Utilities, 4 Config Free, 5 Modem Region Select Utility, 6 Alps Touch Pad Utility, 7 Easy Capture, 8 ATI Control Panel, 9 Drive Letter Access Component, 10 Shared Driver Component, 11 Config Free Service, 12 Toshiba Power Save.

    Then after waiting two hours the message said this was incompatible and to see Microsoft site to have the machine scanned. However I cannot find that site.

     

    Saturday, November 25, 2006 12:52 AM
  • I have a Satellite M115 running Vista RTM and have encountered the same issues.

    From a fresh install, everything big like the Core Duo power management, GMA950 Aero support, HD audio, and standby/hibernate just work. Color me impressed!

    Toshiba-specific features such as the Fn-hotkeys, media buttons, backlight control and display switching do not. For these I find the XP drivers for TBIOS and Toshiba ACPI common modules are required. After loading them, install the Toshiba Control and Hotkey Utilities and turn off the compatibility warnings. The display/brightness/media hotkeys should now work. (The toshiba power manager and hardware setup apps do NOT work on Vista.) Also install the ENE Cardbus/reader drivers if you want full slot functionality. Oh, and the latest synaptics touchpad driver (from www.synaptics.com) is Vista-compatible.

    Now, to get these features integrated into the Mobility Center and power profiles, I think an ACPI BIOS update from Toshiba will be required. Vista expectes some new ACPI functionality for display and backlight control.

    The Satellite A100/M100 machines are almost identical to the Tecra A7/A8 systems, and there are beta Vista ACPI BIOS/driver updates for those machines at http://www.csdsupport.toshiba.com/tais/csd/support/windows_vista/vista_beta.cgi

    Tuesday, November 28, 2006 7:40 AM
  • Thank you for a very useful and informative response, except for where to get those drivers and upgrades. I have not been able to find them.

    Bottom line: Current Toshiba models can't load Vista.

    Wednesday, November 29, 2006 4:37 PM
  • Have you tried Toshiba PC Support? Sorry, I can't link directly to files.

    I gave a link to the Vista beta drivers for certain models. For everything else, try entering your model into the site and use the XP drivers. Do not use XP drivers for sound or video, they aren't compatible. Most everything else is.

    For Intel video, here is the link to the Vista drivers, but you don't really need them. Vista should already support Intel video and audio. In fact, installing the video drivers may cause a hang on a black screen. (But if you wait until the disk activity stops and power cycle the machine everything is installed fine.)
    Thursday, November 30, 2006 7:33 AM
  • The above also seems to work for a Toshiba M7 tablet pc! Great tips!
    Thursday, November 30, 2006 1:19 PM
  • Also through further testing, Vista jacked up my Serial-to-USB device drivers as well. I decided no Vista on the laptop for now as those devices are required by me.

     

    Vista is not ready for delivery simply because of lack of driver support and missing drivers.

    Monday, December 04, 2006 5:54 PM
  • Actually, the XP drivers for the ATI 9000/9100 IGP Chipset works very well with Vista.  It doesn't support Aero as previously stated, doesn't improve your graphics rating at all, but allows you to modify the resolution to widescreen, where the Standard VGA does not (and doesn't support Aero either), so you really have nothing to lose.  I have done some graphic intense gaming on my A75 (which I hate this laptop) with no issues at all using the XP driver.  You can't simply install the drivers normally though, you have to search for them, and select them manually through Device Manager. 

    As for Audio, you can download the AC97 drivers/software for Vista from Realtek, and those work well too, although Vista does install it's own version.  Haven't had to use the XP drivers for those at all.

    Now, if anyone can help me with battery life, that's a different story.  I'm hardly getting more than 30 minutes of battery life since installing Vista, and the power management options don't leave a lot of room to play.

     

     

    Thursday, January 04, 2007 8:39 PM
  • i have exactly the same problem with my toshiba p30 laptop. my radion 9700 driver fails to load as ati's website states its conflicting with the chipset, which toshiba were no help with.

     

    i rolled back to xp to check the device manager and found the following....

    Computer

    XP = ACPI Multiprocessor PC.

    VISTA = ACPI x86 - Based PC

     

    in vista the ATI RS300.RS300M Accelerated Graphics Port is missing in the system section.

     

    Anyone any closer to a result?

    Surely microsoft should be looking at  this problem as it was all ok in xp.

    i have exactly the same problem with my toshiba p30 laptop. my radion 9700 driver fails to load as ati's website states its conflicting with the chipset, which toshiba were no help with.

     

    i rolled back to xp to check the device manager and found the following....

    Computer

    XP = ACPI Multiprocessor PC.

    VISTA = ACPI x86 - Based PC

     

    in vista the ATI RS300.RS300M Accelerated Graphics Port is missing in the system section.

     

    Anyone any closer to a result?

    Surely microsoft should be looking at  this problem as it was all ok in xp.

    Sunday, February 11, 2007 1:51 PM
  • Could you fix that problem with power saver and oth for vista?

    Can you please answer me to xray2002@mail.ru

    Saturday, March 24, 2007 5:48 PM
  • Hi all, I do not have a toshiba laptop but I can say that Vista does not support the RS300 chipset.  I've been trying in vain for the past few days to get Aero glass working using Windows XP drivers.  With the Vista drivers I get an exclamation mark (code 43) for an X800 XT PE even though I have the RS300/RS300M Accelerated Graphics Port driver and SMBus drivers installed.  If I install the latest Win XP catalyst drivers, all is dandy except Aero glass does not work because it does not support the longhorn driver model.  And yet using the Vista Upgrade Advisor yielded no problems, thanks a lot Microsoft...!! (Looks like the only way for me to use vista to its full capability would be to get a totally new system.  Bloody hell!!)  Hope this helps someone.
    Friday, March 30, 2007 12:17 AM
  • at a recent, March 2007, Microsoft Technet show, the speaker said he has a Toshiba that took Vista, but with promting, he admitted he had to update the BIOS. However, he did not say what chip set he has. That is a critical issue as I found going from serial to USB.

    All the best, pg

    Friday, March 30, 2007 4:40 PM
  • http://munksupport.com/ that's the place to get help. I have a laptop and I could not get Vista to work on it, These guys helped me out. even if you don't have your areo glass working these guys know how to get it working for you. Support is free.
    Friday, April 13, 2007 11:49 PM
  • For general info, it seems that on several models the previously named Common Modules package from is now covered under the Value Added Package.

     

    This package installs a range of important utilities.TOSHIBA Components Common Driver   This module is an essential component on Windows Vista.  It is required to make other TOSHIBA original programs work properly.TOSHIBA Power Saver   The Power Saver controls power consumption by switching to optimum power settings,   based on whether the machine is plugged in or on battery power, and based   on the remaining battery power.TOSHIBA Utilities   This program lets you customize your hardware settings according to the way you  work with your computer and the peripherals you use. To start the utility, click  the Windows Start button and click Control Panel and select the TOSHIBA HW Setup icon.TOSHIBA Password Utility   This utility lets you set a password that restricts access to the computer.TOSHIBA Flash Cards   TOSHIBA Flash Cards provides the Hotkey function and the launcher function that   starts you to execute Hotkey and launch the other TOSHIBA util

     

    Since Tosh's have no BIOS setup like most machines this is pretty important for tweaking all those types of settings too.

    Saturday, June 23, 2007 1:13 PM
  • i just purchased a toshiba p100 laptop and everytime it trys to boot it gets to a error message saying "The computer restarted unexpectedly or encountered an unexpected error. windows installation can not proceed" then it says click ok the restart and re install... but the message is always the same. i didnt recieve a vista cd and have no idea how to boot the computer.

    help please
    Monday, August 20, 2007 12:58 PM
  •  

    go to the toshiba web site click support for lsaptops , click downloads next page choose your system in the boxes, first download you should have already done is the version 5.90 Bios . after installing the bios through windows reboot then return to the site to downlaod the rest of the drivers and software needed . All problems you mentioned are resolved
    Saturday, November 10, 2007 6:09 AM

  • For some reason I can't figure out how to get my Toshiba Flash cards to work or my PC Diagnostic tool. Am I missing something? I've been looking for drivers and I'm not sure what to download if any?
    Any thoughts or suggestions would be greatly appreciated!
    Sunday, January 06, 2008 8:47 PM