none
Windows Mobile Device Center: There is no email program associated to perform the requested action RRS feed

  • Question

  • I get this window now when I sync my PDA with Windows Mobile Device Center in Win7 64bit:
    There is no email program associated to perform the requested action. Please install an email program or, if one is already installed, 
    create an association in the Default Programs control panel.

    When I first stared syncing, everything was fine... this is a very recent install. It synced fine before I installed Office 2007, including Outlook. After I installed Office it
    synced fine too, but then I realized that I could sync with Google and decided that I didn't need Outlook at all on my system... I just used it for syncing and backing up my
    Contacts anyway. After I uninstalled Outlook, I started getting this pop up whenever I put my PDA into its cradle... even though I have all email and contact syncing turned off locally...
    Google is used as a fake Exchange server and it syncs fine that way... after reading some forums, I installed Live Mail onto my system, hoping that having an
    email program installed would make it self default, but alas that is not the case. Everything in the Control Panel Default programs seems to be ok, and Live Mail is
    my default email program... what else am I missing here? Thank you!
    • Moved by Carey FrischMVP, Moderator Saturday, October 17, 2009 9:06 PM Moved to relevant category (From:Windows 7 Miscellaneous)
    Saturday, October 17, 2009 9:01 PM

All replies

  • Have you tried deleting the Device Partnership and then Setting up a new Partnership?
    • Proposed as answer by David Dee Friday, October 30, 2009 7:11 PM
    Friday, October 30, 2009 7:07 PM
  • I've posted a fix here:

    http://www.wieser-software.com/topdrop/help/faq.htm#mapierr

    based on this KB article:
    http://support.microsoft.com/kb/315458

    Anthony Wieser
    Wieser Software Ltd
    Wednesday, November 4, 2009 9:01 AM
  • Hi, Than;s for solution but it si not working if only thunderbird installed. I have this message while connecting device even if I don't want to synchronize any data. I have contacts, emails etc unchecked and still this message. I will probably son try live just to get rid this annoying message. I wonder why there is no checkbox say don't show again...
    Friday, December 18, 2009 2:30 PM
  • Hi, Than;s for solution but it si not working if only thunderbird installed. I have this message while connecting device even if I don't want to synchronize any data. I have contacts, emails etc unchecked and still this message. I will probably son try live just to get rid this annoying message. I wonder why there is no checkbox say don't show again...

    Hi Zefir,

    Have you found an acceptable solution for this issue yet?  I made Live my default email client and am still getting this same issue you were getting.
    • Proposed as answer by Zefir Tuesday, February 23, 2010 3:52 PM
    Thursday, January 7, 2010 4:31 PM
  • This is expected (and annoying) behavior. If you try to use Windows Mobile Device Center to sync a Windows Mobile Device without Outlook (or another MAPI-compliant mail program) installed, it will throw this error every time.
    Friday, January 8, 2010 1:43 AM
  • Hi, I'm afraid not. This annoying behaviour drives me crazy - but for now I was no luck with that.
    Friday, January 15, 2010 4:18 PM
  • I've posted a fix here:

    http://www.wieser-software.com/topdrop/help/faq.htm#mapierr

    based on this KB article:
    http://support.microsoft.com/kb/315458

    Anthony Wieser
    Wieser Software Ltd

    I have tried this fix with Windows 64-bit, paying attention to alter the appropriate "Wow5432Node" which then updates the appropriate HKEY elsewhere.

    This fix does not work.

    I tried to comment on the post in the above link, but it require you to register, log-in, etc., and I'm sick of having to create a log-on identity for every freaking blog I visit just so I can comment and try to help people find a solution.

    Sunday, February 21, 2010 9:19 PM
  • I've just tried the fix on 64 bit W7, and it seems that the fix does not work.

    As far as I can tell, the problem is because the smapi32.dll is a 32 bit dll in windows live mail, and WMDC.exe is a 64 bit exe.  As a result, it cannot be loaded into the address space, and the call fails.

    http://support.microsoft.com/kb/315458 describes the mechanism, and the error message can be changed by setting this key:
    HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail::PreFirstRun

    So, it looks like what's needed is a 64 bit mapi32.dll to point to.  However it appears that the keys are mirrored between the 64 and 32 bit versions, so changing it in one place breaks it in the other.

    There also seems to be more information here:
    http://msdn.microsoft.com/en-us/library/dd941355(office.14).aspx


    Anthony Wieser | Wieser Software Ltd | www.wieser-software.com
    Monday, February 22, 2010 11:17 AM
  • Anthony's explanation worked for me (32 Bit Windows 7) but I also had to remove (rename) the key
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Messaging Subsystem\MSMapiApps::WmdHost.exe

    Thanks, this was driving me crazy.
    • Proposed as answer by Zefir Tuesday, February 23, 2010 3:52 PM
    Tuesday, February 23, 2010 12:35 AM
  • It look like removing HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Messaging Subsystem\MSMapiApps::WmdHost.exe helps... Finally
    Tuesday, February 23, 2010 3:53 PM
  • Is that on Win7 32 bit or 64?

    Thanks
    Friday, March 12, 2010 4:44 AM
  • Windows 7 64 bit
    Windows Mobile 6 phone device
    Windows Mobile Device Center 6.1 64 bit
    Office 2010 Beta

    I have tried everything mentioned above without any change in behavior.

    The first time I sync after uninstall/reinstall WMDC, after clicking "OK" to error:

    There is no email program associated to perform the requested action.  Please install an email program or, if one is already installed, create an association in the Default Programs control panel.

    WMDC > Mobile Device Settings > Change Content Sync Settings tells me "Outlook has not been installed" for "Calendar" and "Contacts". (My phone receives email directly from POP3).

    Subsequent attempts to sync don't show the "Outlook not installed" but I cannot check the box for "Calendar" and "Contacts".

    I check the file association using Control Panel > Programs > Default Programs and .MSG and other email files point to "Microsoft Office Client Virtualization Handler" which seems to be the correct value for Office 2010 (.doc, .docx, .xlsx, etc. all point to Microsoft Office Client Virtualization Handler).

    I have run FixMAPI.EXE from the 64 bit location without change in behavior.

    Given I'm running a 100% Microsoft configuration and many others have the same problem, I'm surprised that Microsoft QA didn't identify this problem and get Microsoft Engineering to create a bug fix.  Not syncing Calendar & Contacts severely limits the usefulness of a Windows Mobile phone.

    Thanks

    Monday, March 29, 2010 5:31 AM
  • Cannot check “Contacts” or “Calendar” in Content Sync Settings of Windows Mobile Device Center.

    “Outlook has not been installed” appears when mouse over “Contacts” or “Calendar”

    Outlook 2010 beta installed on Windows 7.

    Help?

    Wednesday, March 31, 2010 1:03 AM
  • To anyone at Microsoft...

    I'm sorry, but I am beginning to wonder if ANYONE at Microsoft is paying attention. This has been a problem since at least the middle of last summer that I know of. It does not only show up when I run Mobile sync, it shows up when I try to run Genie backup and one or two other programs that I run on rare occasion and I getting more than just a LITTLE TIRED of it! This was not a problem on any other version of Windows that I have used until I got to Win 7 64 bit. I am very happy with the email program I have (Thunderbird) and I have NO intention of changing it. I would be happy if there was just a check box saying "Don't display this message again". This is not a problem that should have to be reverse engineered by a few of frustrated users, this is a Microsoft problem, fix it.


    I'm off my soap box now..

    Wednesday, March 31, 2010 5:20 AM
  • The solution is to uninstall 2010 Home and Office because it is only "Click-to-Run" and "Click-to-Run" has a bug that causes the "No email program" with WMDC.  I installed Office 2010 Professional and it works correctly.  Details:

    http://social.technet.microsoft.com/Forums/en/office2010/thread/e5c242dc-47ee-4c55-b9eb-867ad5762d68

     If your version of the 2010 Beta is Click-to-Run, not being able to sync your mobile device with Outlook is a known limitation of Click-to-Run.

    To check to see if you have Click-to-Run:

    1. Boot any 2010 app
    2. Click on the File tab
    3. Click on Help
    4. On the right side of the screen, if you see a section labeled "Click-to-Run Product Updates", you have it installed.

    Special thanks to Emily Kao Messmer of Microsoft!

    -jkk

     

    Friday, April 16, 2010 10:42 PM
  • I have the same problems.

    Receive always the message. There is no email program associated to perform the requested action. Please install an email program or, if one is already installed, create an association in the Default Programs control panel

    Though Outlook is the Default Program.

    My software versions are:

    Windows 7 Enterprise Edition 64-bit
    Microsoft Office 2010 Professional Plus 14.0.4763.1000 also 64-bit

    The phone does not get sychronized because of this problem.

    Greetings

     

    Friday, August 13, 2010 8:18 AM
  • Hello JKKAscension,

    Thank you for your post, it's the only one I have been able to find that actually provides a resolution to this issue.

    I fall 100% into the aforementioned issue: Did not know that the version of Office Home and Business 2010 that I was provide is "Click to Run", attempted to load and sync my phone by loading WMDC, received the "no email program associated..." issue, and have now lost all the contacts on my phone...But I digress... :(

    My question is on the next step you suggest:

    Situation: I've just purchased a computer and have also purchased Office Home and Business 2010 - I just activated my version of OHB 2010, had my Outlook 2007 filese migrate properly, and now I need to Uninstall OHB2010 and install O2010 Professional.

    My dilema is:  I've just "activated" my current version of OHB 2010 and to purchase and install Office 2010 Professional is, 1) more Office than I need for my business and 2) more $$$ to essentially upgrade.  What do I do here?  The product and price I want, I already have.  From what you are telling me, the only way to get my phone to sync using WMDC is to spend more money buying Office 2010 Professional and wasting systems that I'll most likely not use (Publisher and Access). 

    Any suggestions about what to do here?

    Thank you,

    John. 

    Saturday, October 9, 2010 10:37 PM
  • Here's the thing.  we use the WinMo devices in a warehouse to scan inventory.  No e-mail, no contacts, just inventory files.  We need to have the data sync from the device to the computer automatically upon the device being connected.  The only way I can figure out how to make that work on Windows 7 is with Windows Mobile Device center, and creating a partnership.  Again, no e-mail, no contacts, nothing but files.  How do I simply make this message go away?  I'm not going to install and set up outlook on the workstations in the warehouse, and I don't need to be getting support calls from the warehouse guys about setting up e-mail everytime they connect the device.

    Thanks,

     

    -Craig

    Wednesday, December 22, 2010 5:13 AM
  • Have anyone figured out this problem?
    I have recently seen this problem on a Windows 7 enterprise machine that don't have any version of office on it (I pressed the start button and typed "Outlook" and nothing came up beside the possibility on installing live essentials)

    This is a new PC that has just been installed.


    Ragnar Talgø
    Thursday, March 10, 2011 3:01 PM
  • Hi,

    If you are using Genie backup Manager and you keep getting this message, then please refer to the following:

    Make sure that you have the latest build 8.0.364.534 from Help -> About, you may download it from the following link: http://www.genie-soft.com/download/download.html

    If you still receive this message please refer to the following Knowledge Base article:

     http://www.genie-soft.com/asp/community/KnowledgeArticle.asp?KBID=147

    If the problem persists and Outlook is not installed, please go to Start -> Run -> type regedit -> and delete the following key: HKEY_CURRENT_USER\Software\Microsoft\Office\12.0, 11.0, 10.0, or 9.0 and delete Outlook key Please let us know what happens.

    I hope this was helpful :)

    Tuesday, March 29, 2011 8:19 AM
  • I'm in similar boat with the person that posted about warehouse inventory.  We use MC1000 devices to scan product and use WMDC to sync with windows7, then use an app on the mc1000 to ftp the data.  Closest solution I've found is after initial driver load of device you need to add this registry entry.

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows CE Services]
    "GuestOnly"=dword:00000001

    I then do not setup a partnership.  It seems that you'll still get a popup of WMDC but you don't need to click anything to allow the ftp program do its thing.  But if you plug the device into a different USB port the driver has to reinstall itself and it reverts the GuestOnly edit back to a value of 0.  So have to remember to change it back to a 1.

    Monday, April 4, 2011 4:37 PM
  • I also had to remove (rename) the key
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Messaging Subsystem\MSMapiApps::WmdHost.exe

     

    That is the key! (No pun intended!)  AAARRRGGHHH!  I've been trying to fix this for over six months.

    Thanks!

    Wednesday, April 6, 2011 12:29 AM
  • Thanks this did it for me.

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Messaging Subsystem\MSMapiApps::WmdHost.exe was the only one I needed to delete and it worked superb finally

    (I had 64 bit so I found it in HKLM\Wow64... instead)


    Ragnar Talgø
    • Proposed as answer by Rokke Friday, April 8, 2011 9:14 PM
    Friday, April 8, 2011 9:14 PM
  • Thanks Rokke,

    My Win 7 x64 no longer nags me about this (after a loooong time searching for a solution)!

    Microsoft really needs to remove this silly nag once and for all by default. No registry editing should be needed as I don't expect my Windows Live Mail and Windows Mobile 6 phone emails to synch - I use Hotmail on both so there's really no need.

    Monday, June 6, 2011 5:20 PM
  • Hi, i had a similar issue with Outlook 2007.  Outlook would start with the error message "There is no email program associated to perform the requested action"

    After clicking on the OK button Outlook would respond correctly.  Looking at Default file extensions was not very insightful as the current settings mimic another working computer.

    After investigation the FIX involved copying [HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\Microsoft Outlook] registry from another working computer.  The computer with the error message was missing all of the keys within this part of the registry.

    Regards

    JON 

    Monday, January 23, 2012 6:43 PM
  • This one worked for me. Windows 7 Pro x64 I followed all steps here http://www.wieser-software.com/topdrop/help/faq.htm#mapierr  and also changed 

    HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail

    to

    HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Windows Live Mail

    Rebooted the PC. Now every time i plug in the device, the message is gone and my device connects with no issues.



    • Edited by Pinkopanter Wednesday, April 27, 2016 8:28 PM
    Wednesday, April 27, 2016 8:24 PM