Cant download anything


  • i have windows 7 on my computer and everytime i try to download something i i click run and it downloads then nothing happends so then i click save and when its done i look for it and its not there, is there any way you guys can help me

    Sunday, June 14, 2009 4:51 AM

All replies

  • Maybe you are forbidden to run executable files from outside and even to save any downloaded files. Have you checked your security settings, permissions, and the like? Are you member of a domain?
    Mobile AMD64 3000+, VIA Apollo K8T800 chipset, 1 G RAM, ATIRadeonMobility 9700, 20x DVDRW, C:XPSP3 (55G),D:WIN7 (25G),F:DATA (250G)
    Sunday, June 14, 2009 1:11 PM
  • yes and i tried i cant figure it out
    Sunday, June 14, 2009 2:25 PM
  • Im on the phone with him also. He is not on a domain, just a straight install of windows 7 on the laptop. Not virtual Pc or anything. We have tried Firefox an IE. It downloads the file all the way through, then the file disappears from the computer. Both trying to Run the file, and Save it to vairous locations have been a no-go so far.
    Learning C# and WPF
    Sunday, June 14, 2009 2:32 PM
  • Hi Goat656,

    Sounds like you may want to try running Sysinternals' Process Monitor from \\\tools\procmon.exe.

    Also consider settings for security / AV software, etc. that may be affecting your ability to interact with files downloaded from the Internet.
    Sunday, June 14, 2009 5:41 PM
  • ok i dont know how to use this program, i dont see how it would help me download stuff

    Monday, June 15, 2009 2:42 AM

  • Hi,

    Mostly, the issue is caused by a third party software. Did you install AVG? If so, please try to temporarily disable AVG to test the issue.

    If the issue still persists, I suggest you test the issue in safe mode

    1. Restart the computer.
    2. Keep pressing the F8 key until the Windows Startup menu appears.
    3. Choose Safe Mode with network, and press Enter.
    4. Please test the issue in Safe Mode.

    Hope it helps.

    Monday, June 15, 2009 6:43 AM
  • The idea is not for the the program to (directly) help you download stuff; rather, the idea is for the program to help diagnose what the problem is.  Run the program, press CTRL+L to bring up the Filter dialog, add an entry for "Path contains <some file you intend to download> then Include", click OK, and attempt to download and run the file.  When you have done so, in Process Monitor press CTRL+E to stop capturing data.  Then, look through the events to attempt to determine why you are not able to run the downloaded file.  In the event you wish for assistance in this part, you can upload a file containing the captured events for others to examine.
    Monday, June 15, 2009 9:34 AM
  • ok im confused is there any other way to fix the problem
    Monday, June 15, 2009 2:30 PM
  • There certainly could be.  The steps I provided can help in diagnosing the problem more easily.  There really isn't a good way to automate them.  You could just run Procmon with no filter, capture all data, download and try to run a file, stop capturing, save the events to a file, and upload a file for others to check out.  It doesn't really get much easier than that, when using Process Monitor.

    However, if you are not comfortable with that, certainly consider the suggestion provided by Robinson Zhang.
    Monday, June 15, 2009 3:21 PM
  • Ok, He sent me his LogFile, and It says that It it is being Deleted..... If anyone has an email address, I can forward the file to you to evaluate it.


    Learning C# and WPF
    Monday, June 15, 2009 3:42 PM
  • I can be reached at my username here, at
    Monday, June 15, 2009 3:52 PM
  • Roger, I sent you an email with the attached file just now.
    Learning C# and WPF
    Monday, June 15, 2009 4:06 PM
  • Still awaiting the message, please double-check the address.  (Or, maybe I'm being impatient... :-/)
    Monday, June 15, 2009 4:51 PM
  • Can you verify your email please, just to be on the safe side...
    Learning C# and WPF
    Monday, June 15, 2009 5:15 PM
  • no.compromise shift_2 hotmail dot com

    Monday, June 15, 2009 5:36 PM
  • File received.  However, it would be most helpful to have the native PML file, rather than the .CSV.  Any chance of getting the .PML file, in ZIP?
    Monday, June 15, 2009 6:04 PM
  • The three "SetDispositionInformationFile" operations all indicate the file is to be deleted.  The stack of the events may provide some further detail as to the nature of the deletion.
    Monday, June 15, 2009 6:09 PM
  • Roger, Im having him send the file right now
    Learning C# and WPF
    Monday, June 15, 2009 6:34 PM
  • Received.
    I was able to reconstruct the stack of one of the SetDispositionInformationFile events using public symbols.

    It looks like IE's attachment execution services (AES) are responsible for the ultimate deletion of the file.  Please create a new user account and try downloading and running a file when logged in as that user.  (There are other things that could be tried such as resetting IE's settings, etc. but I think in this case a new user account will be the cleanest test .)

    You also mention that the same behavior occurs with Firefox. Of course, Firefox doesn't make use of AES, so in order to diagnose that it would be helpful to have a Procmon .PML file captured when following the same exercise, only using Firefox rather than IE.
    Monday, June 15, 2009 7:09 PM
  • You should have gotten the PML file already, hehe. If he didnt send it correctly...
    Learning C# and WPF
    Monday, June 15, 2009 7:13 PM
  • I did receive the .PML file and posted the previous post with additional suggestions and further thoughts.
    Monday, June 15, 2009 8:43 PM
  • ok i tried creating a new user but i still cannot download anything

    Tuesday, June 16, 2009 12:21 AM
  • Presumably, you are referring to downloading something with IE...

    How about capturing another trace in Process Monitor, while trying to download and run something in Firefox?

    Have you attempted Robinson Zhang's suggestion of trying to reproduce the behavior while booted into safe mode?
    Tuesday, June 16, 2009 1:49 AM
  • yes i have tried in safe mode and the same problem persists...i will do it in firefox and i will send you the logfile from that one later
    Tuesday, June 16, 2009 3:46 AM