Vista SP1 - "Not a Valid Win32 Application Error"



    Since installing SP1, I am regularly getting "Not a Valid Win32 Application Error" for various applications, including Office 2007 (Word / Excel / Outlook etc) which refuse to run.


    The problem is resolved by logging off and back on - reboot not required. (No other users logged on and system is fully patched on Windows Update etc)


    Any ideas?

    Tuesday, April 1, 2008 11:26 PM


  • Microsoft is aware of this issue and is working on a fix. As several people have observed, this is konwn to affect Excel 2007, Access 2007, Snipping Tool, and Windows Media Player on Vista SP1.   The fix is to either exit as many apps as possible that you are running (e.g. Outlook), and then load the app (and then you can reload the apps you had running), or a logoff/logon will clear it up for a while (days/weeks).  The error messages are confusing, but the problem is neither an invalid application file nor insufficient system resources.  It only affects certain applications, and typically only after the user has been logged in for an extended period of time.




    Monday, April 21, 2008 12:02 AM

All replies

  • Perform a Disk Cleanup and then Check your hard disk for errors.


    You can help solve some computer problems and improve the performance of
    your computer by making sure that your hard disk has no errors.

    Open Computer.

    Right-click the hard disk drive that you want to check, and then click

    Click the Tools tab, and then, under Error-checking, click Check Now. If
    you are prompted for an administrator password or confirmation, type the
    password or provide confirmation.


    To automatically repair problems with files and folders that the scan
    detects, select Automatically fix file system errors. Otherwise, the disk
    check will simply report problems but not fix them.


    To perform a thorough disk check, select Scan for and attempt recovery of
    bad sectors. This scan attempts to find and repair physical errors on the
    hard disk itself, and it can take much longer to complete.


    To check for both file errors and physical errors, select both Automatically
    fix file system errors and Scan for and attempt recovery of bad sectors.

    Click Start.

    Depending upon the size of your hard disk, this may take several minutes.
    For best results, don't use your computer for any other tasks while it's
    checking for errors.


    If you select Automatically fix file system errors for a disk that is in use
    (for example, the partition that contains Windows), you'll be prompted you to
    reschedule the disk check for the next time you restart your computer.



    Tuesday, April 1, 2008 11:50 PM
  • Hi,


    Looks like we're not the only ones suffering from this problem (mainly Excel).   Since rolling out SP1 we've had two machines develop this problem in the last week?   Might be a coincidence but it's looking less likely?


    Rebooting fixes - haven't tried logging out/in but suspect that will too?


    We've tried a complete uninstall of office, reinstall and full patching - but still get the same problem?


    Any other ideas?





    Wednesday, April 2, 2008 4:31 PM
  • Logging off and back on resolves it for me, at least temporarily which is precisely why I don't think it related to a disk error as outlined above. Also, SP1 is the only thing which has changed about the machine in the last week or so.


    Wednesday, April 2, 2008 5:56 PM
  • This is definitely an issue as I have it happening here for the second time, and it has only happened since SP1.

    (First time I tried office diagnostics, repair etc and finally a reboot fixed it.  This is todays diagnosis: )

    For me, I tried running as an admin, get the same issue.

    Opened in Windows debugger, get the same issue (Windows error 193).

    Then I opened sysinternals processexplorer and got an interesting error: insufficient handles.

    Looking in Task Manager and viewing all processes and including the handle count shows a task called CameraMonitor Application (vsnp2uvc.exe) which is currently using 471,229 handles, and is going up 2 handles a second.

    I am guessing this is for the built in web cam.

    Killing that and running Excel again, didn't make it run.

    Logging off and back on again enabled it to run.

    This is the second time this has happened, and I am wondering if the handle leak on another application is leaving Vista with insufficient resources to allow Excel to run?

    I.e. the issue maybe other software running badly on SP1.

    Just my guess.  Either way, the issue definitely happens, is definitely not a bad drive, and is fixed by logging out.
    Friday, April 4, 2008 5:12 PM
  • i did a clean instalation with windows vista sp1, and i don't have such problems, office runs good, thte installation run without no problems. everythink works good. Maybe it's only for the one who installed service pack standalone package.
    Friday, April 4, 2008 6:32 PM
  • And mine is a clean install of the SP1 DVD, not an upgrade.  Works 99% of the time for me too...
    Friday, April 4, 2008 6:57 PM
  • We have exactly the same problem since installing SP1. Excel is affected and the Snipping Tool, too.


    After one of those errors I tried to start Excel with administrative rights. The error message then changed to: "INSUFFICIENT SYSTEM RESOURCES EXIST TO COMPLETE THE REQUESTED SERVICE"


    So it is definitely a problem with resources.

    Monday, April 7, 2008 8:13 PM
  • Hi Martin,


    I stumbled on this thread trying to find a fix for this.


    I'm also having the exact same issue. It started after installing SP1 and in my case, I only saw the issue with Excel 2007. However, when this happened, I did not spend too much time trying other applications as I needed Excel badly and fixed the problem by rebooting. Problem keeps coming back I suspect a resource issue as it happens only after my computer has been running for a while (it is always turned on).


    Hopefully this is fixed soon. Its starting to seriously bug me. Always happens when I'm in a hurry to open a spreadsheet...


    Best regards,




    Monday, April 7, 2008 9:09 PM
  • Marco


    Here is another approach to resolving this problem. Perform the following.


    Clear the prefetch folder: C:\Windows\Prefetch.
    Delete all of the files in that folder, except the ReadyBoot folder.

    This article was writen for XP, but works for Vista as well.
    How to Clear the Windows Paging File at Shutdown:


    *NOTE: Clearing the page file with every shutdown will result in a slight delay when opening some programs, the first time, immediately after a reboot. 


    Also, if you are using different versions of Microsoft Office on the same system, you may see this same behavior. The fix is the same.


    Check to make sure that other 'exe' files are working OK on the system. If they are experiencing the same problem, the file association for that file type may have become corrupted. If this is the case, perform the following.


    Go to the following website. You will see a box with many file extensions. Click the 'exe' box to download the file. Extract the contents of the zipped file. Double click the extracted file to merge with the registry. This will reset the EXE file association back to the default.

    File association fixes for Windows Vista:


    • Proposed as answer by brightcomit Sunday, October 24, 2010 4:57 PM
    Monday, April 7, 2008 11:13 PM
  • I tried your solution but the error remains coming back.


    As already explained in this topic the error is most probably a resource leak in Vista SP1.


    Sunday, April 20, 2008 1:47 PM
  • Hello Ronnie,


    This fix does not work. I tend to agree with the others. This definitely seems like a resource leak or some kind of corruption that occurs after Vista has been running for a while. I never had the issue before SP1 and now, I get it on a regular basis. My filesystem and executables are in good shape and so are my file associations. As explained, a reboot will fix the issue, so this means (IMHO) that the issue is located "in memory" (i.e. something gets exhausted or corrupted after Vista has been running for a while or something particular happens. But it is not permanent.).





    Sunday, April 20, 2008 6:48 PM
  • Hello again,


    Actually, the problem is even more "localized" and "non-permanent" then I thought. As someone else said, login off and login back on also fixes the issue (at least, it did for me this time as this is the first time I try. Can't say if it will last as long as a reboot before it happens again). So, again, this does not appear to be related to any disk/file corruption or association problem.





    Sunday, April 20, 2008 7:00 PM
  • Yes. And by starting Excel with Admin-rights Vista itself names the cause: "INSUFFICIENT SYSTEM RESOURCES". On a machine with a lot of free memory.


    It seams there is some deep problem with resource management in SP1. All over the web similar threads are appearing since SP1 was published.

    Sunday, April 20, 2008 8:27 PM
  • Microsoft is aware of this issue and is working on a fix. As several people have observed, this is konwn to affect Excel 2007, Access 2007, Snipping Tool, and Windows Media Player on Vista SP1.   The fix is to either exit as many apps as possible that you are running (e.g. Outlook), and then load the app (and then you can reload the apps you had running), or a logoff/logon will clear it up for a while (days/weeks).  The error messages are confusing, but the problem is neither an invalid application file nor insufficient system resources.  It only affects certain applications, and typically only after the user has been logged in for an extended period of time.




    Monday, April 21, 2008 12:02 AM
  • Thanks for the update.

    Can you post a KB number when one becomes available?




    Wednesday, April 23, 2008 7:38 PM
  • You guys are not alone.  I am also getting "Not a Valid Win32 Application Error" as well with Vista Business SP1 on my office applications such as Word 07 and Outlook 07.  A reboot/logoff of course fixes the issue.  I often stay logged in and lock the machine.  As others point out this appears to amplify the occurrences.  Also around about the time it starts to happen Word 07 will cease to do in-line spell checks and will begin to act somewhat flaky.  This may or may not be related.


    Tuesday, April 29, 2008 1:10 PM

    This Office 2007 and Vista SP1 is the latest in the MIcrosoft Release It Before It is Ready Beta.

    SInce I downloaded SP1, Vista is even slower and now cannot open Excel or Word 2007 without getting

    :"Not a Valid Win32 Application Error" and having to reboot. Explain this to me, why can't Microsoft learn

    from ME, XP releases? They were too early and consequently a nightmmare. I got stuck with this Vista because

    someone could not deal with it. I am close to backing out to XP PRO.

    Friday, May 2, 2008 6:32 PM
  • We are seeing this on multiple machines with Vista SP1, with Excel 2007 and with the Windows CE 6.0 Emulator.

    We get it every 3-4 days - this is NOT an "extended period of time"


    Reboot does fix it, but rebooting every 3 days is a pain.

    Sue Wolber



    Friday, May 2, 2008 8:49 PM

    I has this same problem and went to the MS office 12 folder and right clicked on Excel.exe.  from there select the Compatibility tab and tell it to run under WinXP SP2 Compat. mode.   After doing that I launched fine.  After I launched it under compat mode, I removed the setting and it still worked....


    So...for me it was a simple fix.


    Good luck!



    Friday, May 9, 2008 1:47 PM
  • Another data point. Vista SP1 32bit on Intel Dual Core, 3Gigs of RAM. After a few days of going in and out of sleep, I get "insufficient system resources", but so far this only seems to affect Sys Internals process explorer (v11.3). I found this while trying to track down something that seems to thrash the disk drive for long periods of time. Of course, whenever I see this happening, I can't open process explorer due to the resources error. I though I'd be clever (after rebooting) and keep process explorer running all the time to try and catch it - however this morning I found that process explorer had "stopped responding" and now I can't start it because of the resources problem.

    The logging out/in fix works for me (thanks) but I'm looking forward to a real fix. This problem did not exist prior to SP1. So far, the only application that it seems to affect is process explorer - I haven't had any other app refuse to start due to insufficient

    Sunday, May 11, 2008 2:48 AM
  • I'm experiencing this same problem - running Vista SP1 with Office 2007 and the latest critical updates installed.  In fact, I just went through the fun of closing the multiple applications I had running and rebooting.  Lose about 15 minutes everytime I have to do that.


    This represents one of the reasons why my IT shop has not deployed Vista to any of our users.  I was hoping Vista SP1 was going to demonstrate better reliability and compatibility - and it has to some degree, but there is no way I'm deploying Vista to anyone with a problem like this.


    So, where is the patch for this issue?

    Wednesday, May 14, 2008 6:31 AM
  • TechGuy9876:  We're working on it, it's going through full testing right now and should be available in a few weeks if there are no issues found.


    In the meantime: You don't need to reboot, just log off and log back on. It's a per-user issue. That will clear it up if it's the same issue.  I realize it can be a pain and I'm not trying to minimze the issue at all, but the workaround is simpler/quicker than a full reboot.


    It hits different people in different time frames. It depends on how many apps you are running and how often you have loaded/unloaded them. 


    I appologize that it takes this long, but we'd rather not give you an update that had other problems/regressions, so we want to make sure it's fully tested, and that can take a few weeks in an environment as complex as this, as I'm sure you know.  

    Wednesday, May 14, 2008 4:38 PM
  • I have the same problem with Excel 2007 after Vista SP1 install. I also am using a USB flash disk as a ReadyBoost device. I was unsure whether the problem started after SP1 installation or ReadyBoost installation. When i removed ReadyBoost device after getting the error for Excel, it started working. I don't know whether this is a coincidence or not but it sure points to a misusage of RAM resources by Vista and/or Excel.

    Friday, May 30, 2008 10:04 AM
  • Just wanted to make a note that I am having the exact same issue on Windows Server 2008 Enterprise.
    Friday, June 6, 2008 5:12 PM
  • Brad


    Be sure to post the details on the Server 2008 forum.


    Microsoft TechNet Forums Home : General:


    If this post helps to resolve your issue, click the Mark as Answer button at the right of this message.
    This will help others who are having this issue find the answer faster.

    Ronnie Vernon
    Microsoft MVP
    Windows Desktop Experience
    Friday, June 6, 2008 5:32 PM
  • So, nearly 2 months have passed -- is there a solution to this issue?

    Wednesday, June 11, 2008 5:47 AM
  • John,


    It's been a month since you posted "we're working on it". Any idea when this problem will be solved or when a patch will be released?


    Wednesday, June 18, 2008 11:56 AM
  • It gets even better. I used to get "Not a Valid Win32 Application Error", but now I am getting this error:

    C:\Program Files\Microsoft Office\Office12\EXCEL.EXE

    This file does not have a program associated with it for performing this action. Create an association in the Folder Options control panel.
    Wednesday, June 18, 2008 2:14 PM

    I'd like to know as well.  Having to logoff and logon just to open a spreadsheet is ridiculous.  Any update as to when there will be a fix?
    Thursday, June 19, 2008 12:27 PM
  • We are finishing up testing and provided all goes well, should have it available in the next week or so.  We had hoped to have this fix available earlier this month but had a few more t's to cross and i's to dot in the final testing.  Nothing bad (no problems with the fix), just needed some additional runtime on some of the testing that we require prior to a broad public release.



    For the other error message about Excel - i think you get one message when you launch Excel directly and the other one when you just try to open an Excel xls/xlsx file.


    Sorry it's taking a while but it's better to make sure we don't introduce other regressions when we do a fix like this.




    Thursday, June 19, 2008 6:17 PM
  • Ok Cool. This is at least better news. Will this patch go out with new updates on the Microsoft Update site or will you post a direct download link to this thread in the forum?

    Friday, June 20, 2008 11:40 AM
  • I'm glad I am not the only one having the problem, and will try to wait patiently with you for a resolution

    Saturday, June 21, 2008 11:38 AM
  • In case this helps anyone out there or the folks at Microsoft.  My problem was fixed in regards to the "Not a Valid Win32 Application Error" and in my case I didn't have to wait for a MS Patch - I don't know if this applies to everyone else who is experiencing this problem but let me post my scenario and fix.


    My Longwinded Scenario and Fix (I hope it helps anyway):

    • I bought brand new DELL pc
    • Pulled out of the box and installed Office 2003 and then Office 2003 SP2, my USB wireless card and nothing else.
      I Went to Microsoft's update website and selected every update there was
    • All updates were installed but two failed (Office 2003 SP3 and IIRC - Silverlight)
    • I attempted several times to apply Office 2003 SP3 and every time the file was downloaded but the installation failed
    • I manually downloaded Office 2003 SP3 and attempted to install but that's when I first saw the message "Not a Valid Win32 Application Error"
    • I manually downloaded and attempted to install Silverlight 2 and received the same or similar error message about problems with the file
    • I downloaded Eset's NOD Antivirus and could not install either
    • I had trouble accessing my hotmail account and even Yahoo.com.  Several times I had to refresh the page because IE just would not load it or would give me a status of page loaded done but there was nothing loaded from the page
    • It dawend on me that this may be a network problem since the Silverlight and MSO SP3 files were not recognized to be signed by Microsoft (very unlikely scenario)
    • I went to download driver updates for my AirLink AWLL6080 300N Wireless USB Adapter and the containing ZIP file had problems so I was getting closer to a possible answer
    • I used my other computer to download the AirLink driver, installed it in my Vista machine and walla!!! 

      • I was able to run the updates through Microsoft's update site.

      • I was able to download/install Silverlight

      • I was able to download/install NOD antivirus

      • I was able to download/install flash player

      • I was able to access hotmail and the pages loaded


    After all these boring details I would suggest that if you are having trouble with the "Not a Valid Win32 Application Error" message, you check with your network card vendor for driver updates.


    By the way, I did try every other suggestion in this thread and my problem persisted after every attempt.


    I hope that what fixed my problem may fix yours as well.




    Jose Lopez

    Sunday, June 22, 2008 12:50 AM
  • Oh, just you wait.  It will come back.  It always does.


    Sunday, June 22, 2008 12:54 AM
  • Seem the quote from earlier:

    "Microsoft is aware of this issue and is working on a fix. As several people have observed, this is konwn to affect Excel 2007, Access 2007, Snipping Tool, and Windows Media Player on Vista SP1. "

    Its obviously an issue with the Windows 6 platform.  I also don't see any mention of the affected applications in your post.
    Sunday, June 22, 2008 3:23 AM
  • OK, to make this a bit more clear.  In my case, "any" executable or installer was being reported as "Not a Valid Win32 Application Error"


    I hope this helps.




    Jose Lopez


    [Edited Notes:]

    By the way, I AM NOT SUGGESTING TO IGNORE MICROSOFT'S FIX/PATCH - By all means, apply it.  All I'm trying to say is that this is how I fixed my problem while getting the "Not a Valid Win32 Application Error" message.  It may save some a few headaches out there "IF" the scenario applies to their situation.

    Sunday, June 22, 2008 3:58 PM
  • Jose:


    It's clear that you were getting this error message caused by a completely different reason.  The symptoms I outlined earlier are that the issue we found only affects a very specific set of apps and functionality.  I can't tell what was causing this error for you without additional debugging and troubleshooting, but I can tell that it's not the same issue as the fix we have forthcoming. 


    Here is an example using the tired car analogy: 

    A guy goes to a car repair shop and says "there is a loud sqeeking noise coming from under my hood".  The repair shop diagnoses the problem and replaces the fan belt, and that fixes it.  A few weeks later a friend of his says he has a loud squeaking noise as well, and the first guy says it's the fan belt, so the 2nd guy replaces the fan belt.  Not surprisingly, that didn't fix it because although the symptom ("not a valid Win32 application") was the same, the root casue was the bearings in the oil pump had failed and were about to seize.  


    I just want to show that just because the error message is the same, the root cause can be very different. In the case experienced by others, it is only Excel 2007 (and Snipping Tool won't load, and Windows Media Player says that it's not installed correctly, and a few other specific apps); it only happens after the user has been logged in for several days, and a logout/login will always clear it up if this is the cause. We konw that because we know exactly what is causing this to happen (and have the fix nearly ready for release).  In your case, you got the error loading lots of different apps and a logout/login didn't fix it. So something else was causing this error. 


    This error can be caused by either loading a file that isn't an application as an app (e.g. rename a .txt file as .exe and try to load it), or by a valid .exe getting corrupted somehow, either on the disk or when you are downloading it.  In the Excel 2007 case, because a logout/login fixes it, the .exe file on the disk is clearly fine.


    hope this helps make sense,





    Monday, June 23, 2008 5:06 PM
  • Should have tried turning the car off and back on.  Maybe it had been running for several days...
    Monday, June 23, 2008 6:10 PM
  • John,


    Thanks for your reply and the excellent analogy.  I'm sorry if I caused any confusion.  In my case it was definetly a wireless card driver issue that possibly wasn't handling the tcp packets correctly and once the file was downloaded to my machine it was somehow corrupted.


    Anyway, thanks for your hard work.


    Best regards,


    Jose Lopez


    Tuesday, June 24, 2008 2:40 AM
  • I am pleased to announce that the fix for the specific "Excel is not a valid Win32 Application Error" is now available for download.  More info and the download links are available here:




    Not that this update has several other fixes available in it also.


    This will be published on Windows Update as a recommended update for Vista users in July, but in the meantime you can download directly from the Microsoft.com downloads site.


    Thanks for your patience!  This should resolve this issue for those of you hitting it.





    Tuesday, June 24, 2008 5:00 PM
  • John


    Good work. Thanks for sticking with this .




    Ronnie Vernon
    Microsoft MVP
    Windows Desktop Experience

    Tuesday, June 24, 2008 8:30 PM
  • This update improves the reliability of Windows Vista SP1-based computers that experience issues in which large applications cannot run after the computer is turned on for extended periods of time.

    So this does not apply to Notepad and Remote Desktop Connection? Let's wait and see in a few days.
    Friday, June 27, 2008 3:22 PM
  • Thanks so much John for the direct link! I just had the problem occurring today only for the first time and went searching for a solution. Happy to have found one Smile

    Not going to wait till July!

    Sunday, June 29, 2008 4:37 AM
  • I tried to check if my hard drive had any errors and it wouldn't check. This was the error message I received:

    "Windows was unable to complete the disk check"


    I keep getting the same error message "not a win32 app"  , as well as my disk defragement not starting.  My computer recently started running slow and now some site won't work/load properly Help please!

    Wednesday, September 3, 2008 7:54 PM
  • Did this ever get fixed? I'm still seeing the problem here (vista ultimate sp1, 64 bit), and as far as I know I'm fully up to date on patches




    Friday, October 10, 2008 8:55 AM
  • As am I. SP1 Home Premium, 32bit, and it happens on and off with most applications (cmd.exe, calc.exe, notepad, and others). All up-to-date. This happens after only a day of uptime, and it's a new install.
    Friday, October 10, 2008 4:53 PM
  • I am also getting this error message. I tried downloading the patch but the response was that 'it didn't apply to my computer'. That must mean that the update is already there. 

    When trying to upload Adobe Photoshop Starter 3.2 I also get a message that this is a SONY RAW File before being told that the programme is not a valid 32 bit application.


    Just how do I install programmes that I need?



    Wednesday, November 12, 2008 9:56 PM
  • I began getting the error message (“not a Valid Win32 Application") about a week ago. It happens only with Excel.

    Logging off/on or rebooting doesn’t help.

    I too have tried several times to download the fix (http://support.microsoft.com/kb/952709) recommended by John Gray above at 6/24/08. It starts to install, and then I get a message saying that “this update doesn’t apply to your system”.

    I’m running Vista Business SP1 32 bit, on a Lenovo X61 notebook with 4GB RAM.

    Any suggestions will be greatly appreciated. Thank you.


    Friday, November 21, 2008 6:12 PM
  • what if a logoff or reboot does not fix the issue?


    Thursday, December 11, 2008 3:18 AM
  • Hey im using Windows Vista Home premium SP 1
    One day when i turn on my comp. all my shortcuts and launchers for apps,games and such were all documents which said:
    "This is not a Valid Win32 Win32 Application"
    Monday, December 15, 2008 2:11 PM
  • Hello,

    I've been getting this same error since I upgraded to Office 2007 but for me it only happens with Publisher. I have tried the fixes listed but none of them have helped the problem. Rebooting, logging out and in makes no difference. Is there any update for this problem occurring with publisher?
    Friday, March 27, 2009 6:22 PM
  • Has there been any update on the publisher specific Win32 application error? I have the same problem and have tried all the above but with no success. Would the advice be to reinstall SP1?
    Monday, April 20, 2009 11:34 AM
  • I have a (rather clumsy) fix which works for me anyway:
    Create a shortcut to the file you want to open. (You can keep it in the same place so it's always there ready).
    When you want to open the file, right click on the shortcut and select properties.
    Then select the tab Shortcut select "Open file location" and it opens fine.

    This doesn't work if you just try to open the shortcut or if you select Open file location from the right-click context menu of the shortcut. It only works if you do it as I suggest above.
    Saturday, May 30, 2009 10:11 AM
  • I am in a crisi as my businees relies on this and i have had the same problem but when i try installing the update it says this update is not suitable for your machine i am super desperate need for help and it will be greatly appreciated

    i am running vista home premium build 6.00

    kind regards,
    alex stella
    • Proposed as answer by matt_something Wednesday, December 23, 2009 1:52 AM
    Wednesday, November 18, 2009 9:50 AM
  • Here's an idea for all of you out there in cyber space......  instead of crying about this error why not just uninstall the virus called "Microsoft Vista" and go with a real OS such as "Windows XP"

    Microsoft really dropped the ball with Vista we all know it we have all read about it and yet y'all persist with using it.....  So instead of crying about it...  why not just download a new version of windows, coz it aint like 1/2 of you paid for it anyway.... find the missing drivers and run with XP and forget this Vista ____.

    And Microsoft do a better job at tech support since you have major market share with Office spread around the world as the leading software used in office places, schools and homes.  I mean why build in compression into a XLS\DOC file and make it a XLSX\DOCX file anyway.... if people wanted them zipped we would use WinZip to do it you fools.
    Wednesday, December 23, 2009 1:59 AM
  • Restarting the computer fixes the issue but that could be a temporary soution or workaround.

    No permanent fix so far!
    • Proposed as answer by Samyy--- Tuesday, January 19, 2010 1:06 PM
    Wednesday, January 13, 2010 5:49 PM
  • I wish people new how to fix things past giving cookie cutter answers. I'll tell you what causes this problem outside of your lame reasons of it not being a win32 program or a dare I say it "virus" or Corrupt file". Fact is when this error comes up its happening with every program a user tries to install. The problem is a previous program was installed before the one they user is trying to install that messed up the OS. 

    The fix? Restore to a previous point like yesterday. and start installing from scratch what you was working on. Make sure none of the downloads are from sites that have sub par programmers who have bosses who don't care if your computer works after they advertise the heck out of you.

    Simple logic...If one is able to install over and over then all of a sudden it stops working for ANY programs after then something that was installed before caused the problem. 
    Monday, January 18, 2010 10:02 PM
  • The fix? Restore to a previous point like yesterday. and start installing from scratch what you was working on. Make sure none of the downloads are from sites that have sub par programmers who have bosses who don't care if your computer works after they advertise the heck out of you.

    Simple logic...If one is able to install over and over then all of a sudden it stops working for ANY programs after then something that was installed before caused the problem. 

    Well, before I'm going to try such a rather desperate step, I would like to add my little cents to the problem. I have a brand new VAIO with Windows 7 Professional 64-bit, upgraded to Windows 7 Ultimate 64-bit. I wanted to install the latest version of TrueCrypt and I'm receiving this error. Before that, the error popped up with sevral other installations, but so far I found a workaround, e.g. by using the 64-bit version. I also have a Virtual PC (Microsoft) running Windows XP. BOTH OS show the same weird behavior and give me the "is not a valid Win32 application" error for TrueCrypt.

    None of the hints given here have worked so far. The first posting with "is not a valida Win32 application" I have seen in the Net ws from the year 2002... and here, the problem seems to be open since 2 years.

    So maybe deinstalling software or going back to "from scratch" might work. Thanks, BorealisPhoenix.

    Update: the problem (in my case) was related to the latest TrueCrypt version. I went back to version 4.3 and everything worked fine. Sorry for blaming Microsoft.

    • Edited by peppermind Wednesday, June 9, 2010 12:16 PM New info added
    Saturday, June 5, 2010 12:24 PM
  • fixing file association of .exe solved my problem :)
    Sunday, October 24, 2010 4:59 PM

    Since installing SP1, I am regularly getting "Not a Valid Win32 Application Error" for various applications, including Office 2007 (Word / Excel / Outlook etc) which refuse to run.


    The problem is resolved by logging off and back on - reboot not required. (No other users logged on and system is fully patched on Windows Update etc)


    Any ideas?

    yea im get this problem but this application i really need it is because i dont have this driver installed it found out by try my left 4 dead 2 when i load the map it crashed my computer to the blue page thing but when it loaded it have me install a driver but when i try to install it  said " R243820.exe is not a valid Win32 application  "  

    can i post to this or do i have to ask an question?

    Friday, October 29, 2010 1:23 AM
  • Hello,

    My aunt is having this problem.  She is only getting the error when she tries to open an excel document in her "documents" folder.  Can you tell me how to fix the file assocation.  I am not sure where to look to do this.



    Wednesday, March 30, 2011 2:09 PM
  • when ever i try to open a .png file it has the win32 application error. what do i do know?
    Saturday, November 19, 2011 6:02 AM
  • this error can be caused (I have found) by some additional things I have discovered on my XP SP3 machine (SP3 has some of Vista's features): I get this error when:

    • the application I am coding has an incorrect'y written manifest XML resource.
    • the application I am coding's manifext XML resource is written for a higher OS.
    • the application I am running is 64-bit and I have a 32-bit OS (32-bit apps will run on both 32 and 64-bit OS's)

    I am still learning about the whys and wherefores of this pesky error message so I can code my XML manifest resourcees correctly and make my applications cross-windows-version the way I want them to be.  I hope this is possible and I don't have to come up with one set of exe's and DLLs for vista+ and another set for 2000+...  these manifests are new to vista and beyond.

    Saturday, February 11, 2012 9:30 AM