none
Error 0xc0000142 - subinacl.exe (winsxslite) - Windows 7

    Question

  • Hi folks!

    Since my winsxs folder grew to the point of crippling windows by sucking up all available free space I gave winsxslite a try. (Yeah I know, it's just a bunch of hardlinks. Unfortunately windows explorer(?) is too dumb to know that ...)

    I got through pass one but then it's time to 'restore security' which fails because of subinacl.exe (The application was unable to start correctly (0xc0000142) ...).

    The only clue as to what's going on I managed to find is a post by wath

    http://social.technet.microsoft.com/Forums/en-US/itprovistasetup/thread/9411dbaa-69ac-43a1-8915-749670cec8c3?prof=required

    but unfortunately the given suggestions

    "Things to try: 1.Disable antivirus. 2.Reinstalling subinacl. 3.Safemode. 4.Check for hardware failures (mem/hd)."

    did not help me.

    In order to figure this out I made a fresh Windows 7 VMWare image, updated it and then tried again. It still does not work for me. Starting subinacl separately also results in error 0xc0000142.

    Please help me,

    NH365

    Sunday, May 16, 2010 12:02 PM

All replies

  • Have you tried disabling UAC and logging into Windows using your admin account - then run subinacl ?

     

    Monday, May 24, 2010 10:42 PM
  • Hi,

    I am in the exact same position as you. I just finished the Phase 1 scan and apply, then I restart and I get that same error when opening winsxslite and subinacl will not open and therefore I cannot restore the security descriptors. Which leaves me I suspect in a bit of trouble.

    Have you had any luck sorting this out?

    Sunday, June 20, 2010 4:16 PM
  • To answer this question as someone with the same problem, no unfortunately none of those suggestions help.
    Sunday, June 20, 2010 4:17 PM
  • There are a variety of reasons for this error there is no one ultimate solution to fix it. You will want to run the sfc command just to make sure you do not have any issues with the system files. From there a registry cleaner will be extremely useful to not only cleanup your registry but to verify the locations and pointers of all the DLL's to ensure you do not have other issues as well.

    Worst case if these solutions do not fix it then you will want to make sure you have a current backup of all your important information and reload your OS and then you applications. Making sure you run a registry cleaner afterwards to ensure you have a backup of the registry so that you do not have this issue in the future along with any of the multitude of possible issues you may run into with the registry.

    Because of the error and it being such a generic error (application error 0xc0000142) there is really not a lot to go on to help you troubleshoot the issue. But with some patience and running sfc and then a cleaner you should be able to resolve the issue with a minimum of fuss and be back up and running in no time.

    For more info click here.

    Monday, June 21, 2010 10:08 AM