none
Network Sharing Failure: Password Protection off still require password.

    Question

  • Windows 7. I have a desktop and a laptop that were installed clean with the same OS version.

    On a network, the laptop is able to stream my shared media to all other PC's on the network (one is running XP, another is running Vista). PASSWORD PROTECTED SHARING IS OFF

    On the same network, any PC that tries to network into the desktop is prompted to enter a password.

    The laptop is sharing folders on the home network from C:\. The Desktop is sharing folders on the home network from a second hard drive labeled E:\. The media on E:\ is mapped into the libraries (pictures, videos, etc).

    These are all of the things I have tried.


    - turned password protected sharing ON: prompts a password
    - turned password protected sharing OFF: prompts a password
    - Disconnected E:\ to share C:\ only: prompts a password
    - Set permissions to all computers on the network under Admin control: prompts a password
    - Allowed access through firewall: prompts a password
    - Disabled firewall completely: prompts a password
    - disabled wireless card and used LAN: prompts a password
    - used a completely different router: prompts a password
    - allowed sharing on E:\ in advanced settings: prompts a password
    - set permissions to Everyone on every single folder in E:\: prompts a password
    - banged head against the wall: prompts a password
    - raged: prompts a password

    Something to note: If I try to network into the laptop from the desktop, it too is prompted to enter a password for the laptop (this only happens from the desktop, it does not happen to any other PC on the network).

    Keep in mind that  the laptop and desktop were both wiped clean and installed clean with the same version of Windows 7. It is as if my desktop, for no reason whatsoever, is completely locked out of file sharing on ANY network. The exact same problem took place when I had Vista Ultimate installed.

    I have tried getting help with this from 4 different forums, and if nobody here can help me, I am forced to believe that my computer defies all logical troubleshooting and that the hardware refuses to share anything because it is infused with greed.

    This is what I see every single time, no matter what is done. http://i49.tinypic.com/2uqkcv7.png

    Cheers

    -Aaron






    Thursday, November 19, 2009 11:43 PM

All replies

  • Hi Aaron,

    Please help confirm the following information.

    1. If the 2 computers joined HomeGroup.

    2. If so, go to Network and Sharing Center, Change advanced sharing settings, check the setting "HomeGroup connections".

    You can test disable HomeGroup to see the result.
    Monday, November 23, 2009 10:08 AM
    Moderator
  • Hi Aaron,

    Please help confirm the following information.

    1. If the 2 computers joined HomeGroup.

    2. If so, go to Network and Sharing Center, Change advanced sharing settings, check the setting "HomeGroup connections".

    You can test disable HomeGroup to see the result.
    Just tried that and it didn't change anything.
    Wednesday, November 25, 2009 4:12 AM
  • Hi LightBarrier,

     

    Sorry for the delay in reply. I'm tests a lot these days on this issue.

     

    I noticed that when we turn off password protection, Guest account will be enabled in Computer Management. Thus turn off password protection should actually let customers using Guest account to access shared files.

     

    If you computer is Windows 7 Professional or above editions, please tests following steps on target computer (which shared files):

     

    1. Input GPEDIT.MSC in Start --- Search, start Local Group Policy Editor.

    2. Go to Computer Configuration --- Windows Settings --- Security Settings --- Local Policies --- Security Options. Find "Network access: Sharing and security model for local accounts", change it to Guest only - local users authenticate as Guest.

     

    Then turn off password protection, try of we can access shared files now. If still not, check following things:

     

    1. If Guest account is enabled on both computers.

    2. Try share a folder to Guest manually (add Guest account to permission list) to see the result.

     

     

     

    Wednesday, December 02, 2009 9:44 AM
    Moderator
  • Thanks Shaon, changing the local group policy setting worked for me. In my case this was just happening with Vista computers accessing Windows 7 computers (didn't happen with other Windows 7 computers).

    It was a bit confusing for people that in order for them to print they first had to open explorer and accessing a network share with a username and no password each time they start the computer before printing worked.

    Sunday, July 29, 2012 2:43 AM
  • I ran into same problem recently and the problem is rather simple. Windows namely does not allow you to log into another computers share, if your username is the same (but has different password) as exist in this another computer you are trying to access.

    So the solution is either you use same password for this username in both computers or you access the share with different user account with different username (username changing in windows did not work, as it kept the original username still somewhere and only changed display name for the user.)

    Simpler solution is using "Anonymous" username and empty password when the name and password thing jumps up...

    - Deemon


    Thursday, July 24, 2014 2:47 PM
  • Shaon - it is a 6 year old post.  But just stopped me from destroying another keyboard :-) Good on yah

    "Network access: Sharing and security model for local accounts" was on 'Classic'.  I was soo sceptical, but you were soo right.

    Friday, January 30, 2015 9:29 AM
  • This helped me, thank you very much.

    Regards.

    Tuesday, April 28, 2015 7:47 PM