none
Fix for continuous reboot after installing Service Pack 3 in Windows XP

    General discussion

  • After contacting HP Technical Support and speaking to a supervisor we were able to solve the problem of Windows continuously rebooting after installing SP3. Here are the steps that fixed the problem with my HP Pavilion running on an AMD processor. The steps are actually fairly straight forward and easy....

     

    Issue: The computer reboots continuously after installing Windows XP service pack 3

    Computer reboots continuously after installing Windows XP service pack 3 on AMD systems. The problem is that with some configurations, SP3 causes the computer to crash during boot, and Windows XP, by default, is set up to automatically reboot when it crashes. That is why you end up in the endless rebooting scenario.

    Cause:

    On HP computers, the same Windows installation disc image for Intel processor based PC's is deployed for the AMD processor based computers as well. Because the original installation image for both Intel and AMD is the same, all have the intelppm.sys driver installed and running. That driver provides power management on Intel-based computers. On an AMD-based computer, amdk8.sys provides the same functionality for power management.

    Symptoms:

    Ordinarily, having intelppm.sys running on an AMD-based computer appears to cause no problems. However, on the first reboot after a Service Pack 3 installation, it causes a big problem. The computer either fails to boot, or crashes with a STOP error code of 0x0000007e.
    You may not see the error code because the computer reboots too fast. In order to get the error message, you need to set an option during startup. To do so, open the windows advanced menu by tapping the f8 key on startup. Then select the "Disable automatic restart on system failure" option.

    Solution:

    If you have an AMD-based computer, however, you do not need the intelppm.sys driver and can disable it. There are three methods in order to do this.
    Step 1: Please try to log on the system in safe mode.
    1. While using Safe mode open the command prompt....  Start, All Programs, Accessories, Command Prompt
    Run the following command in the command prompt just like it's typed: sc config intelppm start= disabled

    Step 2:
    If the issue persists, please try to log on or boot the system in recovery console (refer to the web document)
    2. Using recovery console:
    If you booted into the recovery console, from a command prompt, type: disable intelppm

    Step 3: Please check in registry.

    3. Using windows registry:
    1. Run regedit
    2. Click on HKEY_LOCAL_MACHINE
    3. From the File menu, select "Load hive"
    4. Navigate to %systemdriver%\Windows\System32\Config on the dead system and select the file name System
    5. Name it something you can remember, such as "horked"
    6. Navigate to horked\ControlSet001\Services\IntelPPM
    7. Double click the Start value and set it to 4
    8. If you did what I did and completely messed things up by running a disk check previously, navigate to ControlSet001\Control\SessionManager. Open the BootExecute value and clear out the autochk entries.
    9. Repeat steps 6-8 for the other control sets.
    10. Reboot

    Reference:
    http://support.microsoft.com/kb/888372

    Additional information:

    Computer Restarts after Displaying Stop Error 0x0000007E (After Updating with Service Pack 3 for Windows XP):

    http://h10025.www1.hp.com/ewfrf/wc/genericDocument?docname=c01457284&cc=us&dlc=en&lc=en&jumpid=reg_R1002_USEN

    For future reference: Service pack 3 Installation steps:

    Before installing the service pack 3 update, please follow the steps listed above and save yourself much time and effort.

    To uninstall service pack 3, I suggest that you uninstall it from add/remove programs.

    Step 1:

    Uninstall service pack 3 from add/remove programs:

    1. Click Start.
    2. Select Run.
    3. Type appwiz.cpl in the run field.
    4. Click OK.
    5. Click change or remove programs.
    6. Select the program -service pack 3 that you want to uninstall or remove.
    7. Click Remove button.
    8. It will pop up the message stating that "Are you sure you want to remove the programs".
    9. Click Yes. It will help you to remove or uninstall the installed programs from add and remove programs.

    Step 2: If the issue persists, I suggest you to perform system restore and then try to install the service pack 3 after performing the steps mentioned above in regards to removing the intelppm.sys Driver.

    Using Microsoft System Restore in Windows Me and XP:

    http://h10025.www1.hp.com/ewfrf/wc/genericDocument?docname=bph07103&cc=us&dlc=en&lc=en&jumpid=reg_R1002_USEN

    Step 3:

    How to obtain the latest Windows XP service pack :

    http://support.microsoft.com/kb/322389/

    Steps to take before you install Windows XP Service Pack 3:

    http://support.microsoft.com/kb/950717/en-us

    I hope this helps someone who is having this problem. It sure took me a minute to get it all figured out. :0)

    Saturday, June 21, 2008 8:06 AM

All replies

  • What if you can't get into safe mode or any other mode? I can only get to BIOS
    Tuesday, December 08, 2009 3:29 AM
  • kudos to you sir...i had the same problem, and option number two solved it! have a nice day!
    Sunday, February 13, 2011 6:25 PM
  •  

     

    I was having the problem running an XP guest in Virtualbox on my HP notebook.

    My HP has an Intel processor but something in the virtualization was causing intelppm.sys   to bsod.

    Step 2 solved the problem.

    Thank you.

     

     

    Tuesday, August 23, 2011 2:11 AM
  • Still valuable advice, after all these years.

    I forgot this bug existed, and was trying to reinstall on a resurrected system.

    What a pain, 'til I found this, and smacked my forehead.

    Thanks again.

    Saturday, October 15, 2011 11:44 PM
  • Still useful as of 12/30/11. Have ten Lenovo 5042 computers with downgrade licenses to run XP and have a ghosted image from another Lenovo 5042 having and Intel cpu. My target computers all have AMD cpus in them and the image would continuously reboot on the AMD computers.

    Used method 1 and it cleared the problem instantly, many thanks for the post and the time and effort it took to dig up the answer..

    Friday, December 30, 2011 3:13 PM
  • Me too also having the reboot issue after install service pack 3 . However , I manage to fix it after uninstall the previous graphic driver in safe mode. After uninstall , my system is able to boot to desktop without any rebooting. After boot to desktop, I reinstall my graphic driver and everything went smooth without glitch. Hope it may help.
    Monday, March 10, 2014 10:20 AM