none
Fix for - Cannot access NAS Drives, \\Share\Folder is not accessible or "Error code: 0x80070035 The network path was not found"

    General discussion

  • Subject

    Cannot access NAS Drives

    Cannot access network attached storage

    Error accessing NAS

    \\Share\Folder is not accessible

    Error code: 0X80070035 The network path was not found

    Hi all,

    I fixed a stubborn networking issue and hopefully someone else can benefit from all the frustration I have experienced over the last few days.

    Some background. This was a workgroup network not a domain client/server.  Also, Windows HomeGroup wizards were not used - just accounts and passwords.  I have five NAS boxes for storage and backup. These NAS boxes use CIFS or SMB file systems. IP address are assigned through DHCP. It is a very simple yet secure workgroup net. Everything was OK then it hit the fan.

    I installed a new router after the old one failed. I powered down the entire network, cabled up and configured the new router. On my old Vista notebook PC all five NAS devices were OK. In Vista, Windows Explorer, I could access all the folders and files on all the NAS boxes.

    However on all the other systems, Windows 7 or Windows 8, I would get errors. In Windows Explorer I could see "\\MyNAS\Share\" but cannot navigate to it. 

    I would get an error:

    "\\MyNAS\Share\ is not accessible. You might not have permission to use this network resource. The specified network name is no longer available."

    Or

    "Error code: 0x80070035 The network path was not found"

    Another symptom of the error: I could not access the NAS admin pages through Internet Explorer on the Win 7 or 8 systems.

    I spent days trying all the fixes proposed in ALL the online search results, including many and various registry hacks, security policy changes, Windows Credential Manager changes, anti-virus and firewall removal, clearing and reregistering DHCP and DNS caches, Router and NAS reconfiguration and permissions, updating drivers and firmware, various command line tools such as ipconfig, netsh, hosts file modifications, reinstalling the TCP-IP stack, etc., etc. and ad-nauseam.

    The most popular suggestion by far was Network security: LAN Manager authentication level - change the authentication level to Send LM & NTLM - use NTLMv2 session security if negotiated (or the corresponding Registry Hack).

    None of it worked.  After much trial and error, finally, the only thing that worked for my situation:

    1) Network and Sharing Center - Change Advanced Sharing Settings

    Turn everything to OFF on all profiles and options - Save changes and close

    Then

    2) Device Manager - Network Adapters - Uninstall Ethernet and Wireless adapters - Action, Scan for Hardware Changes to reinstall these devices and close Device Manger.

    Then

    3) Network and Sharing Center - Change Advanced Sharing Settings - Turn everything to ON for all profiles and options - Save changes and close.

    NAS shares now work properly and I can access the NAS admin configuration pages.

    Now you can restrict some access by setting some of the Advanced sharing settings.

    So simple and easy after all...

    Good Luck!


    mdd

    Friday, February 22, 2013 5:37 AM

All replies

  • Thanks for your sharing.

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”

    Monday, February 25, 2013 8:00 AM
    Moderator
  • Excellent, similar issues and steps taken to remediate, but this worked.  Thank you for sharing!
    Monday, May 13, 2013 10:30 PM
  • I have exactly the same symptoms but what has been suggested here didn't work for me so any other suggestions appreciated as going insane;

    Had a Vista laptop, set up home network using my broadband wireless router and added a Western Digital My Book Live Duo NAS (4TB), installed everything and loaded content on to NAS and all working good... had to replace laptop due to failure, and so got a nice shiny Windows 8.

    On setting it up etc my WD MBLD NAS was recognised and installed and I can see the NAS referenced under my Computer group as a media share and can (using explorer) access folders on the NAS but I cannot add/update/delete etc as it's just as a media share.

    I can also see the NAS referenced under Networks but if I try to access it I get the same Cannot access network attached storage / Error code: 0X80070035 The network path was not found messages.

    Support from WD has failed to resolve, and I can access the NAS via other methods to play media etc so the NAS appears to be working correctly and WD have advised this must be a Windows issue... although my old laptop no longer perfect, it still partly functions and I can still access the NAS using it through the same network, running Vista so this also tends to suggest a specific OS issue or some other setting issue on my new laptop and no fault with the NAS itself?

    It is the same whether accessing wireless or Ethernet and I have tried everything that has been suggested by various forums so am now going insane with this... personally, although I am a no expert, I am wondering if this could be anything to do with Workgroup vs Homegroup - when setting it up originally I had Vista and so set workgroup across the router, NAS and Laptop accordingly which I have also done on my new laptop, but my new laptop also has Homegroup and I'm not entirely sure what the difference is and if there could be a conflict of some sort etc?

    I'm desperate and happy to provide any further information or config settings etc to anyone who may be able to help???

    Tuesday, May 14, 2013 3:20 PM
  • Hi networksareamystery

    I am having the exact same issue you are with your NAS drive and windows 8. I just upgraded to a new computer last week.

    Old computer can see my NAS, new computer can ping it, and access the media through a media share. But I can't actually access the drive.

    Did you ever solve your problem? if so how? I have scoured the internet and none of the suggestions are working for me.

    Thanks

    Friday, September 6, 2013 9:21 PM
  • Yes I did finally through trial and error, find a fix as I mention in my longish post in this thread.

    I did disable Windows managing the network through the Homegroup module. This can be found in other threads.

    Then:
    1) Network and Sharing Center - Change Advanced Sharing Settings
    Turn everything to OFF on all profiles and options - Save changes and close

    Then
    2) Device Manager - Network Adapters - Uninstall Ethernet and Wireless adapters - Action, Scan for Hardware Changes to reinstall these devices and close Device Manger.

    Then
    3) Network and Sharing Center - Change Advanced Sharing Settings - Turn everything to ON for all profiles and options - Save changes and close.

    NAS shares now work properly and I can access the NAS admin configuration pages.

    Good Luck! And let us know if you find a solution.

    Michael Downs


    mdd


    • Edited by michaeldowns Wednesday, October 23, 2013 4:15 PM
    Wednesday, October 23, 2013 4:14 PM
  • Michael,

    It worked not on my computer. The strange is that my Windows 7 laptop is ok but both Windows have the 0x80070035 error.

    Marten

    Thursday, December 12, 2013 8:21 PM
  • Hi,

    Many thanks for your posting on this nas drive issue, was helpful in directing me towards the underlying problem. I ran an unnamed auto-tune software on my Windows 8.1 laptop to try to improve performance, after which I could no longer connect to my WD NAS Drive. Googled to your posting on this page and started to follow your instructions.

    But before turning-off everything in the "Network and Sharing Centre" -> "Change advanced sharing settings", I noticed under the "Private (current profile)" -> "HomeGroup connections" section was set to "Allow Windows to manage homegroup connections (recommended)" which didn't look right. Changed this to the second option of "Use user accounts and passwords to connect to other computers", then logged-out and back in which appeared to have fixed the problem.

    Worth giving this a try first, before the more involved steps outlined above.


    • Edited by sarfrazulhaque Tuesday, December 24, 2013 3:27 AM Improved instruction highlighting.
    Tuesday, December 24, 2013 3:23 AM
  • Worth giving this a try first, before the more involved steps outlined above.

    This simple step worked as well. It is definitely worth giving it a go. I'm not entirely sure what the consequences of the setting is.
    Tuesday, December 31, 2013 1:29 AM
  • Michael,

    thanks for the hint, it worked. In my case was due to the "jumbo packet" setting. Reset to the standard made everything work again.

    Cheers

    Wednesday, January 1, 2014 4:51 PM
  • mmd you're a genius!  Many thanks worked perfect on my d-link NAs-320.
    Sunday, January 5, 2014 7:42 PM
  • I tried the steps above without success. MY problem is slightly different- Everything WAS working just fine, then windows did an automatic update. Now my mapped drives to a NAS don't work, and when I try to access the server, I get a "windows security" pop up asking for the network credentials. I type in the user name and password and it doesn't accept it. It says "User name or password is incorrect" which is not true... I have played with the registry, credentials manager, and now the above steps, none of which worked.
    Wednesday, January 22, 2014 10:33 PM
  • Have exactly the same problem with my IomegaEZ back up media but this did not solve my issue, my windows backup is now broken because my mapped drive to the NAS is disconnected. Any Solution Microsoft ? this came about when i updated painstakingly to windows 8.1 from the windows store and now its giving me more headaches.
    Monday, March 24, 2014 1:34 PM
  • Thanks, Sarfrazulhaque, this has (somewhat to my surprise) worked today on my Medion (Aldi) NAS drive and fully patched Windows 7. I don't understand why my system worked yesterday with the old setting and stopped today. Regardless, changing that setting to "Use User Accounts" from "Allow Windows to manage homegroup connections" has resurrected an otherwise (effectively) dead (unreachable) NAS drive.
    Thursday, May 1, 2014 12:05 PM
  • I have the same problem but unfortunately nothing here has helped.

    I had major problems installing the latest 8.1 update and HAD to do a refresh install of the original 8.1 to get the latest (KB2919355) installed then I get this problem, I can't see other devices in File Explorer or by using the \\device method. Other PC's on the network can be seen but my Synology NAS and Humax HDR only show under media devices when they used to appear under Computers as well.

    I notice there was no "Computer Browser" showing in Services and the browser.dll wasn't in the Windows/System32 folder. Copying that over from another Windows 8.1 updated PC didn't help.

    The CMD prompt net view no longer works

    sfc /scannow doesn't help

    Re-installing the network adapters Client for MS network doesn't help

    etc etc it's driving me mad!!!

    Tuesday, May 13, 2014 9:34 AM
  • This fix my problem

    1).  Run GPEdit.msc

    2).  Goto  Local Computer Policy -> Windows Settings -> Security Settings -> Local Policies -> Security Options

    3) Disable the following options ( arrow) , below

    4). Reboot de Machine

    Info: http://technet.microsoft.com/en-us/library/ff633425(v=ws.10).aspx



    • Edited by Stormbolie Tuesday, May 13, 2014 10:50 AM
    Tuesday, May 13, 2014 10:11 AM
  • Hi Stormbolie,

    Thanks for the tip but unfortunately it didn't work for me. I've tried several combinations of those GPEDIT network settings but none are working for me yet.
    Tuesday, May 13, 2014 3:06 PM
  • At last I found the cause of my problem, during a Windows Refresh some Windows features were turned off, make sure this is enabled:-

    Control Panel / Programs and Features / Turn Windows Features On or Off and make sure SMB 1.0/CIFS File Sharing Support is ticked

    • Edited by Bazzerby Thursday, May 15, 2014 8:39 AM
    Thursday, May 15, 2014 8:37 AM
  • Thankyou Thankyou and Thankyou sooooo much. This gave me months of misery and constant windows recovery to get it working again.  I finally succumbed to my agony called in a PC repair guy and after two hours he couldn't fix it.... I saw your post Michael ....and fixed the problem in front of the PC repairman.   He still charged me 1000 yen cheeky bugger.
    Sunday, June 1, 2014 10:39 AM
  • From: http://social.technet.microsoft.com/Forums/windows/en-US/140eddbc-cf3a-45e3-8bdd-fbb35cad9002/unable-to-connect-to-cifs-share-from-emc-celerra-with-windows-8-rtm?forum=w8itpronetworking

    1. Run PowerShell as Administrator

    2. Set-SmbClientConfiguration -RequireSecuritySignature 1

    Answer Y when prompted to confirm the modification.

    3. Set-ItemProperty -Path "HKLM:\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters" RequireSecureNegotiate -Value 0 -Force

    Thursday, June 26, 2014 12:47 PM
  • This simpler step worked for me as well.  Thanks for the post.  Definitely worth a try before uninstalling and reinstalling components.

    Thanks.

    Sunday, July 6, 2014 2:22 PM
  • >>>>>>>>>>>>>>>>>>>>>>>>>>

    ut before turning-off everything in the "Network and Sharing Centre" -> "Change advanced sharing settings", I noticed under the "Private (current profile)" -> "HomeGroup connections" section was set to "Allow Windows to manage homegroup connections (recommended)" which didn't look right. Changed this to the second option of "Use user accounts and passwords to connect to other computers", then logged-out and back in which appeared to have fixed the problem.

    >>>>>>>>>>>>>>>>>>>>>>>>>>>>>

    Worked perfectly.

    • Edited by SJP777 Sunday, July 20, 2014 1:44 AM
    Sunday, July 20, 2014 1:43 AM
  • Awesome! This has been bugging the crap out of me for a month. Your solution worked perfectly. Thank you very much :)
    Thursday, August 7, 2014 8:54 PM
  • Thanks! It miraculously fixed my problem!
    Thursday, September 11, 2014 1:22 PM
  • Thank you SOOOOO much. I was pulling my hair not being able to access my NAS files via Explorer. Followed your instructions and now it works. You saved my day. Thank you!!!
    Monday, October 6, 2014 9:26 AM
  • It worked like a charm !

    THANK YOU VERY VERY VERY MUCH for posting this !  I was tired of trying everything !

    Wednesday, October 15, 2014 9:37 PM
  • Thanks a ton. Saved my day. Your suggestion worked perfectly.

    In fact, first time, Windows 8 Pro did connect to network drives on a linux server samba shares perfectly. But, next day it kept on giving 0x80070035 error. I tried various things like changing workgroup name etc. Nothing worked except solution given above i.e., switching off private and guest/public options in advanced sharing (I did not touch items on all network part), uninstall and reinstall of network adaptor and turning on everything (as was initially).

    Incidentally, other suggestions mentioned in comments viz., use different credential and using 40 bit (my try) etc did not work for me.

    Friday, October 31, 2014 8:22 AM
  • One more thing. Here while not able to connect to a Linux Samba share, funny part was that I was able to ping the server, connect to Internet through the DSL model on the Linux server etc. but Network map was giving error 0x80070035. Very frustrating it was.

    Thanks to micaeldowns for the correct answer to the pesky problem.

    Friday, October 31, 2014 8:29 AM
  • This suggestion did not work for me while connecting to samba share on a linux server.
    Friday, October 31, 2014 8:38 AM
  • Solved:  I have spent at least 15 hours troubleshooting this problem of Windows 8 not connecting to a NAS that other computers can see.  I tried at least two or three dozen registry hacks, security profile changes, NIC tweaks, reformat & factory reset and many other things. What finally worked was Bazzerby's very simple:

    Control Panel / Programs and Features / Turn Windows Features On or Off and make sure SMB 1.0/CIFS File Sharing Support is ticked

    Monday, November 24, 2014 12:01 AM
  • THANK YOU.  I had been working off and on for weeks to try and figure out how to solve this problem   Your solution worked the first time.  For me, the problem started when I moved my laptop from an ethernet switch (same one as my two NAS boxes) to another room with wireless only.  All the other laptops in the house continued to work fine, it was just the one that moved from ethernet to wireless.  I hope Microsoft can fix this bug at some point.  Thanks again!
    Sunday, February 1, 2015 4:32 PM
  • Thankyou!

    I couldn't access my NAS shares via one PC this week. Thinking back, I'd updated the Network Driver at the weekend. These steps from the top of the thread worked instantly.

    1) Network and Sharing Center - Change Advanced Sharing Settings

    Turn everything to OFF on all profiles and options - Save changes and close

    Then

    2) Device Manager - Network Adapters - Uninstall Ethernet and Wireless adapters - Action, Scan for Hardware Changes to reinstall these devices and close Device Manger.

    Then

    3) Network and Sharing Center - Change Advanced Sharing Settings - Turn everything to ON for all profiles and options - Save changes and close.

    Tuesday, February 3, 2015 10:38 PM
  • Anyone setting up a NAS for the first time might have the same problem that I found myself with. Client for Microsoft Networks and File and Printer Sharing for Microsoft Networks has to be installed on one the network connections. It will be installed to all network connections automatically.

    To make sure you have these items installed Open Network and Sharing Center. Select Change Adaptor Settings. Right click Properties on the network connection you are using. On the Networking tab there should be a list of items installed to the network connection.

    If Client for Microsoft Networks and File and Print Sharing for Microsoft Networks are missing from the list, click install and install them. One is in Client and one is in Service I think.

    Once the items are installed you should see the NAS. You might need to reboot.


    • Edited by cam_joo Thursday, February 5, 2015 4:39 AM Fixed my bad english
    Thursday, February 5, 2015 4:37 AM
  • Anyone setting up a NAS for the first time might have the same problem that I found myself with. Client for Microsoft Networks and File and Printer Sharing for Microsoft Networks has to be installed on one the network connections. It will be installed to all network connections automatically.

    To make sure you have these items installed Open Network and Sharing Center. Select Change Adaptor Settings. Right click Properties on the network connection you are using. On the Networking tab there should be a list of items installed to the network connection.

    If Client for Microsoft Networks and File and Print Sharing for Microsoft Networks are missing from the list, click install and install them. One is in Client and one is in Service I think.

    Once the items are installed you should see the NAS. You might need to reboot.


    This fixed it for me. I was missing those components on my adapter settings for some reason. I installed Client for Microsoft Networks and it automatically installed File and Printer Sharing for Microsoft Networks as well and restarted computer.

    Thank you!

    • Edited by Raf1975 Sunday, February 8, 2015 4:51 PM
    Sunday, February 8, 2015 4:50 PM
  • Thank you Michael, unbelievable! I spent three days trying to make it to work but all failed, It worked after following your valuable instructions. You saved me, thank you again for your excellent contribution. 
    Wednesday, March 11, 2015 9:27 AM
  • The following worked for me.

    In Control panel, change view to small icons so you can see all options.

    Select Credential Manager

    Click on Windows Credentials button at top of the list

    You will now see 3 categories of credentials.

    On top:  Windows Credentials.

    In the middle:  Certificate Based Credentials

    On bottom:  Generic Credentials

    I found my NAS in "Generic Credentials" but my NAS is configured for windows based authentication. 

    So, I deleted the entry in Generic Credentials and created a new entry in Windows Credentials with my server name (no \\ just the server name) and an ID and Password that I had configured on the NAS.

    I presume this causes Windows 8 to send the credentials to the NAS in the same manner it would send to another Windows machine... which my NAS understands as it is configured to emulate windows shared folders.   My mapped drive immediately started working and I'm able to browse via UNC naming in Explorer to shared folders on the NAS.

    Prior to discovering this fix, the following workaround was my only option.  not ideal, but could be useful for testing purposes. 

    Start, type cmd and run as an administrator.

    Type the following: net use \\<nameofyourserver> * /user:administrator

    You will be prompted for the NAS administrator password.  after you enter it should say Command executed successfully

    Now, type Explore \\<nameofyourserver> and it will launch an explorer window pointing to the root shares of your NAS.

    This does appear to be materially different default behavior than in prior versions of windows.  Previously if you just attempted to navigate to a NAS by typing the UNC into the Address window of Windows Explorer, you would get a credentials prompt... save the credentials and it always worked.  Don't save the credentials and it would still work but would prompt you again after logout/reboot/timeout.

    In windows 8 it appears to attempt to authenticate via Generic credentials before attempting via Windows credentials.  My NAS apparently responds that is ok... or windows 8 assumes that it is ok... and then I get Win8 permanently attempting to use generic with that network name. 

    You can override via net use command... which will force a condition using windows credentials for the Explorer you launch from that command window... or you can fix it in credentials manager by deleting the Generic entry and creating an entry in Windows section.

    Now... this doesn't solve the problem if, for security reasons, you prefer to be prompted for credentials when connecting to the NAS.  For that reason I consider this a defect, especially because of the difference compared to how it works in Windows 7 and previous versions including Windows Server products.

    Good luck.

    Cheers

    Jeff

    Sunday, March 22, 2015 6:35 PM
  • Spent hours trying to fix this until I found your post. Great help. Thanks
    Wednesday, April 1, 2015 10:01 AM
  • oh!

    Thank you so much.. This problem was killing me and your instruction nailed it.

    Many tnx

    Thursday, May 21, 2015 7:04 PM
  • Hello,

    I have WD My Cloud 3TB. Everything is ok in Windows 7 and 8.1. I just switched to Win10 and there is a problem!

    I cannot connect to NAS at all. 

    I've tried your command:
    net use \\<nameofyourserver> * /user:administrator

    Strange things is :
    It passed and its visible if I type "net use". Command "Explore" is not present in Win10 - is not recognized as an internal or external command.
    I've add drive letter and it passed as well (net use p: \\<nameofyourserver> * /user:administrator) however it is not visible in my disk via explorer. 
    But I can access it and control it from cmd but this is not good for daily usage.

    I've found articles where this issue has been solved by enforcing communication only to SMB 1.0 (on some other WD NAS products) unfortunately WD MY Cloud dont have that optionon Web GUI. :(

    Any help or advice is more than welcomed !

    Sunday, July 5, 2015 7:43 PM
  • I just installed Windows 10 fresh from ISO after ½ year of running preview.

    On preview I did not have any issues browsing ny NAS, but after the fresh install I can not access the file shares at all. I get the errors described above and have tried all solutions without any luck.

    Help is very welcome!

    Wednesday, July 29, 2015 7:07 PM
  • Wednesday, July 29, 2015 7:12 PM
  • Tries for hours to get a server to connect with a desktop,Thanks A lot for the post followed the steps and had success with it working turns out that it was a port issue with the firewall. :)
    Friday, July 31, 2015 12:25 AM
  • 1. Run PowerShell as Administrator

    2. Set-SmbClientConfiguration -RequireSecuritySignature 1

    Answer Y when prompted to confirm the modification.

    3. Set-ItemProperty -Path "HKLM:\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters" RequireSecureNegotiate -Value 0 -Force

    This worked for me. Thank you John.Bevan!

    In my environment we only had to enter the first powershell command to be able to access CIF shares


    Tuesday, August 4, 2015 12:41 AM
  • At last I found the cause of my problem, during a Windows Refresh some Windows features were turned off, make sure this is enabled:-

    Control Panel / Programs and Features / Turn Windows Features On or Off and make sure SMB 1.0/CIFS File Sharing Support is ticked

    Thanks Bazzerby!  Finally something worked for me!

    Tuesday, August 4, 2015 7:23 PM
  • Thank you very much!!!
    Monday, August 10, 2015 6:07 PM
  • That was it! I had turned on the PIN and both of my NAS disappeared. I logged out, switched to using a password and everything is now visible under NETWORK.

    Thank you very much.  I have been fighting with this for days.

    Denis

    Friday, September 4, 2015 9:41 AM
  • THANKS IT WORKED!! Now I can see my synology nas again!!
    Friday, September 11, 2015 12:43 PM
  • This solved the problem of not being able to access the NAS from the this computer menu option. I was able to create new folder link targets under Network Locations.  However, my programs still can't access the linked network folders. for example if I want to save downloaded video from a camera through it's 3rd party software when I Brows locations the Network Locations don't show up in the option's menu as they did in windows 7.   
    Friday, September 25, 2015 4:20 AM

  • Oh, thank you very much, machaeldowns, I'd like to add that your method works in Windows 10 too.
    Monday, October 19, 2015 7:35 PM
  • All the solutions described here didn't work for me.

    I'm using Windows10 Ent x64 and I can't even see the SynologyNAS in my network, but I can access is via any web browser.

    My solution is:

    1. Go to Control Panel>Network and Internet>Network and Sharing Center> Advanced sharing settings.

    2. Remove the check box from [Turn on automatic setup of network connected devices.

    Viola! Your NAS appeared on your network!

    Regards,
    Ali Tweel

    Thursday, October 29, 2015 11:58 AM
  • Hello Michael,

     Although this solution is 2 years old.    I use it  today and I was able to fix this issue. 

    Thanks 

    Sunday, November 8, 2015 9:55 AM
  • This great fix works on Windows 10 TH2. Thanks!
    Sunday, November 22, 2015 5:05 PM
  • Another thing that worked for me was simply resetting WinSock. That freed up the Synologys in both my Win 10 machines.

    Running cmd as administrator: netsh winsock reset

    Hat tip: Geeks In Phoenix

    Thursday, January 14, 2016 9:29 PM
  • All the solutions described here didn't work for me.

    I'm using Windows10 Ent x64 and I can't even see the SynologyNAS in my network, but I can access is via any web browser.

    My solution is:

    1. Go to Control Panel>Network and Internet>Network and Sharing Center> Advanced sharing settings.

    2. Remove the check box from [Turn on automatic setup of network connected devices.

    Viola! Your NAS appeared on your network!

    Regards,
    Ali Tweel

    Spent hours and tried many fixes. Just about to reinstall Windows and tried this.

    Worked perfectly. Such a simple fix... Thanks.

    Friday, January 22, 2016 6:37 AM
  • This fix worked for a Oppo BDP-103 unable to see networked shares with a Windows 7 Enterprise PC connected to the network.

    The Oppo BDP-013 now sees the content shared over the network. The network chip on the Win 7 Ent box is a Realtek 8111E

    Monday, January 25, 2016 3:02 PM
  • Thank you for the post, however, my solutions was stupidly simple....change the workgroup name to my home networks name, and it worked!

    I was blaming the firmware update I had recently applied to my Buffalo NAS

    Wednesday, February 10, 2016 1:31 AM
  • As others have noted this fix works.  I installed a new Brother printer today and something in the set-up affected my ability to connect to my DLink NAS.  After trying many other supposed fixes, I found michaeldowns' post.  It worked like a charm.  Can't thank you enough!!! 
    Friday, February 12, 2016 11:03 PM
  • I suddenly had a problem on all PCs running Windows 10 accessing a NAS drive on my home network after everything had been working for over a year.  Existing maps to the drive stopped working as did trying to Map the drive and I tried but failed with all of the solutions offered here and on other forums.  What finally worked for me was to add an entry to the Host. file as follows:

    1. Click Start , click All Programs, click Accessories, right-click Notepad, and then click Run as administrator.
    2. Open the Hosts file in your "Windows/System32/Drivers/etc" directory to add an entry to map a name to the IP address of the NAS drive e.g. MyBookLive         192.168.1.174
    3. Click Save on the Edit menu, making sure it doesn’t save with any file extension

    Subsequently, I was able to use the name successfully to map the drive and my existing maps started to work on all the connected machines after I updated my main laptop.

    I was getting the errors mentioned above in the original post:

    Error code: 0X80070035 The network path was not found

    Missing Winsock protocols.

    I hope this saves others from many wasted hours!


    Thursday, March 17, 2016 8:15 AM
  • CIO_Chas, many thanks !!!

    I could access NAS over LAN but not over WIFI on win10 laptop. Adding local IP to host file fixed the problem. 

    Sunday, March 27, 2016 7:56 PM
  • You sir are a legend. I have struggled with this for MONTHS!!!! You just saved so much grief Thank you so much!!
    • Edited by Macrohard_ Friday, April 1, 2016 9:25 PM
    Friday, April 1, 2016 9:25 PM
  • Hi All,

    The fix for me was quite simple and quick.

    Windows 10 for whatever reason changed the network location type to public, this blocked all access to the NAS drive.

    Simply changing the network location to private resolved the problem.

    Hope this helps someone else!

    Friday, April 8, 2016 8:20 AM
  • Success!

    My Window 10 bare-metal install in May 2016: thoroughly blew away my QNAP connection.  Until this article I could find the exact solution.  Thanks for taking the time and effort to get this published where everyone can benefit.

    Here is the specific info that worked:

    "1) Network and Sharing Center - Change Advanced Sharing Settings

    Turn everything to OFF on all profiles and options - Save changes and close

    Then

    2) Device Manager - Network Adapters - Uninstall Ethernet and Wireless adapters - Action, Scan for Hardware Changes to reinstall these devices and close Device Manger.

    Then

    3) Network and Sharing Center - Change Advanced Sharing Settings - Turn everything to ON for all profiles and options - Save changes and close.

    NAS shares now work properly and I can access the NAS admin configuration pages.

    Now you can restrict some access by setting some of the Advanced sharing settings.

    So simple and easy after all...

    Good Luck!"


    • Edited by Wileymm Wednesday, May 18, 2016 5:36 PM Grammar
    Wednesday, May 18, 2016 5:35 PM
  • Hello @ all

    I had quite an issue wit my QNAP NAS and tried to find a fix for that. It is working again since yesterday, but unfortunately, I cannot explain it. I will post what happened just to state that sometimes it needs time and that WIN 10 seems to be very crude sometimes - hoping someone will take care for such issues in the future.

    I have an x64 WIN 10 System running that worked with my QNAP NAS TS-253 Pro quite fine for about 10 months. The NAS itself was used before with the same PC using x64 WIN 7. It was updated to WIN 10 in August, 2015. It is also still used with a x64 WIN 7 Laptop and an ARM WIN 8.1 tablet. Two weeks ago after having worked with the x64 WIN 10 System and the NAS I suddenly could not connect to the NAS anymore for whatever reason. The firewall had no blockings, I could not ma any folder and I even could not ping the NAS from the WIN 10 system while it was working properly with the WIN 7 and WIN 8.1 systems. I even could ping all systems from all other systems, only WIN 10 could not see the NAS. I tried hard to find out what is going on starting with the error message described in this topic and could not find any working solution. I tried all of the above described ones and none worked till Wednesday this week (May 25th, 2016). I finally gave up and thought about re-installing the whole system. But I did not start at once, as there was a bank holiday in Germany and I got a visit from my parents and spent time with my family. My father then asked me to copy some data yesterday and this was the first time I started the WIN 10 system again since Wednesday.... guess what happened: Everything was suddenly working again. I have no idea what happened in the depths of this system but I suppose it is quite weird.

    So, this post might not be a real help. I just wanted to put it down, because I do not trust the WIN 10 system anymore. I had some issues in a while, e.g. with the start menu. And I have to buy a new system in the future for business reasons - and in fact I try to get a WIN 7 system at the moment. I hope WIN 10 will improve in the future, but what happened the last two weeks would have been killing me if it would have been my business computer as I am self-employed.

    So, this is more a message to Microsoft to maybe get the things right WIN 7 was pretty ok as with some other OSes before as well, but WIN 10 sometimes still feels like a Beta to me.

    Cheers and good luck to all others haveing troubles :-(

    Sunday, May 29, 2016 7:58 AM
  • My PC was running Win7 with two user accounts. I upgraded to Windows 10 and initially used a Microsoft Account logon password for each account. I had no issue accessing the NAS drive from either user account. At some point I changed from an MS Account password to a PIN for each account. I then found I could access the NAS drive only from the account that first logged on after a restart. The other account could not access the NAS drive.  The error showed up as "path not found" or "missing protocol" , or as a "Winsock" issue.

    Using the solutions above (as well as others found) would appear to solve the problem but only until I switched from one user account to another when the problem would again occur. After changing both accounts from a PIN log on to passwords I've not had any issues in accessing the NAS drive from either account.

    While this is not a universal fix, it's worth trying if you are using a PIN to logon.

    P.S. --> MICROSOFT this is your issue.

    Sunday, May 29, 2016 10:02 PM
  • My issue is with Windows 10's networking. 2 of my machines run an older operating system (OS/2)...  On my Windows 7 machines and my Windows 8.1 machine, utilizing the resources on those 2 machines is not an issue... Never has been.  On this, my only Windows 10 (pro, insider build) if I choose to log in "Locally", I can see and access all the resources on the OS/2 machines.  However, if I log in with my Microsoft account, I can still "see" the machines listed but cannot access either one or any of the shared resources on them.  Both Local and Microsoft log-ins have Administrator privileges and the line-up of the networking protocols is identical. IPv6 is disabled on all machines and it's not a "Server/Client" environment; merely shared drives/directories. Can anyone point to where the problem lies?

    Summary: Local log in <> older machine resources available  Microsoft log-in <>older machine resources not available "Network path not found" 

    The machines DO appear in my HOSTS file and they do answer Ping. Drives cannot be mapped though when in Microsoft log-in mode.

    Monday, June 20, 2016 4:57 PM
  • I have tried all the solutions kindly given on this site. None worked for me. Meanwhile I found a solution, probably the simplest one: I turned out during 15 seconds the electricity feeding the device my NAS was connected to. It could be your switch, your hub or your router if this one is combined with a switch. To be very clear, I am talking about de device to which you connect your NAS with the ethernet cable. That's all. It works like magic. Simple to try at first.

    I allow myself to ask people publishing on this or other forums, to say precisely what solution has worked for them. Most don't refer to the person who has given the solution. They just say something like "Thank you, it works for me" but one cannot tell out of this what solution they are talking about among the many given by many people.

    Sunday, July 10, 2016 10:31 AM
  • thanks! 
    Tuesday, August 16, 2016 12:21 PM
  • I have a Seagate Nas 220 drive & a fresh  Win 10 reinstall. I bought a new SSD and installed a new copy of Windows

    Before the new install the drive was fine until one drive failed. I went to the store to buy a new Samsung SSD  and I bought a Toshiba 1 TB drive. I was told that the HD replacement didn't have to be a Seagate. I'm second guessing that now but on to my issue.

    Like others after bring up the Black Armor Discovery software I can't map a drive. "No network name found". I performed all the Net turn ons & offs and the Device Manager card removal/ reinstall. Plus the Private tweak of following user accounts. Still no change. 

    When it's working, and typically after you activate the Armor software,  you'll see 3 folders in the window- Public, Download & Wiki. Ever since I reinstalled the armor software I can't see the folders or connect and map a drive.

    Any ideas?

    Thanks

    Saturday, October 1, 2016 1:11 PM
  • 9 October 2016

    I have a Windows 10 Laptop fully updated on a wireless network with an old Zyxel NSA221 connected directly to wireless router. I could see the NAS on the network but got the error that I didn't have permissions to connect. So I turned off all sharing permission for the network. I didn't delete and re-add my adapters. I turned on all sharing permissions and it worked!! I can see my shares again.

    Well done Michael. This worked a treat!

    Turtle

    Sunday, October 9, 2016 8:29 AM
  • Another one worked for me:

    Open your hosts file in C:\Windows\System32\drivers\etc. Ad the IP and name of the NAS or PC that you can't reach, like this:

    192.168.178.40 INTNAS

    Save your host file (sometimes reboot is needed). It worked on several machines for me.

    Regards, lex

    Thursday, October 13, 2016 1:53 PM
  • Thanks so much for sharing; yours was the only answer I found online to help me with this issue.

    I spent up to 5 hours trying to find a solution online, including on LACIE.com site as this was my network storage device. Also, I am going to suggest to my provider at Telus that they should advise people of this possibility when a modem is changed or upgraded!

    Thanks Again!

    Sunday, October 16, 2016 6:08 PM
  • Thank you for sharing, I spent 2 hours with this issue. And your answer was the unique that works for me.

    Regards

    Wednesday, October 26, 2016 7:25 AM
  • While I did all these steps (and some of the others suggested), it did not initally appear to work.  However I examined my Hosts file (as susggested elsewhere in this forum).  I discovered that I had an old entry for this share drive that had an incorrect IP address.  I simply removed that entry altogether since it was not really necessary.  I can now connect to the drive again.

    So I would recommend that folks take a look at the Hosts file along with these steps suggested here.

    Tuesday, November 8, 2016 2:38 PM
  • My obscure solution - not seen here.

    After trying dozens of solutions mentioned here, there, and everywhere I finally hit on a solution that worked for me. It worked to fix a Windows 7 system and to fix a Windows 10 system.

    It requires a simple change in the registry.

    Look at two sets of registry keys. This after the fix:

    ***

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\NetworkProvider]

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\NetworkProvider\HwOrder]
    "ProviderOrder"="RDPNP,LanmanWorkstation,webclient"

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\NetworkProvider\Order]
    "ProviderOrder"="RDPNP,LanmanWorkstation,webclient"

    ***

    This before the fix:

    ***

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\NetworkProvider]

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\NetworkProvider\HwOrder]
    "ProviderOrder"="LMIRfsClientNP"

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\NetworkProvider\Order]

    ***

    Your correct values may vary, but for me "RDPNP,LanmanWorkstation,webclient" is correct.

    Notice before the fix the value on one key is "LMIRfsClientNP" and the other is empty. Now that I know this I see a number cases where "networking software/apps" have corrupted these keys. In my case "LMIRfsClientNP" is part of the LogMeIn package. Both of the broken machines did indeed have LogMeIn installed, then removed, recently.

    I discovered this using Autoruns (Unhide Microsoft and Windows Entries) and looking at  Network Providers.

    To determine what is correct, maybe look at a working system in your environment that is configured as alike as possible.

    I wasted many hours trying to find this solution and hope it helps someone else.

    Also, I second the motion from Roland-s. If something works for you please specify WHICH solution works. Letting everyone know your a happy camper and not sharing which proposed solution helped out makes other campers even less happy than before.

    ogst

    Tuesday, November 15, 2016 6:15 PM
  • Thanks so much

    Started fiddling with etchosts but found your post and went straight to your suggested answer and it worked straight off.  Didnt even need to reboot.  

    Probably also solved my other niggle with my NAS where wizard couldnt find the NAS so I had to hard code the ip address

    Thursday, December 15, 2016 2:58 PM
  • please note my problem as per my reply wasnt actually NAS access because I found a workaround, it was access another windows 8 pc that used to be accessed fine then seemed to stop.

    Removing the drivers seemed to crack it

    Thursday, December 15, 2016 3:01 PM
  • Thanks for sharing. Worked like a charm for me.
    Monday, December 26, 2016 8:23 PM
  • Worked Great! Thanks for sharing (I realize it's 3 years later).
    Friday, January 27, 2017 11:30 PM
  • Yes!!! this fixed it! 1 million thank yous!!!
    Saturday, January 28, 2017 11:41 PM
  • Awesome, thank you Bazzerby. Enabling SMB 1.0/CIFS in windows features allowed me to map to my Buffalo LS210D NAS with Windows 10. After trying 50 other methods that did not work.
    Saturday, February 11, 2017 8:24 PM
  • MDD - Thanks for the tip, it worked on my Win10 computer

    CHLLC

    Thursday, February 16, 2017 2:00 PM
  • THANKS YOU SO MUCH. SOLVE MY PROBLEMS.

    Friday, March 3, 2017 5:18 AM
  • Worked perfectly thanks for sharing this information very helpful

    Friday, March 3, 2017 11:40 PM
  • Stormbolie

    This fixed my issue. Once I disabled the digitally sign communications, I was able to connect to my NAS.

    Thank you


    • Edited by grasshope Tuesday, March 14, 2017 3:29 AM
    Tuesday, March 14, 2017 3:28 AM
  • Thanks so much for this solution michaeldowns! In fact, the second time I had to fix this, I tried using only point 2) of your solution (Device Manager - Network Adapters - Uninstall Ethernet and Wireless adapters - Action, Scan for Hardware Changes to reinstall these devices and close Device Manager) and this worked for me. I don't know if this simplified method would work for everyone though.
    I'm using Windows 10 Home, 64-bit version 1607.

    • Edited by Great Southern Tuesday, March 14, 2017 9:30 AM additional info on Win version used
    Tuesday, March 14, 2017 9:28 AM
  • Thank you SO MUCH! I have had the same issue with 2 NAS servers that I since installing a new router suddently could not connect to from one of my computers.

    Tried every suggestion everywhere, and did try uninstalling ethernet and wireless adapters with no result. However, following your guide worked! I am so greatful :)

    Tuesday, April 18, 2017 5:09 PM
  • Thanks for this!  It worked on my Windows 10 Pro system like a charm!
    Saturday, April 22, 2017 4:57 PM
  • Adding the <g class="gr_ gr_11 gr-alert gr_spell gr_inline_cards gr_run_anim ContextualSpelling ins-del multiReplace" data-gr-id="11" id="11">ip</g> address to the host file also fixed this issue for me.

    Thanks guys

    Wednesday, May 17, 2017 7:36 PM
  • Another answer is when "Windows is managing network folders", instead, the computer (not the NAS) should be set to allow manual username/password settings.

    the steps can be found here:

    https://support.microsoft.com/en-us/help/318030/you-cannot-access-shared-files-and-folders-or-browse-computers-in-the-workgroup-with-windows-xp

    Tuesday, June 6, 2017 4:58 PM
  • At last I found the cause of my problem, during a Windows Refresh some Windows features were turned off, make sure this is enabled:-

    Control Panel / Programs and Features / Turn Windows Features On or Off and make sure SMB 1.0/CIFS File Sharing Support is ticked


    YES! The solution in the original post didn't work for me (in Windows 10), however this one did! I recommend anybody to try this solution first - one tick of a check box, and all my frustration was gone in a flash! :)
    Wednesday, June 14, 2017 10:21 PM
  • Thank you. I had to do a clean reinstall of Windows 10 Pro and then Windows 10 would discover the NAS (Qnap TS-251+) however would not display any files or folders. I added the NAS to the hosts file and no reboot - the files/folders appeared. Glad I found your tip or I would have spent hours fighting with this. 
    • Edited by Errol_T Friday, June 16, 2017 3:14 AM Missed some details
    Friday, June 16, 2017 3:11 AM
  • this just happened to me on our Windows 10 Home system.  Curious if you ever found a solution. Interestingly it still works from my Windows 7 and Mac Book Pro.

    Friday, June 16, 2017 8:37 AM
  • Thank you very much for taking the time and effort to write all this down. I followed your instructions and it worked like a charm!
    Thursday, June 22, 2017 6:46 AM
  • Hi CIO-Chas, i was getting pretty upset that all the myriad solutions presented here didn't do a thing for our problem. Your trick worked even more than a year later. Should have thought of the trick myself. Thanks again!

    Tuesday, July 4, 2017 8:43 PM
  • On Buffalo LinkStation, even with latest firmware, It still needed SMB 1.0 enabled in Windows Program Features or you can not map the drive or use Computer Browser.  So, this suggestion does work, although it can open risk to your machine since SMB v1.0 has vulnerabilities.

    Control Panel / Programs and Features / Turn Windows Features On or Off and make sure SMB 1.0/CIFS File Sharing Support is ticked

    Verification - Disabled and Rebooted, and No Drives could be mapped.  Enabled and Rebooted, Drives can be mapped.  


    Friday, August 11, 2017 8:57 PM
  • I also had a problem where WindowsXP machines couldn't map a drive to a QNAP share.

    The Windows 7 machines would connect without a problem. I could connect with WinXP if using the IP address of the QNAP, so it seemed to be a DNS problem.

    The issue was finally fixed by setting the time the same across all devices.  Somehow they got out of sync, and NTP settings cured it. (Samba domain controller as a virtual appliance).

    Thought I would share my findings.

    Graham

    Saturday, August 19, 2017 12:59 AM
  • Michael,

    thanks for the hint, it worked. In my case was due to the "jumbo packet" setting. Reset to the standard made everything work again.

    Cheers

    __________________________

    I installed an amazon USB 3.0 Gigabit Ethernet adapter (AX88179) and could no longer access my WD MyCloud NAS (even through my browser). I tried all of the solutions above, but the only one that worked was changing "Jumbo Packet" to Disabled. I checked my WD Cloud Drive NAS Network settings and Jumbo packet was set to 2k - I tried matching it with the NIC settings (2k & 4k) and neither were sucessful. I set Jumbo Packet to Default (1500) on the NAS and disabled on the Ethernet NIC.

    Wednesday, September 27, 2017 7:19 PM
  • THANK YOU Bazzerby. I spent my whole day trying different solutions to no avail. I don't know why SMB 1.0/CIFS was disabled by default in windows 10!
    Wednesday, October 18, 2017 2:03 PM
  • I used regedit to update AllowInsecureGuestAuth to 1.  Looks to be set from last Windows Update using preview releases from Microsoft for Windows 10.
    Tuesday, October 31, 2017 5:20 AM
  • Thanks ,helpful
    Sunday, November 5, 2017 6:27 PM
  • Hi,
    I Have windows 10 Enterprise in my laptop and I have the same question for this error code. But I realy helpful by this site:
    https://support.microsoft.com/en-us/help/4046019/guest-access-smb2-disabled-by-default-in-windows-10-server-2016

    You just go to the regedit:
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Lanman Workstation\Parameters]

    change "AllowInsecureGuestAuth" dword= "0" to "1"

    Thank you and GBU.
    Monday, November 13, 2017 9:31 AM
  • Recent change to virgin superhub3. This fix was the only one that worked to establish access to my netgear readynas duo from laptop ...brilliant post thank you!.
    Thursday, November 23, 2017 11:26 PM
  • I have a new windows 10 desktop and it was not able to see the QNAP 212 NAS drive in explorer. The older windows 7 laptop was able to access it fine.

    I tried the solutions proposed by Michael but unfortunately they did not work for me.

    What did work was to modify the post by Bazzerby above.

    I first disabled the SMB 1.0/CIFS File Sharing Support. This is accessed here:

    Control Panel / Programs and Features / Turn Windows Features On or Off.

    The machine was restarted.

    I then enabled (ticked the box) SMB 1.0/CIFS File Sharing Support

    The machine was restarted and presto the NAS is visible in explorer.

    Hope this helps others.

    Tuesday, November 28, 2017 8:09 AM
  • Hi there any one can help me when i am accessing the system on which the printer is installed and shared with other nodes but today after the updates of windows 10 pro i am unable to access the system, either the nslookup is authenticate the Domain server. please provide us the solution. the system on which the printer is installed OS windows 7 and we can access it from other windows7 machine but can not access from windows 10 machine.
    Wednesday, November 29, 2017 9:26 AM
  • Thanks it worked for me
    Wednesday, December 6, 2017 5:16 AM
  • This fix worked for me.  Thank you for sharing.
    Friday, December 29, 2017 1:51 AM
  • Brilliant!  Seems like the latest Windows 10 update (201801) "helped" me by removing my access to my NAS (Buffalo TeraStation).  Thanks much for this post - the gpedit failed, as did the "password" change mentioned previously, but as soon as I enable SMB 1.0 everything was back to normal (after a reboot).

    Many thanks for providing this SIMPLE solution!

    AL

    Thursday, January 4, 2018 11:52 PM
  • At last I found the cause of my problem, during a Windows Refresh some Windows features were turned off, make sure this is enabled:-

    Control Panel / Programs and Features / Turn Windows Features On or Off and make sure SMB 1.0/CIFS File Sharing Support is ticked

    Thank god this worked.
    Friday, February 9, 2018 3:27 PM
  • I am having a similar issue but none of these trips has helped me thus far.

    I just bought a Synology 1817+. I have it connected via 10g to my PC. I have an asus xg-c100c NIC for my PC.  I am running windows 10.

    Every time I attempt to write a file to the NAS it will crash my windows explorer. It opens the dialog box then just hangs, the transfer will not work. I can read files from the NAS fine. I can copy files from the NAS to my PC no Problem, just does not let me copy TO the NAS. 

    When I switch the Ethernet port to the onboard 1g Ethernet I can read and write fine using the exact same PC.

    Anyone ever had an issue like this? 

    Tuesday, February 20, 2018 5:15 AM
  • Thanks a million!

    I have tried to make this work for two days, and God it was a pain in the a**!

    Your solution did it like a breeze!

    I use Windows 10, by the way. Your post is four years old, but it still does the trick!

    Thanks a lot!

    Monday, February 26, 2018 7:44 PM
  • Omgsh that worked wonderfully! Thank you so much!
    Friday, March 2, 2018 1:54 AM
  • High Five Michael Downs - your three step fix has finally and fully restored my long lost dlink and Synology NAS network connections - Thank you so much.

    Sam

    Friday, March 9, 2018 8:15 AM
  • Thanks jgwatt..  you your advice, coupled with Michael Downs three steps, restored both my NAS connections and my sanity!

    Cheers

    Friday, March 9, 2018 8:23 AM
  • Thanks to Bazzerby!!! THIS was the fix that worked for me
    Friday, April 20, 2018 7:51 PM
  • Thanks fixed my problem on Windows 10


    • Edited by EdatTechNet Saturday, April 21, 2018 7:56 PM
    Saturday, April 21, 2018 7:56 PM
  • Nothing worked in my case. Turns out it may have been an issue in resolving the name. So I created a .bat file on my desktop with the following instructions:

    ipconfig /flushdns
    ipconfig /registerdns
    ipconfig /release
    ipconfig /renew
    NETSH winsock reset catalog
    NETSH int ipv4 reset reset.log
    NETSH int ipv6 reset reset.log

    I than ran the batchfile and rebooted my laptop, after which the mapped network drives connected again.

    Monday, April 23, 2018 7:56 PM
  • \\Share\Folder is not accessible

    [...]

    Windows Explorer I could see "\\MyNAS\Share\" but cannot navigate to it. 

    I would get an error:

    "\\MyNAS\Share\ is not accessible. You might not have permission to use this network resource. The specified network name is no longer available."

    After much trial and error, finally, the only thing that worked for my situation:

    1) Network and Sharing Center - Change Advanced Sharing Settings

    Turn everything to OFF on all profiles and options - Save changes and close

    Then

    2) Device Manager - Network Adapters - Uninstall Ethernet and Wireless adapters - Action, Scan for Hardware Changes to reinstall these devices and close Device Manger.

    Then

    3) Network and Sharing Center - Change Advanced Sharing Settings - Turn everything to ON for all profiles and options - Save changes and close.

    NAS shares now work properly and I can access the NAS admin configuration pages.

    Now you can restrict some access by setting some of the Advanced sharing settings.

    So simple and easy after all...

    Good Luck!


    mdd

    Hello mdd.   Even after 5 years, this problem still persists in win7.  I don't have NAS drives, but I do have a variety of "\\SHARE" destinations to folders on other pcs on my network.  One day they they were not accessible from my win7 pc.

    In my case, the problem seemed to be triggered by an unexpected IP conflict.  Another device (actually a debit/cc machine) rebooted and high-jacked the static ip address of the win7 pc (which was off at that time).

    I assigned a new ip address to the debit/cc machine (and forced it to static this time) and resolved the conflict. But the damage was done: the network shares built at the win7 pc were broken.

    Your solution worked wonderfully.  Thank you thank you for sharing your experience and solution.

    ..ogg

    Tuesday, May 1, 2018 3:54 PM
  • Solved:  I have spent at least 15 hours troubleshooting this problem of Windows 8 not connecting to a NAS that other computers can see.  I tried at least two or three dozen registry hacks, security profile changes, NIC tweaks, reformat & factory reset and many other things. What finally worked was Bazzerby's very simple:

    Control Panel / Programs and Features / Turn Windows Features On or Off and make sure SMB 1.0/CIFS File Sharing Support is ticked

    Solved: Hi, I had same issue with Win10 and Synology NAS, I tried various other "fixes" to no avail until I came across this fix. But make sure all three sub-items are ticked under SMB1.0/CIFS File Sharing Support.

    I went further by first uninstalling SMB1.0/CIFS File Sharing Support, then restarted the PC, then reinstalled SMB1.0/CIFS File Sharing Support. This remedied my system.

    Thursday, May 3, 2018 2:43 PM
  • Tried numerous other fixes after losing Windows Explorer access to my NAS - and step 3:-

    Microsoft network client: Digitally sign communications (if server agrees)

    did the trick. It was enabled, and disabling it + a reboot restored directory access!!!

    Thanks Sormbolie, you saved the day - I was getting that desperate I was considering doing a rollback to a back image I made a fortnight ago.

    Sunday, May 27, 2018 6:51 PM
  • Hi 

    Maybe this could help someone. *Warning: I'm a non-techy person."

    Just resolved the "not able to find NAS" issue today:

    I wanted to map the network drive to NAS on my friend's laptop. Map network drive > My computer can find the NAS driver when I type in the drive path (eg: \\shareNAS) 

    Situation:

    Turned on Networking/file sharing 

    Went to map network drive, typed the exact same path (\\shareNAS) on the other laptop as what I did on my computer. Clicked on browse. NAS did not appear. 

    What I did:

    Changed SMB to maximum SMB 3 on the Synology control panel as per suggested. Rebooted NAS.  

    Changed the settings for Internet Protocol Version 4 (TCP/iPv4) as per suggested here:

    https://www.youtube.com/watch?v=_vki_bx4zjI

    The above did not do anything, and NAS remained elusive. 

    I resolved it by clicking on "Add a network location" and typing in the IP address of NAS:

    (eg: \\192.xxx.x.xxx) 

    Click on browse 

    NAS appeared this way, and I was able to add NAS to my friend's laptop. 

    Restarted the laptop and was able to access NAS. 

    Tuesday, June 12, 2018 2:44 AM
  • Try this: https://www.schkerke.com/wps/2015/06/windows-10-unable-to-connect-to-samba-shares/

    It worked for me and is a small registry change. It seems like windows 10 just wants to password protect network sharing, but many of us ahve legacy devices that doesn't support it, or requires too many changes to our networks for it to function. It worked on my WD NAS.

    Wednesday, June 20, 2018 6:52 PM
  • Tried it but no change.  It did lose my wifi adapter and couldn't find it.  The scan for Hardware Changes did nothing.  had to connect with a cable.  Now my wifi is back up.  I can access the NAS dashboard but WE does not see it. It happened when I turned the computer on and MS gave me a message with only two possible answers.  Turn off and go away or restore the OS with a loss of all non-MS programs.  When I reinstalled WD ACCESS is when I saw the problem.  I read somewhere that MS removed a file SBM1 due to a security issue and that could be the problem.  WD Smartware Pro asks for credentials but goes away for a while and comes back to the same screen telling me to click on the drive icon.  The shares are all there the drives checkout good.  Everything is OK except WE can't see it and that makes Acronis not work.  Hellllp.

    Thanks 

    Bill

    Tuesday, July 10, 2018 1:09 AM
  • I don't have a "Home Group" under private.  only Network discovery and File and Printer sharing?????

    I am running W10 64bit home  If that makes a difference.

    • Edited by bibarnes Tuesday, July 10, 2018 1:39 AM
    Tuesday, July 10, 2018 1:38 AM
  • I tried this- but it did not work. Strange thing is I have two NAS drives, both Synology. The one with the lower IP address is visible and accessible, the other is visible but NOT accessible.

    C

    Wednesday, August 15, 2018 1:40 PM
  • THANK-YOU SIR
    Monday, August 27, 2018 9:58 PM
  • I have 3 synology NASes. Never had a problem before from WinXP to Win1064.

    Funny thing, after configuring a Win10 Enterprise virtual machine in the MAC, I could access 2 of them but not the main one.

    The error that denied access is the same you have in this thread. Having not changed anything, it was certainly something to do with the network security of this Win10 and that NAS.

    When I checked 

    CONTROL PANEL - USER ACCOUNT - CREDENTIAL ADMINISTRATOR - WINDOWS CREDENTIALS

    I realizaed the 2 NASess had credentials with their NETBIOS name but the third one was lacking.

    So I created a new Windows credential for the innacesible NAS with its NETBIOS name (IP would work fine too if you don't NETBIOS connected in your NIC) and the admin credentials for my NAS.

    I think the functioning answers in this thread are a more convoluted way of re-creating the access credentials.

    "Home group" sharing I think it has been deprecated in Win10 1803? update.

    Hope this helps.

    Monday, September 17, 2018 12:58 PM
  • If you are using Windows 10, it appears that the SMB1 protocol used by older legacy NAS devices like DLink and Synology is no longer installed.

    See https://support.microsoft.com/en-us/help/4034314/smbv1-is-not-installed-by-default-in-windows to re-install it.

    Also try https://go.microsoft.com/fwlink/?linkid=852747 if the above link does not work.

    Specifically this note bothered me, since my NAS devices worked fine in the past.

    • Windows 10 Home and Windows 10 Professional still contain the SMBv1 client by default after a clean installation. If the SMBv1 client is not used for 15 days in total (excluding the computer being turned off), it automatically uninstalls itself.

    • Edited by ep7 Monday, October 8, 2018 9:04 PM added note
    Monday, October 8, 2018 9:00 PM
  • Top notch - fixed it!
    Sunday, October 14, 2018 7:57 PM