• I just bought a new laptop with windows 7, when I loaded NCLEX-RN4000 on to my laptop successfully but when i try to open it gives me this message: The 'Microsoft.Jet.OLEDB.4.0' provider is not registered on the local machine. I've tried all of the options in the troubleshooting compatibility tab. The program previously worked on my Windows Vista home. I use it to study alot. And I'm not very tech savy so any help would be appreciated.

    Tuesday, December 01, 2009 3:03 PM


All replies

  • Hi,

    This error indicates that you may not have the latest Microsoft.Jet.OLEDB.4.0 on your computer, I recommend you to obtain the latest service pack for the Microsoft Jet 4.0 Database Engine and keep a Jet 4.0 database in top working condition. Moreover, since it is more of coding issue, I kindly recommend you to post your question in MSDN forum for a better assistance.

    Best Regards
    Thursday, December 03, 2009 6:05 AM
  • There is no mention of windows 7 on that page, and the latest versions mentioned there are older than the windows 7 version. This may be a coding issue, but it's one that the coders of programs having the problem cannot reproduce, as it apparently happens only on some wimdows 7 computers.

    Thursday, February 18, 2010 10:43 AM
  • I have the answer for you if you have not figured it out!  You have to install a patch to make it run in 64bit and not 32bit.

    I got that link from their tech support and now it works.

    Monday, July 26, 2010 10:00 PM
  • when you click run in the box it will start and you will see a little window pop up to show it starts but after that no window will pop up and say it completed you have to just go back to the desk top and open the nclex rn4000
    Monday, July 26, 2010 10:04 PM
  • The aforementioned patch doesn't work.  And there isn't any mention of Windows 7 on the other.  How do I get the NCLEX 4000 to work!  I desperately need it!!!

    • Proposed as answer by Jason Everling Thursday, March 03, 2011 5:28 PM
    • Unproposed as answer by Jason Everling Thursday, March 03, 2011 5:28 PM
    Sunday, January 23, 2011 7:22 PM

    The above file does work, it is a self-extracting archive which if you just click it and it says installing but it doesnt. Go download 7Zip and extract the NCLEX4000.exe file and copy and paste it over the original in "C:\Program Files (x86)\LWW\NCLEX-RN 4000\". After that it will work, we had the same issue on our WIN 7 64bit machines here at our school.

    Thursday, March 03, 2011 5:32 PM
  • @ Portcity318 and Jason Everling:

    TNX guys! Got my nclex-rn4000 working....yeah...indeed the above patch/file worked like a charm...just follow these guys instructions and it will work fine.

    by the way am using a windows 7 ultimate sp1 64 bit system

    Sunday, March 06, 2011 1:42 AM
  • I just bought the software, too and it wouldn't work.... now it does! Thanks!


    Monday, September 26, 2011 3:13 AM
  • If you have windows 7 and you’re receiving this message:The 'Microsoft.Jet.OLEDB.4.0' provider is not registered on the local machine. Then here is what you do;

    Click (click run)

    Click   (click, download on the “.exe” type)

    Click the start menu on your computer, click “ 7- Zip File Manger”

     C:\NCLEX4000.exe\NCLEX-RN4000\ should appear, click on the “extract” key (i.e. if doesn’t work press ctrl and alt key simultaneously and click the 4 icons) click  “copy”

    Once the copy box appear, click on the down arrow (beside “C:\NCLEX4000.exe\NCLEX-RN4000\”) click

    "C:\Program Files (x86)\LWW\NCLEX-RN 4000\".  Hit ok,  and there you go!

    Saturday, November 12, 2011 3:28 PM
  • Hi

    I recently purchased the NCLEX 4000 but it won't work due to Windows 7. I have tried clicking on that ftp link. However, every time I click that link it asks me for a username and password. I tried putting anything down but it keeps saying log in error. Is that supposed to happen? I am getting so frustrated with this program. I just want it to work Help!!!!!!!

    Tuesday, April 15, 2014 1:00 PM
  • Its asking for username and password:(
    Wednesday, September 24, 2014 7:59 PM
  • the ftp server is asking for a username and password. what is it?
    Friday, October 24, 2014 6:06 PM
  • I there a user name and password that works. I used my Microsoft sign in but it kicks me out.

    ATT Tilt (HTC TyTnII) WM6 Professional

    Saturday, June 06, 2015 4:15 PM
  • Did we ever find out password?

    Saturday, November 28, 2015 10:29 PM
  • Its asking for password can you give me username and password please

    Saturday, July 23, 2016 1:48 PM