none
Win 7 backup failure - 0x80070002 - after new system drive installed RRS feed

  • Question

  • Hi,

    I've decided to post here to see if anyone knows how to solve this before I go any further.

    Recently I installed a new SSD drive to replace my old SSD drive as the Windows system/C: drive.  After a round of using a combination of Macrium Reflect Free (for cloning the system drive) and EasyBCD (to set the boot partition) things seemed to be working fine.

    However, after my first attempt to use Windows backup I found that I could not and got the familiar 0x80070002 error with the "The system cannot find the file specified" message without the filename.

    Upon more research I found that the filename is not specified because backup is presumably looking for boot configuration data in the "System Reserved" partition. 

    After trying various ineffective solutions, I found other suggestions that led me to find initially that the "System Reserved" partition was not online.  This particular post (pointed to by another TechNet post) seemed to list symptoms similar to my issue: https://superuser.com/questions/411474/windows-backup-fails-with-0x80070002-the-system-cannot-find-the-file-specified.  I found that

    • bcdedit fails with the error "The system cannot find the file specified" when run from an admin command prompt
    • the msconfig Boot tab is empty and non-functional
    • The list of operating systems in the System Control Panel Advanced tab is empty
    • Windows Backup fails with 0x80070002.

    I ended up using 'diskpart' to set that partition online but that did not work.  Further suggestions online pointed to the fact that the "System Reserved" partition should also be hidden so I changed the partition type ID to '0x17' from '0x07' to make it hidden.  Again, that did not work either.

    So I am now stuck not willing to go further for fear of screwing up my system drive.  The current state of that drive using 'diskpart' output is as follows:

      Disk ###  Status         Size     Free     Dyn  Gpt
      --------  -------------  -------  -------  ---  ---
      Disk 2    Online          931 GB  1024 KB
    
    
      Volume ###  Ltr  Label        Fs     Type        Size     Status     Info
      ----------  ---  -----------  -----  ----------  -------  ---------  --------
      Volume 3     C                NTFS   Partition    931 GB  Healthy    System
    
    
      Partition ###  Type              Size     Offset
      -------------  ----------------  -------  -------
      Partition 1    Primary            100 MB  1024 KB
      Partition 2    Primary            931 GB   101 MB
    
    
    Partition 1
    Type  : 17
    Hidden: Yes
    Active: Yes
    Offset in Bytes: 1048576
    
    There is no volume associated with this partition.
    
    Partition 2
    Type  : 07
    Hidden: No
    Active: No
    Offset in Bytes: 105906176
    
      Volume ###  Ltr  Label        Fs     Type        Size     Status     Info
      ----------  ---  -----------  -----  ----------  -------  ---------  --------
    * Volume 3     C                NTFS   Partition    931 GB  Healthy    System

    Everything else is working fine.  Just the items listed above (backup, bcdedit, msconfig, etc.) are not working.  I'm not sure but this might also impact restore points as well, I haven't checked.

    In any case, if anyone has a way to fix this it would be much appreciated.

    Thank you,
    Darko

    Sunday, January 20, 2019 4:16 AM

All replies

  • Hi,

    Please check if the following link can help:

    Fix The system cannot find the file specified Error Code 0x80070002

    https://troubleshooter.xyz/wiki/fix-error-code-0x80070002-the-system-cannot-find-the-file-specified/

    Please Note: Since the website is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.

    Best Regards,


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, January 24, 2019 3:09 AM
    Moderator
  • Hi David,

    Thanks very much for the link.

    I tried the first three and it didn't do it for me.

    (The last two didn't really apply because a) the true issue isn't necessarily the backup -- it appears to be the boot configuration, and b) I can't really restore to a previous point since the issue occurred in trying to make my new SSD the boot drive.)

    I am hoping to not yet resort to using BCDEdit to fix this.  I may try to revert the "System Reserved" back to partition type 0x07 and assigning a drive letter to it.

    Saturday, January 26, 2019 5:58 PM
  • If you boot the Macrium Reflect Free rescue disk it has a utility to fix boot problems. You might give that a try.

    By the way, the Windows 7 backup (AND the restore) function is very temperamental. I would not take much notice of it, especially as you are using Macrium Reflect Free which is far better for routine system images. If you just want to backup files there are plenty of free alternatives (I use SyncBack Free).

    Saturday, January 26, 2019 8:48 PM
  • With Intel based-MB,Intel has specific software for SSD to function with the OS..Best bet,if Intel-based,go to intel.com/support/drivers-software/browse/select Storage/edit the 3 tabs/Win 7/gets you started.However,Intel always say's,The first install after the OS should be the Chipset Driver-Software,it lets the OS configure Audio/Video/Networking/etc..Also,Win 7 uses the Intel Matrix Storage mgr for HDs/Storage devices/some pcs set this in BIOS as Disabled,set to run,read owners manual.DISKPART is great,but in run,type: diskmgmt.msc L.click on a HD,go up to Actions/All/Make active
    Sunday, January 27, 2019 12:59 AM
  • Well months later and this has finally been solved.

    I continued to have no problems using the PC except for the original issues that I stated at the beginning of the thread. However, a recent set of Windows updates triggered a bad situation. After the updates were applied, the usual restart had to occur. When the restart began the bootup phase, I got the error 0xc0000428 "Windows cannot verify the digital signature of this file".

    This left me in a state where I could not get past the boot manager. In the BIOS everything seemed OK except for multiple duplicate boot device entries some of which had different boot behaviour (some would try to boot into my new SSD, some appeared to try and boot using my old drive). In any case, I tried using the Windows 7 installation drive to use Startup Repair. Initially it could not do anything because it did not see an operating system installed -- even though when I tried looking for drivers to load in that screen it could see all of the drives including the one with Windows installed on it. Even bootrec /scanos returned nothing.

    Later I tried disconnecting all but the Windows drive. I found using diskpart that the drive was not active as the boot drive so I set it to be so. Then, when trying the bootrec /scanos, it ended up finding an OS. I then proceeded with the other bootrec commands to try and repair the boot config. However, it still wasn't successful on bootrec /rebuildbcd (something about the device not being found or something -- can't remember now).

    Finally, after some more frantic searching on the web, I stumbled upon a post that sounded quite similar to my bootup issue. I did notice that the Windows boot partition was labelled D: while the System partition was labelled C: The magic formula that fixed it then became:

    > diskpart
    > select vol d
    > active
    > exit
    > bcdboot D:\Windows /s D:
    > bootsect /nt60 all /mbr

    After the restart and selecting the right boot device in the BIOS to boot from, I finally got Windows to start up. After setting the BIOS boot order correctly and re-attaching the rest of the drives I was able to get everything back up. And the rest of the issues at the beginning of this thread were finally corrected. (You wouldn't believe how close I was to re-installing...)

    I hope this post might help others with this extremely frustrating problem.
    Sunday, October 6, 2019 3:08 AM