none
VPN Connect from system tray does not prompt for DOMAIN/username and password RRS feed

  • Question

  • Hi I'm on Windows 10, Version 10.0.18362 Build 18362 and I'm having a problem with initiating a VPN connection.

    I noticed that if I try to initiate it from the system tray's wireless connection, it looks like it is trying to connect, but never asks me for the DOMAIN/username and password.  However, if I go to "VPN Settings" within the Windows 10 Settings area and try the connection from there, it does ask for the required information and then it connects successfully.  

    I'm not sure what is the difference between these two, but something has happened.  I cannot say when this changed, because it used to work from both areas, but I am on the newest version of Windows and I am a Windows Insider user.

    Let me know if there is something I can do to fix this. 

    Mike


    • Edited by waterpolo_man Sunday, June 2, 2019 2:23 PM accidentally put try instead of tray
    Sunday, June 2, 2019 2:23 PM

All replies

  • Hi,

    There are two settings for VPN credentials, please refer to the pictures below.

    Best regards,

    Travis


    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Monday, June 3, 2019 2:56 AM
    Moderator
  • Hi,

    Just checking in to see if the information provided was helpful.

    Please let us know if you would like further assistance.

    Best Regards,

    Travis


    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Tuesday, June 11, 2019 8:38 AM
    Moderator
  • Travis, I have the same issue since the update win 10 to 1903 build 18362.175.

    On the right side of the task bar  I have the Network tray, if I open this, there is also a VPN connection.
    Before the update, I clicked on it, Chose  'Connect ' and the system came up with a login screen for name and pw.
    After the update this login screen does not appear anymore.
    If I do this through Settings->Netwerk and internet->VPN (or through quick actions->VPN) and I click the VPN connection and select Connect, a login screen appears.


    What I already did
    1: Checked settings.
    2: VPN deleted and created a new one.
    3: Settings compared to VPN connection on my laptop (still win 10 1809), settings are the same.

    Tried several settings as proposed above, still no login screen pops up when I try to start VPN from the network tray.

    Thomas 



    • Edited by BSHome Wednesday, June 12, 2019 9:11 PM
    Wednesday, June 12, 2019 9:06 PM
  • Hi BSHome,

    Thanks for your sharing.

    I will report the issue to our product team for further confirmation.

    If there is any related update, I will let you know.

    Best regards,

    Travis


    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Thursday, June 13, 2019 9:41 AM
    Moderator
  • Travis,

    Thanks for the information that you shared above.  I checked my settings and obviously if I set the connection to remember my settings, it will connect using both the CONNECT button in the VPN SETTINGS area of Windows 10 as well as the System Tray of Windows.  Unfortunately, I do not wish to embed the DOMAIN\username and password for most of my connections.

    I'm an IT consultant and I setup these VPN connections to test my client's VPN setups.  I use them to insure that they are still working, because in a few instances, I've had them stop working after Windows updates.

    If my computer would ever be compromised, and the connection already had this embedded, they'd be able to connect and get Domain Admin access to my clients. I'd rather type them each time.

    Mike


    Mike Hanlon

    Friday, June 14, 2019 3:18 PM
  • Hi,

    Thank you for sharing detailed information.

    If you don't want clients to remember user credentials, just uncheck the option.

    Best regards,

    Travis


    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Tuesday, June 18, 2019 6:55 AM
    Moderator
  • Travis, with your last answer you forget the initial question, that there is no popup to fill your login and password

    when using the VPN connection in the system tray.

    So the original problem still exists

    Gr. 

    Thomas

    Sunday, June 30, 2019 12:21 PM
  • Hi,

    Thanks for your reply.

    Yes, I know the issue has not been solved.

    However, I can't reproduce the issue and there is no more information from Microsoft.

    Maybe we can look forward to Microsoft's next update.

    Best regards,

    Travis 


    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Monday, July 1, 2019 7:41 AM
    Moderator
  • Exactly the same issue here and having to resolve to using rasphone.exe to connect.

    Friday, July 5, 2019 4:10 PM
  • I have the same issue in 1903.
    Tuesday, July 23, 2019 6:14 PM
  • I have the same issue. It only happens when you use the system tray ICON. If you start a VPN session from the VPN Settings screen it prompts you for a username and password and works fine. 
    Thursday, July 25, 2019 4:14 PM
  • It seems like it starts after doing the 1903 update on the computer. I have other laptops that use the 1809 version and don't have the issue. 
    Friday, July 26, 2019 8:49 PM
  • It seems like it starts after doing the 1903 update on the computer. I have other laptops that use the 1809 version and don't have the issue. 
    Same issue here with 1903. The Windows Security username/password popup does not appear when using the network tray icon so it's impossible to connect to VPN in the preferred way. It works from Network & Internet but that is a clunky workaround.
    Friday, August 2, 2019 2:22 AM
  • Same issue here. I just did the update to 1903 about a month ago and ever since, I'm unable to connect to the VPN using the system tray Wifi button. 

    It does work fine if I go into the PC Settings > Network > VPN and connect from there. 

    Not a big deal in the grand scheme of things, but is slightly annoying.
    • Proposed as answer by BobK999 Thursday, September 12, 2019 8:32 AM
    Friday, August 23, 2019 1:46 AM
  • Exactly the same issue here and having to resolve to using rasphone.exe to connect.

    Thank you!  This is by far the most useful thing I've come across on these forums in a while.  rasphone.exe is better than the normal ways of connecting in Windows 10 - even when it did work.

    And I know this is so far beyond a joke here at this point, but if you don't completely understand the issue (Travis, and *many* others), just don't answer the question.  Telling people to check obvious settings they've already stated they've checked is the OPPOSITE of helpful. 

    Thursday, August 29, 2019 7:47 PM
  • Not a cure but a simple enough workaround for now.  Thanks.
    Thursday, September 12, 2019 8:33 AM
  • Do you have any fix for this ? 

    After September update the problem is still the same.

    Tuesday, September 17, 2019 10:51 AM
      • Open regedit (WIN+R and type regedit.exe)
      • Navigate to HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Control Panel\Settings\Network
      • Take ownership of the “Network” key/folder (right click, Permissions)
      • Select “Advanced” in the Permissions window
      • In the Advanced window, select “Change” where the owner field is (at the top of the window)
      • Type in your username and save your changes.
      • Close the advanced window
      • Now select “Administrators” in the security tab
      • Make sure “Full control” is selected, then apply changes
      • Now that’s done, double click “ReplaceVan”
      • Change it’s value to 2

    I found this and a thank you goes to Tobias.Csaki


    • Edited by dazroo Tuesday, September 17, 2019 3:29 PM Typo
    • Proposed as answer by Oli004 Tuesday, October 1, 2019 8:04 AM
    Tuesday, September 17, 2019 3:29 PM
  • same here... wonder what takes so long to fix this
    Friday, September 27, 2019 2:41 PM
  • Thanks @dazroo. That is a good solution/workaround. works for me.

    Was very anoying. Now it's better.

    Tuesday, October 1, 2019 8:04 AM
  • This is a great find, and saved me a big headache.
    Monday, October 7, 2019 5:12 AM
  • Worked for me.

    Thanks!!!!

    Monday, October 14, 2019 4:18 PM
  • Worked for me as well. Thanks! Hurry up and fix this Microsoft. So annoying to have to do this to on every laptop.
    • Edited by dmanbob Monday, October 21, 2019 8:16 PM
    Monday, October 21, 2019 8:15 PM
  • I'm staggered that this is still an unresolved issue. Using rasphone.exe is a workaround but how MS can let this be a problem for so long is beyond belief.

    Absolutely pathetic.

    Tuesday, October 22, 2019 6:11 PM
  • Thanks. This worked. Hopefully MS fix this "properties" in next update. rasphone.exe was also helpful advice.
    Tuesday, October 29, 2019 5:40 PM
  • Same problem. I spent hours assuming there was a problem with the VPN on the office end and trying to debug. Even when I started to suspect my client system was the problem it took a long time to stumble across this stupid little failure to pop up a dialog to ask for credentials, especially since it had been working for years. While no one else here has mentioned how long it took them to discover this, can you imagine how many hours of waste there is just for the posters here? And multiply by, what, 1000? 100,000? to count all the others wrestling with this who haven't posted here? [explitive] MS.

    Tuesday, October 29, 2019 8:34 PM
  • I also have this issue and agree with Njem, our engineering team have spent large amounts of time troubleshooting SSTP SSL VPN settings to discover that a bug in Windows 10 is the issue and that our VPN is working fine from our servers. What makes this worse is that the VPN is rolled out via GPO and end users should not have to go looking for the VPN in settings to connect. I have raised this issue on feedback hub for those who are affected and wish to vote on this issue.


    Feedback Hub Title...

    VPN Issue on 1903 When connecting on network list from taskbar.


    • Edited by CJU200 Wednesday, October 30, 2019 9:34 PM spelling
    Wednesday, October 30, 2019 9:32 PM
  • Thank You dazroo. Reg fix worked for me.
    Friday, November 1, 2019 5:10 PM
  • Same issue here. Waiting on the real fix. Where is this issue documented at for Microsoft?
    Thursday, November 7, 2019 4:34 PM
  • I spend about 20 min. trying to figure out WHY THE HECK it did not connecting! Such a miserable fail from MS, and these people are telling me that Win10 is "the best" platform, lol! Its so buggy that it even gets fun.

    They made several stupid and ugly looking places duplicating old good-working settings and now NOTHING is working! Wow! They even steal that ugly switch from iPhones in this new panels - I guess the regular square checkboxes are no-good now! And yes, nobody is using Windows on tablets and never will! 

    They also pushing those buggy updates which breaks something EVERY TIME and I now have to disable them with 3rd party software because is is now a mandatory! Oh well... I miss Bill Gates.

    Wednesday, November 13, 2019 10:58 AM