none
setup has detected that the .net framework version 4 needs to be repaired - June 2012

    Question

  • Hi everyone,

    I'm trying to migrate Vista to Windows 7 and I'm gettint this error message. "setup has detected that the .net framework version 4 needs to be repaired"

    What is causing this issue, and is there any solution?

    I'm using sccm 2012.  I have a vista computer on a domain, then using the SCCM 2012, I created a package with "windows 7" cmd line is setup /unattend:xxxxx.xml. Then i'm scedule the drop on my vista computer as a package.

    AFter the entire installation is completed, the computer reboot then I get the message about .net framework need to do a repair and need to restart the computer.

    Verions of framework 4 installed:

    MS .Net framework 4 Client Profile

    MS .Net framework 4 Extended

    You will get the same result even you get the Windows 7 ISO and do the manual upgrade from the ISO.

    I know there are some post already, but they are dated of 1 year ago.  Is there any new development on this issue.

     

    Mario Savard

    Stc

    Monday, June 25, 2012 11:48 AM

Answers

All replies