locked
Slow folder creation, deletion with anniversary update and Windows Server 2012 RRS feed

  • Question

  • We have detected a bug in regards to Windows 10 Anniversary Update and Windows Server 2012 essentials with Windows Search service (that indexes files for quick search) turned on.

    We are running a small business with about 5 client computers (4 on windows 10, 1 on windows 7). 

    The problem occures on 2 windows 10 computers after they received anniversary update.

    Symtoms:

    On the two problematic client computers, when trying to create a new folder in Windows Explorer on a network file share, there is a huge delay (2-3 minutes) before the folder is created. The delay locks the Windows Explorer window. When the client computer is restarted you might be able to create one or two folders without delays. And after shutting down the file explorer window and waiting a certain amount of time, you sometimes might be able to create one folder without delay  (especially if you acccept the default New Folder name). On all other occations, the windows explorer locks down, and the cursor is left after the last letter entered in the new folder name. The folder gets a timestamp immediately, but it takes 2-3 minutes before it locks up and you can continue to work.

    Also deleting folders usually leads to a delay, a delete progress dialog box occures and shows for a couple of minutes (or the navigation field gets a green progress bar).

    Both problematic client computers however can create new folders locally on their own harddrives without issues. The 3 other client computers can create folders on the file shares without issues.

    THE CAUSE:

    After dedicating one day to troubleshooting, the problem seems to be related to the Windows Search service that indexes files on the server and Windows 10 anniversary update on the client. When stopping the service, the problem disappears. When starting the indexing service, the problem comes back. We have tried to delete and recreate the index in the server, but that did not help

    Anyone else experiencing this? We need a fix or solution quick. Unfortuntaley more than 10 days has passed since the AU update was installed so we have to rely on the windows server 2012 client computer backup if we have to go back to pre-anniversary update


    • Moved by Amy Wang_ Friday, August 19, 2016 3:03 AM Windows 10 related issue from Windows Server File Services and Storage forum
    • Edited by Fredrik70 Friday, August 19, 2016 7:49 AM new info found
    Thursday, August 18, 2016 3:00 PM

All replies

  • Some more info: the problem does NOT occur when running Powershell to create new folders on a problematic client computer.

    It only occures when using the built-in Windows Explorer interface (or a save as dialogue in word, excel)

    It also occures when starting the client computer in safe mode.

    Thursday, August 18, 2016 4:00 PM
  • Hi,

    As this issue is related to Windows 10, I have moved this thread into Windows 10 forum so that you would get more efficient support.

    Best Regards,

    Amy


    Please remember to mark the replies as an answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, August 19, 2016 3:04 AM
  • Hello, is anyone at microsoft monitoring this forum. This is just an incredibly frustrating bug that seriously hampers productivity and makes working with folders a nightmare. Is nobody in this forum using windows server 2012 with file indexing with domain connected windows 10 anniversary clients? It is pretty easy to reproduce this bug. Just try and create folders on a server file share and after the second new folder, folder rename or delete the file explorer  window freezes for almost three minutes per new folder.
    Tuesday, August 23, 2016 8:25 PM
  • Just want to report we also have the same issue. Only Clients with Win 10 Anniversary Update experience the problem when creating or renaming a folder on the Small Business Server 2012.
    Friday, August 26, 2016 11:49 PM
  • Same issue here on 9 computers
    Monday, August 29, 2016 1:38 PM
  • Same issue here. Only on one computer. The only windows 10 client in our test environment.Very simple to reproduce. Not sure if Microsoft has tested this!?!

    Monday, August 29, 2016 3:04 PM
  • We have the same issue on 3 Windows 10 computers in our office which are the only Win10 PCs we have.  Stopping the Server (2012) search service makes the issue stop and starting it back up makes it come back.  Very reproducible.

    Has this issue been reported to Microsoft?


    Tuesday, August 30, 2016 7:35 PM
  • We've been having this issue since the Anniversary Rollout.

    I personally experienced this during the Insider Preview builds on a test PC and reported it each build I experienced it in...

    Wednesday, August 31, 2016 4:21 AM
  • The cumulative update today on August 31st didn't fix it. After a reboot you might be able to create a few folders without delay but then the delay starts again. Also affects deleting. Hello Microsoft wake up do something. How do i submit an official bug report, this is just unbelievable. Breaking the file explorer for business users. Amazing.
    Wednesday, August 31, 2016 7:31 PM
  • I've been testing out some different scenarios wrt this issue and just for reference, the issue persists even in Safe Mode with networking enabled.  My anti-virus was disabled as well.

    I also tried disabling all non-Microsoft shell extensions and that did not fix it either. 

    Tuesday, September 6, 2016 10:44 PM
  • Yes, agree. It is VERY frustrating, any action takes me 70 seconds!  Shame on Microsoft team - just because two MS product does not work together. Really considering QNAP or Synology instead od Windows server.
    Wednesday, September 7, 2016 10:54 AM
  • I am having the same exact issue with multiple computer as they are upgrading to the anniversary edition. 
    Sunday, September 25, 2016 6:50 PM
  • Any official solution?  Now having the same problem on several computers on a domain.  
    Monday, September 26, 2016 6:54 PM
  • Same issue here on 10 computers. Looking for solution.

    I tested on Windows Server 2012 R2 Essentials and it's the same issue.


    mmtnzbro


    Wednesday, October 5, 2016 10:46 AM
  • Same issue here. Hopefully a fix can be issued soon.

    Thursday, October 6, 2016 2:46 PM
  • We're also seeing this issue, hopefully there's a fix soon! We've disabled Windows Search but then of course searching is very slow.
    Thursday, October 6, 2016 4:03 PM
  • Same issue here on several computers, although it started a few days after the anniversary update.
    Thursday, October 13, 2016 2:20 AM
  • Same issue here on anniversary systems, 4 of them so far. Doesn't show on any other systems.
    Friday, October 14, 2016 6:38 PM
  • Very annoying issue. Already more than 50% of computers on our company network have the Windows 10 anniversary update and we have now a lot of annoyed users who are working daily on the file storage server with Windows Server 2012. Please Microsoft, fix this, switching off the Windows Search service cannot be a real solution.
    Tuesday, October 18, 2016 10:23 AM
  • Same issue here. Bueller Bueller Bueller?
    Saturday, October 22, 2016 8:51 PM
  • I have this on a WIndows 10 professional share with win 10 clients as well. Very frustrating to say the least. Trying to disable search service on all machines to see if that helps as a workaround.
    Thursday, October 27, 2016 7:07 PM
  • The same is discussed in this long thread:

    Problem creating a folder on a network share in Windows Anniversary update

    So probably best to continue the discussion there. Amazingly, after 3 months, Microsoft has not been able to say anything other than produce a KB article that says that you only should blame yourself for indexing files on a file server and suggests you turn indexing off.  

    Saturday, October 29, 2016 9:54 AM
  • I just spoke with Adel with Microsoft, he indicates it is a known bug, his comment not mine, he states there is a fix, but the client must pay for premium support for Microsoft to fix their bug????

    Another argument for MAC

    Thursday, November 3, 2016 6:35 PM
  • Have got around it by using FreeCommander XE 2016 to create files but must not have folder open in windows explorer at the same time. Not a fix but a sidestep.
    Sunday, November 6, 2016 10:16 PM
  • Same issue here ;-(
    Thursday, November 10, 2016 2:30 PM
  • Hey guys, Looks like this is fixed in build 14965! 

    https://blogs.windows.com/windowsexperience/2016/11/09/announcing-windows-10-insider-preview-build-14965-for-mobile-and-pc/#msps14PWbYZoPD0p.97

    • We’ve fixed an issue where File Explorer might crash when creating or renaming a folder on a network share.

    You must enable windows insider build in windows update.

    • Proposed as answer by StevenANS Thursday, November 10, 2016 11:36 PM
    Thursday, November 10, 2016 11:35 PM
  • We are experiencing the same issue as well. This is so terrible

    I am receiving this issue as well

    Wednesday, November 30, 2016 7:28 PM
  • I have installed the latest build available with the insider program but still experience the same issue as everyone else where it take a long time to create a folder. Does anyone else have any suggestions?
    Thursday, December 1, 2016 5:25 AM
  • I also still saw the issue after installing this build. The issue was finally resolved after I disabled "search" on the host PC. 
    • Edited by mosaicman Friday, December 2, 2016 9:57 PM typo
    Thursday, December 1, 2016 7:29 PM
  • Everyone should start tweeting @WindowsSupport until they get this fixed.  I just sent them one concerning this issue.  It's ridiculous how long this issue has persisted!

    It also looks like the other thread on this issue has been closed down as I can no longer post to it.  Wonder why that happened???

    https://social.technet.microsoft.com/Forums/windows/en-US/b72c763e-d029-4e65-a2dc-885a5aabf643/problem-creatingrenaming-a-folder-on-a-network-share-with-win10-anniversary-update-error?forum=win10itpronetworking

    Thursday, December 1, 2016 10:56 PM
  • Microsoft  . . . any solution regarding this issue? We have our personnel trying to create a folder or rename folders who still need the server folder indexed.

    I am receiving this issue as well

    Tuesday, December 6, 2016 8:02 PM
  • After hearing that 1607 was Business ready I have upgraded all 100+ computers on our site. What a big mistake this was. My MD is on my back now as this is causing our company alot of problems.

    Now this is acknowledged by Microsoft as a "bug" I thought this might of been classed as a MAJOR issue with companies using their Windows Server 2012 r2 with indexing enabled. The indexing is very important for our company and I would like to know WHY this hasn't been fixed?

    How did this release pass testing for deployment in businesses, and why wasn't this issue discovered?

    Any feedback from Microsoft please?

    Wednesday, December 7, 2016 11:53 AM
  • After hearing that 1607 was Business ready I have upgraded all 100+ computers on our site. What a big mistake this was. My MD is on my back now as this is causing our company alot of problems.

    Now this is acknowledged by Microsoft as a "bug" I thought this might of been classed as a MAJOR issue with companies using their Windows Server 2012 r2 with indexing enabled. The indexing is very important for our company and I would like to know WHY this hasn't been fixed?

    How did this release pass testing for deployment in businesses, and why wasn't this issue discovered?

    Any feedback from Microsoft please?


    They have kept quiet since August, so don't expect them to care. I think they pretty much have stopped developing windows server and anything on premise business related, They only care about Azure and fancy stuff for drawing circles on the screen, boring business stuff has been forgotten, Also I think they just fix bugs that gets millions of Likes or reports, the rest is left to rot.
    Wednesday, December 7, 2016 7:56 PM
  • There is also another thread on this issue found <here>.  It is a continuation of a previous, and much longer thread found <here> that appears to have been closed.

    Susan Bradley opened a new case with Microsoft on this issue, so any status updates on the case will likely be posted there if anyone wants to keep tabs on it.   Even though this is not the first case opened with Microsoft on the issue, I am hopeful Susan's case will tip the balance and get Microsoft to actually fix this.


    • Edited by Vertech Tuesday, December 13, 2016 5:01 PM typo
    Tuesday, December 13, 2016 4:59 PM
  • I trust Microsoft will fix the Windows 10 creating a folder on a peer Windows 10 PC use case as well ... not just Windows 10 to Windows Server 2012 ... this is a (big) peer to peer issue as well.
    Wednesday, December 14, 2016 2:36 PM
  • I just received roll out KB890830 and slow folder creation issue still not fix on our Windows 2012 server R2 box.

    We implemented the work around several months ago by disabling windows search. Result is normal folder creation but slow searches. Any news on this???

    Friday, December 16, 2016 2:51 PM
  • Yup, the very same thing: Windows 10 Anniversary Update workstation take about 3-5 minutes to create new folders on Server 2012 network shares. Disabling Windows Search on the server resolves the problem. Creating folders from affected machines via PowerShell is unaffected with Windows Search running.

    The same affected machines can delete folders with no issues.

    Nothing being reported in the event log

    Friday, January 6, 2017 11:51 PM
  • Last week I tried searching our networked folders for a file and it was super slow.  I noticed the files were not selected for indexing on the server.  After selecting the shared network folders to be indexed and it completed the indexing, I tried to create a new folder from my workstation.  It took a long time to create, just like the original post states.  After remoting into my server, I created a new folder in my shared folder directly on the server and it was very quick.  I troubleshot it by removing the file from indexing and creating a folder from my workstation - it was instantaneous.  I added the shared folder to indexing again and again added the folder from my workstation and it was slow again.

    I noticed I have some updates that need to be applied, so I'm hoping the issue is fixed, but I'm not holding my breath.

    Thursday, January 26, 2017 4:47 PM
  • I have this issue with Windows 10 Pro v1607 14393.693 and Windows Server 2016 v1607 14393.693.

    Folders are created very quickly on a share.  Some folders are deleted quickly while others cause the explorer window to hang for at least 70 seconds.

    Removing the end-user folder structure from Indexing Options at the server appears to address the issue.


    Thursday, January 26, 2017 6:54 PM
  • This started happening to me after I added a Guest account. After removing the account, leaving my single account, folder creation was speedy again.

    Ben.

    Friday, January 27, 2017 3:55 PM
  • Same issue with one of my clients with 17 Windows 10 PCs and Server 2012 R2. Very frustrating!!

    How about a fix Microsoft?

    Tuesday, February 7, 2017 1:08 PM
  • This worked for me:

    1. Open Windows Explorer/File Explorer.

    2. Click the 'view' tab.

    3. Click 'Options' button at the far right hand side of the view ribbon.

    4. On the 'General' Tab, un-tick the two privacy options, and click 'Clear'.

    5. Apply/OK to exit.

    Tuesday, February 14, 2017 8:20 AM
  • Microsoft finally released a Cumulative Update that fixes this. Run Windows Update and install the below update:

    • Cumulative Update for Windows 10 Version 1607 for x64-based Systems (KB4013429)

    Wednesday, March 15, 2017 4:46 PM
  • thanks for the update. It works now, I am able to create folders <g class="gr_ gr_93 gr-alert gr_gramm gr_run_anim gr_inline_cards Grammar multiReplace" data-gr-id="93" id="93">in</g> our Windows 2012 R2 Server from our Client computers with Windows 10 OS. This is a life saver

    I am receiving this issue as well

    Friday, March 17, 2017 3:41 PM