none
SDHC Windows 7 problems

    Question

  • I have been running windows 7 RC for a few weeks, and have now bought a new camera which uses SDHC cards, however both th 8GB and 16GB cards are unreadable, they dont show up in "my computer" and even more importantly cant retrieve my pictures from them. The computer did recognise them when they only had a few pics on, but now they have a few Gigs on them it cant see them? I bought a usb stick to put the SDHC card into and the same happens - nothing. Please can anyone help? 
    Thursday, August 13, 2009 3:57 PM

All replies

  • Hi,

     

    Thank you for posting.

     

    To make the SDHC be recognized by the computer, we need to ensure that the card reader works in Windows 7 first. Please check if the card reader is recognized properly by the computer and you have installed the driver for it.

     

    Meanwhile, you can plug some other storage cards to the card reader and see how it works.

     

    Thanks.


    Nicholas Li - MSFT
    Saturday, August 15, 2009 10:23 AM
    Moderator
  • Hi

    The card reader did, and does work with my SD cards still, it also worked with my SDHC cards when i only had a few pictures on them. As my holiday has put about 7GB of video and pictures onto both my 8GB cards it wont read them, its as if the SDHC card has not been plugged into the reader. If i click on it i get a wait circle for ages and ages, then it goes into "not responding". The reader is a bult in one, on a medion PC so i dont know the make to see if any drivers are updated. There are no new drivers available on the medion website.
    Monday, August 17, 2009 9:49 AM
  • Hi,

    I am haveing exactly the same problem on my Sony VAIO SZ71. 
    My SDHC card was working with Vista. And now with Windows Seven [version 6.1.7600] I can only access to SD cards (<=2GB) and having explorer hangs when trying to access an SDHC card (>=4GB). 
    All my drivers are up to date (checked with DriverMax)

    Drivers used : Disk.sys and partmgr.sys both with 6.1.7600.16385 version (win7_rtm.090713-1255).

    I dont think that the problem is hardware specific, cause I have the same issue on a HP desktop computer.

    Hope to have a Microsoft patch ASAP.
    Monday, October 05, 2009 7:51 AM
  • Hello,

    I have a transcend 16 gb sdhc, the realtek 2 usb card reader internal to my pc and an external usb card reader. My HP tx2517cl reads the card in vista 32bit but not in windows 7 64bit. Both readers successfully read a 2gb sd card from lextar.

    Thursday, November 05, 2009 11:35 PM
  • I have the same like every one else has. Is there a fix for the same. The card reader is working with 1/2GB disks. but not with SDHC in Win 7 64 Bit home premium.

    What a great product microsoft always produces: "This time it is different"
    Sunday, December 20, 2009 7:13 PM
  • I have an HP e9120f and had the same problem when I upgraded to Win7.  The fix for me: 
    1.  Open Device Manager
    2.  In "Disk Drives" dropdown, uninstall the "Generic SD/MMC USB device" drive.
    3.  Restart computer
    4.  Insert SDHC card
    For me, the computer started reading the card after this (PNY 4GB SDHC).
    Hope this helps.
    Tuesday, December 29, 2009 10:15 AM
  • Nice Fix this worked for me.  Thank YOU! 
    Monday, January 25, 2010 3:35 AM
  • I have the Same problem on my Acer Travelmate 6492 with Windows 7 64bit Ultimate edition. Please help if there is any solution. It recognized the 8GB SDHC Card but after some time said "Format the Card to read"...

     

    Please Help...

    W7U

    Tuesday, March 23, 2010 9:43 AM
  • I had a similar problem on my Dell XT2 running Windows 7...the card was not being recognized at all.

    This got fixed when I disabled the SDHC host adapter and then re-enabled it.

    The SDHC card then showed up under Drives!

     

    Tuesday, April 20, 2010 3:11 PM
  • This worked on my Dell XT2 also.


    Thursday, February 09, 2012 2:22 AM
  • I can confirm this "Uninstall" process works, although it's easier just to tell Device Manager to "Action | Scan for hardware changes" after disabling the card. This process fixed an 8GB Kingston USB drive as well!

    Then I started looking at the drivers installed - Two of them are Acronis Drivers (see attached). Uninstalled Acronis True Image 2012 Home and now I'm functional again. One of the problem drivers has Windows Hardware Compatibility! Hm ...

    • Proposed as answer by woodp Friday, April 13, 2012 7:25 PM
    Friday, April 13, 2012 7:25 PM