Windows 7 RTM: unable to connect via PPTP (error 797) RRS feed

  • Question

  • I tried to set up a PPTP connection to a remote server but didn't succeed. This is what I tried:
    - Network and Sharing Center
    - Set up a new connection or network
    - Connect to a workplace
    - No, create a new connection
    - Use my Internet connection (VPN)
    - Internet address: [enter IP address]
    - User name: [enter user name]
    Result: "Connection failed with error 797. A connection to the remote access server was not made because the modem was not found."

    So, apparently Windows is trying to use a modem although I chose "VPN" and entered an IP address. Any ideas?
    Wednesday, September 30, 2009 8:38 AM

All replies

  • The searches I tried for this error seem to indicate a driver issue. So with that said you might try...

    * Make sure all your network interface drivers are up to date.

    * A clean boot to see if you can pinpoint the problem to a specific program causing issues.

    * Use system restore to go back to a point before the issue first started.
    MS-MVP Windows Desktop Experience, "When all else fails, read the instructions"
    Wednesday, September 30, 2009 1:06 PM
  • In addition, I would like to share the following with you:


    Error 797



    Nicholas Li - MSFT
    Monday, October 5, 2009 9:09 AM
  • Thanks Nicholas and Al,
    unfortunately I was not succesful. The thing ist that Windows tries to use a modem while I want to connect directly via LAN. I enter an IP address, but Windows puts it in a field that is otherwise used for a telephone number.
    As I didn't find an appropriate restore point, I uninstalled several applications that install virtual modems or virtual network interfaces - without success. It seems I'll have to live with it for the time being.

    Thanks nevertheless,
    Wednesday, October 7, 2009 2:48 PM
  • I have the exact same problem on one Windows 7 PC (64-bit), but not on another (32-bit).  

    I have also tried a lot of supposed fixes, including reinstalling the "WAN Miniport (PPTP)" device using netcfg.  I ended up with a device named "WAN Miniport (PPTP) #2", but the wizard still insists on using the modem.

    I tried copying the rasphone.pbk file from the 32-bit PC to the failing PC.  (%userprofile%\appdata\roaming\microsoft\networking\connections\pbk)  The connection showed up, just like on the working PC, with the correct icon and device name ("WAN Miniport (PPTP)"), but attempting to connect with it resulted in "device not present".  I tried this both before and after reinstalling the miniport device.  

    So, any suggestions are welcome!
    Wednesday, February 3, 2010 12:02 PM
  • From what i can see error 797 is when the computer cannot find the router / modem, i have a friend who is asking me the same problem, from what he's told me it may be very simple...

    firstly he's just upgraded to windows 7, he tried to connect but he got a message saying "RASPPPOE" wasnt working, so we've sorted that problem out and now he's getting an "Error 797 - Windows cannot find the modem" he's said a few times that he's been set up and his router is hidden so people cant see his router as an access point, check the router settings that is connected to you're LAN that you're trying to connect to as if this is hidden windows wont be able to connect.

    i hope this helps, its not a guaranteed fix as i havent tested this theory yet.

    Monday, January 17, 2011 4:34 PM
  • I am currently having this issue on a Windows 7 64bit machine - "Connection failed with error 797. A connection to the remote access server was not made because the modem was not found."

    No matter what I do it wants to dial and not a connect over internet for the VPN connection.

    As for the theory of it being a hidden device, this is not my issue as I have tested on multiple hidden devices and cannot recreate the issue. Not sure when this issue first started so a restore doesn't make since and I have ensured all drivers are updated.


    Has anyone been able to successfully resolve this issue?

    Monday, February 14, 2011 4:22 PM
  • I've been struggling with the same thing, anyone found an answer yet?


    I've tried the driver swap and pretty much everything else people have proposed.

    Thursday, February 24, 2011 1:57 PM
  • I have this issue after having a pretty bad rootkit virus. Just cleaned it up with combofix but now have this issue. can the driver be repaired/reinstalled?




    Thursday, June 16, 2011 6:57 AM
  • Has Anyone Found a solution to this? I've tried all of the above without luck.

    It just appears as Windows never considers using the current internet connection and keeps looking for a Modem?

    Microsoft must be able to re-create and find the route of this problem?

    Wednesday, November 16, 2011 6:16 PM
  • I too have the same problem. I've used VPN on this PC for years with no problems. Then, one day, VPN failed. I deleted and remade the connection, but nothing I can do will persuade it to do anything but try to connect via my (disabled) modem. Attempted the advice in another thread - adding domain\username - but About the same time I lost access to MS Office, which swears it's not installed. I can't uninstall it, I can't repair it. I've installed Open Office in desperation! but still the VPN problem. 
    Tuesday, November 29, 2011 5:01 PM
  • What worked for me was uninstalling and reinstalling the network adapter.

    If you're running Windows 7, verify you have an internet connection and do the following:

    Right Click Computer > Manage > Device Manager > Network Adapters

    Right click on your network adapter and click Uninstall. This will kick you off the internet. Reboot the machine. Windows 7 will automatically reinstall the network adapater.

    Of course, there is always the possibility you can't get the network adapater reinstalled correctly. But, this solution worked on my PC having the issue.

    • Edited by HoppyBitter Wednesday, January 4, 2012 10:58 PM
    Wednesday, January 4, 2012 10:24 PM
  • SOLVED: Follow the steps below:

    1. Go To Control Panel
    2. Select Device Manager
    3. Select show hidden devices from view menu
    4. Expand Non-Plug and Play Drivers
    5. Right Click on, Remote Access Auto Connection Driver and select properties
    6. Select Driver Tab (Second Tab)

           a) Select Start from Current Status Field

           b) Automatic from Startup Field

    Wednesday, May 8, 2013 5:32 PM
  • Try this worked for me (win8)- registry - HKLM\system\currentcontrolset\control\class\{4d36e972-e325-11ce-bfc1-08002be10318}. Compare that against another installation and make sure it's looks the same. Then find the key below that matches the method you're using to connect. Make sure that also looks intact and drivers / paths match.
    • Edited by twinsennz Saturday, September 7, 2013 10:48 AM
    Saturday, September 7, 2013 10:44 AM