On-Screen Keyboard RRS feed

  • Question

  • I have Vista Ultimate. One morning my keyboard was not functioning when the system booted to the login screen, so I used the Accessibility menu to open up the On-Screen Keyboard. I was able to login and get my keyboard working, so upon next boot up, I disabled the On-Screen Keyboard on the login screen Accessibility menu. It seems to have turned off the OSK on the login screen. However, every time I boot up and login, the OSK opens. It doesn't open on the login screen. Only after I sign in and the system loads.

    Any clue where to look to remove the OSK from the startup? I've checked the Run keys in the registry. I've checked the System Configuration utility. Even the startup folder in the start menu. There is no reference to the osk.exe in either.
    Tuesday, February 13, 2007 4:30 PM

All replies

  • Try opening the Ease Of Access Center, open "Use the Computer Without a Mouse or Keyboard" and uncheck "Use the onscreen keyboard".
    Wednesday, February 14, 2007 3:50 PM
  • Thanks, Jim. I haven't rebooted yet, but that box was checked, so I'm assuming that will do it. I didn't even think to check there because I figured it kept the setting from the Ease of Access Center that displays on the login screen.

    Guess I'll know to check both spots in the future.
    Thursday, February 15, 2007 2:41 AM
  • Just following up. That did the trick. Thanks!
    Thursday, February 15, 2007 5:50 PM
  • thanks...i've been trying to find out how to discontinue osk on startup for a while...thanks again
    Thursday, April 19, 2007 2:24 AM
  • Phew! the OSK on my Vista was getting annoying too.

    Thanks for the tip.   *-)

    Saturday, July 21, 2007 6:23 PM
  • i was getting the same but you sorted it for me to,,,thanks


    Wednesday, March 26, 2008 8:55 PM
  • Cheers. The above answer worked like a charm. This OSK really got under my skin. But still I wonder why it won't turn off even after unchecking it at the login screen. Perhaps something for Microsoft to look into next patch?

    Tuesday, April 8, 2008 7:40 AM
  • Ok so I'm not the only one. My OSK loads up at login screen then its gone. I don't want this here, and I have already tried looking around in the Tablet settings. Also opened the ease of use, that wasn't checked, so I'm lost, and I couldn't find the tablet in the "Programs & Features" section, was hoping to turn it off - not needing it right now. Any one have ideas on how to fix this??

    Tuesday, July 15, 2008 3:15 AM
  • thanks alot ive had this problem for about a year now was getting knda annoying thanks again man
    Monday, September 13, 2010 7:58 PM
  • Hey that was the best answer made my day thanks
    Tuesday, October 12, 2010 7:06 AM
  • That just sorted me out too, thanks.
    Sunday, November 7, 2010 3:30 PM
  • Try This :D


    Desktop: OS : Windows 7 Ultimate Rating : 5.5 Laptop: OS : Windows 7 Ultimate Rating : 5.5 ..............." Microsoft is not about greed. It's about innovation and fairness"
    • Proposed as answer by NEWVGAc12 Monday, November 8, 2010 10:36 AM
    Monday, November 8, 2010 10:36 AM