Setting up Epson LQ-570+ printer using parallel to USB adapter, problems!


  • I am running Windows 7 32-bit Home Premium. The computer has no LPT ports, so I bought a parallel to USB adapter in order to get this Epson LQ-570+ dot matrix printer working. Plugged in the adapter, powered up the printer, Windows auto-installs drivers for the adapter but says no printer is present. I downloaded and installed drivers for this printer (they do have a Windows 7 driver). Now, the computer seems to know that the printer is present, but it will not print. I have selected the USB virtual port as the port for the printer. I also tried selecting, one by one, all other ports (i.e. COM1, LPT1, etc.) but it would not print anything on those either. I tried plugging it into a different USB port, that didn't work either.

    Interestingly, when I have the devices & printers open, and I unplug the USB cable that is coming from the printer, the printer is then greyed out. So, it is as if the computer knows that's where the printer is, and is aware that it is not currently connected. Once i reconnect the USB cord to the computer, the printer shows up normally (as in, not greyed out). But still not able to print anything.

    Any thoughts?
    Saturday, November 14, 2009 10:15 PM


All replies

  • You mention you downloaded and install drivers mean for this printer but they do not have windows 7 driver, in that case run the drivers in either xp or vista compatible mode and next run as adminstrator and see how it goes

    Sunday, November 15, 2009 12:14 AM
  • Hi,

    As your Pinter is so out dated and no proper ports supported, I agree with Daniel that installing Windows XP driver in Compatibility mode worth a try.

    HOW TO: Install a Hardware Device Driver using Compatibility Mode

    1. Place the driver installation file on the Desktop.

    2. Right Click the driver installation file and select Properties/Compatibility Tab. Select the appropriate options in from the list in the following image.

    3. Click Apply/OK.

    4. Right Click the file and select the Run As Administrator option to install.

    I also recommend that you contact the maker of that hardware device and inquire about future driver support for Windows 7.

    Refer to

    Monday, November 16, 2009 10:27 AM
  • Hey,

    I noticed your legacy printer only has Windows 9X/3.1/NT4.0/NT3.51 drivers, check the following website:

    And where did you get the driver for Win7.

    Also I was wondering if it is practical to set up the printer via a parallel to USB adapter, did you ask the manufacture if they support such action?

    Here is their support for your computer:

    Tuesday, November 24, 2009 3:09 AM
  • Dear all,

    Microsoft did a great job on Win 7.  You can choose and install Epson LQ-570 driver from "add new printer" widget.  You cannot find it first, and win 7 will connect to internet and retrieve all other drives for you.  You will find it there and you can install from there.

    Tuesday, October 05, 2010 4:04 AM
  • Hello Heaven9Frogg , I wonder if you finally were able to make your LQ-570+ print. I do even tried to use the Windows Update option in the drivers list, to install the Windows suggested driver for this printer, but no luck. Actually when I connect the printer using the USB to LPT connector a service ("Support for USB Printers"") appear in the Devices and Printers explorer, as well in the Device Manager windows. Anyway even after all of this, and many attempts to install the printer with the compatibilty mode, have not been able to print as well.
    Sunday, February 13, 2011 11:59 PM
  • I have the exact same problem with my Star receipt printer.  Its a fairly new printer so its not the printer's age.  It seems to be the cable.  The cable does not have drivers for Windows 7.  Anyone heard of a converter cable that has worked in Windows 7?
    Friday, July 27, 2012 3:14 PM