none
Mounting NFS Shares

    Question

  • According to all the research I've done, this should be a fairly straightforward matter:

    Add/remove Windows components
    Install Services for NFS and Subsystem for UNIX-based Applications
    From command line: mount server:/share z:

    However, it doesn't seem to be that simple.

    I've tried just about every guide I could find on the matter. My first problem is that when I try to run the "mount" command, there's no executable found for it. A search of my hard drive reveals one buried deep in an obscurely named Windows folder, but when I run the help command (mount /?), it just outputs a blank line, and when I try to use it to mount a share, it does the same (ie nothing).

    Trying to mount the share from a "net use" command, or through Windows Explorer produces nothing useful.

    Has anyone been through this process? Can anyone point me in the right direction?

    Thanks.
    Wednesday, August 26, 2009 2:31 PM

All replies

  • The Mount command is included in Client For NFS. You may need to install Client for NFS in Windows Features.
    Expand Service For NFS and you will find it.

    Please refer to the following article:

    Windows Services for UNIX 3.5 White Paper
    http://technet.microsoft.com/en-us/library/bb463214.aspx

    For net use command, did you receive any error message when failed to mount the network share folders? If so, please let me know the exact error message.

    Thanks!
    Friday, August 28, 2009 12:35 PM
  • Hi Timothy,

    I installed the Client for NFS, and didn't get access to any kind of mount tool. I was going through some old backups though, and found a copy of Windows Services for UNIX (as opposed to Utilities and SDK for Subsystem for UNIX), which did contain mount.exe.

    When I test the exports from my server, I get the following result:

    [C:\nfs]showmnt -e raid
    Exports list on raid:
    /raid0/data/backups                *

    So everything looks to be in order there. The server is set to allow anonymous access, and I am able to browse the share from other non Windows devices on my network with no problems.

    When I try to mount with mount.exe, here's what I get:

    [C:\nfs]mount raid:/raid0/data/backups z:
    Network Error - 50
    Type 'NET HELPMSG 50' for more information.

    And when I try to mount with net.exe, here's what happens:

    [C:\nfs]net use z: \\raid\raid0\data\backups
    System error 1920 has occurred.
    The file cannot be accessed by the system.

    Or using NFS syntax for the share....

    [C:\nfs]net use z: raid:/raid0/data/backups
    System error 67 has occurred.
    The network name cannot be found.

    At this point, I'm pretty much out of ideas for what to try. Any help is appreciated.

    Thanks.
    Saturday, August 29, 2009 4:39 AM
  • Is c:\NFS a root for Unix Services for Windows? In my case I found the executables in (in my case) c:\SFU\bin . This surely ran the required executable.
    Please check this.

    ---------------------
    StarWind Software developer
    Saturday, August 29, 2009 10:14 PM
  • C:\NFS is just a location that I manually extracted the tools to. The Unix Services install location is C:\Windows\SFU, the bin folder inside there contains UNIX binaries (ie not .exe files) that will only run in the supplied UNIX shells, there's no version of mount in there, nor anywhere in the C:\Windows\SFU subdirectories.
    Sunday, August 30, 2009 2:09 AM
  • Oh, the directory where I located the first mount.exe tool that I tried (the one that didn't have any output, no matter what I ran it with) was located in C:\Windows\winsxs\amd64_microsoft-windows-nfs-clientcmdtools_31bf3856ad364e35_6.1.7600.16385_none_ad5854ca0a23343d.

    I'd say it's a fairly safe bet that it wasn't put there for easy access as part of the Client for NFS installation.

    The mount tool only seems to come with Windows Services for UNIX, which is not available for x64 operating systems, the only option being Subsystem for UNIX-based Applications, which doesn't contain that tool. Regardless, according to the working Services for NFS MMC snapin, available in Administrative Tools, I should be able to browse to my share in explorer using the standard \\raid\raid0\data\backups naming, which doesn't work. The Client for NFS service is running, I'm really not sure what else to try, it just appears that NFS support in Windows 7 is sketchy. I've tried setting it to use reserved ports, I've tried the registry hack to tell it to use an anonymous account, and I've tried various configuration options on the server, all of which work fine with an Apple Macbook, and my Popcorn Hour media player.

    Looks like I'm basically SOL for NFS access from Windows 7.
    Sunday, August 30, 2009 2:39 AM
  • Howdy people!

    I've been configuring Ubuntu NFS server which surely works. I can connect to it's shares with my laptop running Windows 7 (32bit) with it's native NFS client found in "Control Panel\Programs\Turn Windows features on or off". But for some strange reason I can't get my Windows 7 (64bit) to connect Ubuntu's shares. And as a side note Microsoft should really improve their "Map network drive" features to include all features that can be found from command line "mount" command. For NFS you usually need to connect with some account/permissions, and at the moment you need to do it like how this guy instructs you here Nguyen's guide .
    • Edited by Tarmo Voima Thursday, November 12, 2009 3:32 AM fixed link
    Thursday, November 12, 2009 3:17 AM
  • Yay. I found solution for getting Windows 7 (x64) NFS mounts working. It is small program by LabTam Inc. and you need to register in their site to download it . It has all features that windows NFS client should already have - like option to login with certain UID and GID, switch client between NFS v3 and NFS v4, async/sync, absolute keeper. Program is free for download up until february 2010.
    Tuesday, November 17, 2009 7:09 PM
  • Can you provide the exact steps on how you got that program to allow you to access NFS shares without an active directory server?

    When i try to mount, i get:

      Windows(R) Lightweight Directory Access Protocol (LDAP) failed a request to connect to Active Directory Domain Services(R) for Windows user <pc-name/username>.

      Without the corresponding UNIX identity of the Windows user, the user cannot access Network File System (NFS) shared resources.

      Verify that the Windows user is in Active Directory Domain Services and has access permissions.

    --

    In the "Services for NFS Properties" there is only "Active Directory domain name" and "User Name Mapping" which is a server.  

    The program you specified, i set my UID and GID to the numbers of my uid/gid from my linux box, but to no avail, it doesn't have an option to map a windows user to a linux user which appears to be the problem according to the Windows Event Log.

    I have also tried setting the AnonymousUID and AnonymousGID Dwords in the registry to no avail.

    If anyone else has a workaround for this please post!


    Thursday, December 24, 2009 3:48 AM