none
Remote Desktop - restore down and then maximize full screen.

    Question

  • Good morning everyone,

    When I have a Remote Desktop window opened and click restore down, I get a small window with my rdp session. This is all fine and good. When I click on Maximize after, it behaves like a maximized screen, not the FULL screen like in XP.

    I need it to go full screen and not just maximize because in maximize I will have to scroll both sides.

    Thank you all for your help.

    Monday, December 21, 2009 2:28 PM

Answers

  • Hi Oscar009,

     

    I would like to suggest you check the following steps.

     

    1.    Launch Remote Desktop Connection.

    2.    Click Options and switch to Display tab.

    3.    Drag the sidebar under Display configuration from Small to Large (Full Screen).

    4.    Click Connect to check the issue.

     

    Good luck!


    Arthur Li - MSFT
    Wednesday, December 23, 2009 3:41 AM
    Moderator

All replies

  • Hi Oscar009,

    Check your display resolution, it needs to be high. otherwise, get the latest vga drivers for your monotor.

    Nura
    • Proposed as answer by KiwiRod Tuesday, January 28, 2014 9:34 PM
    Monday, December 21, 2009 3:44 PM
  • Hi Oscar009,

     

    I would like to suggest you check the following steps.

     

    1.    Launch Remote Desktop Connection.

    2.    Click Options and switch to Display tab.

    3.    Drag the sidebar under Display configuration from Small to Large (Full Screen).

    4.    Click Connect to check the issue.

     

    Good luck!


    Arthur Li - MSFT
    Wednesday, December 23, 2009 3:41 AM
    Moderator
  • Try Alt+Break

    • Proposed as answer by EJO1974 Sunday, January 17, 2010 5:23 PM
    Thursday, January 14, 2010 3:24 PM
  • On my computer the slider was already on Full Screen, so this did not help me.

    Alt-Break changes the Remote Desktop Client to Full Screen, so this solved the problem for me, thanks Doucy!
    • Proposed as answer by ciandro Tuesday, February 21, 2012 4:31 PM
    Sunday, January 17, 2010 5:20 PM
  • More like Ctrl-Alt-Break...
    osomarron.com
    • Proposed as answer by Kleytman Tuesday, February 14, 2012 8:38 PM
    Sunday, February 07, 2010 4:06 PM
  • I'm having the same problem.  I restore a RDP session that is in full screen mode, then maximize the same session and it does not go back into full screen.

    I've been using the remote desktop client for years now and I've never had this problem.

    Regards, Mike DePouw
    Friday, March 05, 2010 2:33 AM
  • I too have the same problem: connect to a remote server with full screen, shrink down, then maximize and get scroll bars and about 7 pixels of the desktop on the right side, however it behaves like full screen (no title bar, and the connection bar appears if I move mouse to top of the screen).  This did not happen with previous versions of RDP (or prepatch... I haven't used RDP from this computer in two months).

    My current environment is WinXP SP3, RDP 6.1.7600, dual monitors running at 1680x1050
    Tuesday, March 09, 2010 11:44 PM
  • I took at look at the default.rdp file and here is what I found:

    After restoring a window the default.rdp gets modified from "screen mode id:i:2" to "screen mode id:i:1" (at least in my case that is what happens)

    I set the 1 back to a 2 and it worked properly again.

    Do we need to create a new thread to get moderator to review this issue since it has been marked answered?

    Regards, Mike DePouw
    Thursday, March 11, 2010 5:16 AM
  • I am having the same problem.

     - RDP -> options -> Display -> Full screen.

     - Connect to a server in full screen, the click [] restore wola, you are done, screwed for life you have to disconnect and reconnect again! to get back into full screen.

     

    MICROSOFT PLEASE FIX IT. Windows 7. x64/32 it's all the same!

    Why!

     

    • Proposed as answer by SteveFromMa Thursday, August 19, 2010 7:11 PM
    Sunday, July 18, 2010 4:33 AM
  • I had this same problem.  No need to exit out of your RDP.

    Just hit Alt + Break. and your screen should be back to full desktop view.  If you are using a laptop or some other unique keyboard, you may need to hit a Function or Fn key as well.  My laptop has the "break" key in box under "Pause" key.  So I need to hit Alt+Fn+break to get the RDP back to Full Screen view.

    Update: Ctl + Alt + Break works too.

    • Proposed as answer by SteveFromMa Thursday, August 19, 2010 7:19 PM
    Thursday, August 19, 2010 7:19 PM
  • Ctrl-Alt-Break as proposed by OsoMarron will achieve this without the need to disconnect and reconnect.

    I only mention it as the original question suggests that they are initially in full screen.

    Friday, August 20, 2010 8:38 AM
  • Main reason for this is because you are using a non-standard (to RDP) resolution on your desktop, I have the same problem:

    See my scenario:
    I have 2 laptops at home. One with 1366x768 native resolution, the other with 1280x800.
    Using first laptop, I get the problem like yours.
    Works fine with second laptop.

    Ctrl-Alt-Break does the trick, thanks to the other answers.

    But I think Microsoft should release an update to support all screen resolutions.

    Cheers...

    • Proposed as answer by MRSA Saturday, December 24, 2011 7:28 AM
    Wednesday, August 25, 2010 11:59 AM
  • Hi Arthur,

    Your isntruction was very precise and was very helpful. Please keep it up.

    Thank you,

    RASRAS 

    Tuesday, October 19, 2010 4:23 PM
  • More like Ctrl-Alt-Break...
    osomarron.com
    THAT is the answer that worked! (On Windows 7 at least.) Thank you!
    Saturday, November 27, 2010 7:50 PM
  • I know this old, but the laptop I am using does not have a Pause\Break key. Is there any other way to toggle the full screen without disconnecting? Thanks!

     

    PS. I have tried the on screen keyboard with this key combo no go. 

    Monday, February 07, 2011 6:17 AM
  • I have the same problem

    See http://social.microsoft.com/Forums/en-US/partnerwinclient7rc/thread/0aa54040-46e9-4df1-968d-e596672c7a8a

    I also have no break key on my keyboard.

    I have tried a number of keyboard mappers (software you can download that will map key sequences onto new keys) but it appears that none of them (that I have seen so far) can map the {break} key onto any other key.

    Microsoft need to fix this as 1366 x 768 is now a standard resolution and {break} keys are not available on all computers

    By the way:  the best keyboard scripting (mapper) software that I have found sofar is available at http://www.autohotkey.com/

    Does anybody know of a keyboard mapper that can map the {break} key to a different key?


    Joe
    Friday, February 25, 2011 9:11 AM
  • I have a workaround

    Using AutoHotKey (available free at http://www.autohotkey.com/)

    I remapped Ctrl+Alt+c to send Ctrl+Alt+Break using the following code snippet in AutoHotKey

    ; Ctrl+Alt+c sends ctrl+alt+break
    ^!c::send ^!{CtrlBreak}
    Now whenever Remote Desktop drops screen size down to a window I can use Ctrl+Alt+c to get it back to Full Screen Mode
    Pending proper support for 1366 x 768 screen resolution from Microsoft, this workaround is fine

    Joe
    • Proposed as answer by Joe Kelly Friday, February 25, 2011 12:24 PM
    Friday, February 25, 2011 12:24 PM
  • That worked.. Thanks a lot..
    Wednesday, August 17, 2011 7:56 PM
  • Thanks
    Monday, September 19, 2011 2:45 PM
  • Thanks much Arthur. It helped to resolve the issue
    Tuesday, October 25, 2011 10:18 PM
  • Esto soluciono mi problema, traté con Alt+Pausa y no funcionó, pero si con Ctrl + Alt + Pause

    This solved my problem, I tried with Alt+Break and didn't work, but Ctrl+Alt+Break work just fine! 


    KA

    Tuesday, February 14, 2012 8:40 PM
  • This is the answer. Not sure the other replies on this post fully understood the issue. Even if you set the display to full prior to making the rdp connection, once you restore down then try to maximize you lose the full screen. the shortcut keys given up worked. I'd been just living with this nuisance for I don't even know how long now. My life is complete now.

    Ctl + Alt + Break

    Saturday, February 18, 2012 3:00 AM
  • I had the same issue. 

    Somewhat, moving the slider back and then again to full screen fixed it!

    Tuesday, February 21, 2012 4:31 PM
  • Hi Steve,

     Its working fine. now my remote desktop window fgor maximized.

    Thanks,

    Kesav

    Tuesday, April 10, 2012 6:35 AM
  • i tries this and worked for me on my windows 7 pro. it was really a pain.

    thanks Oscar009

    all the best

    Kaswili

    Tuesday, April 17, 2012 6:40 AM
  • Worked for me.......Appropriate reply.

    Thank you Doucy

    Thursday, April 19, 2012 7:52 AM
  • The ctrl+alt+break solution did not work for me, but your solution did. Thanks for mentioning this, it was driving me crazy :)

    -Todd

    Tuesday, May 08, 2012 12:45 PM
  • Sorry Friend, But on my laptop (DELL INSPIRON 1525) having Win XP SP3, none of the above options work. But what works is Ctrl+Fn+Alt+Break. Any other options just executes shortcuts for local machine without affecting the remote desktop window.
    Friday, June 01, 2012 5:18 AM
  • Something so simple.... I had it set up to go right past that screen, I should have remembered that screen... Old age I guess, lol.

    Thanks for the tip.

    Saturday, June 09, 2012 12:06 AM
  • Thanx Steve,

    It works and helhful

    Thanks & Regards,

    Vivek Gupta

    Thursday, June 21, 2012 10:20 AM
  • Thanks much... This works cool.
    Wednesday, July 11, 2012 6:31 PM
  • Thanks a lot Li, this solved my PC problem at least. Appreciate!!
    Sunday, July 22, 2012 8:31 PM
  • Check this KB article from MS ...

    http://support.microsoft.com/kb/2582172/en-us Remote desktop is not displayed in Full-Screen mode when the screen resolution is 1366× 768 pixels in Windows 7 or in Windows Server 2008 R2


    Krish


    • Edited by WinAdvUser Monday, August 06, 2012 8:07 PM
    Monday, August 06, 2012 8:06 PM
  • On laptop with Windows 7 Enterprise 64 bit RDP'ing to SBS2008 server.

    Same problem but then Fn+Alt+break worked for me .... Mucho Gratias amigos!!

    Wednesday, August 15, 2012 9:39 AM
  • This worked for me. Thanks!
    Monday, August 20, 2012 11:42 AM
  • thanks............ It worked
    Wednesday, September 19, 2012 6:28 AM
  • Excellent... it was helped me
    Tuesday, October 30, 2012 11:35 AM
  • It worked for me Arthur.

    Windows 7 Enterprise

    Thank You.

    --Raghav


    Raghav

    Friday, November 09, 2012 2:20 PM
  • Try this 

    Ctrl + Alt + Break


    Wednesday, November 28, 2012 11:58 AM
  • This is precisely whats needed

    ashwin

    Friday, March 15, 2013 8:27 AM
  • This code is really works ^!c::send ^!{CtrlBreak}

    i just remap from Ctrl Alt C to Ctrl Alt = instead. Like a charm.

    No pause and break key on laptop is very common nowadays, but just not a good news to developer and system engineer.....

    Thursday, July 11, 2013 9:22 AM
  • Thanks @SteveFromMa,
    you give me the hint for  HP Pavilion dv6 Laptop,

    CTRL + Alt + Pause works, for this case you need to press

    Ctrl + Alt + Fn + Pg Up ( Pause )
    Saturday, July 20, 2013 1:59 PM
  • thanks 

    Ram

    Thursday, September 05, 2013 4:48 AM
  • Hi Oscar009,

    I would like to suggest you check the following steps.

    1.    Launch Remote Desktop Connection.

    2.    Click Options and switch to Display tab.

    3.    Drag the sidebar under Display configuration from Small to Large (Full Screen).

    4.    Click Connect to check the issue.

    Good luck!


    Arthur Li - MSFT

    Great ! This really helped me... Thanks
    Tuesday, October 08, 2013 8:07 PM
  • This works.

    Thanks

    Linda

    Wednesday, November 06, 2013 5:59 PM
  • Thanks I was using the Dell Latitude and for me the keys Cntrl+Fn+Alt+Insert/Pause worked ... Thanks... :)

    Friday, November 22, 2013 12:34 PM
  • Hi Arthur Li,

    Thanks! That helped! :)

    Monday, November 25, 2013 8:38 AM
  • This was the solution!  Thank you for the information...worked perfectly :-)
    Monday, November 25, 2013 7:21 PM
  • thanks a lot.. it works :)
    Friday, December 06, 2013 11:19 AM
  • Hi Li,

    It was really helpful, and solved my problem. Will keep this in mind and help other colleagues :)

    Thanks once again!

    Friday, February 07, 2014 3:11 PM
  • personally for myself (and I realize I am REALLY late to this party), I adjusted my laptop's resolution down one level (fortunately for me the change was so slight, it really isn't even noticeable) and then started up RDP. I can now maximize the RDP window and it goes into full screen mode as opposed to a maximized window.
    Thursday, March 13, 2014 6:28 PM