none
Failure on crcdisk.sys on Toshiba M40 Laptop Vista Install RRS feed

  • Question

  • I've tried installing Vista both using an Upgrade and a Clean Install, and both install fine untill the very last reboot at which stage the laptop hangs during boot-up. Then when I try safe-mode the last driver it loads untill it hangs is crcdisk.sys. I understand that this is sometimes caused by a SATA Hard-drive, which this laptop has I think, however, being a laptop I cannot readily upgrade the harddrive to an IDE or other. Does anyone have a solution for this?
    Tuesday, July 11, 2006 8:37 AM

Answers

All replies

  •  Hi GO13M,

     Go to http://www.microsoft.com/windowsvista/getready/preview.mspx  You may find helpfull imformation on this page.

    Tuesday, July 11, 2006 9:25 AM
  • Unforuently there was nothing there for my problem, so if anyone has a solution, could they please write it, as I spent around $AU20 getting the beta shipped it me and then not being able to use it.
    Tuesday, July 11, 2006 9:38 AM
  •  This is the support site for vista, try it.

     http://windowshelp.microsoft.com/Windows/en-US/default.mspx

    • Proposed as answer by djartsinc Saturday, March 21, 2009 4:58 AM
    • Marked as answer by Carey FrischMVP Wednesday, June 15, 2011 3:24 AM
    Tuesday, July 11, 2006 9:42 AM
  • Lots of people with the same problem but none with a solution that would work for myself, I think the problem may have to do with my Intel 82801FBM Ultra ATA Storage Controller, but I can't seem to find any Vista drivers that I can use for when I install Vista.
    Tuesday, July 11, 2006 9:53 AM
  • Unfortunatly, you are correct. The computer manufacturers don't want to release vista ready updates untill the final product is released. The only thing I can suggest is to keep trying. Maybe someone with more experiance could jump in here and offer an answer. Good luck.
    Tuesday, July 11, 2006 10:01 AM
  • Thanks for trying tho.
    Tuesday, July 11, 2006 9:34 PM
  •  Hi GO13M,

     Your welcome.  Sorry I couldn't be more help  . This vista stuff is new to me also, I am learning as I use it. Good luck

    Tuesday, July 11, 2006 9:39 PM
  • Found the following on a disscusion board at: http://windowshelp.microsoft.com/communities/newsgroups/en-us/default.mspx?dg=microsoft.public.windows.vista.installation_setup&tid=62d18bd4-4abc-4e32-aed9-36608298d65a&lang=en&cr=US&p=1


    Have been searching the forum for months trying to find a solution to 
    the halting installation, usually thought to have been associated with
    crcdisk.sys.

    The problem is in fact caused by pcmcia.sys files! To get round this,
    you need to delete or rename two files, but this can't be done from the
    safe mode command prompt, due to permissions.

    Instead, reboot from the install dvd and go to repair, then command
    prompt. Locate and rename the following files...

    Navigate to: c:\windows\system32\drivers\
    Rename pcmcia.sys pcmcia.old
    Navigate to: c:\windows\system32\driverstore\filerepository\
    Rename pcmcia.inf_539d553e pcmcia.inf_539d553eold

    Tried it on my computer and it worked great, figure you already know this but maybe by chance someone else is looking and this is what they get first

    Sunday, September 24, 2006 3:55 AM
  • Hi there,  crcdisk.sys is a Disk Block Verification Filter Driver.  I now have the same problem on my Server2003 Enterprise edition.

    I am using IDE drives only & this problem occured after installing XP Pro on a seperate partition on the same volume.

    One possible solution or a quick fix until the final version of vista is released is to:

    Perform a clean install, but partition your sata drive & install Vista on the second partition.

    21504mb will give you an even 20Gb partition.

     

     

     

     

    Monday, January 1, 2007 4:26 PM
  • I experienced exactly the same problem and thanks to your post was able to rename the files mentoined by you. This allowed me to get past the 'hung" boot problem and boot into the Windows Vista I installed. The PCMCIA device remains unusabe in device manager but at least the computer runs Vista without any problems. I checked Toshiba's website and there still seems to be no updated Vista driver as at February 4th, 2007.

    Thanks for taking the time to post. After 3 unsuccessful and increasingly frustrating installs, I was very grateful to be able to boot my PC and salvage the rest of my weekend.

    Monday, February 5, 2007 1:42 AM
  • This did the trick for me after trying multiple other things. I had a release copy...
    Friday, February 9, 2007 3:47 AM
  • Try checking your drivers at www.driveragent.com.  You can do a free scan of your system and it will let you know what drivers are out-dated (bad, the call them).  Once you know what's out-dated, you can go to the vender website and look for current ones.

    Perhaps your laptop needs better SATA drivers.  It's worth a try anyway.

    Sunday, February 11, 2007 8:17 AM
  • hello y'am italian y have installed succesfully win vista ultimate for install vista on a toshiba satellite m40 is necessary enter in a repair computer after installation with a boot of vista, command prompt go in the directory  of  C: or D:\\windows\system32\drivers    and delete pcimcia.sys file there is  a problem for failed start of vista now reboot and vista go...but pcimcia d'ont have a driver correct..for question:    racio85--gmail.com  sorry for my english......
    Thursday, March 22, 2007 2:46 PM
  • Hi! I own a Toshiba M40-282 laptop. I experienced the same problem (no boot and hanging on crcdisk.sys).

    I have tried to remove pcmcia.sys and his "fellow", but with no result. And this is because on boot, Vista re-creates these files!!!!

    Why were you all able to remove them and let Vista start, and I experience also this problem??

    How can I remove definetively the files??

    Thank you for your Support, Dadcom

    Sunday, March 25, 2007 3:26 PM
  • when goin te command prompt with repair your computer make sure directory not is x:\ but is your directory of installation vista
    Wednesday, March 28, 2007 3:10 PM
  •  

    For those who have a Toshiba Satellite M45-S265:

    1. Install Vista
    2. Wait until 1st reboot (obviously it will get halted with no disk activity for a long time)
    3. Reboot again, Press F8 and select Safe Mode
       Most probably, while loading drivers, the computer with be stuck at crcdisk.sys
       Reason:
            Vista is trying to load drivers which don't work in Vista
       Failing drivers may be:
     PCMCIA, 1394 (firewire, Texas Instruments)
            (Did you ever use them? I never did)
       Solution:
    4. Reboot and load from your bootable Windows Vista CD and choose to restore.
       Then choose 'other options' and go to console.
       Then do this:

     C:
     cd \windows
     del *pcmcia*.* /s/p
     del *1394*.* /s/p

       This will get rid of everything related to pcmcia and 1394
       including drivers, INF files .....
     
    5. Restart and enjoy!!!

    Notes:

    At first, I only did:   del *pcmcia*.* /s/p   but Vista didn't work.

    I am not sure what will happen if next time I reinstall Vista
    and only do:  del *1394*.* /s/p

    This method may work for other models of Toshiba or even other brands of Desktop/Notebooks

     

    Thursday, November 1, 2007 5:12 PM
  •  

    Hi Noel,

     

    Thanks for your advice.

     

    I am also facing this problem now on ThinkPad T61 with Window Vista. It is after I have loaded in Microsoft office 2007.  

     

    The system is just hang at "crcdisk.sys" when it is going to safe mode.

     

    Can your suggestion "C:cd \windows ....  del *pcmcia*.* /s/p ..... del *1394*.* /s/p"  be done on "Safe Mode With Command Prompt"?

     

    I have tried going to safe mode with command prompt before but it is still hang at "crcdisk.sys".

     

    I do not have the bootable Windows Vista CD but have Recovery CD with burnt from the system before I encourage this issue. Can the Recovery CD help?

     

    Thanks,

    kea

    Tuesday, November 6, 2007 2:27 AM
  • "Can your suggestion "C:cd \windows ....  del *pcmcia*.* /s/p ..... del *1394*.* /s/p"  be done on "Safe Mode With Command Prompt"? "

     

    No, it can't be done this way

     

    "I do not have the bootable Windows Vista CD but have Recovery CD with burnt from the system before I encourage this issue. Can the Recovery CD help?"

     

    Sorry, this method only works for the bootable Vista DVD. The RecoveryCD/DVD doesn't work the same. It is just like an 'image' of your hard drive which is going to be 'recopied' at the moment of recovery.

     

     

    Tuesday, November 6, 2007 10:12 PM
  • I have the same problem on my Lenovo T61 with Vist but the failure started after a while.. The system came with Vista, I installed Office 2007 without any problem. System was working fine for a a month or so. The only problem I had was the system wouldn't stay in Hibernate. It keeps coming out of Hibernate and going back to Hibernate. Then after a month or so it decided to hang right after loading crcdisk.sys.

     

    Since I have a the original Vista disks, i was able to boot and follow the procedure of renaming pcmcia.sys and the pcmcia.inf....  to .old but it didn't help unless it needs a special boot sequence or something...

     

    Any help would be appreciated....

     

     

    Monday, January 7, 2008 5:57 PM
  • My system is a compaq persario c500 lappy with a sata Fujitsu-MHV2080B� HDD... 

    I do not have a Boot disk for Vista,  I had put Ubuntu on half the drive, I can access from Ubuntu the windows drive but I do not have write access. what should I do to achieve this, make a windows boot disk.  the computer was brought 12 months ago.   The comments on changing the name of files has been the most understandable help I have seen so far..
    Thursday, February 21, 2008 2:55 AM
  •  

    Friday, March 14, 2008 11:51 PM
  • Have a question, it is asking me to Delete  " windows\inf\pcmcia.PNF, Delete Y/N "  after deleting  ' del *.* /s/p '
    should I say yes or no? so I can delete ' del *1394*.* /s/p '

    It worked all I had to do was remove laptop battery, who would of known?...........Thanks!!!!!!

    P-105 S6024, satellite

    Smile
    Saturday, March 22, 2008 10:18 PM
  • My son just installed Combat Flight Sim 3 on my Toshiba Satellite Pro running Vista home. Now it won't boot unless in safe mode. in save mode it spends ages on the crcdisk.sys file but does get past it. one of the posts mention that it is because vista is trying to load incompatible drivers. How do I work out which ones and then delete them?

    Sunday, July 27, 2008 1:14 AM
  • Go into your BIOS and switch SATA mode from AHCI to Compatibility.  I did this on a Toshiba and Windows started normally again.  I still have to identify which upgrade caused this problem in the first place, but at least it got this and another system running normally again.
    • Proposed as answer by R-Ptaz Monday, July 26, 2010 5:53 PM
    • Marked as answer by Carey FrischMVP Wednesday, June 15, 2011 3:25 AM
    Monday, July 26, 2010 5:53 PM
  • Huge HUGE HUGE thx to R-Ptaz for his solution and sharing with everyone here.  I had wasted 3 hours trying to re-enter Windows Vista after having the same problem as others here.  I tried his very simple solution though, and within 15 minutes (give your computer time to adjust to the new SATA settings), I was back into my normal Toshiba desktop screen.
    Monday, October 18, 2010 12:53 AM
  • You Sir are a genius as are those who mentioned this fix before. I have spent a long time trying to fix this problem between windows Vista update after an aborted installation of windows 7. I have tried numerous fixes which did nothinga nd almost rebuilt the laptop but this has my laptop installing windows updates as we speak, thanks again :-)
    Thursday, June 23, 2011 4:53 PM