none
Windows 8.1 RDP log-on attempt failing to connect to Remote App RRS feed

  • Question

  • Hi.

    Trying to connect to a Remote App from a Terminal Server running 2008 R2.  Previously accessed via a XP desktop which can still access it perfectly.  Have now got a Windows 8.1 Laptop and using the same credentials to access the same Remote App, the log-on fails every time with the message 'The log-on attempt failed'.  

    Have tried turning off Firewall and adding the Remote IP Address to the gpedit Saved Credentials (TERMSRV\etc).

    Have also ensured that the Remote App has allowed for connections of up to RDP 8.1.

    What is the solution to this problem?

    Tuesday, November 5, 2013 8:48 PM

Answers

  • Hi,

    The Remote Desktop port might be blocked by a firewall.

    If you're using Windows Firewall, follow these steps:

    1.        Open Windows Firewall.
    2.        In the left pane, click Allow a program or feature through Windows Firewall.
    3.        Click Change settings.  Administrator permission required If you're prompted for an administrator password or confirmation, type the password or provide confirmation.
    4.        Under Allowed programs and features, select the Remote Desktop check box, and then click OK.
    5.        If you're using a different firewall, make sure the port for Remote Desktop (usually 3389) is open.

    If your computer is part of a domain, by default you aren’t allowed to save your credentials when you connect to a remote computer. But you can change this.

    You must be logged on as an administrator to perform these steps.

    1.        Type gpedit.msc, and then press Enter.‌  Administrator permission required If you're prompted for an administrator password or confirmation, type the password or provide confirmation.
    2.        Under Computer Configuration, double-click Administrative Templates, double-click System, and then double-click Credentials Delegation.
    3.        In the right pane, double-click Allow Delegating Saved Credentials with NTLM-only Server Authentication.
    4.        In the dialog box that appears, click Enabled, and then click Show.
    5.        In the Show Contents dialog box, type the name of the remote computer (server) in this format: TERMSRV\computername, and then click OK.

    Keep post.


    Regards,

    Kate Li

    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time.
    Thanks for helping make community forums a great place.

    Thursday, November 7, 2013 9:25 AM
    Owner

All replies

  • Have you checked the Security log in the Event Viewer?
    Tuesday, November 5, 2013 8:59 PM
  • yes - but what should this be telling me?
    Tuesday, November 5, 2013 9:33 PM
  • Is there any failure attempts? Maybe, you can get a detailed information about the problem.
    Wednesday, November 6, 2013 6:07 AM
  • there are no failure attempts no.
    Wednesday, November 6, 2013 10:00 AM
  • Hi,

    The Remote Desktop port might be blocked by a firewall.

    If you're using Windows Firewall, follow these steps:

    1.        Open Windows Firewall.
    2.        In the left pane, click Allow a program or feature through Windows Firewall.
    3.        Click Change settings.  Administrator permission required If you're prompted for an administrator password or confirmation, type the password or provide confirmation.
    4.        Under Allowed programs and features, select the Remote Desktop check box, and then click OK.
    5.        If you're using a different firewall, make sure the port for Remote Desktop (usually 3389) is open.

    If your computer is part of a domain, by default you aren’t allowed to save your credentials when you connect to a remote computer. But you can change this.

    You must be logged on as an administrator to perform these steps.

    1.        Type gpedit.msc, and then press Enter.‌  Administrator permission required If you're prompted for an administrator password or confirmation, type the password or provide confirmation.
    2.        Under Computer Configuration, double-click Administrative Templates, double-click System, and then double-click Credentials Delegation.
    3.        In the right pane, double-click Allow Delegating Saved Credentials with NTLM-only Server Authentication.
    4.        In the dialog box that appears, click Enabled, and then click Show.
    5.        In the Show Contents dialog box, type the name of the remote computer (server) in this format: TERMSRV\computername, and then click OK.

    Keep post.


    Regards,

    Kate Li

    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time.
    Thanks for helping make community forums a great place.

    Thursday, November 7, 2013 9:25 AM
    Owner
  • We have the same problem but only when we are running the Remote Apps over RD-Gateway.
    Running the RemoteApps from a Client on the same subnet as the Session Host Server works.

    Client: Windows 8.1 with Remote Desktop Client 8.1

    Session Host Server: Windows Server 2012

    Remote Desktop Gateway: Windows Server 2012

    Running Remote Desktop in full desktop works fine.

    We have the same problem with Windows 7 SP1 clients with RDP 8.x. After uninstalling RDP 8.x all Remote Apps works just fine.


    Anders Månsson Senior Executive Consultant MCITP: Enterprise Messaging Administrator MCITP: Enterprise Administrator


    Thursday, November 28, 2013 1:33 PM
  • We are also experiencing the same problem you describe Anders Månsson.

    Did you end up resolving the issue ?

    Tuesday, March 25, 2014 2:10 AM
  • We still have this problem and we are still waiting for Microsoft to release a RDP Client that works.

    The only workaround is to use Windows 7 with RDP 7.x or to use full desktop.

    Windows 8.1 is not an option (accept if we use full desktop)


    Anders Månsson Senior Executive Consultant MCITP: Enterprise Messaging Administrator MCITP: Enterprise Administrator

    Tuesday, March 25, 2014 9:34 AM
  • Have you tried opening a case with Microsoft and have them issue a fix for this?
    Wednesday, March 26, 2014 6:48 AM
  • For the moment we have solved this with internal processes and stopped the rollout of Windows 8.1. We await an official release from Microsoft as this is obviously a bug

    Anders Månsson Senior Executive Consultant MCITP: Enterprise Messaging Administrator MCITP: Enterprise Administrator

    Wednesday, March 26, 2014 7:08 AM
  • Hi, just upgraded a laptop to 8.1 and now experiencing the same problem. Also, after installing update kb2830477 to a W7 SP1 no connection can be made to a remoteapp. If I uninstall this update then connection is possible.

    When I create a manual RDP to one of the RDSH servers, then connection is also possible, only without SSO. So I suspect something is wrong with the new authentication methods.

    Does anyone know if this issue is solved in update 1, later this week? Or even if Microsoft is aware of this bug?

    We need a solution for this, since it is blocking our W8 project.

    Monday, April 7, 2014 7:22 PM
  • Hi Gerrie

    Did you get any solution for this problem yet? We do have the same issues in our company.

    Thanks for reply

    Thursday, July 17, 2014 9:00 AM