locked
Windows 7 Home Premium - Can't Change Username in Authentication Dialog Box RRS feed

  • Question

  • I was hoping someone might be able to answer a question on how to get a computer running Windows 7 Home Premium to display both the username and password fields when attempting to authenticate to another Windows-based computer.

    Here's the situation:  we allow the executives and other authorized staff at our organization to establish a VPN connection to our corporate network (via Fortinet Forticlient, for what it's worth.)  Once the VPN connection has been established, on the remote computer, the user should be able to access the UNC path to our file server.

    Because the remote user hasn't yet authenticated to the corporate Active Directory domain, when attempting to access a UNC path on the domain, a dialog box should appear prompting the user for a domain username and password.  Enter the username (domain\username) and password, and the share should open, and the user should then be able to access the files contained within the share.

    I (and several other staff members) have been using this method successfully to access files over the VPN connection, and it works fine.  However, it doesn't work whenever the president of the company connects to the VPN from his home computer.

    Whenever the president connects to the VPN and attempts to access the UNC path, he reports that the dialog box that appears on his home computer has only a field for a password; the username field seems to be set to his local user account, and he doesn't have the ability to change it.  (I've asked him if there's a "use other credentials" option, and he reports that there is not; just a dialog box with only one field, the password field.)

    The president is running Windows 7 Home Premium on his home computer, so I thought that the problem might be because he was running that edition of Windows.  However, I installed the VPN client and tested connecting to the file server share using my wife's computer, which is also running Windows 7 Home Premium, and I received the two-field authentication dialog box as expected, and was able to successfully authenticate to the domain and open files from the share without any problem.

    Does anyone have any recommendations on what I can try in order to enable the president to successfully authenticate to our server share?  I'm stumped, and he's anxious to be able to get remote access to files from his home computer.

    Monday, July 13, 2015 12:02 PM

All replies

  • Hi,

    I suggest you delete the login credentials for the shared access, thus making Windows prompt you to login again. Then you can use a different username and password.

    First, you should check the Stored User Names and Passwords or Credential Manger. Open the Run dialog or a Command Prompt, enter the following command, and then remove the computer or server if listed:

    control keymgr.dll

    You should also open a Command Prompt and use the following command:

    net use \\fileservername/del

    Be sure you replace fileservername with the actual computer or server name you’re trying to access.

    Can we fix this issue?


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Wednesday, July 15, 2015 1:20 PM
  • Hi,

    I suggest you delete the login credentials for the shared access, thus making Windows prompt you to login again. Then you can use a different username and password.

    First, you should check the Stored User Names and Passwords or Credential Manger. Open the Run dialog or a Command Prompt, enter the following command, and then remove the computer or server if listed:

    control keymgr.dll

    You should also open a Command Prompt and use the following command:

    Be sure you replace fileservername with the actual computer or server name you’re trying to access.

    Can we fix this issue?


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    My apologies for the delayed reply to this!  I will suggest these options to the user, and see what he reports back.

    Thank you!

    Wednesday, July 22, 2015 7:04 PM