none
Powershell Crash when run new-cluster RRS feed

  • Question

  • Hi guys, i am trying to test creating new cluster via powershell however it crashes whenever i run it.

    New-Cluster -Name "randomClusterName" -node node1 -StaticAddress 10.0.1.253

    PS version 5.1.14393.693


    • Edited by Jimson Huang Friday, June 21, 2019 2:39 AM add ps version
    Friday, June 21, 2019 2:39 AM

Answers

  • Hi Sir,

    I manage to solve the issue by adding -AdministrativeAccessPoint dns.

    Thanks for your help


    • Marked as answer by Jimson Huang Tuesday, June 25, 2019 1:24 AM
    Monday, June 24, 2019 10:06 AM

All replies

  • "Crashes"?  What is crashing?  We know of no errors that say "crashing".  Airplanes and cars crash.  Programs throw exceptions.   There is no program exception that says "I am crashing".

    How to ask   questions in a technical forum


    \_(ツ)_/


    • Edited by jrv Friday, June 21, 2019 3:13 AM
    Friday, June 21, 2019 3:13 AM
  • So sir u mean in the event viewer stated appcrash is not an crash? what do you call it ? Airplane crash?
    Friday, June 21, 2019 3:37 AM
  • Please read the link I posted above.


    \_(ツ)_/

    Friday, June 21, 2019 3:54 AM
  • Hi Sir, i am sorry that i have bad vocabulary hence i try to explain in 2 ways.

    Summary:

    I need to create a failover cluster by using powershell script. The command i ran was ( New-Cluster -Name "randomClusterName" -node node1 -StaticAddress 10.0.1.253 ).

    However the powershell closed by itself after i run the command.

    On the event viewer i found it stated appcrash and event ID is 1001.

    If you need more information i am more than happy to provide it.

    In any case i have also try to reply to your how to ask a question in case my summary is to confusing to you.

    1. Search before you ask
    I have search however no result found.

    2. Ask in the appropriate forum
    My issue was regarding powershell got airplane/car crash (your terminology) after running command ( New-Cluster -Name "randomClusterName" -node node1 -StaticAddress 10.0.1.253 ).
    I believe i am doing powershell scripting and this is for scripting forum hence i am here. If this is not the correct forum to post i am sorry for being a horrible guy to choose some other forum for a scripting issue.

    3. Use a meaningful subject line
    Sorry for this i didnt know there new terms for crash usage.

    4. Don’t make Ted guess
    Sorry i should mention that the event viewer Event ID is 1001

    5. If something didn’t work, you have to say how it didn’t work
    I am sorry due to my limitation of vocabulary i am not sure how to explain powershell airplane/car crash

    6. Ted is not your personal consultant
    Yes i know that and i appreciate anyone who been polite and helpful.

    7. Describe the goal, not the attempted solution
    i am trying to create a failover cluster by using powershell script.

    8. Have appropriate expectations
    Yes i dont expect everyone to reply just hope the person who need more details will be more polite

    9. If your question is answered, don’t forgot to follow up
    Noted and will do.

    Friday, June 21, 2019 6:09 AM
  • Thank you for taking the time to provide correct and clear information.

    Event 1001 indicates that something is not installed or configured correctly,

    See the following for detailed instructions: https://docs.microsoft.com/en-us/windows-server/failover-clustering/create-failover-cluster


    \_(ツ)_/

    Friday, June 21, 2019 8:06 AM
  • Hi Sir,

    I manage to solve the issue by adding -AdministrativeAccessPoint dns.

    Thanks for your help


    • Marked as answer by Jimson Huang Tuesday, June 25, 2019 1:24 AM
    Monday, June 24, 2019 10:06 AM