none
Sysprep and AVG antivirus

    Question

  • Hi all,

    I captured the image of Windows 7 with AVG antivirus installed. When I apply the image to another machine and boot up the installation is aborted. The problem is caused by antivirus. Anyone know how to fix it?

    Thanks!

    Wednesday, March 6, 2013 12:03 AM

Answers

  • Hi,

    You may remove AVG antivirus, then capture the new image and see how it works.


    Tracy Cai
    TechNet Community Support

    Thursday, March 7, 2013 6:50 AM
    Moderator

All replies

  • Hi,

    You may remove AVG antivirus, then capture the new image and see how it works.


    Tracy Cai
    TechNet Community Support

    Thursday, March 7, 2013 6:50 AM
    Moderator
  • Wow... Way to not answer the question there Tracy, yet still mark it as such.

    Keppler, You're using AVG 2013?  2012 was able to be captured without issue, but 2013 will require some special action.  I had the same failure and as such booted to a boot disk.  I dumped the Panther folder to a USB.  If you load the setup.etl file in Event Viewer and filter by errors, you should see about 6 errors.  The bottom two are likely:

    SclRegProcessKeyRecursiveByHandle@330 : (c0000022): Failed to process reg key or one of its descendants: [\REGISTRY\MACHINE\SOFTWARE\AVG]

    SclRegProcessKeySubkeys@517 : (c0000022): Failed to open child key: [AVG2013]

    Before you sysprep Windows, you must run AVGPrep.  Download the one for your version here:  http://www.avg.com/in-en/utilities



    • Edited by SaintFrag Tuesday, April 30, 2013 2:03 PM
    Tuesday, April 30, 2013 2:02 PM
  • Hi SaintFrag,

    That's the exact same error I'm currently getting, and you're right, 6 errors exact.  However, when I run the AVGPrep tool, I still seem to be getting the same errors.  Could you please walk me through exactly how you ran the tool? 

    I downloaded the AVGPrep 2013 tool, and double clicked it to run it.  Then when it asks for the "terminating" 4 characters of the license key, I entered in the 4 characters that WEREN'T shown at the end, the 4 that it hides [does that sound right?], and then hit enter, and the command window disappears.  I then checked in %PROGRAMDATA%\ in the AVG 2013 directory, and the AVGPrep dat file was there, as I've read it should be on some forums.  Then I ran sysprep, and restarted, and had the same error.  Anything different you did?

    Thanks!

    ---------------------------

    EDIT: Solved it!  I also needed to disable AVG Self Protection within the AVG 2013 Business Edition client, as apparently just running the AVGPrep tool still causes it problems.  Before sysprepping, here's what I did in order:

    •Download AVGPrep 2013 from the link provided by SaintFrag, here: http://www.avg.com/in-en/utilities

    •Right click the downloaded application and choose Run as Administrator, and when prompted for the last 4 characters of the license, I entered the actual last 4 characters of my license that AREN'T shown in the key in the command prompt.  It seems to hide the last 4 characters, so find the actual 4 on your licensing documentation and type those in and hit enter.  It should flash briefly that it was successful in creating the AVGPrep.dat file before the command window closes.

    •This is the critical part.  Launch the AVG 2013 client from the system tray or start menu, and in the top right, choose Options>Advanced settings.  Down the left side of the Advanced Settings window, click AVG Self Protection, and uncheck the box next to "Enable AVG Self Protection".  Click Apply, and click OK.

    •Restart the reference machine and when it's restarted, double check the options and that the Enable AVG Self Protection checkbox is still unchecked.  It should be.  From here, run your sysprep command as usual.

    Note: If you use AVG Admin, you can always just have a rule that re-enables Self Protection for the group of computers as soon as you've deployed the image, and make it manditory.  That way you don't have to remember to re-enable Self Protection on each client after deploying.

    • Edited by link470 Wednesday, July 31, 2013 11:58 PM
    • Proposed as answer by link470 Tuesday, October 22, 2013 9:26 PM
    Wednesday, July 31, 2013 9:17 PM
  • I'm sorry, I should have followed up, but I had my alerts turned off. This is correct, AVG Self Protection is causing the issue. I'd opened a ticket with AVG back in May that this issue is occurring and they've not updated the AVG Prep tool yet. :(
    Thursday, August 1, 2013 1:18 PM
  • No problem!  The image deployed, so I'm happy!  Thanks for your reply.  Too bad about AVG not updating the Prep tool, that would definitely help out a lot of people I think.
    Thursday, August 1, 2013 10:44 PM
  • Really had a mess with this imaging what I did to fix the issue was not to reset the image I used ERD to remove the folders and the registry entries from AVG. After doing this Windows 7 was able to continue the installation. Once in you can remake the image with avg removed. The first problem I has though was the whole sysprep use. When I did the image it corrupted the start up in the current installation on the test system.

     So I used Hiren's to get to the .wim file that was generated on the test machine moved it over to a known good working system created an ISO of my windows and dropped it into the sources folder it will ask to replace the current one. Then I was able to reinstall windows then after starting services and setup to continue I got the error caused by avg. Though I have to say really Microsoft in all your omnipotence you cannot create an all in one software for deployment that will do it all including looking for possible problems or at least warn of anti-virus as an issue. This took four hours to get done. 


    • Edited by tdrknt Sunday, December 15, 2013 11:33 PM
    Sunday, December 15, 2013 11:32 PM