none
Tabular 2019 compatibility level 1500: unable to process table or deploy? RRS feed

  • Question

  • I have found that using SQL Server SSAS 2019 models work fine up to compatibility level 1400.

    However, after changing it to level 1500 I am no longer able to process tables locally or deploy.  

    Once set to level 1500 and attempting to deploy or process I get the error:

    Failed to save modifications to the server. Error returned: 'An unexpected exception occurred.
    
    '.

    Tuesday, November 5, 2019 8:42 PM

All replies

  • Hi OneWithQuestions,

    SQL Server 2019 is just released on Nov 4, 2019, you would get many unexpected errors. Have you checked SSAS service log?

    Log operations in Analysis Services

    Best Regards,

    Will


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Wednesday, November 6, 2019 3:04 AM
  • I have a similar issue and have raised a case with Premier Support. 
    Wednesday, November 6, 2019 5:35 PM
  • Would you please post back with any discoveries? 

    Do you get this by chance if you try to process a 1500 level model?

    Wednesday, November 6, 2019 7:16 PM
  • Why release it if the expectation is people will be getting "many unexpected errors"?  Maybe time for a new QA team?
    Wednesday, November 6, 2019 7:57 PM
  • I can’t even deploy my model at 1500, I tried building it up piece by piece with BISM Normalizer but after tables and relationships and a few measures I hit a brick wall with even the simplest of measures. All fine at 1400.
    Thursday, November 7, 2019 1:06 AM
  • Yeah, I get the same issue.

    I can't deploy, I also can't process it inside Visual Studio.

    So I have my workspace on a local SSAS 2019 box and I tried to process it there, also fails.

    All works perfectly fine at 1400, it is just when I flip to 1500.

    Thursday, November 7, 2019 3:12 PM
  • Hi OneWithQuestions,

    Thanks for your reply.

    For such issue, you could also send your feedback via https://feedback.azure.com/forums/908035-sql-server

    Hope this could be helpful to you.

    Best Regards,

    Will


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Monday, November 11, 2019 8:35 AM
  • I have exactly the same issue and tested all the things described abose.
    Please advise as soon as possible.
    Monday, November 18, 2019 9:12 AM
  • I've made some additionnal tests.

    Summary : The issue occur when the compatibility version is 1470 or above.

    Details :

    So it's possible to script, upgrade and process our SSAS DB with compatibily version from 1400 to 1465 but when we upgrade to 1470 or above (1475,1480,1500) the process failed.

    Unfortunately it's not an acceptable workaround because we want to upgrade to use CALCULATION GROUPS and it's available only from 1470.

    I don't know if it's a coincidence but the hypothesis that the major changes made between these two versions (Compat Level1465 and 1470) to introduce the CALC GROUP features seems to cause the issue.

    HTH

    Monday, November 18, 2019 12:48 PM
  • I have found that it doesn't happen to all models, just those that seem to be somewhat more complex.

    I have not been able to determine which exact features or segments of code cause the error.

    Do any of your models use partitions in their tables to allow loading and processing as separate partitions?

    Monday, November 18, 2019 1:56 PM
  • Hi,

    We have not been able to repro this error yet. If you would be able to supply us with more detailed repro steps and perhaps your model.bim file you are using to ProBIToolsFeedback@microsoft.com we will be better able to assist you.

    Thanks,

    Parker

    Tuesday, November 19, 2019 5:48 PM
  • I've raised this with MS Support and they have been able to reproduce the issue.
    Wednesday, November 20, 2019 9:20 AM
  • Hi, Any news from MS Support on this case ?
    Tuesday, December 3, 2019 1:47 PM
  • I was told they are able to reproduce the issue and they have it flagged as a bug and are hoping to have the fix published with the first patch.

    I believe that patch date is sometime in January when it will be released for SQL 2019.

    Tuesday, December 3, 2019 8:20 PM
  • Hi - did MS provide any possible workarounds on this issue while waiting for the patch?  We're in the process of piloting a migration to 2019 - but until this is resolved - we're kind of stuck.  Puts us back several months on the project.  TIA
    Wednesday, December 4, 2019 3:55 PM
  • Actually yes! I just got a note from them this AM.

    They said to disable calculation groups in SSAS 2019 and that should resolve the issue until they can issue a patch:

    ---------

    INSTRUCTION TO DISABLE CALCULATION GROUP IN SSAS 2019 TABULAR INSTANCE:

    =======================================================================

    1. On the SSAS 2019 tabular instance machine, please locate the msmdsrv.ini.

    2. If you are unable to locate the msmdsrv.ini, please use below method to find the msmdsrv.ini.

    a.  In the run command, go to the “Services.msc”

    b. find the SQL Server Analysis Service for default instance,  or SQL Server Analysis Services (Yourinstancename). For example, please is a screenshot of SQL Server Analysis Services (Tab19) because the instance name is called Tab19.

    c.  Right-click on it and select “properties”

    d. Select “General” tab, and review the “Path to executable”. Note down the config folder location where msmdsrv.ini is located.

    3. Edit the msmdsrv.ini.

    a. Make a copy of the old msmdsrv.ini in case you need it in the future.

    b. Use notepad to edit the msmdsrv.ini and add the CalculationGroupsEnable property. Below is an example (in yellow):

    <Feature>

                                    <CalculationGroupsEnabled>0</CalculationGroupsEnabled>

                                    <ManagedCodeEnabled>1</ManagedCodeEnabled>

            ……………………………….

    c. Restart the SSAS instance

    If you ever have to revert the change, perform the following:

    • Stop SSAS service
    • Rename the msmdsrv.ini to msmdsrv_test.ini
    • Rename the msmdsrv-Copy.ini back to msmdsrv.ini
    • Start up the SSAS service.

    Wednesday, December 4, 2019 4:05 PM