LAN adapter only works in 10Mbps Full duplex


  • Hi, I have had this weird problem for days.

    The LAN adapter on my motherboard will only work when I change the speed to 10Mbps full duplex setting. The motherboard is Gigabyte GA-P55-UD4 with 'RealTek PCIe FE Family Controller'. At the same time, I have Ubuntu installed in another partition. The issue arose right after I updated my Ubuntu OS.

    When I booted back to my windows 7 OS and using any other speed faster than 10Mbps, it repeatedly drop and reconnect over and over, and displaying 'network cable unplugged'.

    I have DSL connected to a Cisco switch, I tried all the ports on the switch and I also tried to change the cable. The network cable works instantly once I plug on my another laptop, with auto-negotiation setting enabled. So I guess I ruled out the problem of cable itself and switch. Anyone has any idea why it happened? Reinstalling my computer is not my first choice and I am looking forward the fix. =)

    Thanks a lot in advance!!

    Tuesday, July 20, 2010 8:31 AM

All replies

  • First i would reccomend updating the nic driver for windows.

    If the issue persists you can disable the auto-negotiation and force the NIC to work in 100 mb Full. You should attempt to force this on both windows and the switch.

    Tuesday, July 20, 2010 6:37 PM
  • Hi Kevin,

    Gratitude for the reply.

    What I have done so far was, I tried to remove the NIC card from device manager together with the removal of the drivers, and install it once again after reboot, no success. I tried vary negotiation rates, starting from 10Mbps till 1Gbps, including auto-negotiation, only 10Mbps full duplex works.

    One thing I have also noticed is, once I run Realtek Ethernet Diagnostic Utility, I got MAC address error, which is weird..

    I would suspect that it may has something to do with my Ubuntu partition since it happened right away after I updated my Ubuntu OS?

    Thursday, July 22, 2010 2:57 PM
  • verify port on motherboard , it could be damaged, some wires could be touching
    Thursday, July 22, 2010 5:47 PM
  • Hi Nederita,

    Thanks a lot for the reply. I open the computer case yesterday but didn't see anything unusual. But I was speaking with one of my colleagues and he suggested to remove the LAN card from device manager, in addition, clean up the driver with utility like driver sweeper.

    I may try that solution this weekend and will post back the result.

    Friday, July 23, 2010 7:40 AM
  • i didn't meant to check the motherboard.., just the port, like in the photo,

    i experienced  same problem, it worked in 10mb full duplex, but none in 100mb full duplex or auto negotiation, it turn out to be problem in bad crimp of connectors,

    if you rule out bad cable, bad connectors, bad port on the switch(router), it remains only port on motherboard....

    Friday, July 23, 2010 8:26 AM
  • Hi,

    Will the LAN adapter work in 100 mbps full duplex in Ubuntu? If the same issue, I agree with Nederita Dumitru, check the 8  pins.

    If only the windows 7 OS encounter the issue, I suggest boot into Safe mode with Networking to check if it is due to a faulty NIC driver.

     the driver could get corrupted, clear  the driver  completely and reinstall the driver when it worked before.

    On the network side, would you please recheck the configuration in switch? Here is the detailed document.

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Tuesday, July 27, 2010 8:12 AM
  • Hi Magon,

    Thanks for the advice and sorry for not being able to come back in time since I was in vacation. I still haven't fix my problem yet, I have completely removed my Ubuntu partition and currently only working with my Win7 OS, unfortunately the problem still persists. I have checked my port, as what Nederita suggested and it seems totally fine. By the way, just for your information, I just assembled that computer from scratch couple of weeks ago, meaning all new components, so I guess the chance that I get hardware failure is little.

    I have also completely removed the hardware with existing driver in assistance of driver sweeper, nothing has changed. However I was not aware of the switch configuration document, I am going to read it through, perhaps it can be switch problem.

    I will post back if I find out anything interesting. Thanks again.

    Friday, August 06, 2010 11:14 AM
  • I have this same problem starting today. Windows 10 was connected to the internet for a number of days after I upgraded from Windows 7. After installing Linux (Lime Cinnamon Sarah 18) it worked for about an hour but then after a reboot it didn't work at all in Windows 10 or Linux until I set the Speed and Duplex setting to 10MBPS. Full or half duplex both work but not at speeds > 10MBPS. Coincidence?
    Monday, August 15, 2016 12:35 AM