none
Program not able to update without UAC asking for Admin credentials

    Question

  • We installed United Parcel Services' program Worldship on our Windows 7 professional PC.  We had to disable the UAC in order to allow our regular users (non admin) access.   Although the users can open the program and work in it, the program constantly tries to update itself.  It requires a Admin username and password to allow the updates to install.  This program is constantly updating and installing it's updates.  We went into the folder where the program resides and gave the folder full control under the user ID that is being used to login to the PC, but we still get the UAC whenever the update needs to install.  We even ran a command to update the registery (from UPS support) to allow the updates to install, but UAC still prompts.  Can you recommend a fix for this? 
    Tuesday, January 25, 2011 8:58 PM

Answers

All replies

  • Looks like the Updater includes a manifest to request admin rights.

    Ask the developers of the tool to implement the updater as service which updates the data without user interaction.


    "A programmer is just a tool which converts caffeine into code" CLIP- Stellvertreter http://www.winvistaside.de/
    Tuesday, January 25, 2011 10:51 PM
  • Thank you for responding.   Here is some more information...The issue isn't the communicator software, but the software that needs to update on the PC.  The Worldship program will communicate with UPS servers and download a piece of software that usually prompts the shipper to close the program then go back into it, but before it goes into the program it runs an updater for the downloaded software.  The UAC comes up asking for credentials even though UAC has been deactivated.  This is a PC that is part of a domain.  The user who logs in is also a local administrator (not domain), but this UAC is still coming up.  We gave the folder full rights for the logged in user, but still can't figure out why UAC is still coming up. 


    Lino Reyes
    Tuesday, January 25, 2011 11:15 PM
  • The UAC prompt is triggered by an UAC manifest in the Updater Exe:

    http://msdn.microsoft.com/en-us/library/bb756929.aspx

    You can try to use Microsoft Application Compatibility Toolkit to disable the UAC prompt:

    http://www.ghacks.net/2010/07/08/get-rid-of-uac-prompts-with-microsofts-application-compatibility-toolkit/


    "A programmer is just a tool which converts caffeine into code" CLIP- Stellvertreter http://www.winvistaside.de/
    Wednesday, January 26, 2011 12:13 AM
  • Has anyone tried this and did it work?

    Thanks,

    J.

    • Edited by JasonT2000 Monday, September 26, 2011 6:10 PM
    Monday, September 26, 2011 6:10 PM
  • Yes, I was able to get the Microsoft Application Compatibility Toolkit to fix the issue with UPS Worldship 2011 requiring Admin credentials to update. It was a Windows 7 workstation on the domain with "standard user" access, but I used "Run As Administrator" when launching the Compatibility Manager program and then created the whitelist database.  No need to use the command prompt to install the whitelist database as you can right click on the database and select "Install".  So far, it appears to be working.

    Followed Andre's links from above:

    http://www.ghacks.net/2010/07/08/get-rid-of-uac-prompts-with-microsofts-application-compatibility-toolkit/

     

    Wednesday, October 05, 2011 2:41 PM
  • Which executables did you have to fix?  Did you only have to use the "RunAsInvoker" fix?  It eliminates the UAC prompt, but then when it looks like it's going to start installing, I get the message "The UPS Patch program could not update UPS Software".

    Thanks.

    Wednesday, October 26, 2011 2:59 PM
  • The executable I chose with the Compatablity Tool was runpatch.exe found in C:\UPS\WSTD and used "RunAsInvoker".  I could not run the test on it as described in the ghacks.net article.  Prior I ran RegAccess as Administrator found in the C:\ups\WSTD directory and gave Users full control of C:\UPS and its subdirectories.  It now works without invoking UAC when an update is required. 
    • Edited by SSchindler Thursday, December 29, 2011 11:46 PM
    • Proposed as answer by SSchindler Thursday, December 29, 2011 11:46 PM
    Thursday, December 29, 2011 11:43 PM
  • I ran across this post while trying to get WorldShip 2012 to run updates without admin rights. Between Andre.Zigler's application compatibilty program suggestion, and SSchindler's suggestion of running regaccess, I was able to get it working. Thanks!
    Monday, April 02, 2012 2:58 PM
  • Thanks to all for the advice. 

    The UAC part works now for updates, but now my issue is that the SQL database service will not start, unless I login to local services as admin and manually start it. I tried to create load admin credentials into the service, but it still won't start the service automatically for some reason. 

    Any ideas are appreciated. Thanks. 

    Tuesday, June 12, 2012 3:57 PM