none
Windows 7 32bit - Nvidia 8400GS - Cannot get 1080p on HDTV

    Question

  • I have a 3Ghz P4 HP MCE m7060n with an Nvidia 8400GS PCI card connected to a Sony 50" SRXD HDTV, DVI to HDMI. I dua boot between Windows 7 32bit and XP Pro. I am using the latest Nvidia 1.85.85 drivers. With XP Pro, I can set the Digital Signal to 1080p (1900x1080) and shrink the Overscan, using the Nvidia Control Panel, so my Windows Desktop fits insice the 50" display. With Windows 7 32bit, and the 185.85 drivers, when I open the Nvidia Control Panel, the "Resize the Display" option is there, but the Sliders, that let me shrink the Overscan, are maxed out at the low end and will not let me shrink the Desktop. The only way I can do it is to choose 720p, but I only get 1280x720.

    I built a new PC with an Asus P5Q mobo, an Intel Quad Core Q9400 processor, 4Gb Corsair Ram, and an Nvidia Gforce 9800GTX+ PCI-e video card. I installed Windows 7 64bit and it booted up at 1080p. When I launched the Nvidia Control Panel, I was easily able to use "Resize the Display" to shrink the Desktop to fit my 50" screen. I am using the same 185.85 Nvidia drivers, the same DVI to HDMI cable and the same HDTV.
    Thursday, May 21, 2009 1:49 PM

Answers

  • This looks like an EDID problem. Your HDTV probably has a poorly designed EDID. The idea is to create an INF file ( driver) for your HDTV, modify it so that it accepts 1080p and then load it. 

    1- In order to read the current EDID information in Win7, you can use the free EnTech Monitor utitility. You can then click on the option to create an INF file, which will create an EDID override driver that you can then modify and use to load as your new driver for your HDTV (PnP Monitor in the device manager).

    2- The trick is to modify the EDID override section in that INF file so that it tells Win7 that 1080p is a resolution supported by your HDTV.

    The best way to do this is to use the free "Phoenix EDID" ulitility in order to read the current EDID data from the registry, add custom resolutions in the program (1080p @ the refresh rate you need) and then export the EDID information to a file using the menu option.

    3- You then need to compare that EDID information with the EDID data saved in your INF file and change the EDID portion that is different in the INF file. By doing so you will have created improved drivers that enable 1080p support. Those will enable an EDID override (which ignores the hardware EDID of your HDTV)

    4- You load those drivers through the device manager (select manually from the folder where you saved them).

    5- Restart your computer or use the WIndows Key+P in order to switch between the various dual monitor modes (this should force a driver refesh in most cases, though restarting is the safest way).

    Notes: 
    - You can still revert back to the old driver if this didn't work for you, so this is a safe procedure.
    - Comparing both EDIDs is a bit time consuming. But if you changed only 1 or 2 resolutions/ refreshr ates, not many bytes will change (max 4+the last byte)
    - Use google in order to download both utilities, they are easy to find. 
    - Another option is to make the EDID changes directly in the registry. The Monitor Info utility lets you do this. However if you installed several graphical driver versions in a row you may sometimes have several entries for the same Monitor in Win7 and it is not always clear under which entry you should make the change, so making that change to both EDID entries can be time consuming.

     
    • Marked as answer by Adam M MCP Monday, May 25, 2009 3:41 PM
    Monday, May 25, 2009 6:34 AM

All replies

  • I have the same issue....


    Any fixes or workarounds on this that anyone is aware of?
    Saturday, May 23, 2009 2:46 PM
  • This looks like an EDID problem. Your HDTV probably has a poorly designed EDID. The idea is to create an INF file ( driver) for your HDTV, modify it so that it accepts 1080p and then load it. 

    1- In order to read the current EDID information in Win7, you can use the free EnTech Monitor utitility. You can then click on the option to create an INF file, which will create an EDID override driver that you can then modify and use to load as your new driver for your HDTV (PnP Monitor in the device manager).

    2- The trick is to modify the EDID override section in that INF file so that it tells Win7 that 1080p is a resolution supported by your HDTV.

    The best way to do this is to use the free "Phoenix EDID" ulitility in order to read the current EDID data from the registry, add custom resolutions in the program (1080p @ the refresh rate you need) and then export the EDID information to a file using the menu option.

    3- You then need to compare that EDID information with the EDID data saved in your INF file and change the EDID portion that is different in the INF file. By doing so you will have created improved drivers that enable 1080p support. Those will enable an EDID override (which ignores the hardware EDID of your HDTV)

    4- You load those drivers through the device manager (select manually from the folder where you saved them).

    5- Restart your computer or use the WIndows Key+P in order to switch between the various dual monitor modes (this should force a driver refesh in most cases, though restarting is the safest way).

    Notes: 
    - You can still revert back to the old driver if this didn't work for you, so this is a safe procedure.
    - Comparing both EDIDs is a bit time consuming. But if you changed only 1 or 2 resolutions/ refreshr ates, not many bytes will change (max 4+the last byte)
    - Use google in order to download both utilities, they are easy to find. 
    - Another option is to make the EDID changes directly in the registry. The Monitor Info utility lets you do this. However if you installed several graphical driver versions in a row you may sometimes have several entries for the same Monitor in Win7 and it is not always clear under which entry you should make the change, so making that change to both EDID entries can be time consuming.

     
    • Marked as answer by Adam M MCP Monday, May 25, 2009 3:41 PM
    Monday, May 25, 2009 6:34 AM
  • If this is an EDID problem, why is it that I have no problem with the Windows 7 64bit machine but yet I have the problem with the Windows 7 32bit machine?
    Thursday, May 28, 2009 2:30 PM
  • The overscran or underscan problems happen as a result of the EDID problems. All you do with the drivers is fiddle to correct an issue that shouldn't be there in the first place. Of course it may be that improbed 32 bit drivers will allow you to correct this issue but the most natural solution would be to use an EDID override driver for your monitor / HDTV.
    Thursday, May 28, 2009 7:02 PM
  • Hi, I had the same problem with my Desktop which has Nvidia GTS 450 Graphic card, which connected to LG 32LE5500 - HDTV (1080p) through HDMI and it got resolved using your resolution. Thanks alot
    • Proposed as answer by iyyappan_t Wednesday, January 05, 2011 8:16 PM
    Friday, December 03, 2010 4:06 PM