locked
Unable to connect to WPA2-Enterprise wireless network

    Question

  • After installing Windows 8 Consumer Preview I'm unable to connect to our corporate wireless network.  (Actually had the same problem in Developer Preview, but dismissed it as "preview bug")  I'm running on the Samsung tablet given out at Build.  I'm able to connect fine using several different machines using Windows 7.  I've replicated the settings from a working machine, but when attempting to connect (after being asked for credentials) I see "The network is taking taking longer than usual to connect" and then a connection failed message.  My settings are:  WPA2-Enterprise security type, AES encryption type, Microsoft: Protected EAP (PEAP) authentication method, NO Validate server certificate, EAP-MSCHAP v2 authentication, Fast reconnect enabled, User or computer authentication mode.

    My IT guys tell me that when I attempt to connect I am associating with the Access Point.  At one time we saw the AP log a message indicating that authorization had been attempted using the machine name of the PC (which failed).  This happened before I was asked for credentials.  We don't see anything else on the AP side.  Any help would be appreciated.

    Tuesday, March 20, 2012 10:13 PM

All replies


  • Hi,

    Please double check the settings or create the wireless connection manually.

    In 802.1x settings, please select “Specify authentication mode” and choose "User authentication" to have a try.

    Hope this helps.

    Thanks.


    Nicholas Li

    TechNet Community Support

    Friday, March 23, 2012 5:57 AM
    Moderator
  • @Nicholas-

    I've tried your suggestion.  No go.  One of the interesting aspects of this problem is that I can connect to this wireless network just fine using both Win 7 and my Windows Phone.

    Friday, March 23, 2012 2:59 PM
  • I have the same problem like you

    I have a problem with wifi access in my university. I dont know much about wifi system so i hope that you can understand what i mean. My Wifi system in my university use security type : WPA2-Enterprise and all computers are manager by MAC address. Each user is provided an accound and that account can only accessed on only one computer Belows are some picture of our wifi configurationhttp://nj6.upanh.com/b1.s16.d1/53082c4934ce27b5aafe786e4df9a949_42349546.sshot20.pnghttp://nj7.upanh.com/b3.s13.d5/b46c1aef54febc6c9049a402d5d57d7b_42349547.sshot21.pnghttp://nj5.upanh.com/b2.s16.d1/9f9780ac08cc8328e44198ed29b316e1_42349555.sshot22.pnghttp://nj5.upanh.com/b6.s13.d3/f0f5006769c66ba68535ceb360bec1d7_42349565.sshot23.pnghttp://nj7.upanh.com/b5.s13.d3/a51288ec998b30ed54ec398d0dc2438c_42349567.sshot24.pngBut i can't connect to the network on my Windows 8 Consumer Preview. In another building of my school, they use WPA Enterprise with TKIP encryption type, i could access the network but i had to add @fun.edu.vn after my account or fun\account so that i could log in. But in my case with WPA2-Enterprise with AES encrytion type, i have been trying so many ways to access but it's still impossible. I hope you can direct me to access or if that's an error, please fix this. Thanks


    Saturday, March 24, 2012 2:16 AM
  • same problem 
    Tuesday, April 03, 2012 2:37 PM
  • I have the same issue here.
    Thursday, April 05, 2012 6:32 PM
  • I'm also having the same problem
    Monday, April 09, 2012 6:17 PM
  • I am facing the same problem as Thread Starter but rather in my schools campus. I am dual booting win 7 and win 8 CP , the connection works in win7 but not win 8 CP. Worst is I am developing a Win 8 App for a module project and needs to connect throught the school wireless for intranet connectivity.
    Thursday, April 26, 2012 8:29 AM
  • Hi

    Looks like multiple folks are facing this problem. Can one of you send me the following information

    1. The details of the PEAP settings in your profile

    2. Logs from the connection attempt. Run the following commands in the command prompt

       netsh ras set tr * en ----this enables logging

       netsh ras set tr * di ----this disables logging

    You can find the logs under %WINDIR%\tracing. Can you send them to me at aanandr@live.com?

    Monday, May 07, 2012 9:24 AM
  • @Aanand: I have been having the same problem with WP2-Personal wifi networks... which are protected by password rather than via PEAP. Last time was at a conference a couple weeks ago... everybody could connect every one of their devices (computers, tablets, smartphones), except me with my Win8 tablet (the Samsung one distributed at the //BUILD/ conference).

    A few MSFT employees were present at the conference and they were demonstrating Windows 8, so I went to see them to talk about the network connectivity. Both of them had 2 tablets: the model distributed at //BUILD/ and a newer model of the Samsung tablet... like me, they could not connect the //BUILD/ tablet but they were successful connecting the newer model. Hope this information helps...

    Monday, May 07, 2012 12:36 PM
  • Same problem on my campus with Windows 8 on my Samsung tablet.
    Monday, May 07, 2012 5:40 PM
  • Same problem.  Have tried a variety of settings to use a certificate to authenitcate.  can do with windows 7.  some settings have shown me my certificate, but then don't connect.  have connected to pw secured portion of network sucessfully, but not to domain portion
    Thursday, May 10, 2012 12:18 AM
  • Hi. Thanks for the info. In that case can you send me the following logs

    netsh  wlan  set tracing mode=yes

    netsh  wlan  set tracing mode=no

    The logs are under

    %temp%\nettraces

    You can send them to me at aanandr@microsoft.com

    thanks

    Aanand

    Monday, May 21, 2012 11:50 AM
  • Same problem! I dual boot into Win 7 and Win 8. Can connect to my home network with Windows 8 but connecting to any other network has not been working since a few weeks. Have to use Win 7 for that everytime.
    Monday, May 28, 2012 12:14 AM
  • I am also having the same issue. With Windows 8 Release Preview I am unable to connect to our internal WP2 personal and WPA2 enterprise networks within our company. This same system with Windows 7 on it has no problem connecting at all. Aanand, I have sent you the traces you are looking for. Any help would be greatly appreciated. Thanks!
    Friday, June 01, 2012 3:43 PM
  • More information on WPA2 Enterprise side: The machine definitely hits the access point because I can see it in my Cisco Wireless Control System. It also is getting granted access by my 2008R2 RADIUS server. After that point it is not finalizing the connection for some reason.
    Friday, June 01, 2012 6:17 PM
  • Hi !

    Same problem on WS 2012-Release Preview.

    I can connect to an open WLAN, and also to my own smartphone using WPA2, but not to the university-WLAN which uses WPA2-Enterprise with AES.

    Saturday, June 02, 2012 8:18 PM
  • I installed the following driver from the Samsung support site:

    Option Wireless LAN Driver (Driver) (ver.9.2.0.225) Please referece the below install steps.

    Click the attached file and press ''Save'' button. Then press ''Browse...'' button and select the place where you want to save the selected file. After downloading the file, find the downloaded file and right_click on the file. On pop_up menu, select ''Extract All...'' option. On ''Extraction Wizard'', press ''Next'' button and press ''Browse...'' button. Select a folder to extract file and press ''Next'' again. After the file has been sucessfully extracted, see the extracted files. Run ''Setup.exe'' file or ''setup.exe'' file in the folder. -This driver may not be appropriate depending on the computer model.

    Windows 7(32bit) Nov 27, 2011 MULTI LANGUAGE 32.21

    http://www.samsung.com/us/support/owners/product/XE700T1A-A01US

    This fixes the issues for me. For reference, I chose "Driver Only" in the setup, I did not install any of the tools.


    My blog: blog.jessehouwing.nl

    • Proposed as answer by Jesse Houwing Tuesday, June 05, 2012 7:06 AM
    Monday, June 04, 2012 5:07 PM
  • Installing the driver suggested by Jesse appears to have solved the problem.
    Tuesday, June 05, 2012 12:39 AM
  • Windows update will try to re-apply the 'newer' driver, which will break enterprise logon again. Go to the Windows Update screen and rightclick the update, select "Hide Update" to prevent it from applying automatically.

    My blog: blog.jessehouwing.nl

    Tuesday, June 05, 2012 7:05 AM
  • what happens if you are not using a samsung tablet?

    Mine is an ASUS. I reject that this solves the problem, as it only works for certain manufacturers.

    Tom

    Tuesday, June 05, 2012 3:15 PM
  • Yes, I second BurnabyTom's comment. The Samsung driver proposed by Jesse Houwing above is an Atheros WLAN driver. It does not help for those of us having this problem and running a Broadcom or Intel WLAN card. I am having this same problem with an HP TouchSmart TM2-2050US running a Broadcom 802.11b/g/n Wifi chipset.
    • Edited by danubistheconcise Tuesday, June 05, 2012 8:15 PM added my system's model number
    Tuesday, June 05, 2012 8:13 PM
  • it solves the problem of the original poster, and such is an answer to the thread. knowing how these forums tend to work, you'll get better support if you open a new thread and reference this one for reference that is is a driver issue.

    For those with a different adapter, did you try to capture the trace and did you send those to  aanandr@microsoft.com for analysis?

    Have you tried different driver versions than the ones that ship with the release candidate?


    My blog: blog.jessehouwing.nl

    Tuesday, June 05, 2012 8:25 PM
  • Interesting.  Thinking I had an alternative wireless card (not an Atheros), I thought I'd need to install some other driver. Turns out, the ASUS has a Qulacomm Atheros AR9002WB-1NG wireless network adapter.  Could the Samsung driver possibly work?  is it the same adapter as in the Samsung tablet?

    Going to try and load that driver and see what happens....

    Tuesday, June 05, 2012 9:49 PM
  • Try changing wireless security setting to WEP (open) instead of WPA. That works. For some reason, the wireless network doesn't allow you to change the wireless network authentication mode
    Wednesday, October 24, 2012 10:14 AM
  • Try changing wireless security setting to WEP (open) instead of WPA. That works. For some reason, the wireless network doesn't allow you to change the wireless network authentication mode

    Well, it solves the problem, but decreases the security.....

    A much better solution would be to change encryption-type to TKIP instead of AES, then you are still using WPA-2.

    After changing encryption-type i could connect to the WLAN here at my university....


    • Edited by hackerman1 Friday, October 26, 2012 10:10 PM
    Friday, October 26, 2012 10:02 PM
  • Same problem here
    • Proposed as answer by BurnabyTom Monday, November 26, 2012 8:47 PM
    • Unproposed as answer by BurnabyTom Monday, November 26, 2012 8:47 PM
    Monday, November 26, 2012 9:40 AM
  • http://support.microsoft.com/kb/2749073
    • Proposed as answer by Le Roquet Wednesday, December 12, 2012 3:38 PM
    • Unproposed as answer by Le Roquet Wednesday, December 12, 2012 3:39 PM
    • Proposed as answer by rebeltk421 Friday, January 04, 2013 10:01 PM
    Friday, November 30, 2012 5:06 PM
  • Just reinstall the windows 7 network card driver from your puter manufacturer. It has worked on three different machines this far. I think the windows 8 wpa 2 driver supplied by MS for Atheros cards is broken.
    • Edited by Le Roquet Wednesday, December 12, 2012 3:41 PM
    Wednesday, December 12, 2012 3:40 PM
  • I've updated my blogpost to include both the KB Article from Microsoft and Cisco. It links to detailed steps to solve for both the Artheros and Broadcom network drivers.

    You can find it here: http://blog.jessehouwing.nl/2012/10/cisco-responds-to-wpa2-enterprise-issues.html


    My blog: blog.jessehouwing.nl

    Wednesday, December 12, 2012 3:49 PM
  • Definitely agree that the MS driver is broken.  I found that the manufacturer's driver 9.2.0.419 works correctly.  I have now had several Windows Updates that have replaced the driver which broke the connectivity and reverting to the above driver version fixes the problem. Note that to receive the certificate, you need to be connected via wired connection.  OTA certificate doesn't work. 
    • Proposed as answer by BurnabyTom Wednesday, December 12, 2012 3:51 PM
    Wednesday, December 12, 2012 3:51 PM
  • You can go into the Windows Update panel and suppress the update until you know the Access Point has been upgraded:


    My blog: blog.jessehouwing.nl

    Wednesday, December 12, 2012 3:53 PM