none
RRAS - Legacy mode is disabled on this Server RRS feed

  • Question

  • Hi,

    I've installed RRAS on Windows Server 2016, but when I launch the console I get the following;

    

    I've googled the life out of this one but can't seem to find any info on enabling Legacy mode.

    Any help would be greatly appreciated.

    Adam

    Sunday, February 12, 2017 7:29 PM

All replies

  • I think that option is gone in 2016.

    https://technet.microsoft.com/en-us/windows-server-docs/networking/remote-access/ras-gateway/ras-gateway

     

     



    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows Server] Datacenter Management

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees, and confers no rights.

    Sunday, February 12, 2017 8:00 PM
  • Dave,

    Thanks for taking the time to reply.

    I see the note in the linked article saying PowerShell must be used but to be honest, I already knew I could do that. I was hoping there was a way to 'enable legacy mode' as the wording seemed to suggest this is possible.

    Many thanks

    Adam

    Sunday, February 12, 2017 8:52 PM
  • Hi Adam,

    Please check if the following thread is helpful:

    https://social.technet.microsoft.com/Forums/scriptcenter/en-US/e1219c70-a132-4868-a5db-fe1fc8867fa0/detect-efi-or-bios-with-powershell?forum=ITCG

    Best regards,

    Andy


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, February 13, 2017 6:09 AM
    Moderator
  • I'm stuck with this too, did you ever sort this? I need to get access to configure L2TP with Pre-shared key for all the OSX Sierra based Mac computers. It was simple with Server 2012.
    Thursday, April 13, 2017 6:58 AM
  • Hi Adam,

    Please check if the following thread is helpful:

    https://social.technet.microsoft.com/Forums/scriptcenter/en-US/e1219c70-a132-4868-a5db-fe1fc8867fa0/detect-efi-or-bios-with-powershell?forum=ITCG

    Best regards,

    Andy


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    That thread isn't relevant to this issue.
    Thursday, April 13, 2017 6:59 AM
  • Hi

    For those looking for a solutions for this:

    Note: Server Essentials automatically manages the routing for VPN, and therefore Routing and Remote Access (RRAS) UI is hidden on the server to prevent tampering of RRAS settings. As a result, to view, change or troubleshoot the Remote Access settings, you need to install Remote Access GUI and Command-Line Tools using Server Manager or the following PowerShell command:

    Add-WindowsFeature RSAT-RemoteAccess-Mgmt

    This feature enables Routing and Remote Access console and respective command-line tools to manage VPN and DirectAccess. Note that this role may not be required on the server unless you need to change the settings for VPN or DirectAccess.

    https://blogs.technet.microsoft.com/sbs/2014/05/19/understanding-vpn-configuration-in-windows-server-2012-r2-essentials/

    Sunday, September 17, 2017 10:49 AM
  • I'm stuck with this too, did you ever sort this? I need to get access to configure L2TP with Pre-shared key for all the OSX Sierra based Mac computers. It was simple with Server 2012.

    I'd start a new thread.

     

     



    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows Server] Datacenter Management

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees, and confers no rights.

    Sunday, September 17, 2017 12:42 PM
  • Hi

    I noticed that my previous post with a link do not help much. It gives you links to Server Manager Tools list but the RRAS console is still in "Legacy mode disabled.." state.

    According to glennopedia.com,

    "The anywhere access wizard in 2016 uses PowerShell to configure RRAS and disables the RRAS console."

    https://glennopedia.com/2017/08/24/why-i-am-unable-to-access-any-resources-on-my-essentials-vpn/

    And site gives instructions how to re-deploy VPN in legacy mode. Havent tested them thou...

    https://glennopedia.com/2017/08/25/how-to-re-deploy-vpn-in-2016-essentials-in-legacy-mode/

    Sunday, September 17, 2017 5:19 PM
  • the fastest way to enable legacy mode is to remove/uninstall the service, restart the server and than install it again. after that you will get legacy mode enabled.
    • Proposed as answer by Jafar78 Sunday, January 20, 2019 12:47 PM
    • Unproposed as answer by Jafar78 Sunday, January 20, 2019 12:47 PM
    Sunday, September 17, 2017 8:15 PM
  • The "re-deploy VPN in legacy mode" solution is the one I successfully implemented. Thanks the info. 
    Monday, August 13, 2018 8:18 PM
  • Another option is actually a registry edit; change 'ModernStackEnabled" to "0" here:

    image

    Sunday, June 9, 2019 5:05 AM
  • This was exactly my problem: VPN wasn't able to hand out IP address from the DHCP from the router. 

    Thanks for the fix.

    Wednesday, September 11, 2019 4:05 AM