none
Windows Search: Can't open emails / "Internet Shortcut" / mapi error

    Question

  • I have Windows Search running on my Windows 7 machine. I have Outlook 2003. Windows Search is successfully able to present searched terms in the search results pulled from my .PST files. Problem is, clicking on a link gives me the following error: "Unable to open this Internet Shortcut. The protocol "mapi" does not have a registered program."

    I've also noticed that the search results presented are shown within a category called "mapi - {S-1-5-21-...} a SID.

    That's totally wierd.

    So.. clearly, there's some miscommunication between Mr. Search and Mr. Email (Outlook.) Not sure how to get them to shake hands.

    PS: Ran the "Find and fix problems with Windows Search." No change.

    Please advise. Thanks !
    --Jeremy Moskowitz, Group Policy MVP
    Wednesday, August 26, 2009 9:32 PM

All replies

  • Same issue.

    Windows 7 Enterprise RTM x64, Outlook 2007 SP2.  Tried to set Outlook for defaults under "default programs" and no change.  I noticed it also does this for OneNote 2007 SP2 items in search results.  

    I've used Windows 7 since 7000 beta.  I'm sure this has worked at some point in time.

    All items in results that are broke like this have a globe icon rather then their proper app icon.

    Also, it is still indexing new stuff (in onenote and outlook).

    error i get when clicking item in search results
    Title:Problem with Shortcut
    Unable to open this Internet Shortcut.  The protocol "oneindex" does not have a registered program.

    Also, creating a onenote:// shortcut on desktop still works (and shows onenote icon).
    • Proposed as answer by Jean-GUIllaume Saturday, January 02, 2010 6:34 PM
    Thursday, September 24, 2009 3:44 PM
  • I was having the same problem clicking on OneNote search results (running Windows 7). A registry change took care of it. It seems the OneIndex entry is incomplete. I had to create an "open" and a "command" key:

    HKEY_CLASSES_ROOT
    --OneIndex
    ----shell
    ------open
    --------command

    "open" is blank. For the value for "command" I entered: "C:\Program Files (x86)\Internet Explorer\iexplore.exe" "%1" 

    To get the right icon to show in the search (instead of IE's), I also added a "DefaultIcon" key: C:\PROGRA~2\MICROS~1\Office12\ONENOTE.EXE,0


    So, I ended up with this:

    HKEY_CLASSES_ROOT
    --OneIndex
    ----DefaultIcon             (C:\PROGRA~2\MICROS~1\Office12\ONENOTE.EXE,0)
    ----shell
    ------open
    --------command           ("C:\Program Files (x86)\Internet Explorer\iexplore.exe" "%1")

    This works fine for me. After I did this, I noticed the "OneNote" entry in the registry, and it's command is: C:\PROGRA~2\MICROS~1\Office12\ONENOTE.EXE /hyperlink "%1"

    I tried this in my newly added command for OneIndex, and it worked. But, I was receiving a security warning from Office. So, rather than figuring that out (lazy), I switched back to calling IE.


    There may be an easier way of fixing this issue, but, I could not find any other solutions posted.

    Hope this helps!

    • Proposed as answer by Jean-GUIllaume Saturday, January 02, 2010 6:33 PM
    Tuesday, September 29, 2009 5:28 PM
  • Issue : Unable to open mails via windows search.
    Cause: It occurs after uninstalling office 2010 and reinstalling 2007.
    Error : Unable to open this internet shortcut. The protocol "mapi" does not have a registered program

    Need to edit registry settings after taking a backup. Add the new key as follows:

     

    Location : [HKEY_LOCAL_MACHINE\Software\Classes\mapi]

     

    New Key : ShellFolder

    Binary Value : {89D83576-6BD1-4c86-9454-BEB04E94C819}

    Steps to follow:
    To take Backup:
    Go to Start >> run >> type regedit and hit enter.
    Once the registry editor launches, click on File >> Export >> Save the file.

    To add new entry:
    In registry editor, navigate to [HKEY_LOCAL_MACHINE\Software\Classes\mapi]
    On the right panel, right click >> New >> Key >> Enter "ShellFolder"
    Then once the key is created, right click on "ShellFolder" >> Modify Binary Data >> Enter "{89D83576-6BD1-4c86-9454-BEB04E94C819}" without quotes.

    This will fix the issue.

    • Proposed as answer by galaxyjayan Friday, October 30, 2009 12:45 PM
    Friday, October 30, 2009 11:27 AM
  • Hi there!


    To address the issue "'oneindex://' location not opening issue with Windows Search" and  "Security Warning when opening an item from 'oneindex://' location", TonyMN helped us getting that resolved.

    That may help you solve the problem:

    - Entering ONENOTE.EXE /hyperlink "%1" in registry** did open the resulting item from windows search index
     ** (that address the "oneindex://" location not opening issue with Windows Search") but "Security Warning " apears...
     * (see the content bellow to create your own registry file or refer to TonyMN's post above but finish reading this before!)

    -- we did not want that! "Security Warning "

    - we digged that "/hyperlink" was not required for Onenote command Line in the registry. 
     * (Not passing through a "web content" but more what to open (which seems not to be filtered or checked by the security system as a web content make it works!!))

    Anyways, for WIndows 7 you can create a file with the extension .reg with the content bellow
    (text included in between {} not including them or read TonyMN's post above and just don't enter "/hyperlink" when you will edit the registry key.

    starting of the .ref file: {
    Windows Registry Editor Version 5.00
    [HKEY_CLASSES_ROOT\OneIndex\shell\open\command]
    @="F:\\Program Files (x86)\\Microsoft Office\\Office12\\ONENOTE.EXE  \"%1\""
    } the end.

    Hope that helps, (Note there is a button PROPOSED An ANswer above next to Reply/Quote you can click if that's the case ;)

    Regards,

    Jean Guillaume

    ps. We use network location for notebooks
    _________________________________________________

    Windows Registry Editor Version 5.00
    [HKEY_CLASSES_ROOT\OneIndex\shell\open\command]
    @="F:\\Program Files (x86)\\Microsoft Office\\Office12\\ONENOTE.EXE  \"%1\""

     


    JGI
    • Edited by Jean-GUIllaume Saturday, January 02, 2010 7:09 PM the registry content proposed was not apearing at the right place
    • Proposed as answer by Daniel Puzey Thursday, February 04, 2010 10:45 AM
    Saturday, January 02, 2010 7:08 PM
  • Issue : Unable to open mails via windows search.
    Cause: It occurs after uninstalling office 2010 and reinstalling 2007.
    Error : Unable to open this internet shortcut. The protocol "mapi" does not have a registered program

    Need to edit registry settings after taking a backup. Add the new key as follows:

     

    Location : [HKEY_LOCAL_MACHINE\Software\Classes\mapi]

     

    New Key : ShellFolder

    Binary Value : {89D83576-6BD1-4c86-9454-BEB04E94C819}

    Steps to follow:
    To take Backup:
    Go to Start >> run >> type regedit and hit enter.
    Once the registry editor launches, click on File >> Export >> Save the file.

    To add new entry:
    In registry editor, navigate to [HKEY_LOCAL_MACHINE\Software\Classes\mapi]
    On the right panel, right click >> New >> Key >> Enter "ShellFolder"
    Then once the key is created, right click on "ShellFolder" >> Modify Binary Data >> Enter "{89D83576-6BD1-4c86-9454-BEB04E94C819}" without quotes.

    This will fix the issue.


    This answer is right, but not quite accurate. Here are my notes from updating it. I added bold to the differences:
    To add new entry:
    In registry editor, navigate to [HKEY_LOCAL_MACHINE\Software\Classes\mapi]
    On the right panel, right click >> New >> String Value >> Enter "ShellFolder"
    Then once the key is created, right click on "ShellFolder" >> Modify> > Enter "{89D83576-6BD1-4c86-9454-BEB04E94C819}" without quotes.


    Wednesday, February 03, 2010 6:24 PM
  • If I omit the /hyperlink from the "oneindex" key, OneNote doesn't jump to the correct page of the notebook. I'd like to get rid of the security warning, but I'll put up with it for this.

     

    Tuesday, May 04, 2010 4:07 PM
  • this helped and now I can see the files when I start searching but it didnt work when i tried to press on the file acting as I did nothing....
    Monday, June 14, 2010 10:37 AM
  • FYI, this page gives instructions on how to disable the security warning.  I just followed the steps with Office 2007 and it instantly takes away the warning.  The only difference is using "Office\12.0\Common" vs. "Office\11.0\Common" depending on your version of Office.

     

     

    Monday, July 12, 2010 5:37 PM
  • I know this is an old post. I have the same problem, except mine started after I switched from Office 2010 Beta to Office 2010 H&B. My ShellFolder key already matches what's in this thread and it still doesn't work.
    Tuesday, September 07, 2010 1:29 PM
  • I figured it out. My home machine did not have this problem. Today, I tried to install a piece of software that syncs with Outlook. It said Outlook is not installed on my work computer, but worked fine on my home computer. I ran the Repair from the Setup application for Office and whala! It works fine now.
    Friday, September 10, 2010 1:02 PM
  • I have the following problem with onenote as well: Security warning - Problem with shortcut.

    unable to open this internet shortcut. the protocol "oneindex" does not have a registered program.

     

    I tried to muddle through the responses above but the directions are not clear.

    I wonder if someone could rewrite as directions to use.- I am just an end user not a programmer!

    I am guessing that you are meant to go to command prompt to do this -

    on mine - the first line is c:\Users\ADMIN>

    What do I type next??

    Help is appreciated - without the ability to search onenote is almost useless.

    You can only search the Open notebooks from within Onenote.

    Sunday, July 24, 2011 2:57 PM