none
Windows 7 can't find my D-Link wireless network

    Question

  • I just installed Windows 7 RC but I can't connect to my wireless network.  I can see the neighbors and connect to theirs but it doesn't find my D-Link DIR-615.
    The wireless card is an Abit Airpace that I installed as an Atheros 5600XS, and it was working fine into a computer with XP Pro.
    I moved the router 2 feet away from the computer and still no signal at all.
    Now I'm going to connect them via an ethernet cable, but that's not the way I want it.
    Does anyboady had the same issue or have some suggestion?
    Thanks a lot.
    Saturday, June 06, 2009 3:47 AM

All replies

  • Hi Mecit,
    I take it that win7 has detected & installed your NIC, If not I would suggest going to the Abit site for driver updates
    Is the network you are trying to connect to a displayed or hidden SSID?
    If it is hidden?, you will need to set the router to show SSID so you can detect the device & then reconnect, but in doing this make sure you are using a computer that is hard-wired to the router, I would also suggest turn on "Trusted devices" on your router, so your card will auto recognise, once you've done this then try connecting with the hidden SSID.
    You say you can connect to your neighbours network, so I would suggest that this is an unprotected/unsecured network? (unless they have given you access to it) I show 2 other available networks apart from my home network. 
    I had similar problems with both my NIC's (desktop & Laptop) after installing Win7
    Regards Fagan 
    Sunday, June 07, 2009 11:05 AM
  • Hello. Only one time I could saw my network. After never more. I can´t see printer and shared files and carpet.
    How is i?
    Can you help me?

    Sunday, June 07, 2009 6:23 PM
  • Hi Toto,
    Can you give everyone a bit more info please, I take it you are talking about a wireless network?

    Network Interface Card (NIC)? If unsure control pannel/ device manager/ Network Adapters/ ???????
    Router?
    Network setup? Homegroup, Workgroup or public?

    Is the original network SSID: Hidden (so others can't see it?) or visible?
    What protection are you using WEP, WPA/PSK or other?

    How many computers do you have and how many running Windows7? are any of the other computers wired to the router? 

    Is the printer set up on a Win7 computer or a computer running another O/S (Vista, XP, ME, 98 & So on)

    Your shared files? is that in your homegroup / workgroup or on another computer running a different O/S 

    Carpet? sorry this I have no Idea about!

    Regards Fagan
    Monday, June 08, 2009 7:34 AM
  • I don't suppose you misclicked last time you saw it so it won't show up again? Can you reinstall the driver?
    Saturday, June 20, 2009 3:56 PM
  • Ok, here goes..

    I had exactley the same problem as you, Windows 7 would detect neighbours routers but never my own. So after endless research on the net and trying many different things within the router I found out that one simple thing fixed the problem.

    As others have said above make sure that your router's SSID is visible. Now if it still wont detect it after that you need to go to ( this should be the fixer lol ) " CHANNEL WIDTH ". Once in Channel Width change the channel to channel 8. It will show a Ghz frequency on the side of the channel number.

    Like you I tried everything, but once I changed the channel number and re-freshed the box on the toolbar on the laptop that searches for routers / networks my D Link instantly appeared.

    I'm not a betting man normally, but I bet you this will fix your problem.


    PS... If channel 8 dosen't work, try some other channel numbers. I tried a few different numbers and it still wouldn't work for me till I chose channel 8.

    Hope this helps. Good luck :)
    • Proposed as answer by Seth De Bolle Thursday, December 09, 2010 6:45 PM
    Thursday, January 28, 2010 8:11 PM
  • Hi Neil,

    I just wanted to tell you that I went through this same problem today, with my new HP laptop, and after several hours on the phone with tech support, I was still in the same place I started.  After trying everything I and the tech guy could think of, I was very close to taking this computer back, and then I came across your post, followed your wonderful advice, and it worked.  So, THANK YOU!!!!!  You have made my day, and put a huge smile on my face!  Thanks so much!!!!

    Friday, July 02, 2010 11:37 PM
  • Hello,

    I am having the same problem, except I am using my friends wireless netwok and I am trying to connect my PC. I was primarily using my PC with windows 7 at work, where there is no wireless connection (so I used a cable). Now, I am using in on weekend at home and it shows the wireless network, but it wont connect. It wont even ask for the password (this is the first time I am using this PC on this wirelss network).

    HOw do I get to Channel Width and change it? Please help, I am a little technology challenged :)

     

    Saturday, July 03, 2010 2:47 PM
  • Just got a new Toshiba Laptop. It has windows 7, and it will detect other networks but not mine.

    My laptop which runs Windows XP detects it just fine.

    I don't believe my SSID is hidden since my laptop running XP finds it without problem.

    Can someone please help me!!

    Wednesday, July 07, 2010 10:56 PM
  • you will find the Channel in 'wireless settings' on your router. Just change it from 'Auto' to whatever channel you want...it should work. I had the same issue when set-up to 'Auto' I could not see the network. I could have connect on my Iphone to it but not on my laptop..
    Friday, July 09, 2010 10:47 AM
  • Neil_of_Wales,

     

    I had the same problem and I cannot understand why... I use your tip and it work fine!!!

    You could not be a betting man, but in this you are the winning man!!! ;)

    Thanks for the tip and regards from Portugal!

    Sunday, September 05, 2010 6:55 AM
  • Hi Neil_Of_Wales,

    Read yr post after trying for a good two hrs. Changed to channel 8 and it works. Cheers !

    Monday, November 29, 2010 9:09 AM
  • Neil,

    Thank you for your information ! This was very helpful... even the IT department in our company didn't know how to solve this issue... finally after 3 evenings of browsing in forums on the web I read your infromation above...

    Connected by cable, went to the router homepage, changed the channel to 8... and I am WIRELESS :) FREEDOM AT LAST ;)

    Thanks again.

    Seth.


    Seth
    Thursday, December 09, 2010 6:45 PM
  • This was AMAZING.  Channel 8!  TOOK ME 24 HOURS TO FIND THIS!  YOU ARE THE BEST!
    Thursday, December 30, 2010 2:21 AM
  • Great!! this solution worked to me too!!
    Saturday, December 31, 2011 7:32 AM
  • I'll join the choir of people praising this solution =) though I'd like to know what I've turned off...
    Friday, January 06, 2012 8:08 PM
  • One more thumbs up for this solution. It worked like a charm for me too! Can't thank you enough for helping me resolve my week old problem!! Channel 8 worked for me too! :)

    Thank you very much!!

    Monday, September 03, 2012 3:46 PM
  • That was it!!! Thanks. Finally got mine working after hours of searching on the internet.
    Friday, November 23, 2012 1:03 AM
  • hello!

    the thing with channel 8 worked for me too. Thanks a lot!

    Tuesday, January 28, 2014 9:28 PM