none
How to network windows 7 and windows 10 computers RRS feed

  • Question

  • I have a windows 10 and a windows 7 computer at home. Networking them together has failed miserably and I can find no help in the help file or on the web.
    Can someone advise me the simplest way to share a folder between the two computers please? It really should be easy to do.
    Monday, August 29, 2016 2:29 PM

Answers

All replies

  • Create a homegroup on the win 10 machine>add the win 7 computers>share as needed.  Be sure to write down the homegroup password or change it to something you will remember

    Wanikiya and Dyami--Team Zigzag Windows IT-PRO (MS-MVP)

    Monday, August 29, 2016 3:32 PM
    Moderator
  • I created a homegroup on the win 10 machine. I tried also to add a homegroup on the win7 machine, which I did, but they could not see each other. There must be more to it than just adding a home group on each machine.
    Monday, August 29, 2016 8:38 PM
  • Do they have a malware/firewall app running?  Are they public shares?

    Wanikiya and Dyami--Team Zigzag Windows IT-PRO (MS-MVP)

    Monday, August 29, 2016 9:27 PM
    Moderator
  • Malware and firewall, both turned off. They're shares....
    Monday, August 29, 2016 10:45 PM
  • Hi Boristhecat,

    You don't "add" a homegroup on each machine.  You create one homegroup, and join all the machines to this homegroup.  Adding new homegroups on each machine may not working if they are different homegroup names. Please make sure on the Windows 7 machine, you are joining the homegroup created by the Windows 10 machine.  This is why you will need the password,  to join the homegroup. 

    Monday, August 29, 2016 10:49 PM
  • I make a homegroup on wind 10 machine, I can't see it on win 7 machine. 
    I give up. Windows is sh*t. 
    Thanks for your time everyone.
    Tuesday, August 30, 2016 12:16 AM
  •   If you don't like homegroup or can't make it work, old-style file sharing from way back still works. It works on all my machines from XP to Windows 10. I don't use a homegroup at all but can share files between all my machines.


    Bill

    Tuesday, August 30, 2016 1:59 AM
  • Hi ,

    Please ensure Windows 10 and Windows 7 machines are in same local network and workgroup, then refer to the following link to setup homegroup again to have a try.
    HomeGroup from start to finish
    https://support.microsoft.com/en-us/help/17145/windows-homegroup-from-start-to-finish

    If you just want share a folder, we can simply right-click the folder, then select "share with" to share this folder with everyone. Then we will be able to access this folder from other computers.

    Best regards


    Please remember to mark the replies as an answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, August 30, 2016 2:30 AM
    Moderator
  • I have a windows 10 and a windows 7 computer at home. Networking them together has failed miserably and I can find no help in the help file or on the web.
    Can someone advise me the simplest way to share a folder between the two computers please? It really should be easy to do.

    I know your post was sometime ago now but I thought I'd post my recent experience with this issue. My attempts to do the same thing also failed miserably and I don't see why it should be so difficult either. It always seemed to be a snip when my PCs were Windows 7 or XP.  I'd make sure the files and folders were shared, map network drives to the other PC's shared resources and bingo!  Now, all I keep getting is the "Windows no longer detects a homegroup ..." error message when I enter the homegroup password.  I made sure all my firewall and AV programs were off, network discovery on and so on but all I got was that blasted error message every time I tried to "join" the Homegroup.

    So.... I've taken an easy way out and installed Stardock's Multiplicity program which allows the use of a single mouse and keyboard to be shared seamlessly by up to 4 PCs AND allows files and folders of any size to be copied or cut and pasted freely between them.  This was basically all I was trying to do by the traditional networking process. 

    I quite often have a Windows 7 and a Windows 10 desktop connected via ethernet to my router, as well as one Windows 10 wi-fi tablet running at the same time. Now they are all as good as networked.  Multiplicity is a paid app with a 30-day free trial but well worth the US$19/- in my view.

    I considered an alternative - Microsoft Garage's MouseWithoutBorders. This app  is free and works perfectly except it doesn't allow folder transfers and file size is limited to 100MB for some reason.

    If I ever have the time and energy, I will have another bash at getting the networking to work sometime in the future because I hate to admit defeat but right now it's not worth the frustration for what I need.




    • Edited by sacentre Monday, October 23, 2017 6:17 AM
    Monday, October 23, 2017 6:06 AM
  • Having the same frustration here. After following the link given by the Microsoft support this is what I've found when you select Windows 10 in the dropdown list. I don't think there's a workaround with this issue.

    NOTE:

    HomeGroup has been removed from Windows 10 (version 1803)

    After you install the update, you won't be able to share files and printers using HomeGroup

    Friday, June 8, 2018 6:15 PM
  • I am having the same frustration.  Can not connect 10 with a 7 computer.  Any one can help?
    Thursday, July 19, 2018 5:07 PM
  • My suggestion is non to use the Home group. Just go through Advanced sharing settings and work from there.

    Visibility should be on as the sharing file option.

    For the criptography I use the standard one.

    For the password settings I use "let windows manage the connection"

    NB: both PC have to be on "private" internet connection 

    Once you do this, get to the folder you want to share, right click, sharing, advanced sharing, "everyone" and give all the permissions.

    Tuesday, July 31, 2018 7:12 AM
  • OK Folks, this IS, I Repeat, THIS IS! The solution, fix, ANSWER!!

    https://winaero.com/blog/network-computers-not-visible-windows-10-version-1803/

    This explains how to start the: Function Discovery Resource Publication Service. Which is IN-FACT the Culprit. On Win 10 machine, Start this service, set to Auto......... DONE! Thats it! Enjoy.

    LV


    • Edited by L-Vee Monday, October 8, 2018 4:12 PM
    • Proposed as answer by L-Vee Tuesday, October 9, 2018 6:07 PM
    Monday, October 8, 2018 4:06 PM
  • OK Folks, this IS, I Repeat, THIS IS! The solution, fix, ANSWER!!

    https://winaero.com/blog/network-computers-not-visible-windows-10-version-1803/

    This explains how to start the: Function Discovery Resource Publication Service. Which is IN-FACT the Culprit. On Win 10 machine, Start this service, set to Auto......... DONE! Thats it! Enjoy.

    LV


    • Proposed as answer by L-Vee Tuesday, October 9, 2018 4:25 PM
    Monday, October 8, 2018 4:13 PM
  • OK Folks, this IS, I Repeat, THIS IS! The solution, fix, ANSWER!!

    https://winaero.com/blog/network-computers-not-visible-windows-10-version-1803/

    This explains how to start the: Function Discovery Resource Publication Service. Which is IN-FACT the Culprit. On Win 10 machine, Start this service, set to Auto......... DONE! Thats it! Enjoy.

    LV


    • Proposed as answer by L-Vee Tuesday, October 9, 2018 4:29 PM
    Monday, October 8, 2018 4:17 PM
  • I just tried L-Vee's solution. IT WORKED. I've been trying to make my Win 7 machine see my Win 10 machine to no avail...

    THANK YOU!!!

    Monday, October 8, 2018 9:18 PM
  • ;)

    Tuesday, October 9, 2018 4:21 PM
  • OK Folks, this IS, I Repeat, THIS IS! The solution, fix, ANSWER!!

    https://winaero.com/blog/network-computers-not-visible-windows-10-version-1803/

    This explains how to start the: Function Discovery Resource Publication Service. Which is IN-FACT the Culprit. On Win 10 machine, Start this service, set to Auto......... DONE! Thats it! Enjoy.

    LV

    • Proposed as answer by L-Vee Tuesday, October 9, 2018 4:25 PM
    Tuesday, October 9, 2018 4:25 PM
  • This worked the first time. Thanks, LV.  Can this solution be sticky at the top? I went through those other steps to no avail and this worked in seconds.  Thanks so much.
    Friday, October 12, 2018 4:29 PM
  • OK Folks, this IS, I Repeat, THIS IS! The solution, fix, ANSWER!!

    https://winaero.com/blog/network-computers-not-visible-windows-10-version-1803/

    This explains how to start the: Function Discovery Resource Publication Service. Which is IN-FACT the Culprit. On Win 10 machine, Start this service, set to Auto......... DONE! Thats it! Enjoy.

    LV

    Thank you SO much. I Repeat, THANK YOU SOOOOOOO MUCH!!!

    It really IS the basis of the solution. Without this action ANYTHING else won't work. It's just unbelivable that this service is off by default in Windows 10! The excuse is probably the usual suspect named "security reasons" but it doesn't justify for the BIG trouble that so many people are in, trying to interconnect their machines!




    • Edited by yiocha Tuesday, December 18, 2018 2:39 PM
    Tuesday, December 18, 2018 2:36 PM
  • Thank you, Thank you, Thank you!!! I never would have known.
    Tuesday, January 15, 2019 9:41 PM
  • I know this is an old topic, but this solution doesn't work for everything.   I have a Windows 7 Pro PC upstairs where I share my music library and printers and pictures, etc. with all my PC's in my home Workgroup.   I was always able to connect my Windows 10 laptop from downstairs by mapping a drive or creating shortcuts, I was able to print to my shared printer upstairs until Microsoft upgraded Win 10 to version 1809.  Network sharing is enabled, I turned off the firewall, I turned off the AV.  I even updated the following services to run automatically on the Windows 10 PC.

    Services:

       - Function Discovery Provider Host

       - Function Discovery Resource Publication

       - SSDP Discovery

       - UPnP Device Host

    But I cannot connect to the shared drives or printers when I could before this update.  I can use Remote Desktop to and from the Win 7 and Win 10 machines, but I cannot connect to shares using either the host computer name or the IP address.   Has anyone else found another solution?

    Monday, February 11, 2019 9:04 PM
  • This did work for me. HOWEVER, the service was already running. I had to STOP the START the service. IT WORKS! after months of looking..... THANKS!

    Thx, MikeH

    Thursday, February 21, 2019 7:25 PM
  • This is not a Fail safe. I hate homegroup and want to share old school.  Well Heads up this isn't the for sure fix. I know this because I can't do it that way on Windows 10 Home or Pro

    Sunday, March 24, 2019 1:53 AM
  • This is not a Fail safe. I hate homegroup and want to share old school.  Well Heads up this isn't the for sure fix. I know this because I can't do it that way on Windows 10 Home or Pro

    Ok I have Win 7 Ultimate 64 and Win 10 Pro 64 (version 17134) before the 1803 upgrade)) . Now I was having soooo much trouble that I was about to try installing network cards to both machines and hard wire them.

    Now I have set up the systems to see each other BUT they would not talk to each other. The block was a PopUp that wanted Windows Network Login details. I was thinking what I have my pcs open for anyone to mess with so No Login name and password???

    OK I have found the answer ...

    Win 10 . Start menu - Settings - Accounts ... Here you should see "Your Info" Administrator, on your right. It is the Microsoft account login in name. Mine is my gmail email address and the password is the password for my gmail account. ... So I entered that info into the Win 7 "Network Login Details" popup. ... And all of a sudden win 7 could access my win 10 pc.

    BUT it was only one way win 7 > win 10 ..

    Win 7 . Start menu - Control Panel - User Accounts and Family Safety - User Accounts ... Here you should see Your name Administrator, on your right. IT is the actual Administrator Name and is OR is not password protected. Mine was NOT password protected, so it just said My Name and Administrator. ... Ok ... So I entered My Name into the Win 10 "Network Login Details" popup ... Entered a blank password (Because I didn't have one set up) and it FAILED ... WTF ... But then I noticed a quick message that said Blank Passwords are NOT allowed. Arrr OK. .. I then setup a Password for my Administrator account. I then entered My Name and the newly created password ... And all of a sudden win 10 could access my win 7 pc.

    Thank you, at long last they are talking to each other.

    Now they are both have WorkGroup = WORKGROUP

    Yes I know that the 1803 upgrade does not support WORKGROUP ... BUT ... what I did see was that win 10 has a HOME group and I believe that I read that all you had to do was to change the win 7 WorkGroup from WORKGROUP to a new one called HOME and win 10 might see it and connect. I have not tried this yet as I really need to have the two pc's talking to each other. I will get another laptop and put on the latest version of win 10 on it and try to connect.

    Here is a link that might also help: https://helpdeskgeek.com/how-to/setup-homegroup-in-windows/

    I hope that this helps a bit.

    I hope to update this soon. (hoping that it is good news)

    ..

    UPDATED

    ..

    Win 10 Updated and I lost the connection.

    The Above answer from another use is CORRECT.

    Here is a Quote from their post.

    OK Folks, this IS, I Repeat, THIS IS! The solution, fix, ANSWER!!

    https://winaero.com/blog/network-computers-not-visible-windows-10-version-1803/

    This explains how to start the: Function Discovery Resource Publication Service. Which is IN-FACT the Culprit. On Win 10 machine, Start this service, set to Auto......... DONE! Thats it! Enjoy.

    LV

    Thank you SO much. I Repeat, THANK YOU SOOOOOOO MUCH!!!

    It really IS the basis of the solution. Without this action ANYTHING else won't work. It's just unbelivable that this service is off by default in Windows 10! The excuse is probably the usual suspect named "security reasons" but it doesn't justify for the BIG trouble that so many people are in, trying to interconnect their machines!

    Friday, May 10, 2019 9:35 AM
  • Thankyou soooo much :-)
    Thursday, May 16, 2019 6:14 AM
  • I have copied your info about using a password for the admin function.  Interesting.

    I have windows 10 with the latest upgrade and Homegoup has been deleted from windows 10.

    It is WorkGroup or nothing.

    I have the computers, Windows 10 and Windows 7, connect by a crossover ethernet cable.  I can see both computer in the network using WorkGroup, you can select no password protection.

    I can open Windows 10 computer on Windows 7 computer.

    I can NOT open Windows 7 computer on the Windows 10 computer.

    I have been working for hours on permissions of files on the Windows7 computer, and finally have found out how to include "everyone" to have read and write permissions on the C: drive.  Still no luck.  What am I missing?

    Saturday, September 21, 2019 5:33 PM