none
windows cannot connect to printer. access is denied.

    Question

  • I have a Vista laptop connected to a network of XP Home desktop computers. All file sharing works on the network except printing to my printer connected to XP Home doesn't work. I can see the printer on the network but a message says Windows cannot connect to the printer. Access is denied. What do I do?

    Sunday, January 20, 2008 5:58 PM

Answers

  • Hello,

     

    Thanks for your post!

     

    Based on my experience, this issue may be caused by incorrect driver for Windows XP SP2. As a result, security permissions are missing or incorrect for the Spool folder and for its subfolders on the Windows XP SP2-based computer.

     

    For your reference, please try the following steps to see if we can eliminate this problem:

     

    Note: This workaround may make a computer or a network more vulnerable to attack by malicious users or by malicious software such as viruses. We do not recommend this workaround but are providing this information so that you can implement this workaround at your own discretion. Use this workaround at your own risk.

     

    1.    Use an account that has administrative credentials to log on to the Windows XP SP2-based computer. 

    2.    Click Start, and then click My Computer. 

    3.    On the Tools menu, click Folder Options. 

    4.    On the View tab, click to clear the Use simple file sharing check box in the Advanced settings list, click Apply, and then click OK. 

    5.    In My computer, double-click the hard disk drive on which Windows XP is installed.

    Note: By default, Windows XP is installed on Local Disk ( C: ). 

    6.    Double-click Windows.

    Note: If you receive a "These Files are hidden" message, click Show the contents of this folder to view the contents of the folder. 

    7.    Double-click System32.

    Note If you receive a "These Files are hidden" message, click Show the contents of this folder to view the contents of the folder. 

    8.    Right-click Spool, and then click Properties. 

    9.    On the Security tab, click Advanced. 

    10. On the Permissions tab, click Add. 

    11. In the Enter the object name to select box, type the name of a user or of a group. This is the user or the group to which you want to give printer permissions on the Windows Vista-based computer. Then, click OK. 

    12. In the Apply onto list, click This Folder, subfolders and files. 

    13. In the Permissions list, locate Full Control, click to select the Allow check box, and then click OK. 

    14. In the Advanced Security Settings for spool dialog box, click Apply, and then click OK. 

    15. In the Spool Properties dialog box, click OK. 

    16. Add the shared printer to the Windows Vista-based computer. 

     

    Hope it helps!

     

    Regards,

    Lionel Chen

    Microsoft Online Community Support

     

    Tuesday, January 22, 2008 6:54 AM

All replies

  • Hello,

     

    Thanks for your post!

     

    Based on my experience, this issue may be caused by incorrect driver for Windows XP SP2. As a result, security permissions are missing or incorrect for the Spool folder and for its subfolders on the Windows XP SP2-based computer.

     

    For your reference, please try the following steps to see if we can eliminate this problem:

     

    Note: This workaround may make a computer or a network more vulnerable to attack by malicious users or by malicious software such as viruses. We do not recommend this workaround but are providing this information so that you can implement this workaround at your own discretion. Use this workaround at your own risk.

     

    1.    Use an account that has administrative credentials to log on to the Windows XP SP2-based computer. 

    2.    Click Start, and then click My Computer. 

    3.    On the Tools menu, click Folder Options. 

    4.    On the View tab, click to clear the Use simple file sharing check box in the Advanced settings list, click Apply, and then click OK. 

    5.    In My computer, double-click the hard disk drive on which Windows XP is installed.

    Note: By default, Windows XP is installed on Local Disk ( C: ). 

    6.    Double-click Windows.

    Note: If you receive a "These Files are hidden" message, click Show the contents of this folder to view the contents of the folder. 

    7.    Double-click System32.

    Note If you receive a "These Files are hidden" message, click Show the contents of this folder to view the contents of the folder. 

    8.    Right-click Spool, and then click Properties. 

    9.    On the Security tab, click Advanced. 

    10. On the Permissions tab, click Add. 

    11. In the Enter the object name to select box, type the name of a user or of a group. This is the user or the group to which you want to give printer permissions on the Windows Vista-based computer. Then, click OK. 

    12. In the Apply onto list, click This Folder, subfolders and files. 

    13. In the Permissions list, locate Full Control, click to select the Allow check box, and then click OK. 

    14. In the Advanced Security Settings for spool dialog box, click Apply, and then click OK. 

    15. In the Spool Properties dialog box, click OK. 

    16. Add the shared printer to the Windows Vista-based computer. 

     

    Hope it helps!

     

    Regards,

    Lionel Chen

    Microsoft Online Community Support

     

    Tuesday, January 22, 2008 6:54 AM
  • There is no "Advanced Settings" list under Tools/Folder Options/View on my XP SP2 computer.

    Dave Roper
    Tuesday, March 18, 2008 3:37 PM
  •  

    The advice given here is flat-out wrong - as the OP indicates, there is no "advanced" tab in the first place - perhaps the answer giver should update his/her system to service-pack 2.
    Saturday, April 12, 2008 12:52 AM
  • I'm have been pulling my hair out the last few days trying to do something as simple as installing a brand new HP Printer on my brand new Acer Laptop with Windows 7.  I tried the advice above posted by Lionel Chen, which seemed to be going fine until I got to the end.  My error message read..."An Error occurred while applying security information: C:\windows\system32\spool\prtprocs...\LXKPTPRC.DLL.mui  Access is denied."  Any suggestions.  I'm about ready to through my computer against the wall.  Any advise would be greatly appreciated.

     

    Thank you

    Thursday, March 31, 2011 5:25 PM