none
Windows 10 Creators Update Causing Very Slow WiFi

    Question

  • Just updated to Windows 10 Creators update and my WiFi speed is now very slow when accessing files over network share. Prior to the upgrade I would get 10Mbs data transfer speeds as shown in file copy window. Now I am lucky to get 50Kbs! I have an Intel Dual Band AC-7265 WiFi adapter running the latest Intel WiFi drivers. If I switch to Ethernet then I am back to 30Mbs. I tried un-installing the WiFi adapter & then re-adding but no change. I have no custom TCP settings either.

    The WiFi properties show it has connected at 300 Mbs.

    The weird thing is that I can write files over the network at >10Mbs, it is only Reading that is very slow.

    I tried on another PC also running Windows 10 Creators update and performance there is as expected (>1Mbs).

    Is there any diagnostic tool anywhere that will let me find out what is going wrong?


    • Edited by Caratacus2 Monday, April 17, 2017 2:30 PM
    Monday, April 17, 2017 2:15 PM

All replies

  • Type troubleshooting in the left lower corner search to open the troubleshooting control panel.

    Run the network adapter and internet connection troubleshooters.

    If these fix you have completed troubleshooting.

    If the above don't fix the wireless then perform the next steps.

    Click windows and x keys simultaneously and click on device manager.

    Expand network adapters.

    Right click on the wireless AC, then view properties, then driver.

    View you computer manufactures web site for up to date drivers for your computer.

    Uninstall and reinstall drivers for wireless.

    Monday, April 17, 2017 2:35 PM
  • Hi,

    as I mentioned above, I have already done the adapter delete/re-install with latest driver.

    From performing other tests this is what I seem to have:

    1. Very slow READ (file copy) via 1 WiFi connection point. This did not happen prior to update.
    2. SEND via this WiFi is fast
    3. READ via other WiFi connection points to the same endpoint as (1) performs as expected
    4. Another computer running same Win10, using same WiFi connection point & reading from the same Endpoint works as expected. So this discounts (a) a problem with the WiFi router, (b) the endpoint I am reading from

    Rather puzzling. As an experiment I looked into what I could change on the NAS endpoint & found that Jumbo Frames were turned on. So I turned it off, rebooted the NAS. Now I get a file copy READ speed of 1.5Mbs - a lot better, but only 1/2 the speed of the WRITE speed (I would expect READ to be higher). Now, Jumbo Frames don't apply to WiFi, only to 1Gbit Ethernet adapters, so this is even more puzzling!

    So I have better performance now, but not as good as it was.

    Tuesday, April 18, 2017 8:23 AM
  • see if one of these is useful:

    https://www.bing.com/videos/search?q=fix+windows+10+1703+problems+with+wifi&qpvt=fix+windows+10+1703+problems+with+wifi&view=detail&mid=09FCE7C043A047C9E52B09FCE7C043A047C9E52B&FORM=VRDGAR

    https://support.microsoft.com/en-us/help/4000432/windows-10-fix-wi-fi-problems

    http://www.drivethelife.com/windows-10/fix-no-wifi-available-after-windows-10-update.html

    For the wifi you can check your speed with ping command from admin command prompt.  For example ping google.com       Then you can also run round trip commands RT.     These mostly find problems related to your internet provider. 

    https://www.howtogeek.com/208030/how-to-set-up-a-nas-network-attached-storage-drive/

    One of my old internet providers had software updates and software pushes that required a proper sequence for rebooting.  If that was not done in the right sequence there was a noticeable difference in internet speed.  If you have no noticeable difference with Ethernet cable comparisons then that narrows down the problem.

    Tuesday, April 18, 2017 8:58 AM
  • Hi Cartacus2,

    I am experiencing a similar behavior after creators update,

    also tried driver uninstallation, update, bios update, netsh winsock reset, uninstall vpn client, many different things

    my NIC is Intel AC 8260,

    the behavior is for example:

    • skype for busines is not loading completely,
    • outlook does not complete send/receive,
    • opening of specific websites is slow (for example also speedtest.net)
    • remote desktop connections are difficult to establish and slow in displaying

    the odd thing is it happens at our corporate site,

    at home wifi is fast.... weird....

    I discovered that if I establish a VPN connection I can work smoothly even in our corporate wifi.....

    do you have to possibility to test a vpn connection through your wifi?

    I will let you know if I discover something new.

    greetings

    Samuel

    Tuesday, April 18, 2017 9:22 AM
  • Hi Cartacus2,

    I am experiencing a similar behavior after creators update,

    also tried driver uninstallation, update, bios update, netsh winsock reset, uninstall vpn client, many different things

    my NIC is Intel AC 8260,

    the behavior is for example:

    • skype for busines is not loading completely,
    • outlook does not complete send/receive,
    • opening of specific websites is slow (for example also speedtest.net)
    • remote desktop connections are difficult to establish and slow in displaying

    the odd thing is it happens at our corporate site,

    at home wifi is fast.... weird....

    I discovered that if I establish a VPN connection I can work smoothly even in our corporate wifi.....

    do you have to possibility to test a vpn connection through your wifi?

    I will let you know if I discover something new.

    greetings

    Samuel

    I am having the same problem after creators update. At home is really fast but in university is incredibly slow. All other devices work has usual. I am following this thread.

    Hp envy 13, AC 7265

    • Edited by Takethis Tuesday, April 18, 2017 2:38 PM
    Tuesday, April 18, 2017 2:37 PM
  • Having the same issue on  Intel AC 8260.

    Very, very slow WIFI.  Updated drivers to latest version.  This has happened since the creators update.

    Tuesday, April 18, 2017 4:49 PM
  • Open administrative command prompt.

    type:  netsh wlan show wlanreport

    Use file explorer search to find and open this file: 

    c:\programdata\microsoft\windows\wlanreport\wlan-report-latest.html

    Check for errors/problems in the network/wifi report:

    https://support.microsoft.com/en-us/help/4000432/windows-10-fix-wi-fi-problems

    https://support.microsoft.com/en-us/help/4000463/windows-10-wifi-tools-apps

    https://support.microsoft.com/en-us/help/4000462/windows-10-analyzing-wireless-network-report



    Wednesday, April 19, 2017 2:31 AM
  • This helped for me:

    1) open Device manager - Right click "Intel(R) Dual Band Wireless-AC 7265"
    2) "Update driver" and choose "Browse my computer for driver software"
    3) "Let me pick from a list of available drivers on my computer" and choose "Intel(R) Dual Band Wireless-AC 7265 Version: 17.15.0.5 [22.2.2015]" then Next and that's it.
    • Proposed as answer by MarverX Wednesday, April 19, 2017 2:09 PM
    Wednesday, April 19, 2017 8:19 AM
  • This helped for me:

    1) open Device manager - Right click "Intel(R) Dual Band Wireless-AC 7265"
    2) "Update driver" and choose "Browse my computer for driver software"
    3) "Let me pick from a list of available drivers on my computer" and choose "Intel(R) Dual Band Wireless-AC 7265 Version: 17.15.0.5 [22.2.2015]" then Next and that's it.

    Worked for me too.

    Thanks!

    Wednesday, April 19, 2017 2:09 PM
  • Hi Ladifor and MarverX,

    which version did you have before downgrading to 17.15.0.5?

    Do someone has an idea how to fix this for Ac 8260?

    it gives me problems on creators update with:

    19.50.1.5

    19.20.3.4

    19.1.0.4

    not sure which other versions are available for 8260 for my hardware.....

    Greetings

    Samuel

    Thursday, April 20, 2017 8:20 AM
  • I'm actually having the opposite problem. I have the same NIC (Intel 8260) and my internet speeds are great >100 Mbps after a reboot. As soon as I connect to my work VPN, my speeds drop to <1 Mbps until I reboot again. Even disconnecting from the VPN doesn't help. No internet traffic is being routed through VPN.
    Thursday, April 20, 2017 5:01 PM
  • Hi Ladifor and MarverX,

    which version did you have before downgrading to 17.15.0.5?

    Do someone has an idea how to fix this for Ac 8260?

    it gives me problems on creators update with:

    19.50.1.5

    19.20.3.4

    19.1.0.4

    not sure which other versions are available for 8260 for my hardware.....

    Greetings

    Samuel

    I tried all 3 of those and it didn't help my situation.
    Thursday, April 20, 2017 5:11 PM
  • 17.15 seems to be the latest working.

    Full detective work is here: https://answers.microsoft.com/en-us/windows/forum/windows_10-networking/wifi-issues-with-creators-update/4a20ba4f-33dc-4397-9823-e12dcb2607ba

    There are all the instructions (even how to prevent Windows Update from updating 17.15 to newer version)

    Friday, April 21, 2017 6:29 AM
  • Thanks for the link, but 17.15 isn't available for my 8260.
    Friday, April 21, 2017 4:58 PM
  • I just rolled back to the Anniversary Update. Everything is fine again. I'll just have to wait until this is solved before upgrading.

    Start > Settings > Updated & Security > Recovery > Go Back to an earlier build > Get Started

    Friday, April 21, 2017 5:15 PM
  • i'll echo the same fix worked for me. Going back to the control panel and rechoosing the network adapter seems to have fixed the problem.
    Saturday, April 22, 2017 1:33 PM
  • i'll echo the same fix worked for me. Going back to the control panel and rechoosing the network adapter seems to have fixed the problem.

    Can you please elaborate? I have tried everything in this thread and I can not for the life of me get my wifi(Intel AC 7260) to work as it used to before this dreaded update. I have FTTH and 200/100 mbps connection.

    I tried rolling back to drivers 17.15.0.5, latest intel drivers. I uninstalled the creators update and it's still the same. I reset my laptop COMPLETELLY, ie clean install and I still get barely 70 mbps on download. FUnny thing is my upload goes even over 100 mbps. I am at my wits end here...how can it still be broken after a clean install? My chinese smartphone maxes out my 200/100 connection easily...

    Any advice appreciated. 

    Saturday, April 22, 2017 4:46 PM
  • Go to the  wifi properties (several ways to get there).

    From there i picked "configure" on my Realtek -

    Go to Advanced... Pick wireless mode.  I turned off automatic. and picked IEEE 802.11b/g/n and said ok.

    Connectivity seems much more stable.

    Saturday, April 22, 2017 8:05 PM
  • Hi LadiFor,

    so there are three factors and also three possible solutions for the problem:

    - driver (solution is downgrade version)

    - creators update (solution is uninstall creators)

    - some wifi setting (since the problem seems only to happen in some locations)

    going back to 17.15.0.5 seems to be the downgrade version solution for AC-7265,

    unfortunately there is still no downgrade version solution for AC 8260 since it is newer,

    the detective work is interesting, but it would be much more interesting to know which wifi setting is causing this problem, what works strangely with creators update and drivers higher than 17.15.0.5, so we could keep latest drivers and latest update,

    but I tried many setting regarding wifi (band, power) or regarding netsh parameters, like autotuning or rsss, still no luck,

    do someone has other ideas?

    greetings

    Samuel

    Tuesday, April 25, 2017 9:28 PM
  • Sometimes, it could work. We can try to roll back to elder version of Wireless network driver for your computer to check this issue.


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, April 26, 2017 8:22 AM
    Moderator
  • Yesterday i've installed (Clean Install - no update!) Creators Update on my HP 15 ba044 Laptop with all released updates.

    Well - i've tested three different wifi adapters (internal and two different USB adapters) - and the wifi was very, very slow (max 1 mbps).

    To verify this behaviour i've done a complete new clean install of the older Windows 10 version (v1607) and the speed was ok with all adapters (!) like before.

    Has anyone an idea? An addional information: Each wifi adapter has a Realtek chipset (8188CU, 8188EU, 8233). Windows 10 installs the driver itself. Changing the driver doen't change a thing.

    Maybe it's a very big bug in Creators Update.

    Thanks a lot!

    Wednesday, April 26, 2017 8:30 AM
  • Hi,

    Decreasing your MTU for WiFi interface to 1400 may solve the issue. I have fixed my issue by this method.

    0. In the administrator's command prompt, 

    1. Check the name of your WiFi interface.

    > netsh interface ipv4 show subinterfaces

    2. decrease the size of MTU of the wifi interface. Please replace "Wireless Network Connection" with your WiFi interface name.

    > netsh interface ipv4 set subinterface "Wireless Network Connection" mtu=1400 store=persistent

    BTW, May I ask your WiFi environment?

    I have a pc with the same NIC, AC8260 and have the slow trouble with my office environment(Cisco Aironet 802.11ac AP), but don't have the trouble with wifi in my home(Linksys 802.11ac AP).  I fixed the issue of office environment by this method.

    The slow phenomenon is only by TCP downloading, not caused when I try TCP uploading and UDP downloading/uploading. I believe that there are TCP related bugs in Creators Update.

    I guess it's not a best solution, it's only workaround. The issue should be fixed by the update of device driver or windows. 



    • Edited by notnext Wednesday, April 26, 2017 9:18 AM
    • Proposed as answer by Andrey Polienko Wednesday, July 19, 2017 10:05 AM
    Wednesday, April 26, 2017 9:12 AM
  • Hi notnext,

    I were sure I did try setting a lower MTU, cool, now it looks good if I set a lower MTU

    in fact it seems another solution,

    in fact maybe the best for 8260,

    our wifi is Cisco, so maybe it's a problem with PMTUD.....

    Thanks,

    I will let you know if I know more.

    greetings

    Samuel


    • Edited by ssenoner Wednesday, April 26, 2017 5:13 PM
    Wednesday, April 26, 2017 3:10 PM
  • Hi,

    I got the similar problem on my 8260 when I upgraded to the Creator Update. I supposed my campus routers were also Cisco while I have no ideas about the exact model. I tried to set a lower MTU to 1400 but there seemed no sign of improvement. Will the Window 10 fix this problem in the next updates? Or it will be perfect if you got any ideas to solve it right now. I will keep following the thread, please let me know when you got the solution.

    Thanks

    Lux 

    Thursday, April 27, 2017 3:41 PM
  • We troubleshooted the problem with our network expert,

    we did also some packet sniffing on client side with Microsoft Message Analyzer, and saw differences,

    it seems windows with creators update, intel and our wlan infrastructure is not acknowledging some packets, analyzer shows some potential errors,

    the solution was to reconfigure our cisco wlan from MSS 1363 to MSS 1360,

    so adjusting the "tcp-mss-adjust" value,

    actually working quite good on my lenovo X1 yoga, AC 8260 with default MTU (1500) on client side, latest driver with creators update.

    greetings

    Samuel

    Thursday, April 27, 2017 4:01 PM
  • I also can report success with lower MTU setting on an Intel 8260 card.  Changing driver versions did not work for me (maybe the 17.15 driver does not exist for the 8260? I could not find it anywhere)

    One thing to clarify, to get the list of interfaces, I ran 

    netsh interface ipv4 show subinterface

    Then, like the directions above say, run (You need to start the Command Shell as Adminsitrator to make this change) :

    netsh interface ipv4 set subinterface "Wi-Fi" mtu=1400 store=persistent

    where "Wi-Fi" is the name of the interface the first command gave you.

    Lastly, you can verify the MTU is set correctly by executing the first command again.

    Thanks for the solution, this was driving me crazy!

    • Proposed as answer by JKJK Wednesday, June 07, 2017 11:40 AM
    Thursday, April 27, 2017 4:18 PM
  • We also reconfigured "tss-mss-adjust" value of our Cisco WLC and the issue was solved. It's far better than client-side workaround. Thanks! 

    • Proposed as answer by JKJK Wednesday, June 07, 2017 11:40 AM
    Friday, April 28, 2017 7:53 AM
  • I had exactly the same issue. After one of the lastest windows updates, my WIFI connection did not get any faster than 18Kbs!  A lot of connection failure issues (not connected to internet messages)

    I was able to fix it by un-installing the latest update (related to network VM ware updates) and by re-installing my Dell Dual Band Wireless driver (from hard disk, as updating driver from internet did not work). Now it is working again, hope it will not return with the next update.

    Saturday, April 29, 2017 6:48 AM
  • I have a Broadcom BCM4360 based Wi-Fi card.  So far none of the TCP/IP tweaks work.  I tried updating the driver and that had no effect.  There are very few driver releases for this card.   Only connecting out via VPN makes the issue go away.
    Saturday, April 29, 2017 7:37 AM
  • Hi,

    Decreasing your MTU for WiFi interface to 1400 may solve the issue. I have fixed my issue by this method.

    0. In the administrator's command prompt, 

    1. Check the name of your WiFi interface.

    > netsh interface ipv4 show subinterfaces

    2. decrease the size of MTU of the wifi interface. Please replace "Wireless Network Connection" with your WiFi interface name.

    > netsh interface ipv4 set subinterface "Wireless Network Connection" mtu=1400 store=persistent

    BTW, May I ask your WiFi environment?

    I have a pc with the same NIC, AC8260 and have the slow trouble with my office environment(Cisco Aironet 802.11ac AP), but don't have the trouble with wifi in my home(Linksys 802.11ac AP).  I fixed the issue of office environment by this method.

    The slow phenomenon is only by TCP downloading, not caused when I try TCP uploading and UDP downloading/uploading. I believe that there are TCP related bugs in Creators Update.

    I guess it's not a best solution, it's only workaround. The issue should be fixed by the update of device driver or windows. 




    Thank you! You solved my problem! I had really slow connection when connected to my University network, now everything is fine! :D
    Saturday, April 29, 2017 11:59 AM
  • Hi,

    Cisco seems to recommend a MSS of 1300....

    can someone try if also:

    Disable-NetAdapterRsc -Name Wi-Fi

    works?

    found that on:

    https://answers.microsoft.com/en-us/windows/forum/windows_10-networking/wifi-issues-with-creators-update/4a20ba4f-33dc-4397-9823-e12dcb2607ba

    greetings

    Samuel

    • Proposed as answer by CPROV Wednesday, May 03, 2017 8:25 PM
    Tuesday, May 02, 2017 8:05 AM
  • You are a LEGEND!! This solved my issue. Thanks so much for posting this. 
    Tuesday, May 02, 2017 10:11 AM
  • I put off the update because I figured something like this would happen. Worked for me as well. Sidenote you'll likely have issues with GPU drivers (if you're running a dedicated one) as well so I would reinstall those. Also kudos to you for posting a solution rather than just a link.
    • Proposed as answer by JKJK Wednesday, June 07, 2017 11:40 AM
    • Unproposed as answer by JKJK Wednesday, June 07, 2017 11:40 AM
    Thursday, May 04, 2017 6:42 PM
  • Hello

    Disable-NetAdapterRsc -Name Wi-Fi worked in my environment.

    Intel AC-8260 with driver v19.50.1.5.

    With disabled NetAdapterRsc WLAN Performance normal again. As well with connected VPN (here i had the biggest problem's - with connected VPN: upload performance was below 0.1Mbps).

    Thankx!!

    Greetings
    Michael

    Saturday, May 06, 2017 9:19 AM
  • This worked for me also on my Intel(R) Dual Band Wireless-AC 3165 adaptor. Thnx!

    Greetings, Richard


    Sunday, May 07, 2017 6:56 AM
  • Worked for me too. thanks.
    Wednesday, May 10, 2017 2:32 PM
  • Go to the  wifi properties (several ways to get there).

    From there i picked "configure" on my Realtek -

    Go to Advanced... Pick wireless mode.  I turned off automatic. and picked IEEE 802.11b/g/n and said ok.

    Connectivity seems much more stable.


    Thank you Sir! I tried everything but only your Solution fixed it for me.
    Friday, May 12, 2017 9:08 PM
  • Thanks, Disable-NetAdapterRsc -Name Wi-Fi works for me, Killer 1535.

    • Proposed as answer by JKJK Wednesday, June 07, 2017 11:40 AM
    Thursday, May 18, 2017 11:49 AM
  • Thanks! I used version 18.32.0.5 (dated 12/22/2015) and it works for me.
    Thursday, May 18, 2017 3:27 PM
  • Updating to the latest drivers and following the linked instructions , only the first option on this page:

    https://answers.microsoft.com/en-us/windows/forum/windows_10-networking/wifi-issues-with-creators-update/4a20ba4f-33dc-4397-9823-e12dcb2607ba

    Disable-NetAdapterRsc -Name Wi-Fi worked for me. Using Killer Wireless 1535

    • Proposed as answer by JKJK Wednesday, June 07, 2017 12:20 PM
    Thursday, May 25, 2017 2:32 PM
  • Than you!  This worked solution worked for me and my AC8260.

    Same issue - at work I had the same slow symptoms but using my personal hotspot speeds were normal.

    Wednesday, May 31, 2017 12:19 PM
  • This worked! USE THIS FIX PEOPLE! The only one that worked for me. Thank you so much for taking the time to Post this MarverX!
    Wednesday, May 31, 2017 6:03 PM
  • This helped for me:

    1) open Device manager - Right click "Intel(R) Dual Band Wireless-AC 7265"
    2) "Update driver" and choose "Browse my computer for driver software"
    3) "Let me pick from a list of available drivers on my computer" and choose "Intel(R) Dual Band Wireless-AC 7265 Version: 17.15.0.5 [22.2.2015]" then Next and that's it.

    Worked for me too.

    Thanks!

    OMG....after weeks of trying, did this...went from 6 Mbps to 75 Mbps.....THANK YOU!!!!!!!!!!!

    Wednesday, June 07, 2017 10:03 PM
  • Another *solution* to this problem (yep, I'm here with a client that has the same - only not on WiFi but on NiC (update: actually, it's on his laptop, just confirming now if it's WiFi or NIC connected)...

    Start, start typing 'network reset' - and open Network Reset.  And (of course), perform it.

    That works for my client.

    Then Windows Update (presumably) comes along a few days later and kills it again.

    I need to identify the driver and stop it from updating.

    I don't really know how.

    (I made a wee Sway site for my client...)

    https://sway.com/rmxrRGxe7LD9d5ct


    Be keen to hear how I might achieve what I need to do - ie. stop Windows Update from stuffing up his PC again.

    I'm also a bit worried that the Speccy report might not contain the info I need.  Is there another wee util I could get him to run that will provide driver info perhaps?

    Cheers,  Duncan.

    Update:

    The info given in this thread, looks good and promising - will see if I can get back on my client's PC and try some of this stuff...

    https://answers.microsoft.com/en-us/windows/forum/windows_10-networking/wifi-issues-with-creators-update/4a20ba4f-33dc-4397-9823-e12dcb2607ba

    https://support.microsoft.com/en-us/help/3073930/how-to-temporarily-prevent-a-driver-update-from-reinstalling-in-windows-10

    Cheers,  Duncan.



    Wednesday, June 07, 2017 10:26 PM
  • Thank you, for the record, the Disable-NetAdapterRsc -Name Wi-Fi (Powershell command) also worked for me (intel 8265 with latest driver v19.60.0).
    Friday, June 09, 2017 7:07 PM
  • The powershell Disable-NetAdapterRsc -Name Wi-fi solution worked perfectly ON a high-end ZBook Studio G4 with an Intel Dual Band Wireless-AC 8265.

    I had first noticed the problem when using Remote Desktop to connect to a remote host. Persistent lag / high latency delayed the screen redraw response by a up to a few seconds and even sometimes left redraw artifacts. It was not usable. In Remote Desktop's full screen mode, the toolbar's connection quality indicator would typically show only two bars ("good") even though much older and lower-powered equipment in the same location consistently managed four bars (excellent). Switching from a 5.0Ghz WLAN to a 2.4Ghz WLAN did not work. Even switching to a completely different WLAN router accomplished nothing. However, the above symptoms would disappear when physically plugging the laptop directly into an Ethernet LAN port on the same WLAN router. At the same time, no network issue was apparent when performing basic network diagnostic tests or online speed/latency tests.

    Thank you for the solution!

    Wednesday, June 21, 2017 6:11 AM
  • My goodness!

    3GB of update for 1703. Total nonsense I didn't ask for or have the slightest interest in. 

    WTF is provisioning kiosk devices anyway?

    Can't use my computer for 90mins while the thing installs.

    When it comes back internet via WiFi is at 1997 dial up speed.

    After another hour on the phone using the same WiFi I am glad to have read this - thank you it worked!

    But.... How is Microsoft still in business???? Consumer updates trashing internet connection? 3.5GB updates? WHY!!!!

    Total garbage through and through.

    Wednesday, June 21, 2017 10:36 PM
  • I also experienced this issue after upgrading to Windows 10 Creator's edition.

    My Download/Upload speed over WiFi dropped from 100Mbps down/50Mbps up (equal to my broadband fibre connection), to 5Mbps down/50Mbps up.

    I first fixed the problem by disabling my Bluetooth Adapter (in Device Manager) - which is not ideal.

    My Wireless driver for "Intel(R) Dual Band Wireless-AC 7265" was the latest version 19.51.0.4 (March 2017).

    After seeing the above solution from MarverX, I followed the instructions (to downgrade to version 17.15.0.5) by following the steps:

    1) open Device manager - Right click "Intel(R) Dual Band Wireless-AC 7265"
    2) "Update driver" and choose "Browse my computer for driver software"
    3) "Let me pick from a list of available drivers on my computer" and choose "Intel(R) Dual Band Wireless-AC 7265 Version: 17.15.0.5 [22.2.2015]" then Next and that's it.

    After that, I enabled my Bluetooth again.

    My WiFi speed now works as expected!

    So although disabling Bluetooth did work, downgrading the WiFi driver is the better solution for those that need Bluetooth.




    • Proposed as answer by IoTbert Sunday, July 02, 2017 12:54 PM
    • Edited by IoTbert Sunday, July 02, 2017 1:06 PM
    Sunday, July 02, 2017 12:53 PM
  •  Thank you.  Thank You !!!   I followed your instructions regarding the changing the driver & in addition made my default browser Internet Explorer ( not Microsoft Edge ).  My computer has never worked so fast !!!

     Again, thanks a million.  

    Tuesday, July 04, 2017 1:18 PM
  • Fixed on my new HP Elitebook x360 G2 by the following:

    • Open Powershell as Administrator
    • execute: Disable-NetAdapterRsc -Name Wi-Fi

    Before this, downloads max'd out after a few seconds, then dropped to 0kb before trickling again. 

    HP Elitebook x360  1030 G2

    Windows 10
    Version 1703, Build 15063.413

    Intel(R) Dual Band Wireless-AC 8265
    19.60.0.7


    • Edited by stevebor1 Saturday, July 08, 2017 6:53 AM
    Saturday, July 08, 2017 6:51 AM
  • Hi, MTU and disable RSC not running for myself,

    tested driver 19.70.05;19.60.07;19.40.03 without succes.

    just roll back to the oldest driver well (AC 8260 driver version: 19.1.0.4).
    Block automatic driver update to be sure. 

    Rgds

    Thursday, July 13, 2017 11:35 AM
  • Hi,

    Decreasing your MTU for WiFi interface to 1400 may solve the issue. I have fixed my issue by this method.

    0. In the administrator's command prompt, 

    1. Check the name of your WiFi interface.

    > netsh interface ipv4 show subinterfaces

    2. decrease the size of MTU of the wifi interface. Please replace "Wireless Network Connection" with your WiFi interface name.

    > netsh interface ipv4 set subinterface "Wireless Network Connection" mtu=1400 store=persistent

    BTW, May I ask your WiFi environment?

    I have a pc with the same NIC, AC8260 and have the slow trouble with my office environment(Cisco Aironet 802.11ac AP), but don't have the trouble with wifi in my home(Linksys 802.11ac AP).  I fixed the issue of office environment by this method.

    The slow phenomenon is only by TCP downloading, not caused when I try TCP uploading and UDP downloading/uploading. I believe that there are TCP related bugs in Creators Update.

    I guess it's not a best solution, it's only workaround. The issue should be fixed by the update of device driver or windows. 



    Thanks a lot! Setting MTU to 1400 did the trick and now my corp Wifi is back to operating normally.  
    Wednesday, July 19, 2017 10:07 AM
  • This helped for me:

    1) open Device manager - Right click "Intel(R) Dual Band Wireless-AC 7265"
    2) "Update driver" and choose "Browse my computer for driver software"
    3) "Let me pick from a list of available drivers on my computer" and choose "Intel(R) Dual Band Wireless-AC 7265 Version: 17.15.0.5 [22.2.2015]" then Next and that's it.

    2017 July Window 10 version 1703 update wifi device disabled

    Thank you this worked

    I picked December 2015 driver and back online

    Monday, July 31, 2017 11:14 PM
  • I saw the same. Check your network adapter. Is there a bluetooth network adapter and it's active ?  Give it a try and deactivate the bluetooth network adapter. I did it and got my full speed back. 

    Friday, August 04, 2017 4:51 PM