none
HP Laserjet 2100 won't install with Vista 64. ".inf file not found"

    Question

  • I am trying to install an HP Laserjet 2100 printer with Vista 64.  I downloaded the driver recommended by HP.  I try to install it and Vista complains about the .inf file - says ".inf file not found".  I point the browzer at the .inf file which I can see is there and Vista says installation failure.  I've tried everything I know.  Anyone have any other ideas?
    Sunday, September 07, 2008 5:55 AM

Answers

All replies

  • I suggest that you temporary disable the firewall and antivirus, and run the installation again. This time, please extract the contents to Desktop when installing.

     

    If the issue persists, I suggest that you access the website below, and re-download the driver.

     

    http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareIndex.jsp?lang=en&cc=us&prodNameId=14914&prodTypeId=18972&prodSeriesId=25469&swLang=8&taskId=135&swEnvOID=2100

     

    If the issue reoccurs, please select an alternative driver from the above website. Then try to install. If the issue does not occur this time, I suggest that you contact HP support and repost the driver mistake.

    However, if the issue still occur this time, please let me know if you have installed the printer before.

     

    Also, please let me know which drivers you have tried.

     

    Hope it helps.

     

    Thursday, September 11, 2008 2:10 AM
    Moderator
  • Hi Arthur,

     

    I'm having the same problem as liquid11, however my OS is Windows 7 Professional (64bit) and I am trying to connect to a network's LaserJet 2100 PCL 6 (the server's OS is Windows XP (32bit)). I dowbnloaded all the drivers for Laserjet 2100-Windows 7 (64bit) from the HP official website but still it didn't work.

    Any idea? I did the exact same thing as liquid11 and it still keep complaining about 'cannot locate a suitable driver'

     

    Thanks in advance!

    Friday, June 04, 2010 5:09 PM