Windows Media Player 12/Windows 7 Freeze


  • When I'm watching h.264-encoded mp4 files streamed from WMP12 on Windows 7 x64 RC to an Xbox 360, Windows 7 does a sort of "slow freeze" after about 10 minutes of playback. The Xbox freezes playback as if the network connection was interrupted, so the Xbox recovers just fine. However, after I scurry downstairs to my desktop, I find that although I can still move the mouse and click on things, nothing actually works. After about 30 seconds of that, the mouse and keyboard stop responding and the machine fully locks up. I've tried waiting the freeze out, but after about half an hour I gave up on that.

    I have used msconfig to do what I have seen described as a "clean boot": disabled all services after hiding the MS services. This does not appear to have made a difference.

    I previously had the Combined Community Codec Pack installed (mostly just on habit - I assumed it was needed), but I have since uninstalled the pack. I haven't had any issues playing any of the same videos on my desktop since it was removed.

    I have checked the Application and System event logs, but there is nothing there for troubleshooting; there's the usual event ID 6008 (unexpected shutdown) and 41 (unclean shutdown) in the system logs. Every once in a while WMP adds some events to the application log citing the Xbox requesting the media to share, but this isn't consistent, and they're not errors anyway, just informational messages.

    I'd sure appreciate some suggestions for troubleshooting what really looks like a completely silent halt. Windows 7 has opened up brand-new and exciting ways for me to brainwash myself with whopping-high-quality video, but this really puts a kink in my habit.

    Thanks for reading!

    Here's something new - after the most recent freeze, the machine recovered after about 10 minutes, and reported these:

    Event ID 7009
    A timeout was reached (30000 milliseconds) while waiting for the Windows Error Reporting Service service to connect.

    Event ID 14104
    The Windows Media Player Network Sharing Service cannot process the request for URI '' from IP address '' due to error '0x80070043'. is the Xbox 360. Any thoughts?
    • Edited by sandersjds Saturday, September 19, 2009 5:01 AM more data
    Saturday, September 19, 2009 3:52 AM

All replies

  • Things that I have done since this post that have not resolved my issue:
    • Set "Windows Error Reporting Service" to automatic and enabled per this thread's suggestion . This cleared the error reporting service timeouts, but did not resolve the freezes.
    • Disabled "Multimedia Class Scheduler" per this comment . Disabling MMCSS was largely in response to my observation that the service would start and stop nearly in sync with freezes and recoveries, per the system event logs. At first, this appeared to help. And then it froze up again.
    • Disabled all of the power-saving features in the system, so nothing goes to sleep. Ever.
    So now I've got EVEN CLEANER event logs, but I'm no closer to finding a fix for this.
    Tuesday, September 22, 2009 3:54 AM
  • I have a similar freeze with Windows 7 Ultimate, just by watching DVDs. But it usually recovers after a 3 minutes freeze. It's pretty random too, it could happen after 10, 20, 40 minutes of playback. Then the playback would stop, I'm still able to navigate around and type, up to a certain buffer limit. Then the whole system is frozen for 3 minutes, and resumes as if nothing happened. Does it ring a bell with anyone?
    Tuesday, December 01, 2009 11:05 PM
  • I am having a similar freezing problem. But mine stays down. I play movie files (.mod files) on WIndows Media Player from my Windows 7 Ultimate. My kid (2 yr old) likes to watch various vids of our trips and vacations on the computer. The only way for her to watch them now is by me burning a dvd from the files.

      Anyway, after a few minutes of watching these video files my computer locks up.  Windows Media Player works well with all other aspects -burning, music, etc.. Just watching videos (.mod files) seems to cause lockups. Any ideas would be appreciated.

    Here's a thought..
    Is it possible to disable (didn't see it in the programs listings) or uninstall Windows 12 (Win 7 Ultimate version) and install previous versions like WMP 10 or 11?
    Tuesday, December 08, 2009 1:29 AM
  • I wrote the problem above. I thinnk I found out a reason for it.. sorta... I was disabling Yahoo Messenger (v 8) to put in the newest version 10. Well I disabled it and deleted it and then my wife wants to see some vacation videos on the computer.  I warned her that it will lock up as it has been doing for me all morning when I play vidoes on WMP 12. So she uses it and nothing happens! I mean no lockups! So after about 30 minutes she gets off and I finally install Yahoo Messenger (v 10) and guess what, the lockups come back! Everytime I play a .mod video, the machine locksup up after about 5 seconds or so. So I uninstall Yahoo messenger and try to play some videos and again no problems.

    I want to state that when WMP 12 was locking up, I did not have my Yahoo Messenger application running. So I am guessing that Yahoo Messenger and WMP 12 must share some file -maybe some .dll file somewhere that causes this lockup.

    If you are (still) having problems with lockups on WMP 12, I suggest you disable Yahoo Messenger (even if you have it on and never run it). WHen Windows Media Player 12 was locking up on me, I was not using Yahoo Messenger but it still failed.  NOw without Yahoo Messenger running, I just can't make WMP 12 fail.. -no matter how hard I try!

    I discovered this solution by chance. I hope there is a fix for it as my wife likes to use Yahoo Messenger. Any ideas would be appreciated. :-)

    That Latin Guy,
       Johnny C.  
    • Proposed as answer by jonytemp Thursday, December 10, 2009 6:08 AM
    Thursday, December 10, 2009 6:08 AM
  • Using a different version of WMP will not help: I tried using different players like VLC and KMP instead of WMP, and have the same random 3-4 minutes freezes.
    I just played a ripped DVD for one hour without any problem, then it started freezing again.
    There is absolutely nothing in any event logs to help debugging, just a few time outs that are the consequence of the freeze.
    I switched the power options to high performance but it repros with only WMP running, not even Firefox or Windows Live Messenger.
    Wednesday, December 23, 2009 10:48 PM
  • Well Im having the exact same problem as jonytemp described, except I dont have Yahoo messenger installed, any other software that could mess that up? And it seemed to happen only on .mod from my camescope, other movies played without a glitch.

    Tuesday, February 16, 2010 4:05 AM
  • I get these freezes on all players as well (maybe less often on VLC), but mine don't really freeze the computer.  If i just pause the Xbox or whatever player for about thirty seconds, then hit play.  My video will continue for 10+ minutes, and i have to repeat this annoying process.
    Sunday, July 18, 2010 1:33 AM
  • If you have a Seagate disk, you may need to upgrade its firmware:

    There was a bug in some Seagate disks' firmware, where the disk cache would saturate when reading high streams of data such as videos, causing a temporary system freeze for about 3 minutes.

    Sunday, July 18, 2010 2:25 AM
  • I've been having the same problem described, and nothing as of yet has helped, and I've done most of it.
    Tuesday, August 10, 2010 3:27 AM
  • I had this same problem in both mce and wmp and also tried all of the above but nothing worked. Then I noticed that I had two versions of dvdfab installed on my computer (6 & 7).  I uninstalled them and now it works perfecly, no pauses in either wmp or mce.  I suppose that this is similar to the yahoo messenger conflict cited above.
    Friday, August 13, 2010 4:42 AM
  • I found a similar problem recently and this is where I am at with it. When the laptop (Toshiba) with Windows7 2G ram,64bt proc, locks up, i can move the cursor but the buttons will not select anything. control/alt/delete does not interrupt right away. The responses are delayed by a few min. When i finally get the task manager open, and set to show processes from all users... the number one drain on the cpu is wmp network services. By going into control panel (set to icons) administrative tools, services and selecting the wmp network services properties. The only setting which will stop this from restarting on its own is to disable it entirely. This will cause problems with games I play on Facebook, such as collecting money from properties will not appear. By enabling the wmp sharing service this will work but the puter will lock up later. There is an xbox 360 in the house and from other searches im wondering if there is an interaction there I need to investigate.
    Monday, September 20, 2010 7:01 PM
  • Hello All,

    I just did what jonytemp advised. Removed yahoo messenger and also the yahoo applications and it fixed my problems. Thanks jonytemp!

    • Proposed as answer by GusZu Thursday, October 07, 2010 3:10 AM
    Thursday, October 07, 2010 3:10 AM
  • That must have been it, took yahoo messenger off using revouninstaller to get all the BS yahoo would have left behind. Now WMP works fine no more middle of the video hangs.

    My problem wasn't as extreme as some of these other post. Such as having it lock the entire computer up for minutes at a time. Never did that even with yahoo installed. For mine videos would play along fine for a while then start to skip frames or lose the audio/video sync and then quickly try to catch up. Like something was burning up the processor or accessing the crap out of the hard drive that the video was stored on. Restarting the player fixed it but only for a few moments. All the system temperatures reported they were well in range so that told me it wasn't the 9500GT over heating and task manager didn't show any extreme processor usage by any one single program.

    In a nut shell I think the problem has to do with the wmp network sharing service, other programs (like yahoo or another computer in general) may be attempting to connect to the host (mine) computer through the open port in yahoo. Could be snooping attempts by various corporate servers attempting to gain information about the computer usage. I really don't know, all I know is taking yahoo off fixed it, and that just made my trust for yahoo drop to 0%. That makes me mad to, because I love using yahoo 10 for checking the email and its ability to connect to facebooks chat.

    Bottom line, hooking any computer to the internet will screw it up eventually no matter how careful you are. I don't see why the following specs can't run WMP, Yahoo, and Firefox at the same time with out causing WMP to hang like it did.

    ASUS M4A785G with AMD Phenom II X2 Unlocked at 3.1ghz

    NVIDIA 9500GT w/ 1GB DDR2 (dual monitors)

    4GB Corsair Memory @ 800mhz

    3.5GB total storage space across 4 sata II HDD

    Windows 7 Ultimate x64

    If you don't have yahoo installed and WMP is locking up, I'd take a good hard look at other programs that autoupdate. Could include things like codec packs (divx), antivirus software, or having bit-torrrent programs running.

    Thanks for the good info there Jonytemp, you saved me a lot of headache ;)

    Wednesday, April 13, 2011 4:00 PM
  • Well it wasn't yahoo for mine, it still froze video playback later on that night. However it didn't do it near as much and not for as long with out yahoo. Putting it in high performance mode was the answer for mine. Hope it helps someone out. Put yahoo back on, seems fine now.
    Sunday, April 24, 2011 5:43 AM