Windows 7 install - no signed device drivers were found. Cannot install Windows 7


  • I am installing Windows 7 onto machine with a raid 1 array I have formatted through the bios and can see the drives configured (and their lights flicker as I boot up the machine).

    It says No drives were found. Click Load driver to provide a mass storage driver for installation.

    I have now tried Load Driver and browse and re-browse again and again having downloaded drivers from the Amec website that are supposed to be for Windows 7.  I have inserted both the Supermicro CD that has drivers on it and the LSI raid controller CD with drivers on it.  I have also copied the Drivers folder and the Driverstore folder from a similar machine to a memory stick.

    I see a scan progress bar and then

    "No signed drivers were found.  Make sure the installation media contains the correct drivers, and then click OK"

    What are the correct drivers for SATA drives controlled by an ARC-1210 raid controller please?

    can you email me them and how do I get it to re-scan the USB - as browse does not re-show a progress bar and appears not to re-scan.

    Monday, August 26, 2013 11:10 AM

All replies

  • I tried to navigate Areca's FTP but I couldn't determine exactly what you could download. You should contact Areca support.

    Monday, August 26, 2013 3:12 PM
  • Hi,

    1 .can you see any other SATA operations mode from BIOS.

    2. and I couldn't found Model you specified  ARC-1210 from their download link

    2. also as per Tripredacus you should contact their support Team.   


    • Edited by Monday, August 26, 2013 3:21 PM
    Monday, August 26, 2013 3:21 PM
  • It is on their site but it is in the legacy products. When you click to get the drivers it takes you to the FTP which has a ton of different folders and such and it isn't very user friendly.
    Tuesday, August 27, 2013 4:25 PM