none
unable to connect win7x64 to internet by wired network, but works by wireless network

    Question

  • Our Lenovo X61 Thinkpad computers in the field have build in Intel 82566MM Gigabit network adapters to connector to wired Ethernet networks, and wireless Wifi 3945ABG card. This wired and wireless adapters worked well in XP & Vista systems. We are having problem with the wired adapters once upgrading some laptops to Win 7x64 Ultimate.

    The wireless adapters work fine. Only problem is the Intel Ethernet adapters. We cannot connect the laptop to the internet. In the network map, the computers connects to the switch to the gateway, but red mark from the gateway to internet. The laptops can connect to other desktop in the same network.

    We have tried both the original Microsoft drivers comes with the Win7x64 installation and download Intel 82566MM Gigabit Network adapter = PROWin, no difference.

    All “Windows Network Diagnostics” cannot identify the problem. (But works fine as soon as we turn on the wireless adapter).

    Wednesday, July 28, 2010 4:39 AM

Answers

All replies

  • Method 1 – Turn Off Firewall/Anti-Virus Programs
    One common reason why this problem occurs in new installations of Windows 7 is because of a third-party firewall or anti-virus program. Just to make sure it’s not that, go ahead and uninstall any of these types of programs.
    You might be wondering why it would matter, especially if you have the same program running on another computer like XP or Vista. The problem could be that if the firewall or anti-virus program is not compatible with Windows 7, it can accidentally block connections to the Internet.
    Method 2 – Install Drivers in Emulation Mode
    So if you didn’t buy a new computer and are instead installing Windows 7 on a slightly older machine, you problem could be because of incompatible drivers.
    You can fix this in two ways. First, try going to the computer manufactures website and download the latest drivers for your wireless card. Install it and see if the problem is fixed.
    If not, it might mean you need to install the driver in compatible mode. You can do this by right-clicking on the executable file, choosing Properties, clicking on the Compatibility tab and checking the box that says “Run this program in compatibility mode for:” and then choose the OS.
    Again, make sure to run the driver setup program in this compatible mode to see if that fixes the problem.
    Method 3 – Disable Protected Mode
    The other reason you may not be able to connect is because of IE 8, which now ships with Windows 7. Some people have reported that the security settings are set such that they cannot connect to any website at all!
    You can test this by going to Tools, then Internet Options, and clicking on the Security tab. Click on Internet and move the slide bar all the way to the bottom (lowest security).
    Once you move the slider all the way down, click OK. Then close IE 8 and open it again. Try connecting to the Internet. If it doesn’t work, try unchecking the Enable Protected Mode option. Make sure to restart IE again.
    Method 4 – Try Network Troubleshooter
    If nothing else is working, you may as well try the built-in Windows 7 Network Diagnostics tool also. To run it, right-click on the Network icon in your system tray and choose Troubleshoot Problems.
    It will automatically try to detect what the problem is and give you a possible reason and a solution.
    Method 5 – Toggle Automatically Detect Settings option
    Another thing you can try is to check or uncheck the Automatically Detect Settings option in IE. You can get there by going to Tools, Internet Options, Connections, LAN Settings.
    If it’s checked, uncheck it and vice versa. See if that solves your problem. Also, make sure that the “Use a proxy server” box is unchecked.
    Method 6 – Uninstall Network Card
    You can also try to uninstall the network card from Device Manager and let Windows 7 re-install it on reboot.
    Go to the Control Panel, click on Hardware and Sound, and then open Device Manager. Right-click on your network card and choose Uninstall. If prompted to remove the driver, click Yes.
    Then restart Windows and the default Windows 7 driver will be installed, which might get your connection working again.
    Method 7 – Enable/Disable Network Card
    A simpler solution before uninstalling the network card might be to simply disable and then re-enable the network card.
    Go to the Network and Sharing Center and right-click on your network card and choose Disable. Then simply re-enable it and see if this fixes your problem.
    Hopefully, one of these methods will get your Internet connection in Windows 7 working again! If not, post a comment here and we’ll try to help!
    Wednesday, July 28, 2010 5:59 AM
  • OK. Every time after we re-install the Intel 82566MM Gigabit Network adapter driver = "PROWin64.exe" for Win7x64. Then, go to the "Network and Sharing Center", and click the red cross mark between the "Multiple Networks" and "Internet", we ARE able to connect to the Internet. But, then, after we reboot the system next time, we will not able to connect to the Internet.

    Answer to above "Solution_Provider" advices:

    Method 1 - we have no third-party anti-virus or firewall program on this test laptop

    Method 2 - we tried to install XP and Vista drivers, same problem

    Method 3 - we tried Firefox instead of IE8x32, same problem, we tried IEx64, same problem, remove IE8 LAN auto connection detection make no difference

    Method 4 - we open the "Network and Sharing Center" and click on the red cross mark and run the network diagnostic, we got "Troubleshooting couldn't identify the problem"

    Method 5 - remove IE8x32 & IE8x64 automatic detect setting in LAN, run diagnose connection problem, troubleshooter couldn't identify the problem

    Method 6 - re-install Intel 82566MM Gigabit Network adapter Win7x64 driver "PROWin64.exe". Will be able to connect to the Internet immediately for that session. But next time system boot will not be able to connect to Internet.

    Method 7 - plug / unplug / plug network card, see the taskbar "network icon" tried to connect, but then, same unable to connect to the internet.

    Click "Change Adapter Settings" disable / enable the adapter again, we ARE able to connect to the internet. But will not able to connect to the internet without this disable/enable sequence.

    Wednesday, July 28, 2010 3:39 PM
  • Hi Young707,

     

    I would like to suggest you update the router firmware and run IPconfig /all to check the settings.

     

    Please also run the following commands to troubleshoot the issue.

     

    NETSH  INT  IP  RESET

    IPCONFIG  /FLUSHDNS

    Netsh winsock reset

     

    Regards,

     

    Sabrina

    Friday, July 30, 2010 8:39 AM
  • Thank you, Sabrina Shen.

    The router is Cisco Linksys WRT54G version 5. We run the config http://192.168.1.1/ and works find with all other systems in Win 7x64, XP-SP3 and Vista, except these Lenovo Thinkpad X61 laptops upgraded from Vista to Win7x64 Ultimate.

    Today, I download the latest Cisco Linksys WRT54G router firmware - FW_WRT54v5v6_1.02.8.001_US_20091005.bin and installed into the router. Everything else works fine as same before, except problem with this laptop wired Intel Ethernet 82566MM Gigabit adapter.

    I ran the IPConfig /all - shows: the Ethernet adapter Local Area Connection:

    Description: Intel 82566MM Gigabit Network Connection
    Physical Address: 00-16------
    DHCP Enabled: Yes
    Autoconfiguration Enabled: Yes
    Link-local IPv6 Address: f200::85a1:--------(Preferred)
    IPv4 Address: 192.168....(Preferred)
    Subnet Mask: 255.255.255.0
    Lease Obtained: Friday July 30, 2010 5:21:10 pm
    Lease Expired: Saturday July 31, 2010 5:21:09 pm
    Default Gateway: 0.0.0.0
                                 192.168.1.1
    DHCP Server:  192.168.1.1
    DHCPv6 IAID:  3523------
    DHCPv6 Client DUID: 00-01-00-01----
    DNS Servers:   08.94.......
    NetBIOS over Tcpip: Enabled

    NETSH INT IP RESET -  resetting global failed. The requested operation requires elevation (Run as administrator)

    IPCONFIG /FLUSHDNS - successfully flushed the DNS resolver cache.

    NETSH winsock reset - failed. The requested operation requires elevation (run as administrator)

    • Edited by young707 Saturday, July 31, 2010 12:54 AM
    Friday, July 30, 2010 6:24 PM
  • Thank you, Sabrina Shen.

    The router is Cisco Linksys WRT54G version 5. We run the config http://192.168.1.1/ and works find with all other systems in Win 7x64, XP-SP3 and Vista, except these Lenovo Thinkpad X61 laptops upgraded from Vista to Win7x64 Ultimate.

    Can you please tell me how to run these commands to troubleshoot? are these commands for the router or for the laptop?

    Thank you.


    Go to the thinkpad device manager and verify the network adapter is working fine, without any exclamation. Btw have you try connecting the Thinkpad directly to the modem using cable thus bypassing the router for the time being and see how it goes. Also have you try swapping the lan cable?
    Saturday, July 31, 2010 12:35 AM
    Answerer
  • Thank you Daniel Ho,

    I removed the router and connect the laptop directly to the Siemens ADSL modem. Reset and re-boot. The laptop Network and sharing Center map shows the laptop connect to gateway to Internet. All lines are straight and no red mark. I supposedly should have Internet access.

    I tried browsers ( IE8 and Firefox) all failed to connect.

    Yes, we tried two new LAN cables. Same problem. However, if I go to "Change Adapter Settings" and disable, then, enable the LAN adapter. I will be able to connect to the internet.

    Saturday, July 31, 2010 1:30 AM
  • Well, same problem happened to one of the desktop. This system has Intel build in 82566DC Gigabit Network adapter. After boot, the connection from Network to Internet has red mark. No connection to the internet. This system has Intel Celeron D CPU at 3.06GHz, 2GB memory, running Win 7x64 Ultimate.

    Only after, we disable / enable the Ethernet LAN adapter, then, we can connect to the internet. Turn off system, reboot. Same no internet connectivity problem.

    Well, we turned off this computer. Went to lunch. Came back. Booted the system. It connects to the internet without any problem this time.

    Gee, is the problem with Win7x64? Why internet connectivity so unstable?

    • Edited by young707 Saturday, July 31, 2010 6:16 PM
    Saturday, July 31, 2010 4:08 PM
  • You are seeing a known issue with that model nic / chipset combo
    eader.com/thread/Limited_or_No_Connectivity_Wired_Etherne_24gfbX2ud.html

      In the Advaned section of the Device Manager properties for the NIC there is an option "Wait for Link".  Set this to ON.  this does "work" for some folks.

    • Marked as answer by young707 Sunday, August 01, 2010 12:05 AM
    Saturday, July 31, 2010 5:40 PM
  • Bubbapcguy, thank you, I think you got the right answer for us. So far, it is working. Direct connect to the Internet. Will test few more days to be sure. Thank you.
    Sunday, August 01, 2010 12:03 AM
  • your info might b what I need to fix my problem too. I would have 2 search 4 days to get that many troubleshooting techniques.  So THANKS
    Sunday, September 09, 2012 8:15 AM