none
30 second login screen timeout RDP RRS feed

  • Question

  • Hi I have tried many things to fix this but when RDP to Windows 10 Pro, the login screen stays for only 30 seconds and then disconnects. I need to keep the login screen remain connected until a user logs in.

    I have tried the following methods:

    Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Authentication\LogonUI\IdleTime or IdleTimeOut and set it to be longer.

    Computer\HKEY_USERS\.DEFAULT\Control Panel\Desktop\ScreenSaveTimeout and set that to 119 as the guide suggests. I also tried with a larger number just to test and that didn't work either.

    Many thanks


    • Edited by wjonesgb Friday, July 3, 2020 9:20 PM Accidentally submitted query without finishing it.
    Friday, July 3, 2020 9:07 PM

All replies

  • HI
    0.can you enter winver in command prompt on local computer and the remoote win10 computer and look the os version and os version number ?[for example windows 10  enterprise 1809 (os build 17763.316)]
    1.“the login screen stays for only 30 seconds and then disconnects.”
    is the remote win10 computer added in AD domain?
    if we can enter below command in command prompt on remote win10 then look if there are
    set time limit for disconnected sessions
    set time limit for activate but idle remote desktop services sessions
    set time limit for active remote desktop services sessions
    end session when time limits are reached.
    gpresult /h c:\rds.html

    2.if we do a clean boot on remote win10(refer to windows 10 steps),when we remote access to this issue remote win10 ,will the same issue happen ?
    https://support.microsoft.com/en-us/help/929135/how-to-perform-a-clean-boot-in-windows





    Best Regards
    Andy YOU
    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, July 6, 2020 2:36 AM
    Moderator
  • HI
    Is there anything to help you?

    Best Regards
    Andy YOU
    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, July 13, 2020 11:44 PM
    Moderator
  • Hi sorry I completely forgot about this :/ 

    Version: Windows 10 Pro, 19041.388

    Not Azure AD Joined and none of the variables are defined - not configured. This is not for the actual session, only for the login screen. 

    I don't think the clean boot would solve anything as i believe this is windows functionality.


    Many thanks




    • Edited by wjonesgb Wednesday, July 15, 2020 11:45 PM Asked something else but I fixed it - related to shutdown on login screen
    Wednesday, July 15, 2020 11:26 PM
  • HI
    3. we can create a new local admin account on this issue win10 then remote access to this issue win10 by using this new local admin account, will the same issue happen on this new local admin account ?
    Create a local user or administrator account in Windows 10
    https://support.microsoft.com/en-us/help/4026923/windows-10-create-a-local-user-or-administrator-account
    4.we can enable below log on both local win10 and remote win10 then reproduce your issue,can we find related logs about this issue?

    event viewer\windows logs\
    application
    system
    Event Viewer – Applications and Services Logs -Microsoft-terminalservices-clientactivatexcore
    microsoft-winodws-terminalservices-rdpclient/analytic  enable
    microsoft-winodws-terminalservices-rdpclient/debug    enable
    microsoft-winodws-terminalservices-rdpclient/operational  enable
    Event Viewer – Applications and Services Logs -Microsoft-Windows-RemoteDesktopServices-RdpCoreTS_Admin
    Event Viewer – Applications and Services Logs -Microsoft-Windows-RemoteDesktopServices-RdpCoreTS_Operational
    Event Viewer – Applications and Services Logs -Microsoft-Windows-TerminalServices-local sessionmanager
    Event Viewer – Applications and Services Logs -Microsoft-Windows-TerminalServices-remoteconnectionmanagement

    Best Regards
    Andy YOU
    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Thursday, July 16, 2020 2:34 AM
    Moderator
  • I was looking for a regedit tweak or something just to adjust the timer on the login screen, i think this is just windows behaviour, and doesnt matter what user it is - it is before a user has even logged in and is the Other user screen...

    I have disabled the lock screen locally, as it doesnt exist over RDP and if i leave the login screen for 30 seconds, it just goes to the lock screen, not login screen with the clock in the bottom right. With the lock screen disabled,  this doesnt happen locally so i think it is an RDP configuration to reduce bandwidth etc. All i want is for the login screen after 30 seconds to NOT terminate the connection/session and to remain with the Username and password boxes. 

    Many thanks

    Thursday, July 16, 2020 9:29 PM
  • THIS IS THE FIX... FOUND ON: (REMOVE THE SPACES) https://social .technet .microsoft .com/Forums/windowsserver/en-US/d5338638-0c7f-426a-866d-e9183da83bb9/how-to-limit-denied-rdp-login-attempts-before-disconnecting-not-disabling-account?forum=winserversecurity

    AND 

    https:// serverfault .com/questions/422770/changing-the-login-timeout-for-windows-remote-desktop-services

    Windows will disconnect a RDP logon attempt if there is no user activities in the RDP logon window for a while. The default timeout for Windows Server 2003 is 120 seconds; the timeout for Windows Server 2008 R2 is 30 seconds. Unfortunately, as far as I know, there is no such built-in mechanism to disconnect a logon attempt by failed login attempts.

     

    For Windows Server 2008 R2, you may configure the following registry value to configure the timeout:

     

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\WinStations\RDP-Tcp

     

    Name: LogonTimeout (DWORD)

    Value: Specifies the time in seconds – Decimal Value – 300. Hex - (12c) its 5 minutes.

    VALUE CAN BE 999999999 OR THE MAX AND THE LOGIN TIMEOUT WILL BE GONE


    Sunday, July 19, 2020 7:42 PM
  • HI


    Thanks for sharing your experience.i am glad to hear that your issue has been solved.
    but if I only set LogonTimeout (DWORD) value to 30 
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\WinStations\RDP-Tcp
    I can not reproduce your issue ,so I suspect there will be another setting in your win10 and this setting work together with logon timeout.

    "Remote Desktop Services (Terminal Services)" forum will be migrating to a new home on Microsoft Q&A!

    We invite you to post new questions in the "Remote Desktop Services (Terminal Services)"  forum's new home on Microsoft Q&A!

    For more information, please refer to the sticky post.


    Best Regards
    Andy YOU
    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.




    Tuesday, July 21, 2020 12:15 AM
    Moderator
  • You can configure the time outs with the RDP settings on every server or via Group Policy Objects. By default such time outs are not configured with a value, so somebody has already configured those settings.
    Thursday, July 23, 2020 11:48 AM