none
file sharing and network discovery settings

    Question

  • By default in a domain both network discovery and file sharing seems to be
    turned off, now I have a few bits of software that won't work unless both
    these settings are turned on (can't deploy the software as the vista PC's
    can't be seen)

    Now how do I turn these settings on????? I've looked through the various GPO
    settings but I can't find any settings to achieve what I want.  I've even
    tried setting the PC location in an unattended file when auto deploying via
    WDS but the settings are over ridden when the PC is joined to a domain,
    grrrrrrrrrrrr VERY annoying.

     

    This is the behaviour I'm seeing

    http://www.microsoft.com/technet/community/columns/cableguy/cg0906.mspx#ENB

    Behaviour for the Domain Location Type
    When a computer running Windows Vista joins an Active Directory domain, it
    automatically configures the existing network for the Domain location type.
    After joining the domain, the computer determines that it is on a network of
    the Domain location type because it can perform a computer-level
    authentication with a domain controller as part of normal Active Directory
    operations.

    The following settings are automatically configured for networks of the
    Domain network location type:

          . Windows Firewall is turned on by default and configured by Group
    Policy settings downloaded from the Active Directory domain

          . Network discovery is turned off

          . All forms of file and printer sharing are turned off, including file
    sharing, printer sharing, public folder sharing, and media sharing

    does anyone know the registry settings to turn File sharing and network discovery on?

     

    Kerry

    Monday, April 16, 2007 1:24 PM

All replies

  • I am having this exact same issue.  I bought a brand new Toshiba Laptop, and tried to connect it to my brand new desktop, and I can get internet, but I cannot turn on filesharing, or network discovery, or any of these options.  I have it all set up correctly "I believe" and both of my desktops communicate fine, one Vista, and one XP.   Just on this machine, where "Network Discovery" option is in the Network and Sharing center, next to it it says Custom, instead of on or off.  When I try to tell it to turn on, it asks for administrator, tell it continue, then it just reverts back to CUSTOM and turns all filesharing, printer sharing, and network discovery off.

    If anyone can solve this problem, PLEASE help us.  This is sooooo annoying.

    Thanks,
    BigCharlieB.

    Friday, April 20, 2007 4:54 AM
  • It's really simple. This has nothing to do with the domain unless there is a policy set to disable this which I think would be really silly to do so.

    In the Network and Sharing Center you will see Network Discovery and File Sharing. Simply turn them on!

    Voilla
    Friday, April 20, 2007 5:06 PM
  • I did, It wont turn on, instead of showing ON or OFF like on my Vista Desktop, it shows CUSTOM.
    Now you can click the arrow, that brings up the "turn off or turn on" option, but it reverts back to custom which is OFF.
    I spent two hours on the Toshiba tech support line, and they have no idea how to turn this off.
    They said to contact Microsoft which I did, and they wont support me because this Vista came installed on the laptop, and they said Toshiba will have to support me.
    I called them back, and they said I need to re-install Windows on all my PC's and start over again.

    I think they are crazy and there is an option to change this somewhere, I just dont know where,

    Any help would be awesome,
    Thanks,
    BigCharlieB.
    Saturday, April 21, 2007 2:37 AM
  • Ermmmm it has EVERYTHING to do with a domain.

     

    The default behaviour in a domain is for network discovery and file sharing to be turned OFF.  Now turning it on might be all well and good if you have a couple of PC’s but what if you’re deploying hundreds!?  I’m deploying 60, to start with, and I have a completed automated process, BUT because of this issue I now have to login to each PC JUST to turn on these two settings! VERY ANNOYING  we can’t get our users to do it as you need elevated privileges for them to do so, which they don’t have. And without these two settings many bits of software won’t install or won’t work correctly.  Now if I knew the registry settings I could add them in to an unattended install, write a GPO or add them via a login script.  Of Course the easiest thing would have been for MS to have GPO setting already to achieve this.

     

    Saturday, April 21, 2007 12:50 PM
  • Hello Kjhoskin

     

    I am currently investigating the same issue and would like to find a way to enable these two settings in a GPO.  We have approximately 1500 machines to migrate to Vista and don't want to have to mannually set file shareing and network discovery. 

     

    Where you able to find a solution since your last post?

     

     

    Friday, May 11, 2007 8:13 PM
  • Has anyone found a solution for this yet? We also have a lot of PCs to deploy and software not working without this setting.
    • Proposed as answer by Glen Barneson Friday, June 22, 2012 12:02 AM
    Thursday, June 21, 2007 1:23 PM
  •  

    "Windows Firewall is turned on by default and configured by Group
    Policy settings downloaded from the Active Directory domain" [Quote from above]

     

    Hello,

     

    In the context of home networking (as opposed to a domain), I have discovered that the settings in the firewall program can prevent file sharing setting from being changed (to on or off). The firewall setting has to be changed first. I have not had to address the problem f a Vista machine joining a domain, but you might want to tinker first with the Group Policy settings being downloaded to configure the (not jsut Windows) firewall from the Active Directory domain.

     

    Check out my blog at

     

    http://forums.microsoft.com/TechNet/ShowPost.aspx?PostID=1683125&SiteID=17

     

    Regards,

     

    Sunthar

     

     

    Thursday, June 21, 2007 9:54 PM
  • i have the same problem but i have no solution yet.

    Any idea??

    Tuesday, June 26, 2007 6:58 PM
  • Exact same problem here - On our domain network discovery defaults to off in Vista. We too have a program that won't work, because it can't see the Vista machines on the network
    Friday, July 13, 2007 2:15 PM
  • hi, i had same problem turning network/file sharing on, looked on here found nothing so had little go myself,and cracked it on my pc, try this..

     

    Control panel (set to classic view)

    Administration tools

    computer management

    services and applications

    services

    find server click it and ensure it is set to automatic,click apply and then start the service(this should start file sharing)

    I cant be sure of the other which i used, i am sure it was either SSDP Discovery or Remote procedure call(as above settings)

    this one should allow you to change the network discovery to ON

    If none of these allow you to do that take a look at the ones in this list disabled, one of them is a sure spot once you read the description of what it does,i spotted it,,hope this helps with your problem

     

    Kev

     

    Tuesday, July 17, 2007 8:21 PM
  • hi,

       I bought a brand new HP Laptop with Vista, and tried to connect it to my Old desktop with XP, and I can get internet, but I cannot turn on filesharing, or network discovery, or any of these options. Just on this machine, where "Network Discovery" option is in the Network and Sharing center, next to it it says Custom, instead of on or off.

     

    But I have on problem at all. I can share file can play game on LAN and even ONline. I can see both ma computer in Network Places.

     

    No Offence, but i think u all r focusing wrong. It doesn't matter, the network discovery is "ON" or "CUSTOM".

     

    Try this may help u....

     

    case 1: check out ur IP is configured correctly and u r getting ping reply

    first:      ping IP (eg..ping 192.168.1.3)  in command prompt type ipconfig to get ip.

    secong: ping computer_name (eg..ping amdxp) goto control panel-->system properties-->computer name tab. to check out ur computer name...

     

    In this case if u r only connecting 2 computers (PC to PC), then one computer musr have default gateway..

    eg.. 1st pc config in tcp/ip version 4 

    ip address: 192.168.1.2

    subnet mask: 255:255:255:0

    default gateway: 192.168.1.1

     

         2nd pc->

     

    ip address: 192.168.1.3

    subnet mask: 255:255:255:0

    default gateway: keep this empty

     

    u should maintain the Class C here. and u dont need to worry abt same workgroup here...

     

    IF u ve more then 2 computers then one of them must have default gateway and most imp.. same workgroup.

     

    case 2:

    Turn OFF Fireware any third party firewall turn it off...

    After tht go to

    In Vista to NEtwork in start

    in XP to Network Places goto View workgroup computers

     

    it may take several times to show all pc in the network till then keep refreshing...

     

    Note: If u r using router or switch with DHCP on check out tht u only see one private network and if u see one private network as well as one public unspecialied network then click on view and diagnose it.

     

     

    case 3:

    Now if none of the above is ur problem and u can see all pc's in the network but cant access it...

    it showing u tht contact administrator u dont ve access group Privileges bla bla...

     

    try this

     

    In vista it is simple:

    In Network and sharing center

    Turn off password protected sharing

     

    and for XP

     

    1. Run gpedit.msc
    2. Go to Computer Configuration / Windows Settings / Security Settings / Local Policies / Security Options
    3. Double click on Accounts: Limit local account use of blank passwords to console login only
    4. Disable this option

    Also try this

     

    1. Start Regedit
    2. Go to HKEY_LOCAL_MACHINE / SYSTEM / CurrentControlSet / Control / Lsa
    3. Change the value of a key called "restrictanonymous" to 0 instead of 1
    4. Don't change "restrictanonymoussam" value.
    5. Reboot

     

    for share files and folders try this

     

    start--> run-->shrpubw.exe

    or

    cmd-->shrpubw.exe

     

    I hope this information may help ur problem

    Plz Holla @ me (reply)

    Friday, August 10, 2007 7:47 AM
  • hi,

    I forget to mention one thing...

     

    after all this try this if ur probl doesnt resolve then

     

    In Network and sharing Center

    View full map

    thr can u see full map of ur network connections

    all the other computers

     

    try this in windows explorer type

    \\computer_name\     and ENTER

    eg \\amdxp\

     

    even if u cant C computer names in network places, u can still can access them like.

     

    I think u should try Vista X64 bit, i ve tried both and conclude tht vista X64 is more stable, reliable and faster then x86.

    i didnt get any network error thr. YET

     

     

    Best of Luck

    Saturday, August 11, 2007 6:52 AM
  •  

    Hi people,

     

    It's just a matter of making the right firewall exceptions.

    When you go to windows firewall / exeptions tab you click for example file and printer sharing on.

     

    then go to the network and sharing center under Sharing and discovery you will notice the green light is on and it displays on. Uncheck the file and printer sharing in the firewall exceptions and click apply. switch to the network and sharing center and notice the green light is off again.

     

    you can do the same for the network discovery.

    -edit- I see now their is not option for network discovery... bummer.

     

    Kind Regards

    Pascal Slijkerman

    Thursday, August 16, 2007 10:31 AM
  •  

    Back again with a complete new view on the windows firewall.

     

    On the administrative tools section of your vista machine is a mmc that is called Windows Firewall with Advanced Security. That is almost some kind of isa server :-)

     

    Their you can configure much more settings. Their you can also configure the network discovery for the domain, private and public profiles.

     

    al these rules can also be configured through GPO on the computer settings\windows settings\ security settings\Windows firewall with Advanced security\

     

    Good luck!

     

    Kind Regards

    Pascal Slijkerman

    Thursday, August 16, 2007 12:02 PM
  • Hi folks, I have run into this issue as well. Have been looking all over the place in Group Policy for this. I saw the various rules on the Vista firewall w/Adv Security for Network Discovery. Just wondering if anyone has successfully enabled Network Discovery through Group Policy using these rules, if so could you list which ones you specifically enabled?
    Monday, August 20, 2007 5:52 PM
  • Hi foks,

     

    i'm still strugling to find the right rules. When i have al the rules right on the vista client i made an export. And tried inporting it in the GPO, but some how that doesn't work it look like it crashes during import because not al policies are applied.

     

    Let you know when i have the right settings.

     

    Kind Regards

    Tuesday, August 21, 2007 7:37 AM
  • hi kev.

    i to was having the same problem " network discovery will not switch on" but i followed

    you`re instructions and now i can at least turn on net discovery, i will now try to install

    my lexmark wireless printer and see if vista recognises it .

    thanks kev for posting you`re fix ,it has helped me heaps.

    steve

     

     

    Monday, October 8, 2007 7:45 PM
  • Glad it helped you a little, although i have decided to go back to xp pro for time being, vista has made me pull all my hair out, i will wait for a year or so before i try again,

     

    kev

    Tuesday, October 9, 2007 9:44 AM
  • Thanks, Kev.

     

    Had exact same problem. I'll try this when I get back to my PC...glad to find a solution...this has been very frustrating to say the least. I really need to stick it out with Vista and try to get more comfortable with it as soon enough it will be all I use, I'm sure.

     

    Tuesday, November 20, 2007 8:37 PM
  •  

    Hey guys,

     

    I had the same problem. Here's what I did:

    1. Run services.msc

    2. Turn on SSDP and UPnP Device Host

    3. Go back to Network/Sharing Center and click on "On" on Network Discovery and hit "Apply"

    4. This time it should stay "On"

     

    thanks to Kev for starting on this line of thought.

    Monday, June 16, 2008 5:34 PM
  • Looks like some system services are disabled or not started.
    Click Start and type Services.msc in the dialog box to open the services snap-in.
    Then check if the following services are started:
    --SSDP Discovery
    --TCP/IP NetBIOS Helper
    --Computer Browser
    --Server
    If not, set the startup type to automatic and click start to start the services.
    I also has a vista ultimate pc and was not able to turn network discovery on. I checked in the services snap-in and found that the SSDP Discovery was not started. With the SSDP Discovery services started, I was able to turn the network discovery on.
    You should try this.
    Friday, July 18, 2008 9:27 AM
  •  Andriy | Digital Support Tech wrote:
    Looks like some system services are disabled or not started.
    Click Start and type Services.msc in the dialog box to open the services snap-in.
    Then check if the following services are started:
    --SSDP Discovery
    --TCP/IP NetBIOS Helper
    --Computer Browser
    --Server
    If not, set the startup type to automatic and click start to start the services.
    I also has a vista ultimate pc and was not able to turn network discovery on. I checked in the services snap-in and found that the SSDP Discovery was not started. With the SSDP Discovery services started, I was able to turn the network discovery on.

    You should try this.

    Also make sure that DNS Client is also on and on Automatic.

    Friday, December 5, 2008 6:08 PM
  • I Try to turn on network discovery or any other settings in the Network and Sharing center
    but they just go back to off immediately.

     In Vista;

    1. Access your windows Firewall
    2. Click "Change Settings"
    3. Click the "Advanced" Tab
    4. Click "Restore Defaults"

    In My case, The above restored the ability to turn on Network Discovery and other settings in the Network and Sharing center.

    Good Luck.

    Louis
    • Proposed as answer by Louis Collado Sunday, December 14, 2008 5:57 AM
    • Edited by Louis Collado Sunday, December 14, 2008 4:26 PM Misspelling
    Sunday, December 14, 2008 5:48 AM
  • Jus wanted to say thanks, was looking everywhere and this was the one that worked thanks x
    Saturday, June 20, 2009 2:36 PM
  • Thanks this work for me.
    Wednesday, July 15, 2009 3:11 AM
  • I did bod things: restore firewall to default, AND change all the settings in the services.msc.

    I don't know which one made the trick, but it worked.

    DID I MENTION I AM ON WINDOWS 7??

    good luck all!
    Friday, September 11, 2009 6:45 PM
  • Thanks, Kev!  That was exactly it.  Three VMWare installations of Windows Server 2008, all at the same time, and just one of them didn't offer didn't offer a "Sharing" tab in "Properties" on Windows Explorer.  Then when I tracked it down to "Network Sharing Center", "Sharing and Discovery", "File sharing" being set to "Custom", I found that the "On" setting wouldn't stick.  I was about going nuts.

    So it all depends on the "Server" service, which had been randomly set to "Disabled" on that one machine.  Thanks so much for your post!

    Rory 
    Friday, October 2, 2009 4:08 PM
  •  Andriy | Digital Support Tech wrote:
    Looks like some system services are disabled or not started.
    Click Start and type Services.msc in the dialog box to open the services snap-in.
    Then check if the following services are started:
    --SSDP Discovery
    --TCP/IP NetBIOS Helper
    --Computer Browser
    --Server
    If not, set the startup type to automatic and click start to start the services.
    I also has a vista ultimate pc and was not able to turn network discovery on. I checked in the services snap-in and found that the SSDP Discovery was not started. With the SSDP Discovery services started, I was able to turn the network discovery on.

    You should try this.

     

     The option to enable this is GRAYED out. What do I need to do?

    Also make sure that DNS Client is also on and on Automatic.


    Thursday, May 13, 2010 10:36 PM
  • I tried to enable SSDP Discovery but its GRAYED OUT.
    • Proposed as answer by liable Monday, May 31, 2010 5:14 AM
    Thursday, May 13, 2010 10:37 PM
  • make sure the following services are running and automatically start up

    dns client

    function discovery resource publication

    ssdp discovery

    UPnP Device Host

    Monday, May 31, 2010 5:26 AM
  • By default in a domain both network discovery and file sharing seems to be
    turned off, now I have a few bits of software that won't work unless both
    these settings are turned on (can't deploy the software as the vista PC's
    can't be seen)

    Now how do I turn these settings on????? I've looked through the various GPO
    settings but I can't find any settings to achieve what I want.  I've even
    tried setting the PC location in an unattended file when auto deploying via
    WDS but the settings are over ridden when the PC is joined to a domain,
    grrrrrrrrrrrr VERY annoying.

     

    This is the behaviour I'm seeing

    http://www.microsoft.com/technet/community/columns/cableguy/cg0906.mspx#ENB

    Behaviour for the Domain Location Type
    When a computer running Windows Vista joins an Active Directory domain, it
    automatically configures the existing network for the Domain location type.
    After joining the domain, the computer determines that it is on a network of
    the Domain location type because it can perform a computer-level
    authentication with a domain controller as part of normal Active Directory
    operations.

    The following settings are automatically configured for networks of the
    Domain network location type:

          . Windows Firewall is turned on by default and configured by Group
    Policy settings downloaded from the Active Directory domain

          . Network discovery is turned off

          . All forms of file and printer sharing are turned off, including file
    sharing, printer sharing, public folder sharing, and media sharing

    does anyone know the registry settings to turn File sharing and network discovery on?

     

    Kerry


    What I have found with the network discovery if it shows custom you need to do the following:

    >start - Run - Services.msc

    Now look for SSDP discovery and UPnP. turn there starup type to automatic and then start them. make sure your firewall exceptions are on for network discovery. Turn on network discovery and file sharing again and it will always be on and not custom...

    Friday, October 8, 2010 12:45 PM
  • UPnP Device Host service must be changed from Disabled to Manual. It does not need to be started. Network discover will now be set to "Turn on network discoverty" in Advanced Sharing Settings.

    There may be other services I have enabled during troubleshooting as mentioned in other posts. However UPnP was the one I was missing, and definitely shuts off network discovery when disabled, or at least shows as "Turn off network discovery" whether it is running or not. And actually, before I set UPnP Device Host to Manual and network discovery was "off", I could still see all the computers on the network.

    I remember enabling remote desktop and not being able to connect using the computer name (not sure about IP). I think it was SSDP Discovery that allowed me to do this. This may be required for network discovery also.

    Thursday, March 31, 2011 5:39 PM
  • Hi Guys, quite an easy one this as well as the ssdp int the Service look for the Function Discovery (FD) network discovery providers set to automatic .....apply then start. This will allow you to enable network discovery setting to ON remember and check that all the dependancies are also started/

    If you need help ken.thomson@t2compufix.co.uk

    Wednesday, April 18, 2012 5:27 PM
  • Hey i'm not sure if this is a dead thread or not but i have a similar problem the only difference is mine is saying that "The specified service does not exist as an installed service" im not sure if that means i lost some of my software or if an update messed it up or what but please help me iv already lost the use of my usb ports and sd card ports so i cant move my files to my other comps any other way 
    Thursday, April 26, 2012 8:07 PM
  • Hey i'm not sure if this is a dead thread or not but i have a similar problem the only difference is mine is saying that "The specified service does not exist as an installed service" im not sure if that means i lost some of my software or if an update messed it up or what but please help me iv already lost the use of my usb ports and sd card ports so i cant move my files to my other comps any other way 
    It is probably an old thread but if you are using VMWARE and running Windows 2008, you might experience the same issue. I turned off all firewall settings. You might have to install file & printer protocol.

    Microsoft manager to programmer: You start coding. I'll go find out what they want ...

    Monday, September 24, 2012 4:47 AM
  • "Network discovery requires that the DNS Client, Function Discovery Resource Publication, SSDP Discovery, and UPnP Device Host"

    I opened the Services MMC snap-in and saw that the following services were disabled:

    • Function Discovery Resource Publication
    • SSDP Discovery
    • UPnP Device Host

    Enabling and starting these services did the trick and now Network Discovery is enabled and I can see other servers. Check Windows Help next time!

    Tuesday, March 12, 2013 12:57 PM