Canon Scanner driver problems


  • Canon Scanner 4200F;
    OS Windows 7 (64)
    Downloaded, from Canon site, the CanoScan toolbox AND the 64 bit driver.
    Both installed correctly and are recognized by the system.
    When I tried to scan, using the toolbox, the Scanner lamp goes on but the scan will not initiate
    and the error "Cannot communicate with the scanner - check cable and connection."
    Changed USB ports - same msg.
    reloaded drivers - same msg.
    Canon help claims that the problem is that the OS is "blocking the Communication"

    Q:  If this is true how do I unblock?
    Monday, November 16, 2009 8:18 PM


  • The issue IS that although the Canon supplied driver for the 64 bit Windows 7 OS loads the WIA driver is required for the scanner to operate.  The WIA driver that came with the 4200F is 32 bit and will not load.

    Contacted Canon support and finally got them to understand the situation.

    The outcome is that they are sorry for the inconvience - BUT there is no 64 bit WIA available.

    Looks like the only solution is to purchase a new, compatable, scanner.

    Canon won't get the business.

    Thanks to all.
    • Marked as answer by Gene N. _ Monday, November 23, 2009 7:37 PM
    Monday, November 23, 2009 7:36 PM

All replies


    Actually, the oprating system cannot block the scanner by system area. This issue can occur by incompatible driver or damaged hardware. I suggest you perform the following steps to troubleshoot the issue.


    1. Unplug the Scanner and plug it on another machine for a test. Does it work fine on another machine?


    2. Uninstall all printer drivers and Scanner drivers on the machine, and then reinstall the Scanner driver for Windows 7 64bit again. For your reference, please download the driver from the link below:


    Canon 4200F driver


    Please Note: Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.


    If the issue persists, please upload the picture to Skydrive ( and share the link to me for research.





    Wednesday, November 18, 2009 3:51 AM

    The scanner does scan on another system running Vista.
    Downloaded the pgm from your link, Lamp comes on, no scan - msg "communication Problem" TWAIN data transfer error.

    Next.  Removed USB cable, deleted Toolbox and Driver, Reinstalled, plugged up the USB Msg says driver loaded and is OK. Lamp on - no scan.

    Next. Did the same thing but before downloading driver restarted system W/O services and startup. Driver installed and was "OK" Lamp on - no scan.

    Love to "Upload the Picture to Skydrive" but haven't a clue as to what picture is being referred to.

    Thanks again,
    Gene N.
    Wednesday, November 18, 2009 8:36 PM

    First, I would like to confirm the following questions:


    1. Is there an exclamation mark or question mark in Device Manager after plugging the scanner? If so, please let me know.


    2. Which software is used on the machine to scan file, the built-in application or Canon software? When trying to use the application to scan, is there any error information?


    At this stage, please download the Canon software and install it for a test.


    Canon Scanner software


    Then, please use the Canon application to scan file again.


    If there is any error message, please upload it for research. Meanwhile, please access the following folder and upload the file.




    Hope this helps.



    Thursday, November 19, 2009 3:21 AM
  • Thanks:

    1. There are no marks of any kind next to any item in the device Manager after plugging in the Scanner.

    2. The Canon Scanning software has always been used.  The error message alwaws comes after the scanner fails to initiate the scan. The error message appears in a window with the title From ScanGuard CS  "Cannot communicate with scanner.  Cable may be disconnected or Scanner turned off.  Check status. Scanner driver will be closed."  Under this message in a second window is another that says " TWAIN data transfer error."

    3. Downloaded the Canon Software from your suggested site - It is identical to that on the computer.  Initiated scan using "CanoScan" selected "Copy" (also used "File" for a second try) As before we get a pop-up Window saying "scanning in progress do not open lid ....."  Lamp lights then after ~2 min error message as in 2 above appears. 

    Two questions:

    A. Where or what is the "Built-in Application"?

    B. How or where do I go to upload a 5K .DEV.LOG file?

    Another piece of info.

    Onthe "Devices and Printers" panel, the CanoScan appears BUT when clicked on an Exclamation point message appears saying:
    ! You need a WIA driver to use this device.  Please install it from the Installation CD or manufacturer's website and try again.

    Didn't we go through this with the downloads?
    Thursday, November 19, 2009 9:07 PM
  • It sounds to me like one of two things happening:
    A) You have TWAIN drivers installed and are initiating scans with a WIA only software-
    B) reverse of above.

    Have you tried initiating scans through any other image editing software?

    I had a similar problem with a Canoscan Lide60 scanner and both canon scanning software and Photoshopx64. Both programs use Windows Image Aquistition (WIA) but the scanner communicates only through TWAIN. Had to scan only to 32 bit software that will accept TWAIN communication to use the scanner. (Not a problem for me as Photoshop installs both versions)

    I've also seen where scanners install with an either/or on the communication driver. Yours may support both but only one (the wrong one for your software) installs automatically.

    Might be worth checking.
    Thursday, November 19, 2009 11:55 PM
  • The issue IS that although the Canon supplied driver for the 64 bit Windows 7 OS loads the WIA driver is required for the scanner to operate.  The WIA driver that came with the 4200F is 32 bit and will not load.

    Contacted Canon support and finally got them to understand the situation.

    The outcome is that they are sorry for the inconvience - BUT there is no 64 bit WIA available.

    Looks like the only solution is to purchase a new, compatable, scanner.

    Canon won't get the business.

    Thanks to all.
    • Marked as answer by Gene N. _ Monday, November 23, 2009 7:37 PM
    Monday, November 23, 2009 7:36 PM
  • I have the same problem with the WIA drivers. I think it is ridiculous we should dump a scanner that is still able to function just because a multinational like Canon is too lazy to adapt the WIA drivers. Canon neither takes sustainability nor its customers seriously. To me that's just irresponsible money grabbing.
    Monday, March 01, 2010 4:34 PM
  • The Vista WIA driver for the Canon LIDE25 works fine with Windows 7


    Wednesday, July 07, 2010 2:52 AM
  • Same problem, different Canon scanner, no solutions. Canon = fail
    Tuesday, August 10, 2010 5:12 PM
  • Just install the wia driver for vista 64 and it works.

    You need to extract them manually from the zip and then do an update driver from the device manager

    Thursday, August 12, 2010 5:22 AM
  • How do you install the wia driver for vista 64?  I downloaded the vista driver package and unpacked it for my mp500, but there doesn't seem to be a way just to update the wia driver.

    I'm having the same issue as everyone else- my canon mp500 prints and copies, but gets errors when trying to scan. Just spent an hour with canon tech support (2nd time, tried six months ago too) and they say it's microsoft's problem.  I don't think so, though, seems to be a driver issue.  I'm also going to try to find some twain drivers for windows 7 see if that works.

    Wednesday, September 01, 2010 6:22 PM
  • When you extract them, you right click on "Computer" and then open the device manager.  From there, you double click on your device, and then you click update driver.  It will ask you if you want to automatically install or manually install, select manually and then browse to the location that you extracted the files.

    Oh, and by the way, I was able to bypass the wia issue by going to Word, Excel, or Adobe Pro and import from scanner.    WIA is the application that lets you look at the scan output, however, other applications hold their own image aquisition product, which allows you the ability to bypass the windows image aquisition software.

    Saturday, October 23, 2010 7:20 AM
  • Hi, Like many others I am unable to get my 4200F to scan from Win 7 (Home Premium) 64bit

    I have downloaded 4200fvst648620a_64en

    I get the same error message and symptoms as Gene N. who started this thread: "Cannot communicate with the scanner - check cable and connection."

    I did try to download the Canon LIDE25 WIA driver as suggested by BoomerBella above, but it downloaded as lide25wiavst1212en.exe and not as a .zip so I wasn't sure how to extract the WIA driver

    I was also intrigued by Solarfinder's suggestion of importing directly into Word.  Help told me that was not possible in Word 2007 and that I should import via Clip organiser - but that first gave me an error message 'cannot acquire file' and subsequent attempts cause it to open ScanGear CS and take me back to the original error.

    I hope someone can help - thank you


    Thursday, December 02, 2010 9:43 PM
  • I have a 8400, what I get is similar and different.

    When running from the canoscan toolbox I got the error "Cannot communicate with the scanner - check cable and connection."

    BUT, i had this little flinker working just fine, when I was doing it's install I specifically tested it,  the last thing i was going to do was believe it :-)  or believe some MS error , the troubleshooter was useless again, as it often is when there is a deeper or intermittant issue.

    When clicking on the Scanner in the control pannel  "Devices and printers" pictures section, I get "you Need a WIA driver to use this device" Asumption, this isn't going to work EVER.  BUT how could it have worked before?

    Out of the blue after retrying it a few times with the cano-scan and its scangear CS scanner pannel, it just works Fine. Previews fine, scans full res fine, acts like nothing has happened.  Strange I didnt replace it ??  I didnt change the drivers. All I did was not believe the error, and persists against the Odd.

    It is using a twain, but another stange thing , If there is no WIA connection, how does the hardware buttons on the scanner "scan copy PDF e-mail"  function still?  on the Xp system these items would only function if the WIA service was operational?  

    I am going to use it like this, and hope it doesnt come up with any more weirdness, In XP even with WIA off , using just the twain , this scanner had been problem free for years.

    If anyone should come up with changes in drivers, or changes in backwards compatability with W7 64 for this particular problem, i would be interested.  

    Thanks everyone for sharing your Informations. 

    • Edited by psycogeec Wednesday, January 04, 2012 4:20 AM
    Wednesday, January 04, 2012 4:13 AM
  • Hello, I have similar problem as original poster, searched for solution on the internet and this looks most close to what I'm observing with my scanner.

    Scanner model = LiDE 200 via USB2
    Scanner driver = ScanGear 64bit
    OS = Windows 7 /x64

    My scanner is connected, fully detected and using the latest driver offered from Canon web for my OS platform (lide200vst641403ea24).

    The problem appears when I open ScnaGear and make a preview, scanning head makes the snapshot and stays frozen at the rear end (no return), and it's not always but in most cases. From this moment on the scanner refuses any further communication with PC until it's physically reconnected.
    I exclude any hardware based reasons because testing it out of virtualboxed clean Windows XP confirmed the scanner, cable and ports are operating properly. Current driver operated fine as well some months ago yet concluding the driver is OK too. Eliminatiing all these suspects problem must be something between Scangear/driver and physical USB port. For confirmation I clean-reinstalled driver and changed USB ports with same results. I have asked the Canon tech support which confirmed a software problem on my OS but can't determine the problem more closely, btw. making a scan with WIA interface introduces the same problem. All software tests of the scanner finish happily.

    Hopefully someone provides a working solution, thanks in advance.

    • Edited by Hchkrdtn Wednesday, March 28, 2012 10:21 AM
    Wednesday, March 28, 2012 10:19 AM
  • I have exactly the same hardware/ Software as Hchkrdtn above and am experiencing the same problem

    I don't want to buy another scanner.

    Tuesday, April 17, 2012 9:11 PM
  • For whatever it is worth - my Canon MF4770n will scan if you use MS FAX software; but then you lose all the adjustments available in the Canon software - not really much of a solution - and it wants the info for sending the fax - LOL.
    Monday, December 23, 2013 12:12 AM
  • The fix is to remove the driver and then re-install them using the version from the site. This is specially true for Windows 7 and Windows 8.1.


    Thursday, December 11, 2014 9:10 PM
  • Similar but unequal result: My problems here with failure to establish a connection with WIA [for Cannon MF4150 ImageCLASS] did not arise until AFTER upgrade to Windows 10.
    Saturday, January 23, 2016 4:03 PM
  • Similar problems with my MF6540 printer/scanner. Installed the Canon drivers on my Win 10 Pro system, and I have no problem printing. I can *sometimes* scan. Many times, however, the initial call to CoCreateInstance(CLSID_WiaDevMgr) hangs for several minutes or fails outright. I have the same symptom on a second 10 Pro system and on a 10 Home Surface. Ditto with a Neat NM-1000 scanner.

    IMO this is *not* a driver problem -- it's a problem with the still-imaging service. It seems to relate in some way to arrival and removal of  USB scanning devices, which suggests that the problem may be localized to the PNP message processing within the service.

    • Proposed as answer by lian00 Thursday, August 04, 2016 1:36 PM
    • Unproposed as answer by lian00 Thursday, August 04, 2016 1:40 PM
    Sunday, May 29, 2016 5:17 PM
  • I had some similar problem with Canon 5600F scanner in Windows 7 then Windows 10. Strangely, the scanner worked with another PC Windows 7.

    The failure was quite strange: the scanner worked one time and could not scan a second time - it stopped during preview scan after a while. The "Cannot communicate with the scanner - check cable and connection." message was showing. I decided to stop the antivirus - Avira - and everything went nice. So, for my personnal problem, the antivirus guilty.

    Thursday, August 04, 2016 1:40 PM
  • Hmmm....This issue is generally occurs in most printers. But don't worry. Try any one suitable method from following:

    1. Download latest scanner drivers from official Canon website.
    2. Make sure there should be appropriate network b/w your scanner and system.
    3. Restart your both devices and test scanning again. 
    4. Update your drivers/system. 
    5. Note that you should using those drivers that is compatible with your OS.

    If all these methods are not useful then check try other online support services in Canon 4200F Manual-

    Friday, January 13, 2017 4:44 PM
  • I have an MF3010 and i tried several of the above but what got it to work is to remove the device completly from the device manager and then reinstalling the driver on canon site.

    THIs is very important too.!!!!!

    "Precaution When Using a USB Connection
    Disconnect the USB cable that connects the device and computer before installing the driver.
    Connect the USB cable after installing the driver. "

    Wednesday, May 24, 2017 6:00 AM