locked
Windows 7 - network shares are not available after wakeup RRS feed

  • Question

  • Hi,
    I am using W7 RC1 (64bit). After wakeup in shared network (without a domain) the network shares are not available immediatly after wakeup from sleep. This wasn't a problem with XP or Vista. Both other OS are still in use. Shares are shared in workgroup from XP.
    However, if I click on the network drive (in explorer) the share comes available after a couple of seconds.
    Seems to be specific to W7.
    Any ideas?
    Best regards
    tk
    Wednesday, August 12, 2009 1:40 PM

Answers

  • Seems to be related to the re-authentication / re-establishing of the SMB session after the wakeup. You might consider using netmon / processmon to determine which has hanged the access. Is it on the network layer (re-authenticating users/re-setup the smb session) or application layer (like the explorer.exe or the lanmanserver service on the server side holding file shares)?

    Meanwhile, to narrow down the issue, you can also try to access a share on another which hasn't been mapped directly via UNC path (click start and type the UNC path to access).

    BR

    • Marked as answer by Nicholas Li Friday, August 21, 2009 2:17 AM
    Friday, August 14, 2009 6:57 AM

All replies

  • I have the same problems with shares on a SAMBA based NAS. I thought this problem was specific to SAMBA mounted shares, but it seems to be a more general problem with Windows 7. In my case the delay can be 1-2 minutes before the shares are available. I don´t notice this behaviour for public shares, only private shares for some reasons. It seems related to authentication.

    This is really annoying and I have spent hours searching for a solutions of this problem.

    BR
    Ulf

    Wednesday, August 12, 2009 4:24 PM
  • Seems to be related to the re-authentication / re-establishing of the SMB session after the wakeup. You might consider using netmon / processmon to determine which has hanged the access. Is it on the network layer (re-authenticating users/re-setup the smb session) or application layer (like the explorer.exe or the lanmanserver service on the server side holding file shares)?

    Meanwhile, to narrow down the issue, you can also try to access a share on another which hasn't been mapped directly via UNC path (click start and type the UNC path to access).

    BR

    • Marked as answer by Nicholas Li Friday, August 21, 2009 2:17 AM
    Friday, August 14, 2009 6:57 AM
  • I have some more info on this. It seems like it is the general network connectivity problem I have. When I loose connection to my SAMBA share, it seems like I have problems to access all resources both on the LAN and on internet. I have read numerous posts on this and tried to find a solution. When I checked the NIC  (Realtek) driver version it seemed to be very old (Microsoft from 2007 or something). I downloaded the latest from Realtek (dated July 2009), and tried to update the driver. Got the message the driver was up to date! Then I uninstalled the dievice and deleted the original driver, searched for new hardware and manually loaded the new Realtek driver. Then I managed to plug in the new driver version!

    Now the network has been up and running for more than an  hour without problem. I will try standby and see if it works after this test as well.

    One strange thing is that Windows update tells me there is an updated driver available, and refers to the old Realtek driver. I will not recommend taking that again....

    I cross my fingers and hope the problem is gone!

    Latest Info:

    I think I dare to say the problem is gone now. Even access to my SAMBA share works fine after standby! Watch out for shaky NIC drivers in the RTM, that's my advice!
    Sunday, August 23, 2009 9:47 PM
  • Hi, I am using realtek and intel nics. I have just updated my intel nic driver to the newest version. Problem remains.
    From my point of view this is more a problem of Windows 7 (perhaps explorer only?) and not a network card driver problem.
    best regards
    tk
    Tuesday, August 25, 2009 5:37 AM
  • Hm. the original problem with the SAMBA network share remains for me as well. I made my conclusion to quick, based on the fact the new NIC driver solved an even more serious problem that masked the first problem. So I'm back where I started. I have disabled automatic standby in the balanced power scheme as a remedy for this problem until someone from Microsoft jumps in and try to do something about it. Reading this forum clearly indicates Microsoft has more network problems in Windows 7 at this stage than can be good for them with this product introduction.

    Tuesday, August 25, 2009 9:54 PM
  • Hi,
    I tried to ignore the explorer now. I have installed an alternative explorer and all in sudden, it seems to work. I can start Outlook (with network shared PSTs) immediatly after standby - no probs. And the alternative explorer is able to access the files from network shares immediatly as well.
    Ulf B: can you try to close all explorer windows before going to standby?
    It seems to me that explorer is disconnecting/connecting drives directly after wakeup from standby... This wasn't a problem before with Vista,XP.
    Best regards
    tk
    • Edited by Tk001 Friday, October 23, 2009 5:10 AM
    Wednesday, August 26, 2009 4:24 AM
  • I can't really notice any difference with or without Explorer. The delay until the  share is available varies a lot. In best case it just takes a few seconds. In worst case the share will not be available until I reboot the system.  And this happens quite often. This is really strange. It might be worth sniffing the signalling between my PC and NAS with Wireshark and see what happens.  See if I can find some time to continue debugging this. It would be nice if someone from Microsoft comments on this. I think this is a pretty serious problem in a new product like Windows 7.
    Wednesday, August 26, 2009 7:29 PM
  • I must admit I haven't tried the new driver or Explorer bit but I have the same problem with wake up. This also includes authenticating my vodafone dongle so ant type of network is included. I can only get it back by rebooting, a real pain when it is a laptop that I'm using. XP worked properly on the same machine with the same connections so obviuoslt a Windows 7 problem.
    I'm reluctant to put in an order for a ful retail version until this is fixed.
    Thursday, August 27, 2009 3:00 PM
  • I might have found something. Looking at a Wireshark dump, I noticed some IPv6 signaling towards the NAS, and figured out both protocols are enabled on my NIC. Made a try and disabled IPv6, and the problem has not showed up since then. There are some posts recommending turning of IPv6 to solve different network issues. Even if I don't understand why, it looks like this might have an impact.

    Touch wood, maybe this is the solution. I will come back with report within a couple of days.
    Thursday, August 27, 2009 5:34 PM
  • Well, my IPv6 was disabled all the time already. May be different issues.
    Thursday, August 27, 2009 6:33 PM
  • Disabled my IPv6 and still no joy. Must be some fundermental network software difference between W7 and XP.
    Thursday, August 27, 2009 6:35 PM
  • Once again I was to quick to believe the problem was solved. Disabling Ipv6 doesn't make any difference. However, it seems related to switch of user. If I´m the only one logged on to the computer, everything seems to to work fine. I can go to sleep, wake up the computer, and my shares are there as expected. However, if I have another user logged on and switch user, then the authentication fails and I have no access to my shares. If I wait a minute or two, it seems like the authentication kicks in and access is granted. But it takes a while before this happens. I'm curious if anyone else could reproduce this problem.
    Friday, August 28, 2009 6:28 PM
  • Hi,
    well, I would confirm my statement that the explorer is doing something strange after wakeup. It seems to check availability of all drives - including network drives. This is OK, but it ignores the fact that the reconnect of the network card/driver takes some seconds (even one or two seems to be to long). This wasn't an issue with Windows XP - and it's also not an issue if you are using FreeCommander instead of explorer. I am using FreeCommander since two weeks - no issue since then. Running smoothly, even in sub directories of network drives. You can click on those directories immediatly after wakeup - no reason to complain. They are available instantly.

    @Microsoft: you should investigate this issue please! This is very annoying to a lot of users.
    Thanks
    tk
    Wednesday, September 9, 2009 7:07 PM
  • Having the same issues, particularly with the LM82567 series nics. Broadcom Nextreme xx57 seem to work instantly as do the Intel LM55 (or something like that, can't remember the exact model). Both 32 and 64bit versions
    Tuesday, September 15, 2009 1:22 PM
  • Hi,
    I just tried final version of W7 - and the problem remains the same. Can you still confirm, that broadcom nextreme is running fine?
    There are not so many cards available, well obviously only: Broadcom NetXtreme Gigabit Ethernet Plus NIC from HP (FS215AA).
    Any other brands available?
    However, in the end, it seems to be a problem of windows 7 - because it worked well with XP and Vista.
    Regards
    tk
    Friday, October 23, 2009 5:09 AM
  • I've been having a similar problem with trying to connect to my NAS after coming out of standby since I switched to Win7.  Any click on the mapped network drive will freeze explorer until I force close.  I found what so far seems to be a solution, and it looks like it could help you too.  I'd post the steps, but this site does a great job with illustrations and details:
    http://www.tannerwilliamson.com/2009/09/windows-7-seven-network-file-sharing-fix-samba-smb/

    I hope this helps!
    Tuesday, November 24, 2009 3:01 PM
  • Thanks for this hint, but unfortunately it did not solve my problem. My problem is definitely related to standby and switching users. For some reason, authentication request is not triggered if I switch user after standby. Most times, authentication  is triggered after a minute or so, and after that I have access to the drive again. However, sometimes it takes longer than that and occasionally I have to logoff/logon to restore access to the drive.

    This is extremely annoying and I really hope Microsoft finds a solution for this.
    Tuesday, November 24, 2009 6:09 PM
  • I don't know what you're talking about.  However, after Windows 7 wakeup from sleep, my ethernet is either disconnected or No Internet Connection.  The only way to resolve this issue is to physically unplug the ethernet cable from the back of the PC and reconnect it.  This is very very inconvenient.

    MSF: please find a real solution for this issue.

    PN: This issue never occured on the same PC with Vista Boot.  All network configurations are automated from Router DCHP Server.
    Wednesday, January 13, 2010 9:09 PM
  • I have the same problem,for me its more interesting, After restarting my Wired Network does not work, I have to disable the Network Connection and enable it again before it will communicate on the network. If the pc wakes up from hibernation or sleep mode the network connection will be working but all my mapped drives will be disconnected.It will only reconnect them after you have clicked them and that usually takes up to a minute. Other than this Iam happy with my Windows 7

    Friday, January 15, 2010 10:45 AM
  • Hi Zizebra,

    Since I'm bit tired of waiting for MS solution I've looked else where.  I've tested this method with only one sleep, so not sure if it will work on a regular basis.

    The problem with hardware not waking up from sleep mode may due to "Hybrid Sleep" mode in your power setting, which delays hardware to wake-up longer than normal sleep mode.  Here is how to turn it off:

         Goto Control Panel -> System and Security -> Power Option
         Click onto "Change Plan Settings" to the right of your pc selected preferred plans i.e. (Balanced)
         Next Click onto "Change advanced power settings"
         In the box, find "Sleep" option and expand to "Allow hybrid sleep" then change "Setting" by scroll down to "Off"
         Now select "Apply" with the new change and exit Power Option.

    Let me know if this is working for you.

    Thursday, January 21, 2010 8:18 PM
  • Hello,

    Same problem here.
    3 computers, 2 via WiFi and 1 via LAN. On all three I have a delay in connecting to the other computers. 3 differtent network cards.
    Concerning delay in connecting after wake-up: the WIFI on two computers is much faster in connecting to the router then in Vista. I have internet instantaneously, but my shares in my homenetwork takes 30-40 seconds. In addition: if I close explorer and try to connect to the shares a minute later I have the same problem, again a delay.

    So far no fixes found

    Jaja
    Tuesday, February 16, 2010 1:00 PM
  • Hi Zizebra,

    Since I'm bit tired of waiting for MS solution I've looked else where.  I've tested this method with only one sleep, so not sure if it will work on a regular basis.

    The problem with hardware not waking up from sleep mode may due to "Hybrid Sleep" mode in your power setting, which delays hardware to wake-up longer than normal sleep mode.  Here is how to turn it off:

         Goto Control Panel -> System and Security -> Power Option
         Click onto "Change Plan Settings" to the right of your pc selected preferred plans i.e. (Balanced)
         Next Click onto "Change advanced power settings"
         In the box, find "Sleep" option and expand to "Allow hybrid sleep" then change "Setting" by scroll down to "Off"
         Now select "Apply" with the new change and exit Power Option.

    Let me know if this is working for you.

    As I understand it, hybrid sleep doesn't do that. Hybrid sleep saves the data in a hibernation file in case of a power outage during sleep, then uses standby "as usual". But I could be wrong.
    Friday, June 4, 2010 8:20 AM
  • A simple solution for this issue is to use Suncross' Network Drive Manager.

     

    Sunday, September 4, 2011 5:11 PM