none
Device Stage Hangs, Can't Safely Remove Hardware

    Question

  • I'm having a problem on a Dell Latitude E6400 system with Windows 7 Release Candidate (64-bit version) in which both Device Stage and the Remove Hardware system tray icon hang.

    Specifically, DeviceDisplayObjectProvider.exe hangs when clicking onto those icons.

    I have confirmed that I have the latest available Dell drivers (the few that are needed in 7 from Vista x64), BIOS update (A14), and I'm at a loss for why this happens. It will be working perfectly one day, and then the next it will stop. If I reinstall, it works again for a few days or weeks and then stops working again. System restore to a day when I know it was working also doesn't fix the issue.

    Has anyone else seen this issue, and if so, how did you resolve it?
    Saturday, June 13, 2009 12:36 AM

All replies

  • GoodThings2Life,

    Which removable devices are you connecting?
    -Alex
    Saturday, June 13, 2009 2:44 PM
  • Doesn't matter... USB flash drives generally, but also my Zune and HTC Touch Pro.
    Saturday, June 13, 2009 2:46 PM
  • One of my old Vista PCs with an Intel P4 3Ghz CPU and VIA chipset, had the same problems.
    As I remember, some BIOS update solved this problem around disconnecting USB stuffs.
    Sunday, June 14, 2009 4:29 AM
  • Thanks for the feedback, but the problem is with the DeviceDisplayObjectProvider.exe hanging in the background (trying to build the device listing, I'm sure), not with the removal of hardware... the inability to remove hardware using the tray icon is just the symptom. In fact, I should clarify that I can still go into Computer, right click on the device, and Eject it without issue.
    Sunday, June 14, 2009 12:32 PM