HP LaserJet 1100 and MS Vista


  • I have an HP Laserjet 1100 and I cannot get Vista to recognize it.  The manual claims that as soon as I plug the cable into the USB Vista will automatically connect the driver.  Guess what?  I will not do it and HP has no idea whatsoever. By the way, I have a DELL Inspiron 530.

    Please advise


    Friday, July 18, 2008 5:44 PM

All replies

  • Hi,


    Yes, this printer driver is build-in Windows Vista and we do not need any software for it.


    Before moving on, please confirm the following points:


    1.Have you try to use another USB port to troubleshoot this issue?

    2.Do you have other USB device (External USB hard drive, USB flash drive)? Does it work?

    3.Do you have another known computer? Does the printer work on the computer?


    In order to narrow down the issue on Windows Vista’s side. At this time, let’s install the printer in Clean Boot.


    How to take a Clean Boot


    1. Click Start, type "MSCONFIG" (without the quotations) in the Search Bar and Press "Enter" to start the System Configuration Utility.

    2. Click the "Services" tab, check the "Hide All Microsoft Services" box and click "Disable All" (if it is not gray).

    3. Click the "Startup" tab, click "Disable All" and click "OK".

    4. Restart the computer and test the issue.


    Note: Clean Boot is a troubleshooting step. If some programs have been disabled, we can re-enable them later. If you see the System Configuration Utility, check the box of "Don't show this message" and then click "OK".


    Hope it helps.



    Monday, July 21, 2008 8:52 AM
  • Hi,


    As this thread has been quiet for a while we will be changing the issue type to Comment.


    If you wish to return to this question you can go ahead and change the type back to ‘Question’. Then you can edit your initial post and change the radio button at the top of the post editor window.


    If the issue has been resolved, we’d love to hear your solution. By sharing your experience you can help other community members facing similar problems.




    Wednesday, July 30, 2008 10:14 AM
  • I've got the very same problem -- an HP Laserjet 1100 that Windows Vista on a Dell Inspiron 530 desktop doesn't recognize.  My two other printers on the computer are fine & this printer worked fine in Windows XP. 


    Because the 1100 printer has no USB connection & a proprietary parallel cable attachment on the printer, I had to buy a USB - to - DB25 Female adaptor to make the connection.  I've never done anything like a "Clean Boot" & am very concerned that this procedure will screw up the computer.  If it helps with the HP 1100 printer, what do I do next?  Do I have to turn back on what I've turned off?  How do I "re-enable" other programs later?    


    Friday, August 01, 2008 3:05 PM
  • Has anyone solved the problem of running a LaserJet 1100 with Vista? If so, please decribe what was done. A USB to DB25 Female adapter is the easy part  - as-is using an older RS-232 switch to make this work. What I need to know is if the communication issue has been solved between Vista and the printer.




    Glen Stewart


    Sunday, October 12, 2008 5:06 PM
  • I'm having this problem too, people.

    I configured the laserjet 1100 via the USB port and am using a USB to DB25 cable to attach the laserjet 1100.

    Vista configures the printer and tries to send a test page, but only a couple of lines of overprinted rubbish comes out.

    The Vista driver is for a laserjet 1100 (MS) but I dont know what the MS signifies.

    Any help will be greatfully received.



    Monday, October 27, 2008 2:24 PM
  • I have an update for this post. I have successfully configured the printer on my vista. I used a USB to DB25 cable that I got at a Tiger Direct store for about $20. The first cable that I tried worked on the desktop and could be swapped to either of my laptops just fine. For later efforts to share the printer by adding another USB to DB25 cable and an older switch that I have, it took three tries, with returns to Tiger Direct in between before I got another cable that worked. (That is right, the third adapter that I bought had good results - and each time I isolated the USB to DB25 problem cable by switching back and forth with the original adapter that I bought - there were definitely two bad adapters in there.)


    So before you give up, try another cable or two, you may be experiencing the same problem.


    By the way, I am not able to use the scanner feature on the laserjet 1100 with my Vista system. I have not tried it with the laptops XP system yet. I would like to know if anyone has solved this problem of not being able to scan with a Vista to 1100A interface.


    Glen Stewart 

    Tuesday, October 28, 2008 2:56 AM
  • Here's how I solved the problem for my 1100A.  It's not in any manuals & it took me a lot of trial & error time to hit on it, but so far it works.
    Start with the computer off, the USB-DB25 adaptor cable disconnected on both ends, the parallel cable's special HP end connected to the printer only & the printer power cord plugged into the outlet but not plugged into the printer
    Turn on the computer & when it's fully booted --
    plug the USB-DB25 cable into the USB port in back of the computer (DO NOT USE a USB port hub or a USB port in front of the computer), then --
    connect the DB25 end of the parallel cable to the DB25 end of the adaptor cable, then--
    plug the power cord into the printer.
    The printer should now work.
    Here's the catch -- you must do this every time you turn on the computer.  So after shutdown, disconnect the USB adaptor from both the computer & the parallel cord & unplug the printer.  Repeat the procedure next time you turn on the computer. 

    Tuesday, October 28, 2008 11:26 PM
  • Don't forget to change the port in the printer properties from LPT1 (probably the more common port) to USB. That's what finally worked for me.


    Tuesday, November 04, 2008 10:57 AM
  • I am having the same problem - ie Vista does not recognise the printer when you plug it into the USB port, and when you try and install it manually vista shows error message - it does not have a driver.


    Here is a link to HP's definitive list of printers supported in Vista:

    The 1100 (MS) is supported but the 1100 is not included in the list!


    It is just possible that another HP printer driver could be installed instead. This worked for another printer - see

    Any help greatly appreciated!

    Friday, November 07, 2008 5:31 PM
  • I will add my success to this thread.  The HP1100A with a scanner is great.  I have been using it for a long time and do not plan to upgrade, even though I could.  I recently got a Vista computer and finally got the scanner working.  I can scan with the built-in Vista Fax program, Adobe Acrobat, etc.  I often scan documents into Adobe as .pdf's.


    I am using the original LPT1 connection cable, into the back of my Dell docking station.  I installed the original HP drivers for the 1100.  They were designed in the WinNT era.  But they work.  The HP Document Assistant shows up in the lower right taskbar, but I found out today that even if HP Doc Assistant isn't running, the driver is still working so I can scan in Adobe. 


    I can't tell you the exact procedures with the HP software, but it is hard to find and it is out there and it will work with Vista. 


    Friday, December 05, 2008 2:16 PM
  • I don't have a USB-Parallel dongel, only a StarTech plug in card.  The card works perfectly for my
    HP5MP printer, in both Vista and Ubuntu, but it will not drive the HP 1100.  My feeling is that the
    driver simply does not work with most connection types, only a few USB-Parallel dongels.
    However, if anyone has a suggestion, I'd be VERY glad to hear it.

    Thank you.
    Wednesday, December 17, 2008 9:44 PM
  • Harvey,

    This works great but it is a bit annoying.  Has there been an update to this issue? 

    I have the HP Laserjet 1100.  I did exactly what you said and the printer works fine.  Why is it that when I power down the computer and then restart the printer is no longer recognized?

    Saturday, April 11, 2009 1:04 AM
  • I also have a HP LaserJet 1100 connected to Vista. From time to time I would get the same problem that Vista couldn't recognize the device after for instance both the my and printer were unplugged, re-plugged in, and Vista rebooted.

    As suggested by Harvey_049, all you have to do is to make sure Vista is booted before you plug in the USB. And, Vista Plug-and-Play will work in this case.

    No idea why Vista fails to recognize the device if the USB is plugged in first. Anybody?

    Jiryih Tsaur
    Sunday, May 17, 2009 9:17 PM
  • I had the same problem, but instead of going to the HP website I went to the google.  I suggest you go there and type:  hp laserjet 1100 for vista.  Search for the link that says "HP LaserJet 1100-Driverzone-Free Driver Downloads."  Click on the link and you'll see "HP LaserJet 1100" on the top.  The name of the file is lj1100pcl5ewin2kxp2003-en.exe and it has 1.52MB size.  Download and save it at the desktop, unzip it and your printer is automatically installed.  If you've additional questions, don't hasitate to ask.

    Alex Duru

    Monday, January 25, 2010 6:29 AM
  • It's the right driver - MS only says the driver comes from Microsoft
    Wednesday, February 03, 2010 1:18 AM
  • In the add new printer dialogue you must uncheck the option "Automatically detect and install my Plug and Play printer"
    Then select: Use the following port. In the list of ports, select Virtual printer port for USB.
    Then select HP LaserJet 1100 (MS) - (MS) only indicates it's a Microsoft driver

    Wednesday, February 03, 2010 1:27 AM
  • I just found Harvey_049's post today.  It sure helped me!!!  I did one wrong thing (not in your post): I uninstalled the printer before restarting my computer.  Bad idea.  I reinstalled the 1100 manually - it didn't print when I was done, or, rather, it printed unintelligible characters and used a lot of paper doing it, its usual failure mode -  after which I unplugged the cables as instructed, and rebooted and reconnected the cables.  This does indeed work.

    P.S. I'm using a db25-to-USB cable I bought online from Walmart for $9 and change.

    Thanks much, albeit 2+ years later!!!

    Tuesday, February 01, 2011 2:41 AM