none
WDS 2012: UEFI Client Network Boot results in error 0x102

    Question

  • I've got a WDS 2012 and a DHCP Server 2012 running on the same subnet, but on different boxes. I have been deploying Windows 8.1 x64 without any issues to BIOS clients, using DHCP Options 66 and 67.

    Now I am trying to deploy Windows 8.1 x64 to HP Computers with UEFI.

    I changed DHCP Option 67 bootfile name to boot\x64\wdsmgfw.efi.

    When the UEFI Client tries to boot from LAN, it successfully loads wdsmgfw.efi, but then it keeps on "Contacting Server (IP-Address of WDS)" for some minutes and then stops with this message:

    Windows Deployment Services encountered an error: Error Code: 0x102

    I guess I am missing something here, but I don't know what it is. DHCP Option 60 does not seem to be an option, because dhcp and wds are on dedicated servers.

    As soon as I switch back to BIOS and wdsnbp.com everything works again.

    Wednesday, May 27, 2015 8:01 AM

All replies

  • I don't think you need to change your boot file for UEFI clients, just specify the boot image for UEFI x64 in WDS.

    Here is an example picture:

    • Proposed as answer by Roger LuModerator Friday, May 29, 2015 7:46 AM
    • Unproposed as answer by woodrapp Friday, May 29, 2015 12:11 PM
    Wednesday, May 27, 2015 2:36 PM
  • Without changing the bootfile, this setting leads to boot error.
    Friday, May 29, 2015 12:12 PM
  • What happens if you do not specify Option 67?

    Or you can try changing the Option 67 to \boot\x64\pxeboot.com

    I can't test your specific setup as my Server 2008 R2 has DHCP and WDS on it. I have 3 WDS Servers on the network and when I added the 2012 WDS, I didn't have to configure anything... it just worked... Of course, I do not have Option 67 set on my DHCP server, so when a PXE request is sent to either of the 3 servers, the server itself determines which boot rom to use.

    Friday, May 29, 2015 2:48 PM
  • What happens if you do not specify Option 67?
    BIOS:  PXE-E53 No bootfile name received
    UEFI: PXE-E18 Server response timeout
    boot\x64\pxeboot.com: An error occurred with the boot selection

    Monday, June 01, 2015 12:22 PM
  • Got DHCP options 66 and 67 removed and ip helper address pointing to wds installed  - boot.wim can now be downloaded. Thank you guys!

    EDIT: It worked for two days without dhcp options, then -without any changes neither to wds nor to dhcp- the clients stopped getting ip-addresses from dhcp... guess I have to roll back to dhcp options

    • Marked as answer by woodrapp Monday, June 01, 2015 1:51 PM
    • Unmarked as answer by woodrapp Monday, June 08, 2015 6:24 AM
    • Edited by woodrapp Monday, June 08, 2015 6:27 AM
    Monday, June 01, 2015 1:50 PM