none
Vista identifying network problem

    Question

  • Was working fine(accessing the internet and such) after I had just set the WEP code to my wireless router to keep off unwanted freeloaders. Had to wipe the computer clean and reinstall everything on it (Downloaded some sort of registry virus *sigh* the dangers of upkeeping home PCs) Now I can connect to the local wireless network in a limited fashion as it keeps trying to identify the network. Reinstalled most recent drivers for usb wireless adapter, didn't work, removed norton antivirus, no dice.

    No idea what I can do from here, have read and tried disabling tcp/ipv4 and 6. Still nothing, won't even show the wireless network as available then. Bugging out, going to bed finals tomorrow. Please, please, please someone help.
    Thursday, December 13, 2007 6:53 AM

Answers

  • Hi,

     

    Thank you for your post. I understand that the Windows Vista machine can connect to the local wireless network but cannot access the Internet.

     

    Before we go further, I would like to confirm the following points with you:

     

    1.    Was the system infected virus before? Have you format the disk and reinstall the system?

    2.    Regarding the local wireless network keeping trying to identify the network, would you please capture a screenshot of it for further research?

    3.    Can the Windows Vista machine detect the SSID of the wireless network?

    4.    Is there any other computer located in the local network? If so, how does it work?

    5.    Have you tried to connect the router through wired connection? How does it work?

     

    In addition, I’ve listed some links related to Windows Vista wireless as below for your reference:

     

    How to connect to a wireless network in Windows Vista

    http://support.microsoft.com/kb/928429

     

    MSBBN: How to troubleshoot wireless connection problems

    http://support.microsoft.com/kb/831770

     

    Hope it helps.

     

    Sincerely,

    Joson Zhou

    Microsoft Online Community Support

     

    Monday, December 17, 2007 10:02 AM
    Moderator
  • Hello Malcrow,

     

    To further diagnose your issue, when you resume from hibernation check the default gateway ip address using the ipconfig/all at the command prompt. What does it say?

     

    Do you have KB938979 installed? This KB article refers to a network problem when resuming from hibernatation when you lose the default gateway ip address.

     

    http://support.microsoft.com/kb/938979

     

    --

    Eric Cross

    Microsoft MVP (Windows Networking)

    http://mvp.support.microsoft.com

     

    Wednesday, December 19, 2007 2:47 PM

All replies

  • Hi,

     

    Thank you for your post. I understand that the Windows Vista machine can connect to the local wireless network but cannot access the Internet.

     

    Before we go further, I would like to confirm the following points with you:

     

    1.    Was the system infected virus before? Have you format the disk and reinstall the system?

    2.    Regarding the local wireless network keeping trying to identify the network, would you please capture a screenshot of it for further research?

    3.    Can the Windows Vista machine detect the SSID of the wireless network?

    4.    Is there any other computer located in the local network? If so, how does it work?

    5.    Have you tried to connect the router through wired connection? How does it work?

     

    In addition, I’ve listed some links related to Windows Vista wireless as below for your reference:

     

    How to connect to a wireless network in Windows Vista

    http://support.microsoft.com/kb/928429

     

    MSBBN: How to troubleshoot wireless connection problems

    http://support.microsoft.com/kb/831770

     

    Hope it helps.

     

    Sincerely,

    Joson Zhou

    Microsoft Online Community Support

     

    Monday, December 17, 2007 10:02 AM
    Moderator
  • This problem sounds similar to one I am having

    For some reason vista will not reconnect to the internet after the computer has been hibernating.  It says I have local access but that is all.

    If I reboot the computer it connectes with local and internet access.

    My router is a D-Link WBR-2310 using wpa-psk the firmware is the most up to date.

    The network adapter is a Broadcom 802.11 wireless network adapter.

    Do I need to use that Microsoft broadband network how do I run it?
    Wednesday, December 19, 2007 1:32 PM
  • Hello Malcrow,

     

    To further diagnose your issue, when you resume from hibernation check the default gateway ip address using the ipconfig/all at the command prompt. What does it say?

     

    Do you have KB938979 installed? This KB article refers to a network problem when resuming from hibernatation when you lose the default gateway ip address.

     

    http://support.microsoft.com/kb/938979

     

    --

    Eric Cross

    Microsoft MVP (Windows Networking)

    http://mvp.support.microsoft.com

     

    Wednesday, December 19, 2007 2:47 PM
  •  

    Try Using Different wireless security option, wpa personal, TKIP, or try using no wireless security,  try changing the channel #s to 6 or 11, and lastly, remove any previously created wireless profiles, remove any spaces in the ssid, or just reset the router, if you need any further Help reply back,  with details about your router, wireless card, modem.
    Sunday, February 03, 2008 5:17 PM
  • I tired download this fix, but once it downloads it tells me it's not for me.

     

    I'm having the same problem.  My laptop connects to the network fine and stays connected to the network.  I'm using an LinksysN wireless router and a LinksysG wireless card in my desktop.

     

    My desktop seems to be the only one having the issue.  It keeps losing connection.

     

    My 2nd desktop is hard wired into the router and that works perfectly too.

     

    Any suggestions how to fix it?

     

    Saturday, March 01, 2008 2:47 AM
  • Forget wireless connecitons.  I have a Vista Business wired connection which fails 8 out of 10 connections.  It gets stuck in "identifying network".  After about 10-15 repair attempts it will eventually allow internet activity.

    The "network" consists of multiple computers connected to the internet via a Motorola SBG900 modem gateway.  All computers go through a LInksys switch which is then connected to the SGB900.  This provides local access to all computers while allowing internet access with ease.

    Non-Vista operating systems, Mac OS, Linux, and XP all connect flawlessly on the first attempt.  VIsta fails 8 out of 10 times.

    I have tried both static and non-static configurations assigning static IP's to each Vista system (I have two Business and one Ultimate editions) along with static DNS settings.  Statics have not helped as it still fails.

    I suspect that Vista is attempting to "ping" my DNS servers to confirm their availablity.  Given the fact my ISP blocks most pings (to prevent denial of service attacks) it is little wonder Vista cannot verify their existence.


    One would think you can configure Vista to not identify the network but simply use it.  I have been unable to find this setting.

    Anyone have any ideas I have not tried?

    I have tried (without success):

    Turning on and off the TCP/6 stack
    Turned on and off sliding windows support.
    Enable/disable network diagnostics.


    Tuesday, June 17, 2008 12:38 PM
  • This issue took me a week of Googling and cursing Vista before I found the solution on one of the support forums that I found using Google.  I can't find the forum where I found the solution to give them credit and give them thanks.  Therefore, I am posting the solution here so others can find it using Google.  Here is the Microsoft KB that fixes this problem:  http://support.microsoft.com/kb/928233
    • Proposed as answer by Dallas123654 Friday, December 16, 2011 2:24 AM
    Thursday, July 03, 2008 7:46 PM
  • For those above talking about wireless networks, this is on a wired connection.  There's nothing wrong with the machine, other than having Vista on it (sigh).  I've tried the broadcast flag thing from the KB mentioned, that didn't help.  I still think that it would be really useful if I could tell Vista to just stop trying to identify networks.

     

    A bodge I've found is to tell the laptop to disable the internal LAN on battery power.  Then the internal LAN is disabled and enabled when I pull the mains out and plug it back in, which gets it over the 'unidentified network' problem.  Easier than going into Device Manager but still not really fixed, is it?

    Wednesday, July 30, 2008 10:55 AM
  •  

    I found a permanent solution to the "Vista" identifying network problem.  I bought a new router.  Since then I get a 100% sucess rate with our without any registry changes.

     

    For your information, I ditched a Motorola SBG900 and picked up a D-Link DIR-655 Gigabit Router.  At the same time I upgraded my wireless legs of my network to N.  All legs are now 100% reliable with Vista (any flavor).  Heck I am using Wireless connections they connect quicker than Vista can finish booting now.

     

    So while I considered the calls to "upgrade your router" misplaced, they proved correct.

     

    Wednesday, July 30, 2008 1:07 PM
  • Are you serious?  reformat and re-install the system is your first reccomendation?  I mean, you have it as number one on the list.  I know this is the internet and all, but that has to be the worst suggestion I have ever heard to solve a network issue.  Your joking right?  You have to be joking.  Im gonna guess that you are joking.
    Saturday, January 09, 2010 7:55 PM
  • I had this problem with my laptop also.
    I restarted the laptop with the wireless connection switch shut off.
    After reboot was complete, then I turned the switch back on.
    Then open control panel, Network & Sharing Center.
    Should be your default network now & private network status.
    Across from that click Customize.
    At the bottom of the pop-up click 'Merge or delete Network Locations'.
    In the pop-up if there is a Network that is not in use delete it, then close/cancel the remaining open windows.
    I have a third party software firewall (Comodo) installed on my laptop which I use and thought I had the windows firewall disable but I guessed wrong.
    So I went to start menu, control panel, windows firewall, and found that even though I had it turned off it was still monitoring my system.
    To disable the Windows Firewall on a network connection:

       1. Click Start and click Control Panel.
       2. Click then select Windows Firewall.
       3. Click Change Settings.
       4. From the window that appears, click the Advanced tab.
       5. Remove the check beside the connection that you want to disable the Windows Firewall for.
       6. Click OK.
    Then from the start menu, run command, type 'services.msc' without the quotation marks.
    Find windows firewall, highlight and right click, then click properties.
    At service status click Stop.
    Then from the 'startup type' drop down menu click 'Disabled'.
    Click Apply, then OK.
    Reboot.
    After the reboot I received a window asking what type of network I would like, I chose Home/Private.
    Then Control Panel, Network & Sharing Center.
    Should be a Private Network now, click Customize.
    In open window click Merge or Delete Network locations.
    If there are 2 click on the 1 not being used then click Merge.
    In the open window select the 1 being used and click Merge, Apply/OK.
    That's all folks, good to go.
    • Proposed as answer by gtghip Friday, April 16, 2010 2:03 PM
    Wednesday, February 10, 2010 7:55 PM
  • I Once had this problem but later found out the cause was bumat'rts Trojan horse on my computer, try scanning with your computer.. Norton, act and windows defender couldn't even find it but Microsoft security essntials could...
    Wednesday, May 12, 2010 5:36 PM
  • Are you a Microsoft salesman? LOL
    Sunday, July 18, 2010 3:23 PM
  • Was working fine(accessing the internet and such) after I had just set the WEP code to my wireless router to keep off unwanted freeloaders. Had to wipe the computer clean and reinstall everything on it (Downloaded some sort of registry virus *sigh* the dangers of upkeeping home PCs) Now I can connect to the local wireless network in a limited fashion as it keeps trying to identify the network. Reinstalled most recent drivers for usb wireless adapter, didn't work, removed norton antivirus, no dice.

    No idea what I can do from here, have read and tried disabling tcp/ipv4 and 6. Still nothing, won't even show the wireless network as available then. Bugging out, going to bed finals tomorrow. Please, please, please someone help.

     

    "unwanted freeloaders" haaahhhhahhaha

    Keep an open network @ss hole, I dont care if you dont I will still audit/crack your incription. For all you people who subscribe to internet please get 6 mbps download/512mbps upload or faster I cant have your sucky 3.0 speed laging my xbox live . Get vorizon fiber optic internet speed it has 50 mbps download and 20 mbps opload , only 125 $  per month.

    Wednesday, August 25, 2010 7:21 PM
  • This issue took me a week of Googling and cursing Vista before I found the solution on one of the support forums that I found using Google.  I can't find the forum where I found the solution to give them credit and give them thanks.  Therefore, I am posting the solution here so others can find it using Google.  Here is the Microsoft KB that fixes this problem:  http://support.microsoft.com/kb/928233

    after pulling all my hair out and trying 1000 fixes  this did it you rock
    Friday, December 16, 2011 2:24 AM
  • Yeah you just announced something that you can arrested by The government and put in jail for 10 - 20yrs depending on your state. Plus you admit that your too poor to afford internet so your really good at your life. In prison you'll met a man named Jesus. I hope you enjoy getting Touch by him.
    Wednesday, January 23, 2013 12:39 AM
  • Yeah you just announced something that you can arrested by The government and put in jail for 10 - 20yrs depending on your state. Plus you admit that your too poor to afford internet so your really good at your life. In prison you'll met a man named Jesus. I hope you enjoy getting Touch by him.
    I couldn't have said it better myself!

    MCP MCSA MCSE MCTS MCITP CompTIA A+ CompTIA Net+ CompTIA Sec+

    Monday, September 16, 2013 4:05 PM