none
acpi.sys+0x1af7c consuming 100% CPU on a core/System process consuming 100% CPU on a core RRS feed

  • General discussion

  • This appears to be a long-running, common problem with Windows 7 (and likely more recent OS versions).

    It also appears to be an on-going problem, and needs to be actually fixed by Microsoft.

    At some apparently random time after the system boots, one of the CPUs cores will become occupied at nearly 100% by a thread associated with something similar to "APCI.sys+0x1af7c".  With one core completely occupied by this thread and its associated interrupts, the whole system becomes sluggish.

    While this wild thread/interrupt series appears to be random, it is more likely to occur around the time that a cell phone is plugged or unplugged into the PC via a USB cable or possibly when using Firefox and streaming video from sources such as CNN or YouTube (it does not appear to be a problem when streaming from Netflix, Amazon, HBO, and the like).

    There are two ways to work-around this:

    1.  Reboot your machine.  The problem will come back at some point, at which time you can reboot again.  This solution harkens back to one of Bill Gates' signature accomplishments from Windows 1, where he got people to believe it was acceptable to hit the reset button on your computer multiple times a day.  Yes, the problem will keep coming back, but at least for some random period of time after you reboot your PC, it will not be sluggish.

    2.  Disable "Wake on..." features from your wired network card (not wireless network), whether or not your PC is actually connected with the wired network card.  This fix may be a permanent solution to the problem, if your PC does not need the "Wake on..." functionality--which is probably the case for most home PCs, but less likely to be the case in corporate environments where the IT infrastructure performs remote backups and updates of PCs and need to use the "Wake on..." feature to effect those backups and updates.

    Here are the steps to perform work-around #2.  Note that if you follow this procedure when your PC is in the bad state, you will see immediate results without having to reboot.  Also, if you follow this procedure, you might not want to have any other applications running so that only 1 core is being consumed and the other cores are effectively idle--this makes it easier to tell if your wild thread problem is solved:

    A.  Bring up the Device Manger (Start Menu, type "Device Manger" into the search box at the bottom of the Start Menu and hit the Enter key.  The Device Manager will start up.).

    B.  In the Device Manager Window, scroll down to find the "Network adapters" entry, and click on the "+" icon to expand the list of adapters.

    C.  Find the wired network adapter.  There may be several network adapters listed.  The wireless adapters will have 'wireless' in their name, and some will have 'Virtual' in their names--those can be ignored.  There should be only one or two network devices without "wireless" or "Virtual" in their names.  An example might be "Intel(R) Ethernet Connection I217-LM", but there are many different models of network adapters, so yours will likely be some other name.

    D.  Right-click on your wired network adapter and select "Properties".

    E.  In the Properties dialog, select the tab labeled "Power Management".

    F.  Find the Options labeled similar to "Wake on...", which might include "Wake on Magic Packet", "Wake on Pattern Match", "Wake on Magic Packet from power off state".  These are likely in a box titled "Wake on LAN".

    G.  Uncheck all of the "Wake on..." options.

    H. Click on "OK" (or "Apply").

    If you are performing this procedure while the wild thread is eating up one of your CPUs cores, you should immediately see the CPU use on that core drop to zero.  By immediately, I mean within 5 seconds of clicking on "OK".  You do not need to reboot to see the wild thread go back to idle.

    Note that this fix has had no ill effect on my PC since doing it, whether I'm using the wired network or wireless network card.

    Since this fixed the problem for me (and hundreds of other people as well), and since this problem comes on randomly, it is pretty clear that this is a software bug in the System process and/or the wired network driver (since the wild thread happens no matter which wired network card is in the PC), and this is clearly a problem that Microsoft should be able to fix.  It's embarrassing that this problem has been around since at least 2009 (over 6 years!).  It's likely some sort of stuck/unclear interrupt, and I can't believe it's that difficult to find and fix.

    Friday, January 15, 2016 6:33 PM

All replies

  • Hi Iclif,

    Thank you for your question.

    By this issue, we suggest you update BIOS to check if the issue persist, we could refer to the following link:

    https://social.technet.microsoft.com/Forums/windows/en-US/24a4c47b-175a-4492-b706-01c4935547a7/acpisys0x1af7c-consuming-cpu?forum=w7itproperf 

    Best Regard,

    Jim Xu

    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Jim Xu
    TechNet Community Support

    Monday, January 18, 2016 8:59 AM
  • =) Thank you so much typing this out!!, for me it worked hopefully for others too. The key was to disable LAN connection wake, simple, but only when you find it lol. (especially if you are not using LAN to anything :o )


    • Edited by MakTomi Saturday, April 20, 2019 7:31 PM
    Saturday, April 20, 2019 7:30 PM