none
Windows 7 RC Build 7100 won't shut down. (SOLUTION FOUND! Cause: M-Audio Delta 2496)

    Question

  • It started when I first installed windows 7 RC. When I choose Shut Down, all programs exit like they need to, the "logging off" screen appears, but it keeps hanging at the "Shutting Down" screen.
    I read all topics related to this problem, but didn't find a solution.

    EDIT2:
    So the cause was my M-Audio audiophile Delta 2496 sound card. The solution (Thanks to jjjjbbbb & Steviekeyz from the M-Audio forums)
    http://forums.m-audio.com/showthread.php?t=8629

    Steviekeyz said:
    1) Create a .bat file (create txt file and change extention to .bat)
    2) Right Click on file > "edit" and enter following info:
    net stop "Audiosrv"
    net stop "AudioEndpointBuilder"
    3) Save file as "Audio stop"(or whatever you want) to your main drive ie: C:\Audio stop
    4) Open "run" from start menu and enter "gpedit.msc" (without quotes) and hit "OK"
    5) Now navigate from right pain of window "User Configuration" > "Windows Settings" > "scripts (Logon/Logoff)" > "Logoff"
    6) From window that opens from clicking "Logoff" Click "Add" then browse to where you saved "Audio Stop.bat" earlier and double click on it.
    7) Hit "Apply" and close.
    You are done
    Window7 will now Automatically stop the Audio services when Shutting Down or Restarting allowing system to complete the process.


    if for some reason the audio service doesn't start back up just do the same thing for logon but use "net start" of course and create a whole new titled 'audio start.bat" batch file, just so theres no confusion with what bat file is what. hope this helps you, it did for me. I got this off the windows seven beta forum from a user. It solved it but then my audio service wouldnt load on startup at random times so I added a net start and now works flawless.

    good luck!



    Possible solutions that DIDN't help me (But might help you!):
    -Turn off the Firewire port in BIOS.
    -Install usbehci.sys (For usb hubs)
    -Exit all programs before shutting down
    -Adjusting the power button settings in the control panel
    -Turning off all non-microsoft services in MSCONFIG
    -Windows DOES close when I open it in safe mode. It doesn't close when I try to sleep/hibernate.

    Specs:
    MSI Mainboard (So not an ASUS!) ms 7350
    Geforce 7900GTX
    Operating system dual boots with Windows XP (which shuts down fine)
    M-Audio Audiophilie 2496
    • Edited by Joepsz Sunday, May 31, 2009 10:56 AM Solution found
    Tuesday, May 26, 2009 9:40 AM

Answers

  • Joepsz

    The problem is with the sound card that you are using.  I have the same card and this is one of three issues that caused me to stop testing build 7000.

    I apoligize but I don't know how to insert a link, there is a link on the M-Audio forum that addresses this problem.  If you follow the instructions this problem will be corrected.  It took care of mine.


    JB
    • Marked as answer by Joepsz Sunday, May 31, 2009 10:45 AM
    Sunday, May 31, 2009 4:53 AM
  • Joepsz

    The problem is with the sound card that you are using.  I have the same card and this is one of three issues that caused me to stop testing build 7000.

    I apoligize but I don't know how to insert a link, there is a link on the M-Audio forum that addresses this problem.  If you follow the instructions this problem will be corrected.  It took care of mine.


    JB

    Thank you very much!
    http://forums.m-audio.com/showthread.php?t=8629
    This is the thread.

    Steviekeyz said:
    "
    1) Create a .bat file (create txt file and change extention to .bat)
    2) Right Click on file > "edit" and enter following info:
    net stop "Audiosrv"
    net stop "AudioEndpointBuilder"
    3) Save file as "Audio stop"(or whatever you want) to your main drive ie: C:\Audio stop
    4) Open "run" from start menu and enter "gpedit.msc" (without quotes) and hit "OK"
    5) Now navigate from right pain of window "User Configuration" > "Windows Settings" > "scripts (Logon/Logoff)" > "Logoff"
    6) From window that opens from clicking "Logoff" Click "Add" then browse to where you saved "Audio Stop.bat" earlier and double click on it.
    7) Hit "Apply" and close.
    You are done
    Window7 will now Automatically stop the Audio services when Shutting Down or Restarting allowing system to complete the process.


    if for some reason the audio service doesn't start back up just do the same thing for logon but use "net start" of course and create a whole new titled 'audio start.bat" batch file, just so theres no confusion with what bat file is what. hope this helps you, it did for me. I got this off the windows seven beta forum from a user. It solved it but then my audio service wouldnt load on startup at random times so I added a net start and now works flawless.

    good luck! "
    • Marked as answer by Joepsz Sunday, May 31, 2009 10:46 AM
    Sunday, May 31, 2009 10:46 AM

All replies

  • There are a few things that you can look at:

    1.  Click the Start button.  Rick-click>Properites on an empty space somewhere on the Start Menu.  Up near the top there is "Power button action:"  If it doesn't say "Shutdown" click on the arrow for the pull-down menu and choose "Shutdown".

    2. Go to the Control Panel>System and Security>Power Options.  On the left pane click on "Choose what the Power buttons do".  You'll see "When I press the power button:" on the middle right for Battery and Plugged in.  If you want to change those settings to "Shutdown" go right ahead.

    3 Click the Back arrow at the top to take you back to the Power Options window.  On the right you'll see "Change plan settings" for both the Balanced and Power Saver plans.  Click on either one of those, then click on "Change Advanced power settings" over on the left.  In the window scroll down a bit and you'll settings for the Power buttons and Lid. 

    HTH.


    GA P35 DQ6 Mb, Intel Wolfdale 8600 3.33Ghz C2D CPU., 4x2Gb Mushkin DDR2 1066 PC2 8500 Ascents Memory Mods., PNY-nVidia GE Force 8800 GTS (640MB), 4-Western Digital Caviar SATA(2) HDD's (internal), 1 EIDE-USB External; Hauppauge PVR 1600 TV tuner, Dual Monitor: (1) Standard up top, (1) WideScreen below; Altec Lansign Speakers...
    Wednesday, May 27, 2009 3:21 AM
  • If the issue persists after you change related power settings, I suggest that you boot in Clean Boot Mode. This method will help us determine if this issue is caused by a loading program or service. Please perform the following steps:

     

    1. Click the Start Button type "msconfig" (without quotation marks) in the Start Search box, and then press Enter.

     

    Note: If prompted, please click Continue on the User Account Control (UAC) window.

     

    2. Click the "Services" tab, check the "Hide All Microsoft Services" box and click "Disable All" (if it is not gray).

    3. Click the "Startup" tab, click "Disable All" and click "OK".

     

    Then, restart the computer. When the "System Configuration Utility" window appears, please check the "Don't show this message or launch the System Configuration Utility when Windows starts" box and click OK.

     

    Please test this issue in the Clean Boot environment, if the issue disappears in the Clean Boot environment, we can use a 50/50 approach to quickly narrow down which entry is causing the issue.


    Arthur Xie - MSFT
    Wednesday, May 27, 2009 9:44 AM
    Moderator
  • Thanks for the replies!
    I tried them and none worked. I disabled all services and all startup apps that are non-microsoft but it didn't help.
    Windows didn't shut down since I first installed it, so I don't think it's a third party software thing.

    Windows DOES close when I open it in safe mode. It doesn't close when I try to hibernate.
    Wednesday, May 27, 2009 12:37 PM
  • I really do not think it's a 3rd party software issue.

    If this problem you are having happens with nothing but Windows 7 installed then it could be hardware related or it just could be a bad install, or bad Windows 7 ISO download, bad burn to disc, etc...; the possibilities are numerous.

    What kind of system do you have: hardware - motherboard, memory, VGA card: the more you details you can provide the better we can possibly help.
    GA P35 DQ6 Mb, Intel Wolfdale 8600 3.33Ghz C2D CPU., 4x2Gb Mushkin DDR2 1066 PC2 8500 Ascents Memory Mods., PNY-nVidia GE Force 8800 GTS (640MB), 4-Western Digital Caviar SATA(2) HDD's (internal), 1 EIDE-USB External; Hauppauge PVR 1600 TV tuner, Dual Monitor: (1) Standard up top, (1) WideScreen below; Altec Lansign Speakers...
    Wednesday, May 27, 2009 1:30 PM
  • Thanks for your time.
    My specs are:
    MSI P6N SLI mainboard
    Club 3d Geforce 7900GTX
    2x 1024MB DDR 
    Intel Core2 Duo  6600
    Samsung Spinpoint 360GB HDD
    M-Auidio Delta 2496 PCI soundcard

    This not shutting down problem happens to quite a lot of people.
    Saturday, May 30, 2009 9:07 AM
  • I also have this problem.
    Soyo K7V Dragon+, AMD 1500+, 2x1G DDR3200, ATI Radeon 9550, Creative XFI Fatality.

    I know this is an older system that's not supposed to work with Win7, but it worked fine (more than fine, much better than XP) with the BETA, and with RC1 until I installed the Creative Beta XFI Drivers (without which I get no sound since Win 7 RC1 doesn't even recognize this card).

    The "clean boot", which disables lots, but not the Creative drivers apparently, since I still get sound, does not fix the shutdown problem. By the by, I can't shut down from "safe" mode either. Oh, and I didn't get the usual system config utility prompt when I restarted after changes to MSCONFIG. The changes, however, were made.


    Saturday, May 30, 2009 10:24 PM
  • Joepsz

    The problem is with the sound card that you are using.  I have the same card and this is one of three issues that caused me to stop testing build 7000.

    I apoligize but I don't know how to insert a link, there is a link on the M-Audio forum that addresses this problem.  If you follow the instructions this problem will be corrected.  It took care of mine.


    JB
    • Marked as answer by Joepsz Sunday, May 31, 2009 10:45 AM
    Sunday, May 31, 2009 4:53 AM
  • Joepsz

    The problem is with the sound card that you are using.  I have the same card and this is one of three issues that caused me to stop testing build 7000.

    I apoligize but I don't know how to insert a link, there is a link on the M-Audio forum that addresses this problem.  If you follow the instructions this problem will be corrected.  It took care of mine.


    JB

    Thank you very much!
    http://forums.m-audio.com/showthread.php?t=8629
    This is the thread.

    Steviekeyz said:
    "
    1) Create a .bat file (create txt file and change extention to .bat)
    2) Right Click on file > "edit" and enter following info:
    net stop "Audiosrv"
    net stop "AudioEndpointBuilder"
    3) Save file as "Audio stop"(or whatever you want) to your main drive ie: C:\Audio stop
    4) Open "run" from start menu and enter "gpedit.msc" (without quotes) and hit "OK"
    5) Now navigate from right pain of window "User Configuration" > "Windows Settings" > "scripts (Logon/Logoff)" > "Logoff"
    6) From window that opens from clicking "Logoff" Click "Add" then browse to where you saved "Audio Stop.bat" earlier and double click on it.
    7) Hit "Apply" and close.
    You are done
    Window7 will now Automatically stop the Audio services when Shutting Down or Restarting allowing system to complete the process.


    if for some reason the audio service doesn't start back up just do the same thing for logon but use "net start" of course and create a whole new titled 'audio start.bat" batch file, just so theres no confusion with what bat file is what. hope this helps you, it did for me. I got this off the windows seven beta forum from a user. It solved it but then my audio service wouldnt load on startup at random times so I added a net start and now works flawless.

    good luck! "
    • Marked as answer by Joepsz Sunday, May 31, 2009 10:46 AM
    Sunday, May 31, 2009 10:46 AM
  • I tried the .bat file but your syntax was a little off. There should be no quotes around the net commands. Also, when you issue the net stop audiosrv command there is a "do you want to continue? prompt". How do I pass a "Y" parameter to the prompt?
    Anyway, I shut down audiosrv and audioendpointbuilder using task manager and then tried to shut down or restart. The process still hangs.
    Isn't there a debug type command to let me step through the shutdown process to see where it's getting hung?

    Sunday, May 31, 2009 2:55 PM
  • OK, this "won't shut down" problem has reached outrageous, ridiculous proportions.
    I did the following.
    1. Re-partitioned and reformatted  the drive using a combination of Maxtor's (Seatgate's) utilities and the WINXP install disk (WIN7 for some inexplicable reason has no option to partition a disk that's already formatted. Why???
    2. Re-installed WIN7 without the Creative XFI sound card or any other sound.
    3. Installed a few programs. At some point, the "won't shut down" problem recurred.
    Not having created a drive image, I repeated step 1, with the Creative card installed.
    Again, I installed a few programs. This time I thought I was really clever - I created a Windows Backup Restore Image every few programs.
    I installed, (OK is there some secret program that kills you if you install this program - DVD43?) It installed, then initiated a restart, which it normally doesn't do.. The restart hung. I hit the restart button, and after startup completed, I removed DVD43 using Control Panel and then manually deleted the remaining registry entries using regedit (why doesn't the add/remove programs menu remove the whole effing program?)
    I tried to restart. Nope.
    I brought the system up with the Windows restore disk. I instructed it to restore to the drive image I created before installing DVD43.
    It installed the image.
    The no shutdown/restart problem continued.
    I again brought the system up with the restore disk. This time I told it to format the freeking drive before restoring the system image I had created when Win7 would still shut down.
    The system was restored. It restarted. And it still won't  effing shut  the ____ down!
    I have also tried the shutdown \f from the command prompt. It doesn't do the job.
    Am I pissed? Yes.
    I ran the Beta on this system with absolutely no problems. I thought I'd died and gone to heaven.
    What the H have you done to what seemed to be the greatest thing since sliced bread?????
    I anxiously await a reply fromsomeone from MS to this idiotic problem.
    Ubuntu Linux calls.
    Monday, June 01, 2009 8:40 PM
  • OK, this "won't shut down" problem has reached outrageous, ridiculous proportions.
    I did the following.
    1. Re-partitioned and reformatted  the drive using a combination of Maxtor's (Seatgate's) utilities and the WINXP install disk (WIN7 for some inexplicable reason has no option to partition a disk that's already formatted. Why???
    2. Re-installed WIN7 without the Creative XFI sound card or any other sound.
    3. Installed a few programs. At some point, the "won't shut down" problem recurred.
    Not having created a drive image, I repeated step 1, with the Creative card installed.
    Again, I installed a few programs. This time I thought I was really clever - I created a Windows Backup Restore Image every few programs.
    I installed, (OK is there some secret program that kills you if you install this program - DVD43?) It installed, then initiated a restart, which it normally doesn't do.. The restart hung. I hit the restart button, and after startup completed, I removed DVD43 using Control Panel and then manually deleted the remaining registry entries using regedit (why doesn't the add/remove programs menu remove the whole effing program?)
    I tried to restart. Nope.
    I brought the system up with the Windows restore disk. I instructed it to restore to the drive image I created before installing DVD43.
    It installed the image.
    The no shutdown/restart problem continued.
    I again brought the system up with the restore disk. This time I told it to format the freeking drive before restoring the system image I had created when Win7 would still shut down.
    The system was restored. It restarted. And it still won't  effing shut  the ____ down!
    I have also tried the shutdown \f from the command prompt. It doesn't do the job.
    Am I pissed? Yes.
    I ran the Beta on this system with absolutely no problems. I thought I'd died and gone to heaven.
    What the H have you done to what seemed to be the greatest thing since sliced bread?????
    I anxiously await a reply fromsomeone from MS to this idiotic problem.
    Ubuntu Linux calls.

    Do you have an M-Audio 2496? If not, the bat file won't help.
    Do you have an Asus mainboard? If yes, check this topic: http://social.technet.microsoft.com/Forums/en-US/w7itprogeneral/thread/c1456629-a482-438e-9b7b-474226b5b4b7
    Do you have firewire enabled in the BIOS? Then try putting it off.
    Did you try shutting down without any USB devices plugged in?
    Monday, June 01, 2009 8:44 PM
  • It started when I first installed windows 7 RC. When I choose Shut Down, all programs exit like they need to, the "logging off" screen appears, but it keeps hanging at the "Shutting Down" screen.
    I read all topics related to this problem, but didn't find a solution.

    EDIT2:
    So the cause was my M-Audio audiophile Delta 2496 sound card. The solution (Thanks to jjjjbbbb & Steviekeyz from the M-Audio forums)
    http://forums.m-audio.com/showthread.php?t=8629

    Steviekeyz said:
    1) Create a .bat file (create txt file and change extention to .bat)
    2) Right Click on file > "edit" and enter following info:
    net stop "Audiosrv"
    net stop "AudioEndpointBuilder"
    3) Save file as "Audio stop"(or whatever you want) to your main drive ie: C:\Audio stop
    4) Open "run" from start menu and enter "gpedit.msc" (without quotes) and hit "OK"
    5) Now navigate from right pain of window "User Configuration" > "Windows Settings" > "scripts (Logon/Logoff)" > "Logoff"
    6) From window that opens from clicking "Logoff" Click "Add" then browse to where you saved "Audio Stop.bat" earlier and double click on it.
    7) Hit "Apply" and close.
    You are done
    Window7 will now Automatically stop the Audio services when Shutting Down or Restarting allowing system to complete the process.


    if for some reason the audio service doesn't start back up just do the same thing for logon but use "net start" of course and create a whole new titled 'audio start.bat" batch file, just so theres no confusion with what bat file is what. hope this helps you, it did for me. I got this off the windows seven beta forum from a user. It solved it but then my audio service wouldnt load on startup at random times so I added a net start and now works flawless.

    good luck!



    Possible solutions that DIDN't help me (But might help you!):
    -Turn off the Firewire port in BIOS.
    -Install usbehci.sys (For usb hubs)
    -Exit all programs before shutting down
    -Adjusting the power button settings in the control panel
    -Turning off all non-microsoft services in MSCONFIG
    -Windows DOES close when I open it in safe mode. It doesn't close when I try to sleep/hibernate.

    Specs:
    MSI Mainboard (So not an ASUS!) ms 7350
    Geforce 7900GTX
    Operating system dual boots with Windows XP (which shuts down fine)
    M-Audio Audiophilie 2496


    It worked for me.
    Logoff scripts as described, everything shutdown verywell now.
    Sound initialize very well on start.


    HERE'S my spec's

    Asus P5Q-Pro Turbo
    Quad Q8400
    Radeon 4830 1GB
    M-Audio Delta 66 custom drivers
    Windows 7 rc7100 french

    Maybe a soundcard issue?
    Or maybe an Uncertified WHQL drivers issues?
    Sunday, June 07, 2009 4:30 AM
  • I have an m-audio Audiiophile 192 card, which uses the delta drivers, on an Asus Rampage 2 Extreme notherboard. I have had the same problems as everyone here with m-audio drivers and sleep/shutdown.

    I have all of these functions working correctly now.

    The shutdown issue was easily solved by making an AudioStop.bat, as above, and associating this with Logoff.

    Sleep was a bit more complicated. Here is the batch file:

    net stop "Audiosrv"
    net stop "AudioEndpointBuilder"
    c:\PsShutdown.exe -d -t 0
    net start "Audiosrv"
    net start "AudioEndpointBuilder"

    PsShutdown is available (and documented) here: http://technet.microsoft.com/en-us/sysinternals/bb897541.aspx

    It works fine in Windows 7.

    The system sleeps after the PsShutdown command. On resume, it is necessary to restart the audio drivers, and the batch file resumes running after sleep where it left off.

    I set up the batch file to run minimized, and assigned it to a soft key on my keyboard.

    Sunday, June 14, 2009 7:41 PM
  • Adobe Acrobat 8 caused same problem on my computer. Isolated it by choosing an earlier restore point.
    Sunday, July 04, 2010 1:56 PM
  • Okay, this worked for me. Disabled all I was meant to and shut down took about 20 seconds, and restart took about 30 seconds. Prior to this shut down was taking 10mins or more, then it would reboot instead of shutting down and then I'd be faced with the blue screen. For the first time in 4 days my computer shut down cleanly. Woohoo! Now I just have to work out what the culprit is.
    Sunday, November 06, 2011 10:00 AM
  • I have 64-bit Window 7 Home Premium and I was having the same problem.  I think it started when I set up a home network.  Here's what worked for me: I clicked on the little arrow on the "Shut Down" button, clicked on "Switch User," clicked on the shut down button on the right bottom corner of the switch user screen,  computer took about a minute to shut down.  I restarted and found that Shut Down is now working normally.
    Saturday, April 07, 2012 1:55 PM