none
USB Intellimouse acts erratic after coming out of sleep mode

    Question

  • I'm not sure what the issue is but almost everytime my Windows 7 Ultimate pc comes out of sleep mode my mouse acts erratic until I move it off the mouse pad a few times while turning it in a circle. Sometimes I have to move it for about 15 seconds before it becomes effective. I've reinstalled the latest MS Intellimouse Optical drivers and still now resolution.

    Anyone have any ideas?

    Dell XPS 720 - Intel Core 2 Quad Q9450 w/4gigs of ram
    Windows 7 Ultimate 32 bit

    Thanks

    Thursday, December 3, 2009 2:15 AM

Answers

  • It's the USB Intellimouse Optical which i was able to get it working by just changing the usb port. Not sure why this would fix it since the usb port i took it out of works fine with anything else i plug into it, it was just the erratic movement of the mouse issue on it.

    I'll leave this one as one of the Windows 7 usb issues can continue using the other usb port.

    thanks for the help on this.

    Billy
    • Marked as answer by Vivian Xing Wednesday, December 9, 2009 8:58 AM
    Saturday, December 5, 2009 3:13 AM

All replies

  • I've seen this weird behavior from time to time. But it hadn't occured to me to link it to sleep mode. Maybe so.

    Are you using Retail or pre-Retail version?

    Are you saying it occurs immediately after sleep mode?
    Or at random times, but only if computer has been to sleep first?
    Thursday, December 3, 2009 4:02 AM
  • I'm using my allowed copy from technet which i'm assuming is the retail version.

    It occurs immediately after coming out of sleep mode. It never happens while just using the computer or after restarting, just after sleep mode.

    I'm ready to just get a logitech mouse to see if the mouse is the problem but I don't think so since it worked just fine when i was on Vista Ultimate.

    thanks for the reply ....

    Billy

    Thursday, December 3, 2009 11:53 AM
  • Hi Billy,

    Would you tell us the model of your mouse, is it wireless?

    The symptom seems a recharging process to me, you can go to device manager, right click "Mice and other pointing devices", properties, under power management, uncheck the box before "allow the computer to turn off this device to save power".

    Also check if your mouse was list from the following website:
    http://support.microsoft.com/default.aspx/kb/928631

    It may add some tips here.
    Friday, December 4, 2009 7:42 AM
  • It's the USB Intellimouse Optical which i was able to get it working by just changing the usb port. Not sure why this would fix it since the usb port i took it out of works fine with anything else i plug into it, it was just the erratic movement of the mouse issue on it.

    I'll leave this one as one of the Windows 7 usb issues can continue using the other usb port.

    thanks for the help on this.

    Billy
    • Marked as answer by Vivian Xing Wednesday, December 9, 2009 8:58 AM
    Saturday, December 5, 2009 3:13 AM
  • I may have found a real solution to this.

    Option #1 Disabled USB Selective Suspend Settings

    1. Browse to:  Control Panel\All Control Panel Items\Power Options\Edit Plan Settings.
    2. Select Advanced Settings.
    3. Select USB Settings\USB Selective Suspend Setting.
    4. Change option to Disabled and press OK.

    Option #2 Disable Sleep Mode for USB Hubs in Device Manager

    1. Open Device Manager.
    2. Expand Universal Serial Bus Controllers
    3. For each USB Root Hub listed, right click and select Properties.
    4. Select the Power Management tab.
    5. Uncheck "Allow the computer to turn off this device to save power".
    6. Press OK.

    https://www.pugetsystems.com/labs/support-software/How-to-Disable-USB-Selective-Suspend-1190/

    Sunday, May 19, 2019 11:35 AM